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Welcome          

 

Welcome to the user guide for SIMCA 13. This is your guide to SIMCA and its 
capabilities.   

This user guide does not include in-depth background material to multivariate data 
analysis. For such information, see the book Multi- and Megavariate Data Analysis. 

Content 

The help is parted into 16 chapters, two appendices, and a reference list. 
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Assumed prior knowledge 

We assume that you are already familiar with Windows. You should be familiar with 
the topics discussed in your Microsoft Windows User's Guide, including how to use 
the mouse to select, click, shift-click, control-click, press, drag, and choose from a 
menu or tab. You should also know how to search through folders to find files. 
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How to get started 

Introduction 
This chapter holds information about the installation, including system requirements 
and such, as well as a short introduction to using SIMCA. 

Content 

 License information 

 What is in the package 

 System requirements 

 Installation 

 Starting SIMCA 

 SIMCA projects 

 Work process for regular projects 

 Work process for batch modeling 

License information 
Before installing the SIMCA product, carefully read the license agreement included 
with your SIMCA software package. 

In case you do not fully accept the terms of the license agreement, you should 
immediately return all parts of the package to your local supplier. 

What is in the package 
The SIMCA package contains the following: 

 Installation files. 

 SIMCA User Guide (.pdf). 

 Installation instructions document. 
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System requirements 
The minimum recommended system requirements: 

 Pentium based computer (PC) with a 1.5 GHz or faster processor. 

 1 GB RAM or more. 

 1 GB available hard disk space. 

 Color graphics display with at least 800x600 resolution. 

 DVD-ROM or CD-ROM drives if the SIMCA package was delivered on CD. 

 Microsoft Windows XP, Vista, or 7. 

 Graphics card that has hardware 3D acceleration and supports Open GL. 

Installation 
To install, follow the installation instructions delivered with the installation program. 

Note: You must have administrative privileges to be able to install the 
software. 

Registration and activation 
To register and activate, follow the instructions delivered with the installation program. 
See also the Register section in the Help chapter. 

Starting SIMCA 
Start SIMCA by double clicking the icon or by starting it from the Start-menu. 

Continue by: 

 Reading about the SIMCA software in the Help or User Guide. Both contain 
same information. 

 Starting a new investigation: click File | New. 

 Running tutorial examples: Find the tutorials and tutorial datasets at the 
Umetrics web site www.umetrics.com, or contact your Umetrics sales 
office. Select a suitable tutorial example, import the listed dataset used in the 
tutorial and follow the described steps. 

SIMCA projects 
What is a project? 

SIMCA is organized into projects. A project is a .usp file containing the results of the 
analysis of one or more datasets. 

Creating a new project 

Start a new project by importing a dataset. The default unfitted model is created when 
exiting the SIMCA import and it is displayed in the Project Window. 
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Project window 

The project window displays, for every model, one line summarizing the model results. 
The active model, the one you are working with, is marked in the project window. 

Default workset and model 

The default Workset consists of all variables and observations imported with the roles 
defined in the import. All variables are default centered and scaled to unit variance. 
How the variables were defined at import also defines which type the default model is. 

Creating a new model 

Unfitted models are implicitly created by SIMCA when: 

 Specifying a workset or 

 When changing the model type of a fitted model (fitted model is the active 
model). 

Activating and opening the model window 

To activate a model click it in the project window. 

All plots and lists created from the Home, Analyze and Predict tabs are created for the 
active model. 

To open the model window: 

 Double-click it in the project window or 

 Mark the model in the project window and then select the Model Window 
check box on the View tab. 

The model window opens with the details of the model results, displaying one line per 
component. 

Opening the workset dialog 

To open the workset dialog use one of the following methods: 

1. Right-click the model in the Project Window and then select Edit Model x. 

2. Click the Workset button in the Model Window. 

3. On the Home tab click Edit | Model x. 

Work process for regular projects 
The work process in SIMCA consists of the following steps: 

Step Objective How to do it 

1. Creating a new project. Click File | New Regular Project, and then 
select the dataset file or files to import. In the 
import spreadsheet define identifiers,  X, Y, 
and qualitative variables etc. 

2. Viewing and 
preprocessing the 
data. 

When warranted, preprocess your dataset 
using the available Spectral Filters or Time 
Series Filters on the Data tab. 
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Step Objective How to do it 

3. Specifying the workset 
and model type. 

On the Home tab, open the Workset dialog 
by clicking New/Edit in the Workset group. 
Select the variables and observations to 
include or exclude, define classes, transform, 
scale, or lag variables, and Trim-Winsorize 
the variables. Optionally select Model type 
before clicking OK to exit the dialog. 

4. Fitting the model. In the Fit model group click Autofit. 

5. Reviewing the results 
and 
performing diagnostics. 

Create plots found in the Diagnostics & 
Interpretation group to detect trends, 
groupings, deviations, etc. 

6. Using the model for 
predictions. 

On the Predict tab, use the predictionset to 
see how new data fit with the active model. 

Import another dataset with the new 
observations or use observations not 
included in the model as predictionset. 

Creating a new project by importing a dataset 
Create a new project by importing a dataset and specifying data properties in the 
SIMCA import spreadsheet. 

Selecting the dataset 
Click File | New Regular Project and then browse to find the file or files to import.   

To import from a database, Cancel the Open dialog and then click New Spreadsheet | 
From Database in the SIMCA import. 

You can import more than one dataset at the same time in SIMCA import by clicking 
File | New Spreadsheet. Selecting another file adds a new spreadsheet to the SIMCA 
import. These spreadsheets are imported individually at Finish and you can create the 
workset from a selection of the datasets. 

Indicating file contents 
Specify Primary ID and as many Secondary IDs as desired for both variables and 
observations. 

Specify qualitative and date/time variables when present. 

Clicking Finish imports all currently open spreadsheets. 

Viewing and preprocessing the data 
Click the Dataset-button (on the Home tab) to open any available dataset. Use the 
Data tab to manipulate and preprocess datasets. 

Viewing the dataset 
Before preprocessing your data you may want to display the variables or observations 
in a plot. You can do this directly from the dataset spreadsheet by marking the 
variables or observations and on the Marked Items tab clicking one of the plots in the 
Create from Marked Items group, or XObs/YObs or by opening the Quick Info (on 
the View tab). 



How to get started 

5 

To plot all the X observations as line plot, click Data | Spectra | dataset. 

Preprocessing the dataset 
Quick Info 

The Quick Info window holds interactive plots tied to the dataset displaying variables 
or observations in the time or frequency domain. When displaying variables, 
Trimming / Winsorizing for a single or all variables is available. 

Generate new variables 

Generate new variables as functions of existing ones or from model results (Data | 
Generate Variables). 

Filter the dataset 

Filter your dataset (Data | Spectral Filters), for example using: 

 Multiplicative Signal Correction (MSC). 

 Standard Normal Variate (SNV). 

 Wavelet transform and compression. 

 Wavelet transform time series data using compression, decimation/denoising. 

Specifying the workset 
The default Workset, at the project start, is the first dataset with variables defined as X 
and Y as specified at import, centered and scaled to unit variance. The associated 
model (unfitted) is listed in the project window. 

To fit the default model click Autofit in the Fit model group (Home tab). 

An unfitted model is generated by SIMCA when clicking OK in the Workset dialog 
and when switching model type for a fitted model by clicking the Change Model 
Type-button. 

New 
In the Workset group click New to create a workset of the entire firstly imported dataset 
with X and Y as defined at import and scaling as defined in Project Options on the File 
tab. 

New as model 
In the Workset group click New as | Mx to use the workset of the selected model as 
starting point. 

Edit 
In the Workset group click Edit to open an already created workset. 

Modifying the workset 
To fit a model different from the default model, with maybe other or more datasets 
included, excluded variables and observations, or transformations, or different scaling, 
it is necessary to modify the default Workset. 
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The following pages are available as tabs in the Workset dialog: 

Tab Functionality available 

Select Data Selecting which datasets to include. Only available when there are 
more than one dataset to choose from. 

Variables Excluding and including variables. Defining variables as X or Y. 

Observations Including and excluding observations. Grouping observations into 
classes for classification. 

Transform Applying transformations for variables. Trim-Winsorizing variables. 
Note that trimming / Winsorizing the workset does not affect the 
dataset but just that particular workset. 

Lag Defining lag structure. 

Expand Expanding terms with cross, square, and cubic terms. 

Scale Scaling variables. 

Spreadsheet Trim-Winsorizing variables. Note that trimming / Winsorizing the 
workset does not affect the dataset but just that particular workset. 

Simple mode 
You can select to have the workset wizard guide you through the specification and 
automatically fitting of the model by clicking the Use Simple Mode button in the 
Workset dialog. To turn it off, click the Use Advanced Mode button. 

Specifying and fitting the model 

Selecting the model type 
You can change the model type, and when the workset specification allows it, by selecting 
another fit method than the default in the Model type box in the Workset dialog or by 
clicking Change Model Type in the Workset group. 

Selecting a new model type after fit 
You can, after fitting the model, select a new model type. SIMCA then creates a new 
unfitted model with the selected model type. 

For example, if you have defined your Workset variables as X and Y, you can first fit a 
PCY (PC of the responses), then change the model type to PLS and fit a PLS 
model (another model) to the same data. 

Fitting the model 
Fit the model using one of the fitting types listed. 

Autofit 

Rule based fitting of the marked model or group of models. 

Two First 

Calculates two components whether they are significant or not. Often used to get a 
quick overview of the data. 
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Add 

Calculate one component at a time. Here it is possible to force components to be 
calculated regardless of significance rules. 

Remove  

Remove the last component 

Autofitting class models 

To fit a group of models in a wrapper model, CM, mark the wrapper and click Autofit. 
All models in the wrapper are then autofitted.  

Reviewing the fit and performing diagnostics 
After fitting, the whole spectrum of plots and lists are available for model 
interpretation and diagnostics. 

Important plots 

 Summary plots 

 Scores: t1 vs. t2, t1 vs. u1, etc. 

 Loadings: p1 vs. p2, w*c1 vs. w*c2, etc. 

 Hotelling's T2Range 

 Coefficients 

 Variable Importance (VIP) 

Important plots for diagnostics 

 Distance to Model 

 Residuals N-Plot (Analyze tab) 

 Contribution plots 

 Permutations (Analyze tab) 

 For batch evolution models: batch control charts (Batch tab) 

Note: By default, all cumulative plots and lists are displayed for the last 
component. To select a different component for display in the plots, and/or a 
different variable, introduce the change in the Data group, on the Tools tab. 

Using the model for predictions 

Importing datasets for prediction 
Later you may import additional data for use in predictions. Click File | Import 
Dataset. 

Building the predictionset 

Click the Specify-button on the Predict tab to build your predictionset from any or all 
datasets. You can display the predictionset as a spreadsheet or just plot or list results. 

If you do not specify a predictionset, the predictionset is by default the first dataset. 
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Displaying the predictions 

Use any fitted model to: 

 Classify the observations from the predictionset with respect to a PC or PLS 
model. 

 Predict responses (values of Y variables) for the observations in the 
predictionset with respect to a PLS or OPLS/O2PLS model. 

All the prediction results (scores, y-values, etc.), computed with the active model, can 
be displayed as plots or lists. 

Plots/Lists 
On the Plot/List tab you can find general plot and list routines. Here it is possible to 
plot and list any data, results from the analysis and predictions. 

There are scatter, line, column, 3d scatter, list, time series, control charts, 
histogram, normal probability plots, response contour, response surface, wavelets 
plots, and step response plots available. 

Note: With an active plot or list, use the Change Type group, on the Tools 
 tab, to generate lists from plots and plots from lists. 

Work process for batch modeling 
A SIMCA batch project consists of one or more batch evolution datasets and models 
and optionally one or more batch level datasets and models: 

1. The batch evolution datasets with several observations per batch with the 
variables measured during the evolution of the batch. 

2. The batch level datasets consisting of the completed batches, with one batch 
being one observation (matrix row). The variables of the batch level datasets 
are the scores, original variables (raw), or statistical summary variables (raw 
data statistics) of the batch evolution model, BEM, at every time point folded 
out side-wise. The BLM may also contain batch condition variables. 

Batches may be divided into phases. 
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The work process in SIMCA consists of the following steps: 

Step Objective How to do it 

1. Creating a new project. Click File | New Batch Project 
(alternatively File | New Regular Project | 
New Batch Project if the last created 
project was regular). Select the dataset file 
or files to import. In the SIMCA import 
spreadsheet, define Batch ID, Phase ID, 
X, qualitative, time or maturity as Y, and if 
present Batch Conditions. 

With phases, in the Batch window 
optionally Rename, Merge, Delete, switch 
the order or time/maturity for the phases, 
or apply Conditional Delete. 

Batch conditions can be imported with the 
batch evolution dataset, or as a separate 
dataset. SIMCA import assumes that a 
dataset with only one row per batch 
contains batch conditions.   

2. Viewing and 
preprocessing the data. 

When warranted, preprocess your dataset 
using the available Spectral Filters or 
Time Series Filters on the Data tab. 

3. Specifying the workset. On the Home tab, open the Workset 
dialog by clicking New/Edit in the Workset 
group. Select the variables and 
observations to include or exclude, crop, 
transform, scale, or lag variables, and 
Trim-Winsorize the variables. Use the 
Variables page to configure the x and y-
variables to the relevant phases, and y-
variables smoothing/shifting/normalizing. 

4. Fitting the model. Mark the wrapper BEM and click Autofit. 

5. Reviewing the batch 
evolution results and 
performing diagnostics. 

Create BCC-plots found in the Analysis 
Control Charts group on the Batch tab to 
detect trends, groupings, deviations, etc. 

6. Using the model for 
predictions. 

Create the BCC-plots found in the 
Prediction Control Charts group to see 
how new data fit with the active model. 

7. Creating the batch level 
dataset. 

On the Batch tab, click Create Batch 
Level and go through the wizard. 

8. Importing batch 
conditions. 

To import batch conditions, click File | 
 Import Dataset, select the file or files to 
import and specify batch ID.  
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Step Objective How to do it 

9. Specifying the workset. The Workset dialog opens at Finish. Note 
that the Create a batch level model 
check box at the top of the Select Data 
page is selected. Select the batch level 
and batch conditions datasets to use and 
then continue to the variables and 
observations pages to include or exclude 
etc. 

10. Fitting the model. In the Fit model group click Autofit. 

11. Reviewing the batch level 
results and 
performing diagnostics. 

Create plots found on the Home tab to 
detect trends, groupings, deviations, etc. 

12. Using the model for 
predictions. 

On the Predict tab, use the predictionset 
to see how new data fit with the active 
model. The batch evolution predictionset is 
automatically rearranged to a batch level 
predictionset. 

Batch project overview 

Batch evolution 
With batch data, you start by importing the batch evolution data and create the batch 
evolution model, BEM. 

Batch and phase identifiers and maturity variable 

In the data, you must have a Batch ID (identifier), indicating the start and end of the 
batch, and if phases are present, also a Phase ID. You may also have a variable 
indicating the evolution of the batch or phase and its end point. This variable can be 
Time or Maturity. You can have different Maturity variables for different phases. 

Default unfitted models 

Unfitted batch evolution models are implicitly created by SIMCA. When batches have 
phases, each phase is fitted as one PLS class model with Time or Maturity as Y for 
each phase. By default all variables in a phase are centered and scaled to unit variance. 

Fitting the model 

Click Autofit with the BEM marked to fit all models at once. 

Reviewing the results 

Display the results of the analysis of the workset batches in the Analysis Control 
Charts group on the Batch tab, either as scores, DModX, Hotelling’s T2Range, 
predicted time or maturity, or as individual variables. 

Predictions 

More datasets can be imported with new batches. The predictions can also be displayed 
in Batch Control Charts in the same way by selecting the plot from the Prediction 
Control Charts group on the Batch tab. 
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Batch level 
The batch level dataset is based on scores, original variables, or statistics of the 
original variables for completed batches, obtained from the BEM. The model created 
from these batch level datasets is named batch level model, BLM. 

Creating batch level dataset 

Create the batch level datasets by clicking Create Batch Level, in the Dataset group, 
on the Batch tab. Specify the properties of the batch level datasets to create.  

Creating batch level model 

Clicking Finish in the Create Batch Level Dataset wizard opens the Workset dialog 
with the Create a batch level model check box selected. Here you can select any 
batch conditions and batch level dataset created from the same BEM. To import batch 
conditions, click File | Import Dataset. 

You can change the default model type to any desired model type allowed by the 
workset specification. Alternatively specify hierarchical (Create Hierarchical Batch 
Models on the Batch tab) or partial (select the Create partial models for each phase 
check box in the Workset dialog) models. 

Reviewing the results 

Display the results of the analysis of the workset batches in the Diagnostics & 
Interpretation group, on the Home tab.  

Predictions 

The batch evolution predictionset is automatically rearranged to a batch level 
predictionset. This means that to make predictions for a BLM you select data from 
batch evolution datasets and SIMCA takes care of the rest. 

Project window for batch projects 

The project window displays, for every model, one line summarizing the model results. 

When batches have phases the PLS batch class models (one for every phase) are 
grouped under an umbrella BEM. Both the BEM and BLM are grouped under an 
umbrella called BMxx, xx is a sequential number. 

  

Use the tutorial to get a guided tour for 
building PC and PLS models.  
  

  

Find the tutorial in Downloads on www.umetrics.com. 
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Introduction to multivariate 
data analysis 

Introduction 
This chapter gives an introduction to multivariate data analysis of regular and batch 
processes. 

Content 

 Process data analysis 

 Batch data analysis 

 Traditional data analysis: One or two variables at a time 

 Multivariate approach 

 Conclusion 

Process data analysis 
Any investigation of a real process or system is based on measurements (data). Fifty 
years ago, measurement devices were expensive and few, and consequently the amount 
of data, measured on processes, was limited; a temperature and a pressure here, a flow 
rate there. The monitoring, display, and analysis of these few data was relatively 
simple, and a few running charts of the data provided all available information about 
the state of the process. 

Today, batteries of sensors and on-line instruments are providing data from all parts of 
the process in various forms, often at very short intervals. The masses of data are fed 
into computers, re-computed into moving averages (per minute, hourly, daily, weekly, 
etc.) and displayed and stored. 

This change from a situation with few, fairly infrequent measurements, to many, 
almost continuously measured variables has still not affected the manner in which 
process data are treated, potentially leading to large losses of information. With 
appropriate multivariate analytical methods, such as Principal Components (PC) and 
Projection to Latent Structures (PLS) modeling in the SIMCA package, the masses of 
process data can provide easy to grasp graphical information about the state of the 
process, and relations between important sets of process variables. These multivariate 
methods make efficient use of all pertinent data, with little loss of information. 
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Process data properties 
Before going into the analysis of process data, it may be useful to discuss their nature. 
The data are usually measured at regular intervals over time; say every day, every 
hour, or every minute. These intervals are often different for different variables. We 
can recognize five categories, types, of process data: controlled process variables, 
result variables, characteristics of raw material, intermediate result variables, and 
uncontrolled variables. The variable types are described in the text that follows. 

Controlled process variables 
Related to the controlled setting of the conditions of the process, these are variables 
that, in principle, can be changed, thereby affecting the results, the output, of the 
process. We shall denote the values of these variables by xik (observation i, variable k). 

Examples of such variables are: 

 T1, T2: the measured temperatures in reactors 1 and 2. 

 P1, P2: the pressures in reactors 1 and 2. 

 f12: the flow rate from reactor 1 to reactor 2. 

Result variables 
The availability of multivariate result variables (output, responses) measuring 
important properties of the products coming out of the process dramatically increases 
the possibilities to better understand and optimize a process. The result variables, are 
denoted yim (data point i, y-variable m). 

Examples of such variables are: 

 yi1 = yield of main product (%). 

 yi2 = impurity level (%). 

 yi3 = amount of side product no. 1 (%). 

 yi4 = tensile strength of product. 

Characteristics of raw material 
The characteristics of the raw material (inputs) are also denoted by xik. These variables 
are often of great importance for the process and the product properties, but usually 
difficult or impossible to control. 

Examples of such variables are: 

 Concentrations of iron, coal, nickel and vanadium in feed. 

 Fiber length distribution in input pulp. 

 Gas chromatographic and spectroscopic (NMR, IR, etc.) analysis of feed 
stock. 

Intermediate result variables 
Intermediate result variables are denoted by xik, yim, or zit. 

Examples of such variables are: 

 Viscosity of output from reactor 1 (=input to reactor 2). 

 Concentration of oxygen in output from reactor 1. 
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Uncontrolled variables 
Uncontrolled variables are denoted by xik, or zit. 

Examples of such variables are: 

 Air humidity, temperature of cooling water. 

 Amount of oxygen in sparging nitrogen. 

The purposes of measuring the data on the process and its input and environment are 
to: 

 Provide information allowing a better understanding of the process, 
relationships between different parts of the process, which chemical or other 
reactions occur inside reactors, etc. 

 Yield information about the "state" of the process, recognizing trends, 
peculiarities, etc., all to keep the process under proper control. 

 Discover how the output is affected by the process and input variables in 
order to improve product quality and minimize manufacturing costs, 
pollution, etc. 

Batch data analysis 
With batch processes, K variables are measured on N batches at regular time intervals. 
This gives a J x K matrix for each batch (J time points (X) times K variables). 
Consequently, a set of N normal batches gives a three-way matrix of dimension (N x J 
x K). 

Variables

Batches

Time

One batch

 
  

Figure 1: Three-way table of historical data of, for example, N batches with J time 
points, and K variables. Often the batches have different length (not shown in the 
picture) and may also be divided in phases. 
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Batch data properties 
One of the differences between batch data and process data is that the batch process 
has a finite duration. Each batch can also go through several phases before completion. 

Since the batch data are collected batch wise they need reorganization before 
importing. 

Reorganization of 3D table before import 
To be able to import the dataset, the 3-way data table has to be unfolded to preserve the 
direction of the K variables (see figure 2). The resulting matrix has nobs = N x J 
observations (rows) and K columns. Hence this matrix, X, has the individual 
observation as a unit, and not the whole batches. 

B1

B2

X Y

Time

B3

…

Bn

Variables

Batches

Recorded variables:
Ethanol,
Temperature,
Molasses flow,
NH3 feed,
Air flow,
Tank level,
pH.

 
Figure 2. The three-way matrix of figure 1 unfolded along the batch direction to give a 
two-way matrix with N x J rows and K columns. Each row has the data (xijk) from a 
single batch observation (batch i, time j, variable k). 
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Traditional data analysis: One or two variables at a 
time 

To gain insight into the state of a process it is common to display important variables 
and their change over time (figure 1). This works fairly well with up to 5 to 10 
variables, but thereafter becomes increasingly difficult to comprehend. Furthermore, 
these "time traces" reveal little about the relationships between different variables. 

 

 
Figure 1. Two of the variables plotted against time on horizontal axis. 

Scatter plots of pairs of variables are common complements to time traces (figure 2). 
One hopes to identify correlations, thereby identifying important process variables 
causing changes in the output variables. 

The basic problem with pair-wise scatter plots is that they provide little information 
about the real relationships between, on the one hand, input and process variables, and, 
on the other hand, output variables. This is because the output (y) is influenced by 
combinations of the input and process variables (x). 

 



User Guide to SIMCA 

18 

 
Figure 2. Scatter plot of y8* (impurity) against x2in (one of the inputs). 

Multivariate approach 
With multivariate methods, one can investigate the relations between all variables in a 
single context. These relationships can be displayed in plots as easy to understand as 
time traces and pair-wise scatter plots. 

The methods for multivariate process data analysis included in SIMCA are PC analysis 
and modeling, PLS modeling, OPLS modeling, O2PLS modeling and more. The 
principles and mathematics of the fit methods are briefly described later in the 
introduction, and more thoroughly in the statistical appendix. References are also given 
to additional pertinent literature. 

Here we will indicate how to use these methods to solve typical problems in process 
data analysis. 

Summarizing a set of process variables 
Data measured on a process are usually stored in some kind of database. A process 
database containing the values of K variables for N data points can be regarded as a 
table, a matrix. We denote the whole table by X. Each column in the table corresponds 
to one variable (xk), and one row (xi) corresponds to the values observed at one point in 
time. 

Inputs or outputs or both can be displayed in multivariate control charts. 

Summarizing batch data 
Data measured batch wise are also often stored in some kind of database. One of the 
differences between batch data and process data is that the batch process has a finite 
duration. Each batch can also go through several phases before completion. 

Inputs or outputs can be displayed in batch control charts. 
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PCA - Principal Component Analysis 
Principal component analysis of a data table gives vectors of scores, with values tia, 
which summarize all the variables entering the analysis. It is customary to calculate 
two or three score vectors, and then plot them against each other (tt-plots). This gives a 
picture that is the best summary of the process behavior over time! In this plot we can 
see trends, unusual behavior and other things of interest. With experience, one will be 
able to recognize an area in this PC score plot in which the process remains under 
"normal" operation, thus providing a multivariate control chart. 

The score plot in combination with the loading plot, indicate the responsible variables 
for deviations from normal operation. 

The PCA also gives residuals, deviations between the data and the PC model, named 
DModX. When these residuals are large, this indicates an abnormal behavior in the 
process. To see this, we make a plot of the residual standard deviation, DModX 
(residual distance, root mean square).  

Observations with a DModX larger than the Dcrit are outliers. When DModX is twice 
Dcrit they are strong outliers. This indicates that these observations are different from 
the normal observations with respect to the correlation structure of the variables. 

PLS - Partial Least Squares Projections to Latent 
Structures 

Relating the result variables to input and process variables 
A common problem is “process diagnostics”. That means identifying those input and 
process variables, X, that are “responsible” for the change in output variables, result 
variables, Y. For this purpose, one often attempts to use multiple regression, which, 
however, leads to great difficulties because process data usually do not possess the 
correct “properties” for regression modeling. In particular, regression deals with each 
result variable (ym) separately, and one therefore ends up with a set of models, one for 
each output of interest. This makes interpretation and optimization difficult or 
impossible. 

To allow strict interpretation of "cause and effect", the data should be collected in a 
careful experimentation using statistical design (with software such as MODDE). To 
search for relationships between input and output in process logs is risky and often less 
successful. This is because a process does not provide data with good information 
content when the important factors are well controlled within small "control intervals". 

PLS - Scores 
PLS modeling has been developed explicitly for this type of situation with numerous, 
often-correlated input and process variables and several to many result variables. One 
just specifies which variables in the database that are predictors (X), and which 
variables are dependent (Y), and PLS finds the relation between the two groups of 
variables. 

The PLS model is expressed as a set of X-score vectors, Y-score vectors, X-weight and 
Y-weight vectors, for a set of PLS model dimensions. Each dimension (index a) 
expresses a linear relation between an X-score vector (ta) and Y-score vector (ua). The 
weight vectors of each model dimension express how the X-variables are combined to 
form ta, and the Y-variables are combined to form ua. In this way the data are modeled 
as a set of "factors" in X and Y and their relationships. Plots of the scores and weights 
facilitate the model interpretation. 



User Guide to SIMCA 

20 

PLS - Loadings 
The PLS analysis results in model coefficients for the variables, called PLS-weights or 
loadings. The weights for the X-variables, denoted w, indicate the importance of these 
variables, how much they “in a relative sense” participate in the modeling of Y. The 
weights for the Y-variables, denoted by c, indicate which Y-variables are modeled in 
the respective PLS model dimensions. 

When these coefficients are plotted in a w*c plot, we obtain a picture showing the 
relationships between X and Y, those X-variables that are important, which Y-
variables are related to which X, etc. 

PLS - Residuals 
Analogous to PC, PLS gives residuals, both on the Y-side and on the X-side. The 
standard deviations of these (residual distances) can be plotted just as for PCA to give 
a third "SPC" plot (Statistical Process Control) showing if the process is behaving 
normally or not. 

OPLS and O2PLS - Orthogonal Partial Least Squares 
OPLS is an extension of PLS and addresses the regression problem. OPLS separates 
the systematic variation in X into two parts, one part that is correlated (predictive) to Y 
and one part that is uncorrelated (orthogonal) to Y. This gives improved model 
interpretability. In the single-Y case, there is only one predictive component, and all 
components beyond the first one reflect orthogonal variation. However, with multiple 
Y-variables there can be more than one predictive OPLS component. 

O2PLS is yet another extension of PLS and addresses the data integration problem. 
Thus, in the two-block (X/Y) context, O2PLS examines which information overlaps 
between the two data tables and which information is unique to a specific data table (X 
or Y). O2PLS accomplishes this task by a flexible model structure incorporating three 
types of components, that is,  

(i) components expressing the joint X/Y information overlap,  

(ii) components expressing what is unique to X, and  

(iii) components expressing what is unique to Y. 

For both OPLS and O2PLS the different components are interpretable the usual way, 
since the scores, loadings, and residual-based parameters with a familiar meaning are 
preserved. 

Batch modeling in SIMCA 
A SIMCA batch project consists of one or more batch evolution models, BEM, and 
optionally one or more batch level models, BLM: 

1. The BEM has several observations per batch with the variables measured 
during the evolution of the batch. Batch evolution models are commonly 
applied for real time process monitoring. 

2. The BLM consisting of the completed batches, with one batch being one 
observation (matrix row). The variables of the BLM are the scores, original 
variables, or summary variables (statistics of the original variables) of the 
BEM at every time point folded out side-wise. Batch level models are 
commonly applied to investigate variations between batches, sites, 
campaigns or to study impact of process variations on product quality. 
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A BM, sequentially numbered, holds the BEM and the BLM-models built on datasets 
created from that BEM. 

Batches may be divided into phases. 

Batch evolution modeling 
When importing the dataset in SIMCA, an index y-variable starting at 0 is constructed 
if no maturity is specified. This is the "relative local batch time".  

The default model, after completed import in SIMCA, is a PLS model for the centered 
and scaled X and y, or "relative local batch time" as y if no other y was specified. If a 
maturity variable, recorded relative to the start of each batch, was defined as y, it is the 
variable used as y. 

When fitting the batch evolution PLS model, “Autofit” will stop when 85% of X has 
been explained, but will also give at least 3 components, as long as the number of 
components does not exceed number of variables/2. This is necessary in order to 
ensure that much of the X-matrix is "explained". This results in an (nobs x A) score 
matrix, T, plus PLS weight and loading matrices W and P (of dimensions K x A). 

Modeling the evolution of batches in the workset 

At the start of a batch project, when phases are present, the BEM workset is created 
with an unfitted model for every phase. The BEM is the wrapper grouping all the PLS 
class models (one for every phase). Maturity or time, as specified for each phase, is 
used as Y, the other variables as X, and all are centered and scaled to Unit Variance. 

When batches have no phases, there is only one model in the BEM, with time or 
maturity as Y and all other variables as X, centered and scaled to Unit Variance. 

   

Note: A model is positioned in a BEM only when the data was imported as 
batch and it is a PLS model with Time or Maturity specified as y-variable. 

To fit the model(s), mark the BEM and click Autofit. 
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The BEM is built on the good batches when the goal is to define a process monitoring 
model with the ideal evolutionary trace. Around this trace, 3 SD limits are used to 
define the acceptable variation. 

Examine the batch evolution models using the Batch control charts (BCC), starting 
with the Variable BCC to ensure that the process data is good and reliable for all 
batches. Look for outlier batches in batch control chart scores and/or the DModX plots. 
Interpret deviating batches with contribution plots. 

Batches with different length 

Alignment of data is done differently depending on configuration of the time/ maturity 
variables. For batches of similar length the impact is small. The default y configuration 
aligns the batch length by cutting the longer batches at median (or average) batch 
length. Batches that are shorter than the median (or average) batch, are filled up with 
the last value up to the median batch length.  

The used length in average batch is the shorter of the median batch length and the 
average batch length rounded down. 

Batches with several phases 

When batches have several phases, observations are organized in classes, one class for 
every phase. Separate PLS class models are fitted for every phase. 

Smoothing the maturity variable 

If a maturity variable is used as the response variable Y, indicating the degree of 
completion of a phase, the maturity variable has to be strictly monotonic in a given 
phase, but can be ascending or descending. 

Different phases can have different maturity variables. Different phases can have 
ascending or descending maturity. 

When maturity variables are not strictly monotonic, they are smoothed within each 
phase. The smoothing is done by fitting a constrained quadratic polynomial, using a 
piece wise least squares algorithm. This is to ensure that the maturity is strictly 
monotonic within a phase. The smoothed maturity is used by default, both as the 
response variable Y, and for alignment. 

Result variables 

The score matrix T is a good summary of X, and PLS focuses this summary on y (local 
time). Hence the first column of t (t1) will contain strong contributions of those X-
variables that vary monotonously with y, i.e., either increase or decrease with time. 
The second component (t2) is an aggregate mainly of those variables that change 
“quadratically” with time, i.e., first go up to a maximum, and then decrease, or first go 
down, and then up. The third component catches the variables having a cubic behavior, 
etc. 

The value of "local time" predicted by the PLS model (with the number of components 
determined by cross validation ), ypred, is very suitable as a "maturity index" that can be 
used to indicate how far the batch has evolved, if it is ready for termination, etc. 
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Calculating limits to build control charts 

To monitor the evolution of new batches, one calculates the typical evolution trace of a 
normal batch in terms of the scores, DModX, etc. This is in short done as follows: 

1. Reorganization: First the scores of the BEM are chopped up and 
reorganized so that the scores of one batch form one row vector (t1 followed 
by t2, followed by t3, etc.) in a matrix ST. This matrix has N rows (one per 
batch) and A x J (AJ) columns from the A score vectors and the J "time 
points" per batch. When batches have phases, the scores of each batch are 
collected from the different PLS phase models and the calculations are done 
separately for the different phases. 

t1

Batch
Average

StDev

Avg + 3 sd

Avg – 3 sd

Time
 

Figure 4. The score values for each batch are arranged as row 
vectors under each other, giving an N x (J x A) matrix, ST. Above we 
see only the first part of ST corresponding to the 1st component (t1). 
From this matrix one calculates the averages and standard deviations 
(SDs) of the matrix columns, and then control intervals as the 
averages  3 SD. 

2. Calculating tolerance limits for score batch control charts: Now the 
matrix ST is used to derive minimum and maximum tolerated values at each 
time point (j) of tj1, tj2, tj3…, tjA from the column averages and standard 
deviations of ST, as indicated in figure 4. In MSPC one would typically use 
tolerance intervals of the average  3 SD at each time point. Hence, we now 
have for each score vector an average trace with upper and lower tolerance 
limits (figure 4). This specifies the normal evolution traces, one for each 
score component, of new batches. 

3. Calculating tolerance limits for y predicted batch control chart: An 
additional trace is constructed from the values of predicted y (local time or 
maturity), for each time point of each batch. The predicted y-values should 
be fairly close to the "real" y-value for a batch evolving at the "normal" rate. 
SIMCA forms a matrix RY with the traces of predicted y of each batch as 
rows, and then analyzing it in the same way as ST above, and gives tolerance 
intervals of ypred for each time point. 

4. Calculating tolerance limits for DModX batch control chart: An 
additional trace is constructed from the values of the residual standard 
deviation (distance to the model, DModX), for each time point of each batch. 
The residual standard deviation (DModX) is calculated from the 
residuals, i.e., after subtracting ti x P' from the scaled and 
centered observation x-vector. For an observation to be judged OK (non-
deviating), DModX should be smaller than a critical limit, Dcrit calculated 
from the F-distribution. 

Note: When batches have phases, the limit calculations are done by phase. 



User Guide to SIMCA 

24 

Monitoring the evolution of new batches 

The batch evolution data of new batches are inserted into the PLS model, giving 
predicted values of the score values t1 to tA. These results can now be plotted in the 
appropriate batch control charts, with limits derived as described in Calculating limits 
to build control charts. These charts indicate whether the batches are starting 
normally or not. If the values are outside the normal ranges, contribution plots based 
on the x-values or the residuals indicate which variables together are related to the 
deviations. 

In addition, the PLS model gives predicted values of y (local time or maturity index). 
Plotting ypred vs. yobs gives a very interesting indication of whether the batches are 
developing too quickly (over-mature, ypred > yobs) or too slowly (under-mature, ypred < 
yobs). 

When batches have phases, the appropriate PLS phase model is used to predict the t 
scores of every phase. The scores are collected for every batch and results are plotted 
in the control charts. 

Batch level modeling 
This section describes modeling of entire batches as observations (rows) using batch 
level modeling. 

Why batch level modeling? 

Batch level modeling may be advantageous in the case that the measurement of Y is 
laborious and time consuming, and one wishes to make an initial fast quality 
assessment before the real Y is available. This is often the case in biotechnological 
production, where extensive analysis and testing of the final products is made before 
acceptance (or rejection). 

The batch level model (BLM) also allows the full interpretation of the batch data. 
Groups of batches may be discovered, outliers will be found, etc. Critical time periods 
will be indicated by "periods" of large weights, loadings, and VIP values. Analogously, 
important factors in the batch conditions will stand out.  

Creating the batch level model 

The batch level model can be created based on scores, original variables, summary 
variables (raw data statistics), duration and endpoint, plus batch conditions (Z). 
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Modeling batch level 

The objective of batch level modeling is to make a model of the whole batch in order 
to understand how Y is influenced by the combination of batch conditions and the 
batch evolution. This model will be based on (when available) the batch conditions (Z), 
the evolution trace matrix ST, and when applicable the properties and quality of the 
completed batch (Y), as shown in figure 5. The resulting model is used to predict Y for 
new batches from their batch conditions and their evolution traces. 

Back
ground

Data

Final
Results

Data

Scores t1, t2, t3
or

original variables

X Y

 
Figure 5: The data for batch level modeling. Each row has the data from one batch. 
The left matrix contains data describing initial batch conditions. The middle matrix 
contains the unfolded scores/raw variables, which describe the evolution of each 
batch. The optional right matrix (Y) contains the responses, the properties of the 
complete batch such as yield, purity, activity, etc. 

In the case that Y-values do not exist, the X-matrix can still be used to develop a 
PC model. We see that this is the same type of model as the X-part of PLS in the batch 
evolution model. The difference is that in PCA the scores (T) are calculated to give an 
optimal summary of X, while in PLS this optimality is somewhat relaxed to make T 
scores better predictors of Y. 

This PC model can then be used to classify new batches as normal (similar = well 
fitting to the PC model) or non-normal (far from the model). 

Predicting results or classifying whole new batches 

The batch level model is used to predict quality of the final batch (Y), or classify the 
batch as normal good batch or bad batch or predict their final quality. 

If you have fitted hierarchical models of the batch level data at different percentage of 
completion, you can classify or predict the final quality of new batches as they are 
evolving when they reach the percent of completion of the models. 

If the values are outside the limits, contribution plots indicate which variables together 
are related to the deviations. 

Create a batch level model 

When creating a batch level dataset, clicking Finish opens the Workset dialog with 
the Create a batch level model check box selected.   

Select the datasets to use and then use the other pages in the dialog for editing the 
workset as desired. Clicking OK in the Workset dialog creates the unfitted BLM. 

Note: Selecting and clearing dataset check boxes in the Select Data page 
result in resetting the workset. All variable and observation/batch settings are 
cleared along with any changes in transformations, lags, expansions, scaling 
and trimming and the result is the default workset. 



User Guide to SIMCA 

26 

Hierarchical batch models 

For batch level datasets you can fit hierarchical models of the whole batch, for 
different levels of completion: 

 One model for each phase and component in BEM. 

 One model for each phase. 

 Sequential models covering parts of the batch completion, for example for 
25%, 50%, 75% and 100% completion for models without phases. 

These models can predict the final batch quality or classify the batch, before the batch 
is finished. 

Conclusion 
Projection methods such as PCA, PLS, OPLS and O2PLS find the information in 
masses of process data by projecting these data down on a few "scores". These scores 
provide a very good summary of process data tables (X and Y), and score plots display 
this in an easy to grasp form. The coefficients of the projections, i.e., how the variables 
are combined to form the scores, are called loadings or weights. Their plots show the 
importance of the variables, their similarity, their connection, and other things of 
interest. 

The parts of the data not seen in the score plots, i.e., the residuals, are displayed (in 
summarized form) in the DModX and DModY plots (row residual standard 
deviations). 

For further reading, see the Multi- and Megavariate Data Analysis book and the 
reference list. 
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Overview of SIMCA 

Introduction  
This chapter describes the following: 

 Application icon and symbol. 

 SIMCA Projects. 

 SIMCA window interface. 

 Ribbon content. 

 Shortcut menu. 

 Conventions including limitations and missing values representation. 

 Presentation of SIMCA results 

Application icon and symbol 

 
The application icon is a purple circle with a white S inside (below). 

 

Projects 
Multivariate data analysis in SIMCA is organized into projects. You can think of a 
project as a file folder containing all the information related to the analysis of a number 
of datasets. Projects are default named after the first selected dataset in SIMCA import.  

This information is organized in the following components: 

 Datasets used for the analysis. 

 Other datasets used for predictions and model validation. 

 Workset and multivariate models. 
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Datasets 
For continuous processes, the data are observations made sequentially in time, usually 
at a constant sampling interval. Such data are called time series. In the analysis of time 
series, the observed outcome at time t is often modeled as a function of the previous 
observations at time t1, t2, etc. 

With PLS, the time series analysis is performed by creating lagged variables, i.e., 
variables shifted in time, and fitting the model. For PLS time series analysis to give 
correct results the observations must be contiguous in time (the sampling interval is 
constant), and with no missing observations. 

A batch process has a finite duration. Each batch can go through several phases before 
completion. Since the batch data are collected batch wise they need reorganization 
before importing. 

Workset 
A workset is a subset or all of the data in the selected datasets with a particular 
treatment of the variables, i.e., role (predictor variables X, or responses Y), 
scaling, transformation, lagging, etc. 

The workset is by default the first dataset with all imported variables and observations 
included and the variables centered and scaled to unit variance, for regular projects. 
For batch projects the default workset is all batch evolution datasets included when 
creating the project. 

When you define a workset, SIMCA creates an unfitted model, and both the model and 
the workset are identified by the same name. 

Models 
Models are mathematical representations of your process and are developed using the 
data specified in the workset and with a specified model type, for example, PCA-X, 
PCA-Y, PCA-X&Y, PLS, etc. 

With a specified workset, you may be able to fit several models by selecting different 
model types. For example, if you have specified a workset by defining the X-variables 
(predictors) and the Y-variables (responses), you may first fit a PC of the responses (Y-
block) and then fit a PLS model, by just selecting another model type. 

Models are created by SIMCA when: 

1. You specify a workset, New/New as Model. 

2. You make a selection under Change Model Type with a fitted model, 

You work with one model at a time, the active model. This model is marked in the 
Project Window and displayed in the caption of the Project Window while the 
project window is docked.  

There is always an active model. You may have several models open, but only one of 
them is active. 
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SIMCA window 
The SIMCA window consists of the ribbon with regular and context tabs, the quick 
access toolbar, and dockable windows. 
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SIMCA ribbon description 

 
Description of the ribbon using the terminology according to Microsoft: 

 The File tab, which presents a menu of commands that involve doing 
something to or with a document or workspace, such as file-related 
commands. 

 A Quick Access Toolbar, which is a customizable toolbar that displays 
frequently used commands. 

 Core tabs are the tabs that are always displayed. 

 Contextual tabs, which are displayed only when a plot or list is open, Tools 
and Layout or when items are marked in a plot or list, Marked Items. 

 Galleries, which are lists of commands or options presented graphically. A 
results-based gallery illustrates the effect of the commands or options instead 
of the commands themselves.  

 Enhanced tooltips, which concisely explain their associated commands and 
give the shortcut keys. Enhanced tooltips reduce the need for command-
related Help. 

 Dialog box launchers, which are buttons at the bottom of some groups that 
open dialog boxes containing features related to the group 

License information 
The Microsoft Office User Interface is subject to protection under U.S. and 
international intellectual property laws and is used by MKS Umetrics under license 
from Microsoft. 
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Ribbon 
Available functionality can be accessed through the SIMCA interface.  

 
The SIMCA interface includes: 

 the Quick Access Toolbar  

 the regular tabs File, Home, Data, Batch, Analyze, Predict, Plot/List, and 
View 

 the context tabs Tools, Layout, and Marked Items 

 and the Help menu. 

On the regular and context tabs the commands are parted in groups. Some of the 
groups have a dialog dispatch launcher which opens a dialog closely connected to the 
features in the group.  

For a short introduction see the sections that follow here. For more, see the respective 
chapters. 

Quick Access Toolbar 
The Quick Access Toolbar allows you to have your favorite commands easily 
accessible. By default it has: 

 The standard commands Save, Paste, Cut, Copy, Undo and Select All. 

 Find – Allows you to search in plots. 

File tab 
The following is available on the File tab: 

 New Regular/Batch Project – Creates new SIMCA projects after selecting 
a dataset in SIMCA import. 

 Open – Opens old project. 

 Save – Saves the current project. 

 Save As | Save Project As/Save Plot As/Save List As – Saves the current 
project/plot/list to the specified path and name. 

 Print | Print/Print Preview/Print Setup. 

 Manage:  
Encrypt – Encrypts the project using the user entered password.  
Compact Project File – Compacts the project file by removing selected 
parts from the .usp.  
Delete Project - deletes the current project. 

 Import Dataset – Imports selected datasets. 
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 Generate report - Creates a HTML report with the selected template or an 
existing report. 

 Close – Closes the current project. 

 Recent files - Lists the projects most recently opened. 

 Project Options button - Displays the current default options for the current 
project. 

 SIMCA Options button - Displays the current default options for SIMCA. 

 Exit - Closes the current instance of SIMCA. 

Home 
On the Home tab you can change the model type, fit the model and review the fit. Plots 
and lists to analyze the model are available from this tab. 

On the Home tab the following is available: 

Dataset group 

 Dataset – Lists and opens all available datasets. 

Workset group 

The workset is a working copy of the selected datasets with certain properties defined. 

Note: The datasets are NOT affected when you exclude variables/observations 
or by any other operation in the workset. 

In the Workset group the following is available: 

 Statistics | Descriptive Statistics – Displays statistics of selected variables 
of the active model. 

 Statistics | Correlation Matrix – Displays the correlations between the 
variables for the active model. 

 New – Creates the default workset consisting of the first listed dataset with 
the variables set as X or Y as specified at import, and scaled according to the 
specified scaling in Project Options. For batch all datasets imported when 
creating the project are included in the default workset. 

 New As – Creates a new workset as a copy of the selected model. 

 Edit – Opens the selected specified model for editing. If the model has 
already been fitted that model will be deleted and at OK a new unfitted 
model is created. 

 Delete – Deletes the selected workset, and consequently also the model. 

 Change Model Type - Displays the available model types:  

 Overview - PCA-X, PCA-Y, PCA-X&Y 

 Regression - PLS, OPLS, O2PLS  

 Discriminant analysis - PLS-DA, OPLS-DA, O2PLS-DA 

 Class - PCA, PLS, OPLS, O2PLS 

 Clustering - PLS-Tree 
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 Model Options – Available from the dialog box launcher (arrow beneath the 
Change Model Type arrow) and displays the options of the active model. 

Fit model group 

For the model or model group (CM/BEM): 

 Autofit – Autofits according to the autofitting rules. 

 Two First – Calculates the two first components. 

 Add – Calculates the next component. 

 Remove – Removes the last component. 

Diagnostics & Interpretation group 

Overview - Displays the 4 default plots X/Y Overview, Scores, Loadings, DModX. 

Summary of Fit: 

 Summary of Fit plot and list – Displays the cumulative fit over all variables 
for each component. 

 X/Y Overview plot and list – Displays the cumulative fit of all variables for 
each x-variable for PCA and each y-variable for PLS, OPLS and O2PLS. 

 X/Y Component – Displays the fit of a variable for each component. 

 OPLS/O2PLS Overview - Displays OPLS and O2PLS specific R2. 

 Component Contribution – Displays the contribution of a model 
component to the fit. 

Review the fit and investigate diagnostics: 

 Scores t1 vs. t2, Num vs. t1, etc. – Displays trends, groupings, outliers. 

 Loadings p1 vs. p2, w*c1vs. w*c2, etc. – Displays important variables, 
variable correlations. 

 Hotelling’s T2 – Displays a measure of how far each observation is from the 
center. 

 DModX for X or Y – Displays the distance from the observation to the 
model, by default after the last component. 

 Observed vs. Predicted – Displays the actual value versus that observation 
predicted by the model for the selected response (y) variable. 

 Coefficients – Displays the coefficient of the model for each response (y) 
variable cumulatively over all components. 

 VIP – Displays the overall importance of each variable (x) on all responses 
(Y) cumulatively over all components. 

Data 
On the Data tab the following is available: 

Modify Dataset group 

 Merge – Merges the selected datasets and deletes the second dataset 
(source). 
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 Split - Splits the selected dataset as specified in the dialog. Only available 
for independent datasets. 

 Transpose – Transposes the selected dataset and deletes dependent models 
and datasets. Not available for batch projects or dependent datasets. 

 Delete Dataset - Deletes the selected dataset and any dependent models and 
datasets. 

 Generate variables – Creates new variables as functions of the existing ones 
or from model results. 

 Local Centering - Import local centering or View already imported local 
centering data.  

Filters group 

 Spectral filters - Filters the selected dataset using the selected filter creating 
a dataset in the current project. The available filters are: Derivative (1st, 2nd, 
and 3rd derivative), Multiplicative Signal Correction (MSC), Standard 
Normal Variate (SNV), Row Center, Savitzky-Golay, EWMA, 
Wavelet Compression, Wavelet Denoising, Orthogonal signal correction 
(OSC) and chained filters. 

 Time Series Filters - Time series filters the selected dataset using Wavelet 
Compress Time Series and Wavelet Denoising/Decimation creating a new 
dataset in the current project.  

Summary group 

 Dataset Summary – Displays a summary of the performed filtering. 
Available for filtered datasets. 

 Missing Value Map - Displays an overview of a dataset with respect to 
missing values. 

 Trimming Overview – Opens an overview window of the trimming. Only 
available after trimming. 

 Spectra - Displays ObsDS, for the variables specified as X, of the selected 
dataset. 

Base Model group 

 Hierarchical - Specifies the current model as hierarchical base model 
creating a hierarchical dataset. 

 Non Hierarchical - Removes the hierarchical base dataset. 

Batch 

Analysis Control Charts and Prediction Control Charts groups 

 Batch Control Charts – Displays scores, distance to model, variable, 
Hotelling’s T2, or predicted y with limits in plots and lists for models and 
predictions (BEM only). 
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Time/Maturity group 

 Observed vs. Smoothed Y - Displays the maturity for selected batch in 
original and treated form (BEM only). 

 Unaligned vs. Aligned - Displays the selected vector for the selected batch 
aligned and unaligned (BEM only). 

Dataset group 

 Create Batch Level – Creates the batch level dataset according to the 
selections made by the user. Available with a BEM marked only. 

 Create Hierarchical Batch Models – Creates hierarchical batch models 
according the selections in the dialog. Only available for batch level 
datasets. 

Variable Summary group 

 Variable Importance Plot – Displays the overall importance of the variable 
over the whole evolution on the final quality of the batch. Available for BLM 
only. 

Analyze 

Analysis group 

 Biplot – Displays scores and loadings superimposed. 

 Inner Relation - Displays t1 vs u1, t2 vs u2 etc. 

 S-plots - S-plot, S-line, SUS-Plot display p in forms informative for OPLS 
with one Y. 

 Contribution – Displays variables likely to be causes for upsets in the score, 
DModX, Hotelling’s T2Range, or predicted response plots. 

 RMSECV - Indicates predictive power. 

 Y-Related Profiles - Coefficients rotated displaying the pure profiles of the 
underlying constituents in X using the assumption of additive Y-variables for 
OPLS and O2PLS. 

 Residuals N-Plot – Displays the residuals on the normal probability chart for 
the selected Y. 

Validate group 

 Permutations– Displays the validity and the degree of over fit for the 
model (only PLS). 

 CV-ANOVA – For assessing the reliability of the model. 

 CV Scores - Displays the cross-validated complement to the regular 
scores plot 

Clustering group 

 HCA– Displays the clusters from the cluster analysis in a tree diagram. 

 PLS-Tree - Displays the cluster analysis result using PLS-Trees.  
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Predict 
On the Predict tab you can select a predictionset, display the predictionset as a 
spreadsheet, and display the prediction results using the active model. 

The following is available: 

Specify Predictionset group 

 Specify – Defines the predictionset in the Specify Predictionset dialog. 

 As Dataset - Predictionset is the selected dataset.  

 As Workset - Predictionset is the current workset. 

 Complement Workset/Complement WS Batches - Predictionset is the 
observations/batches not included in the current model.  

 Class - Predictionset is the selected class. 

 Delete Predictionset - Deletes the selected predictionset.  

List group 

 Prediction List – Displays the predictionset, some predicted vectors such as 
membership probability, scores, and the predicted response for PLS models. 

Plots group 

 Y PS – Displays the predictions for the selected response (y). 

 Scores PS – Displays the predicted scores. 

 Hotelling’s T2 PS – Displays a measure of how far the predicted value for 
the observation is from the center 

 DModX PS for X or Y – Displays the distance from the predicted value for 
the observation to the model. 

 Predicted Control Charts – Displays the selected vector in the selected 
control chart: Shewhart, CUSUM, EWMA, or EWMA/Shewhart. 

 Contribution plots – Show variables likely to be causes for upsets in the 
predicted score, distance to model X, Hotelling’s T2Range, or predicted 
response plots. 

 Time Series - Displays the selected vector in a line plot. 

 Coomans' plot – Shows class separation for two selected models. 

 Classification List - Displays the classification of a predictionset with 
respect to all the class models. 

 Misclassification Table – Summarizes the number of observations, with 
known class belonging, correctly classified in class or PLS-DA models. 

Plot/List 
The Plot/List tab holds general facilities for plotting and listing model and prediction 
results. 
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The following types of plots are provided: 

Standard Plots group 

 Scatter Plots 

 Scatter 3D Plots 

 Line Plots 

 Column Plots 

 Lists 

Control Charts group 

 Time Series Plots 

 Control Charts 

Custom Plots group 

 Histogram  

 Normal Probability  

 Response Contour  

 Response Surface  

 Wavelet Structure 

 Wavelet Power Spectrum 

 Step Response Plot 

View 
On the View tab the following is available: 

Show/Hide group – Shows or hides the following dockable windows: 

 Audit Trail – Displays all actions taken in the project. 

 Analysis Advisor - Explains all plots on the Home tab. 

 Favorites – Holds a shortcut to selected plots, lists, and commands. 

 Item Information – Displays information about the marked items (points). 

 Marked Items – Displays the items, observations or variables, marked in a 
plot. 

 Model Window – Displays the model window of the active model. 

 Observations – Displays the observations in the active model. 

 Project Window - Displays the models of the current project in the Project 
Window. 

 Quick Info – Displays information about the marked observation or variable. 

 Variables – Displays the variables in the active model. 

 Status Bar – The Status Bar displays an explanation when positioning the 
cursor over a button. 
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 Full Screen - Displays the ribbon when clicking a tab but not otherwise. 

Add group 

 Add to Favorites – Adds the current plot or list to the Favorites window. 

 Add to Report – Adds the current plot or list to the HTML report supported 
by SIMCA. 

Window group 

Use the Window group to access the standard window commands. 

Tools contextual tab 
The Tools tab becomes available when opening a plot or list. The content is context 
sensitive. Changes introduced on the Tools tab apply to the active plot or list. 

Change Type group 

Change the plot type to 

 Scatter 

 Line 

 Column 

 List 

For batches: 

 Sources of variation - Converts the column plot to a sources of variation 
plot. Only available with BLM including one or more raw or score-variables. 

 Out of Control Summary - Displays the percentage outside the displayed 
limits. 

 Batch Control Chart - Available when the Out of Control Summary plot 
(OOC plot) is displayed and displays the batches in the OOC plot. 

For dendrograms 

 Create List - Displays the background to the plot. 

 Merge List - Displays the calculations behind the HCA dendrogram. 

Data group 

For the current plot or list the Data group: 

 Model - Displays the active model. 

 Comp - Displays the current component. 

 Batch - Displays the selected batches. 

 Variable - Displays the selected variable in for instance a BCC variable plot. 

 Observation - Displays the selected observations in for instance a spectral 
plot. 
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Properties group 

The Properties group contains features also available in the Properties dialog for the 
current plot or list. The Properties group displays the properties of the plot, list, or 
window 

 Color by - Applies the selected coloring. 

 Labels - Displays the selected labels. 

 Size by - Applies the selected sizing. 

 Dialog box launcher - Opens the Properties dialog. 

Highlight group 

 Select – Selection modes. 

 Find - Opens the Find dialog. 

 Series - Grays all but the series hovered. 

 Sort - Sorts lists, spreadsheets and column plots as specified.  

Zoom group 

 Zoom – Zooms according to the selected zooming type. 

 Zoom Out - Zooms out one step. 

Layout contextual tab 

Template group 

 Load - Switches to the selected template for all open and future plots. 

 Save as - Saves the current plot formatting to a plot formatting file. 

 Save as default - Saves the current plot formatting to the default plot 
formatting. 

 Open templates folder - Opens the folder where the custom templates are 
stored. 

 Restore Defaults - Restores the default template. 

Show group 

 Maximize Plot Area - Quick access to showing/hiding the header, legend, 
footer etc. 

 Header 

 Footer 

 Legend 

 Axis Titles 

 Axes 

 Timestamp 

 Regression Line - Displays the regression line and equation in the current 
plot. 
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 Resolve Coefficients - Available for hierarchical top models and results in 
coefficients for base models. 

Format Plot group 

 Format Plot - Opens the Format Plot dialog.  

Marked Items contextual tab 

Create from Marked Items group 

 Scatter - Creates a scatter plot holding only the marked items. 

 Line - Creates a line plot holding only the marked items. 

 Column - Creates a column plot holding only the marked items. 

 List - Creates a list holding only the marked items. 

Drill Down group 

Contribution plots 

 Point to Average Comparison 

 Group to Average Comparison 

 Point to Point Comparison 

 Point to Group Comparison 

 Group to Group Comparison 

Line plots 

 Plot XObs - Plots the marked observations X-part in a line plot using a 
numerical ID as x-axis if available. 

 Plot YObs - Plots the marked observations Y-part in a line plot using a 
numerical ID as x-axis if available. 

 Variable Trend Plot - Plots the marked variables in a line plot. 

Modify Model group 

 Exclude - Excludes the marked observations or variables. 

 Create new BEM and BLM without marked batches - Available after 
marking in a BLM score plot. Excludes the batches in the BEM, fits the 
BEM and automatically creates the new BLM. 

 Include - Adds the observations or variables to the unfitted model. Creates a 
new model holding only the included observations or variables if there is no 
unfitted model.  

 Class - Depending on what is marked No Class, Class, Create Class Models, 
Create OPLS-DA, and Create PLS-DA may be available enabling quick 
creation of class/DA models.  

Layout group 

 Labels - Displays the selected label on the marked points. 

 Hide - Hides the marked points. 
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 Show All - Shows all items. 

 Format Symbol - Opens the Format Plot dialog with the new Custom node 
enabling customizing the marked items style. 

 Format Label - Opens the Format Plot dialog with the new Custom node 
enabling customizing the marked items labels. 

Help 
Standard help menu providing access to the SIMCA help, the registration and About 
SIMCA dialogs. 

Shortcut menu 
Right-clicking any plot or list in SIMCA opens the context sensitive shortcut menu that 
includes general commands, such as Copy, Print, Format Plot, and Properties.  

Conventions 

Limitations in project names 
The project name length (including path) cannot be larger than 255 characters. 

Limitations in observation and variable identifiers 
Observation and variable identifiers (names) can be up to 256 characters long. 

The primary observation and variable identifiers must be unique. When importing 
more datasets you are forced to have unique primary identifiers. 

To be able to use a dataset as predictionset, the primary variable identifiers have to be 
identical to those of the model. 

Case sensitivity 
SIMCA is case insensitive. Lower or upper case in names will be displayed as entered, 
but for all comparisons lower or upper case are considered the same. 

Menu and tab reference syntax 
In this user guide we use the following syntax when referring to the File tab 
commands: 

 Click Tab | Command. An example: Click File | Save As | Save Project As. 

 On the Tab tab, click Command. An example: On the File tab, click New 
Regular Project. 

 Click Command on the Tab tab. An example: Click New Regular Project 
on the File tab. 

In this user guide we use the following syntax when referring to tab 
commands/buttons: 

 On the Tab tab, in the Group group, click Command. An example: On the 
Home tab, in the Workset group, click New. 
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 Click Command, in the Group group, on the Tab tab. An example: Click 
New in the Workset group on the Home tab. 

 Click Tab | Command | Menu item. An example: Click Home | Statistics | 
Descriptive Statistics. 

In this user guide we use the following syntax when referring to a tab/menu item or 
gallery item accessed by clicking a button: 

 On the Tab tab, in the Group group, click Button | Menu item. An 
example: On the Home tab, in the Diagnostics & Interpretation group, 
click Summary of Fit | X/Y Overview. 

 On the Tab tab, in the Group group, click Button, and then click Menu 
Item/Gallery Item. An example for menu: On the Home tab, in the 
Diagnostics & Interpretation group, click Summary of Fit, and then click 
X/Y Overview. An example for gallery: On the Home tab, in the 
Diagnostics & Interpretation group, click Scores, and then click Line.  

 Click Tab | Button | Menu item. An example for menu: Click Home | 
Summary of Fit | X/Y Overview. An example for gallery: Click Home | 
Scores | Line. 

Select and mark 
Select or Mark an item in plots, lists, or menus signifies clicking the item leaving it 
highlighted. 

Vector and matrix representation 
Capital letters signify matrices, for ex. X, Y, P, T. 

Letters typed in lower case signify vectors, for ex. x, y, p, t. 

Prime <’> represents that the vector is a row vector. For example, t signifies a column 
vector with the values found under each other while p’ signifies a row vector where the 
values are found after each other. 
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Missing values representation 
Missing values are represented by blank or space < >.  

You can select another value to also represent missing in the SIMCA import Options 
dialog, opened from the File tab in the SIMCA import, Missing Value field. 

Note that –99 is assumed to be a valid value in your data and therefore automatically 
changed it to –99.0001 to avoid confusion in the internal calculations in SIMCA. 

If -99 represents missing value, enter -99.0001 in the Missing Value field in Options 
in the SIMCA import. 

 

Consequences of missing values 
The present NIPALS algorithm works with missing data as long as they are relatively 
randomly distributed, i.e., do not occur with a systematic pattern. Otherwise the results 
of a model fitting can be very misleading. The default is to warn when the missing 
value content in an observation or variable exceeds 50%. 
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Presentation of SIMCA results 

Plots for publications 
To create and save a plot of user defined resolution suitable for publication, follow the 
steps below: 

1. Create desired plot in SIMCA and edit if necessary so that the plot has the 
desired appearance and content.  

2. File | Print; the Print dialog opens.  

3. Under Printer, Name: select Microsoft XPS Document Writer, OK, enter 
file name and save to preferred location.  

4. Download and install Converter for XPS Documents from 
http://www.openxml.biz/xpsconverter.html.  

5. Start the program, File | Open and select *.xps file.  

6. File | Convert to…, select Image Type (e.g. TIFF is required by many 
publishers) and Resolution (often a minimum of 300 dpi is required).  

7. Choose folder to save results in and click OK. 

Plots for reports 
For suitable formats to copy or save, use one of the Umetrics predefined, see the Save 
As subsection in the File chapter.  
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Quick Access Toolbar 

Introduction 
The Quick Access Toolbar is by default positioned at the top above the tabs and allows 
you to have your favorite commands easily accessible. The Quick Access Toolbar is 
standard in Windows software with ribbons.  

 
The Quick Access Toolbar in SIMCA default displays the following features: 

 Save - CTRL+S 

 Paste - CTRL+V 

 Cut - CTRL+X 

 Copy - CTRL+C 

 Undo - CTRL+Z 

 Select All - CTRL+A 

 Find – CTRL+F. 

Note: Undo is unavailable after adding or deleting rows/columns. 

Customizing Quick Access Toolbar 
You can add buttons to and remove buttons from the Quick Access Toolbar.  

Removing buttons from Quick Access Toolbar 
To remove a button from the Quick Access Toolbar: 

 Right-click the button and click Remove from Quick Access Toolbar. 

 Click the arrow to the right of the available Quick Access Toolbar buttons 
and clear the relevant check box. 
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Adding buttons to Quick Access Toolbar 
To add a button to the Quick Access Toolbar, right-click the button on the ribbon and 
click Add to Quick Access Toolbar. 

 

Moving the Quick Access Toolbar 
To position the Quick Access Toolbar closer to the workspace you can select to 
position it below the ribbon by clicking the Show Below the Ribbon in the Quick 
Access Toolbar menu. Click Show Above the Ribbon to move it back to its original 
position. 

Minimizing the ribbon 
To maximize the workspace you can minimize the ribbon so that it folds away like a 
menu. 

The Minimize the Ribbon command is available: 

 When you right-click a button in the Quick Access Toolbar. 

 In the Quick Access Toolbar menu. 

 When you right-click a button in the ribbon. 
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Find 
With an active plot, list or spreadsheet, Find enables finding items meeting selected 
criteria. 

The Find dialog is opened by clicking Find in the Highlight group on the Tools tab, 
by pressing CTRL+F or from the Quick Access Toolbar. 

 

 
In the table, the available items in the Find in, Find what, and Logical Expression 
boxes are listed. 

Find in Searches in Logical expressions 

Identifiers  The text or values of the selected 
identifier, primary or secondary, or 
all identifiers. 

For batches the secondary identifiers 
include the batch level IDs Phase, 
Maturity, Source, and Number, and 
the batch project IDs $BatchID and 
$PhaseID when available. 

For numerical identifiers:  

>, >=, <, <=, between, =, not 
equal. 

For text identifiers: 

begins with, ends with, 
contains, =, not equal. 

All Data  The vectors displayed on all axes. 
For the default score scatter plot, the 
search is done on both t1 and t2. 

>, >=, <, <=, between, =, not 
equal.  

Series 
Data  

The vectors that are selected as 
series. For 2D scatter, line, and 
column plots that means that the 
search is limited to the y-axis vectors 
while for the 3D scatter plot the 
search is limited to the z-axis 
vectors. For example, for the default 
score scatter plot, the search is 
limited to searching in the vector t2 
found on the y-axis. For lists, this 
option is the same as All Data. 

>, >=, <, <=, between, =, not 
equal.  

X Axis  The vector displayed on the x-axis. 
Available for plots only. 

>, >=, <, <=, between, =, not 
equal.  
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Find in Searches in Logical expressions 

Vectors The selected vector in Find what. 

When selecting Vectors in Find in: 

 The Find what box contains 
all vectors available for the 
type of vector displayed in the 
active plot or list, e.g. if the plot 
displays t1 vs. t2, the available 
vectors are all vectors of data 
type Variables and Scores. 

 The Vector Details section 
becomes available enabling 
selection of model. 

>, >=, <, <=, between, =, not 
equal.  

Text  The list as if all entries where text 
and marks the matching cells. 
Available for lists and spreadsheets 
only. 

begins with, ends with, 
contains, =, not equal. 

Note: To search in a variable, in the Find in box select Vectors and in the 
Find what box select XVar. Then in the X Terms box in the Vector details 
section, select the desired variable. 

Marking type 
There are three marking types: 

 Clear previous – clears the previous marking and marks according to the 
current criterion. 

 Union with previous – marks the items that satisfy the current OR the 
previous criterion but not both.  

 Intersection with previous – marks the items that satisfy both criteria, both 
the previous AND the current. 

The default marking type is Clear previous. 

Open the dockable window Marked Items (select the Marked Items check box on the 
View tab) to see the items previously and currently marked. For more, see the Marked 
Items subsection in the View chapter. 
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Using Find 
Here follows a step by step example of using the Find function. 

1. Open a plot or list. 

2. Click Find in the QAT. 

3. In the Find in box, select the category of the attribute. 

4. In the Find what box, select the attribute and then specify the criterion. 

5. Click the Mark All button and all objects in the plot or list satisfying the 
criterion are marked. 

6. Then switch criterion and select Marking Type to the union or intersection 
with the previously marked objects. The intersection will select among the 
objects already marked those that satisfy both criteria. The union marks 
objects that satisfy either criterion but not both. 
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File 

Introduction 
This chapter describes all features available on the File tab. 

The following commands are available: New Regular/Batch Project, Open, Save, 
Save As, Print, Manage (Encrypt, Compact Project File, Delete Project) Import 
Dataset, Generate Report, and Close. The buttons Project Options, SIMCA 
Options and Exit SIMCA are available at the bottom of the menu. The right-side of 
the menu lists Recent files. 

 

New - Creating a new project 
When creating a new project you have to select which type: New Regular Project or 
New Batch Project. The first time you create a new project, the default is New 
Regular Project. After that the type selected last time a project was created is the 
default.  

 
Click File | New Regular/Batch Project to open SIMCA import, select your data and 
create a new project. See the SIMCA import chapter for more. 



User Guide to SIMCA 

52 

Open - Opening an existing project 
Click File | Open to open an existing SIMCA project by selecting the corresponding 
SIMCA project *.usp-file. 

Each instance of SIMCA can only open one project while several instances of SIMCA 
can be open in parallel. 

Opening pre-13 projects 
Projects from SIMCA-P version 8.0 and earlier cannot be opened by this version of 
SIMCA, but you can import the *.sim file. 

Projects from SIMCA-P 9 to SIMCA-P+ 12 are automatically converted when opened. 
All models are refitted. 

Note: Datasets from SIMCA-P 9 to SIMCA-P+ 12 usp-files can be imported. 

Opening pre-13 filtered projects limitations 
When converting a filtered project the following functionality is unavailable in 
SIMCA: 

- Reconstruct.  

- Spectral Filters and Time Series Filters. 

- File | Import Dataset. 

Opening pre-13 batch projects 
When opening a batch observation level project, all connected batch level projects are 
listed and you can choose which one to convert resulting in a project with both the 
observation level models and batch level models. For more, see the Batch chapter.  

Batch projects have been reorganized to include both levels in the same project. The 
observation level model and dataset have been renamed batch evolution model and 
dataset, abbreviated BEM and BE DS, while the batch level model and dataset names 
remain batch level model and dataset, abbreviated BLM and BL DS. Both the BEM 
and the BLM are positioned in a BMx, where x is a sequential number. 

Save project 
To save the open project to the current name and location, click File | Save. 

Save As 
Under Save As you can select to save the active project, plot or list to a specific file 
name and path. 
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Save Project As 
To save the open project to a different name or location than specified when exiting the 
SIMCA import click File | Save As | Save Project As. 

Save Plot or List As 
To save the current plot or list to file, click File | Save As | Save Plot/List As. 

Plots can be saved as Enhanced Metafile (*.emf), Bitmap files (*.bmp), Jpeg files 
(*.jpg), or PNG files (*.png). 3D plots can additionally be saved as Encapsulated 
Postscript EPS (*.eps) and Scalable Vector Graphics SVG (*.svg) but not as (*.emf). 
Lists can be saved as Text File (*.txt), DIF Files (*.dif), or Matlab Files (*.mat). 

To save a plot: 

1. Display it and make sure it is active. 

2. Click File | Save As | Save Plot As. The Save Plot dialog is displayed. 

3. In the Size box you can choose between 
- Custom  
- A) 600x375 (Suitable for portrait (A4, US Legal, etc.)) 
- B) 300x300 (Square, fits two side by side) 
- C) 600x600 (Square) 
- D) 755x465 (Suitable for PowerPoint, one per slide) 
- E) 755x270 (PowerPoint, fits two above and below) 
- F) 370x465 (PowerPoint, fits two side by side) 
- G) 800x600 (4:3 format) 
- H) 1024x768 (4:3 format) 
- I) 1280x720 (16:9 format, HD 720) 
- J) 1920x1080 (16:9 format, HD 1080) 
- Original size 

4. In the dialog select the Keep aspect ratio check box to keep the proportions 
of the plot as on the screen (Original size) or according to a predefined plot 
size. 

5. Click OK when done.  

6. Select location, file name, and file type. Click Save. 

 
To save a list: 

1. Display it and make sure it is active. 

2. Click File | Save As | Save List As. The Save dialog is then displayed. 

3. Select location, file name, and file type. Click Save. 
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Print, Print Preview, and Print Setup 
The commands Print, Print Preview, and Print Setup are the standard printing 
functions available by clicking File | Print. 

Note: Plots are printed as viewed on the screen except when printing to a pdf 
writer. 

Manage 

Encrypt 
To encrypt and lock a project, click File | Manage | Encrypt. The Encrypt Project 
dialog opens and you are prompted by SIMCA to enter a password. 

 
After entering the password twice and clicking OK, the project is locked and can only 
be opened by providing the password. 

Compact Project File 
When compacting a project file, this is done by removing unnecessary data and 
optionally data considered unnecessary by the user. Compacting a project file is 
particularly useful when models or datasets have been deleted in the project.  

Click the File | Manage | Compact Project File to compact the project file. 

 
In the Compact Project File dialog, select which data to remove. The available 
choices are listed in the table. 

Note: Compact cannot be undone. The compacted project file is saved when 
clicking OK. 
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Delete Project 
To delete the current project, click File | Manage | Delete Project. 

   

Import 
To import more data to the current project, click File | Import Dataset. See the 
SIMCA import chapter for how to continue. 

For batch projects batch condition data can be imported at the same time as the batch 
evolution data or later using Import Dataset. 

Merging with another dataset while importing is not necessary as all relevant datasets 
can be selected in the Workset dialog and merged by primary ID on the fly when 
creating the workset.  

Generate Report 

Introduction 
SIMCA has an automatic report generator available by clicking File | Generate 
Report. 

In the report generator, basic formatting functionality for writing text is available. 

Plots, lists, and model results of SIMCA can be added to the report at any time. These 
items are added to the report as placeholders. 

A placeholder stands in the place of contents which SIMCA will provide; let it be a 
plot, list, text or number. 

The placeholders enable using the same report, as a template, in different projects. Edit 
the text, and just click Update report to update all SIMCA results using the active 
model. 

Note: To avoid updating a plot, you must remove the placeholder. For more, 
see the Tools menu in report subsection.  

For details about how to send a report by e-mail, see the knowledgebase at the 
Umetrics web site www.umetrics.com. 
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Starting to generate a report  
To create a report: 

1. Click File | Generate Report. 

2. In the Generate Report dialog select to: 

a. Create a new report selecting Create new using and selecting 
[Blank] or [Umetrics Default Template] or 

b. Open a report by selecting Open existing and selecting an existing 
report. 

3. Click OK. 

 

Generate Report window 
The report for the active model opens in a new window, the Generate Report 
window. This window is separate from SIMCA but is closed when SIMCA is closed. 
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The Generate Report window contains the following: 

 Menu bar holding the menus File, Edit, View, Insert, Format, Tools, and 
Help. 

 Generate report toolbar with commonly used commands. 

 Formatting toolbar with commonly used formatting commands. 

 Main window showing the report template. 

 Placeholders window with a list of built-in placeholders. 

 Report Generator FAQ window with a short introduction to how to use the 
report generator. 

 Properties window where plot size and placeholder properties can be edited. 

Default templates 
SIMCA has a default template for the following models: 

 PCA 

 PLS, OPLS, O2PLS 

 PLS-DA, OPLS-DA, O2PLS-DA 

 Batch 

Default template content 
The SIMCA default template consists of: 

1. Introduction and Objective (text to be filled by user). 

2. Description of the included datasets. 

3. Pre-processing such as spectral filters etc., if any. 

4. Model summary. 

5. Transformation and scaling. 

6. Goodness of fit. 

7. Model results. 

8. Predictions (plots and lists to be added by the user). 

9. Conclusion (text to be filled by user). 
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Appending to, inserting in, or replacing existing report 
With an open report, right-clicking a model in the Project Window and clicking 
Generate Report opens the following dialog: 

 
This enables: 

1. Appending the report updated for the active model to the current report by 
clicking append to existing report. 

2. Inserting the report updated for the active model to the current report at the 
caret position in the report by clicking insert at the caret position in the 
report. 

3. Replacing the existing report with an updated report using the active model 
by clicking replace existing report. 

Note: After selecting 1 or 2 above and clicking OK, the placeholders for the 
previous report are removed. 

Creating a report including several phases 
To generate a report for all the phases of the batch evolution model: 

 Right-click the BEM in the Project Window. 

 Click Generate Report. 

 Select the phases to include in the report. 

 Click OK to open the report. 
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Menu bar in report 
The menu bar consists of the File, Edit, View, Insert, Format, Tools, and Help 
menus. 

   

File menu in report 
Under the File menu the general Windows commands New, Open, Save As, Print 
Preview, Print and Exit are available. 

Additionally the report generator commands Continue edit with, Templates and View 
in browser are available. 

   

General windows commands 

The functions of the general windows commands are described in the table. 

Command Use to 

New Create a new report from the selected template or report. 

Open Open a report saved in HTML format. 

Save As Save the report in HTML format. The report is saved with 
placeholders and can be used as template. 

Print, Print Preview Print the report. Preview the report. 

Exit Close the report. 

Continue editing report with 

Continue to work with the report in the editor of your choice by under the File menu 
clicking Continue edit with, and then selecting the editor. The applications listed here 
are the applications that have registered with Windows that they can edit HTML text. 

Continue edit with is also available as a button in the Generate Report bar. 
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Templates 

Save templates, restore templates and add or remove custom templates by clicking 
Templates under the File menu. 

 Select Save as default template when you have changed/created a template 
according to your wishes and want to use it as the default template next time 
you generate a report for the same model type. 

 Select Restore default templates if you have made changes to the default 
templates and want to remove those changes. 

 Select Save as custom template when you have changed/created a template 
according to your wishes and want to save it to be able to use it again. 
Custom templates will be listed in the Select template or open existing 
dialog (File | Generate Report) and when clicking Insert | Template. 

 Select Add / Remove custom templates when you want to add an already 
created template or remove one of your custom templates. 

 

View in browser 

To view the current report in your default internet browser, on the File menu click 
View in browser. This works with Internet Explorer and Mozilla Firefox. 

  

Edit menu in report 
Under the Edit menu the commands Undo (CTRL+Z), Redo, Copy (CTRL+C), Paste 
(CTRL+V), Paste unformatted (CTRL+SHIFT+V), Clear (DELETE), Select All 
(CTRL+A), and Find (CTRL+F) are available. 

Paste unformatted is useful when the text copied is formatted. 

View menu in report 
Under the View menu, select to hide or show the Toolbars, Status bar, Placeholders 
window, and Properties window. You can also customize the toolbars, command 
menus and toolbar and menu options in Customize. 

 To show or hide the toolbars click Toolbars and then click Generate 
Report or Format. Both toolbars are displayed by default. For more about 
the toolbars, see the Generate Report bar and Format bar subsections later 
in this chapter. 

 To show or hide the Status Bar, click it. The Status Bar displays an 
explanation when positioning the cursor over a button. 

 Click Placeholders to display the window. For more see the Placeholders 
window subsection later in this chapter. 

 Click Properties to display the window. The properties of plots and images 
can be customized in the Properties window. For more see the Properties 
window subsection later in this chapter. 
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Insert menu in report 
Use the Insert menu to insert a Hyperlink, Image, File, or Template in the current 
report. Here you also can toggle the Grab plot or list mode. 

 

Hyperlink 

To insert a hyperlink, mark the text or plot in the report and then click Insert | 
Hyperlink. The following dialog opens: 

 
In the URL field, enter the hyperlink address. 

Insert Hyperlink is also available as a button in the Format bar. 

 

Image 

To insert a picture in the report, click Insert | Image, and then click the Browse button 
to find the file. 

 
Insert Image is also available as a button in the Format bar. 

 

File 

To insert a Web page file (*.htm, *.html), a Text file (*.txt), or a picture file (*.jpg, 
*.png, *.gif, *.bmp.), click Insert | File. In the Open dialog, select the file. 
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Template 

To select a template to insert in the report, click Insert | Template. In the Select 
Template dialog, select the custom template to insert in the report. 

 
For a template to be available in this dialog, it must first have been saved using File | 
Templates | Save as custom template. 

Grab plot or list 

To add a plot or list with one click, click Insert | Grab plot or list. This menu toggles 
the Grab plot or list mode. 

When the Grab plot or list is toggled on, hovering over a plot or list in SIMCA 

displays the cursor as a hand . This hand signifies that clicking the plot or list 
inserts (grabs) it at the insertion point in the open report. 

When done click the menu again to deactivate the Grab mode. 

Format menu in report 
Use the Format menu to customize Font and Styles and formatting when specifying 
your style sheet. 

 

Tools menu in report 
Under the Tools menu find the commands Update report, Update placeholder, Show 
all placeholders, Show placeholder, Remove all placeholders, and Remove 
placeholder. 

Command Result after selected 

Update report Updates all placeholders with the plots and lists of the 
active model. Update report is also available as a button 
on the Generate Report bar. 

Update placeholder Updates the marked placeholder. 

Remove all 
placeholders 

Removes all placeholders. Use this option when you do 
not want any items, plots, or lists to be updated. Remove 
all placeholders is also available as a button on the 
Generate Report bar. 

Remove placeholder Removes the marked placeholder. Use this option when 
you do not want a certain item, plot, or list to be updated. 

Show all placeholders Shows all underlying placeholders. 
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Command Result after selected 

Show placeholder Shows the underlying placeholder of the marked plot, list, 
or item. 

  

Help menu in report 
To access the FAQ of the report generator, click Welcome page and FAQ on the Help 
menu. The Report Generator FAQ window opens to the right. 

Generate report bar 
The Generate Report bar includes the general commands New, Open, Save, Cut, 
Copy, Paste, and Undo. All these commands work according to Windows standard 
except for the New command described here. 

The generate report bar additionally includes the commands Update placeholders, 
Remove all placeholders, Grab plot or list, and Continue edit with. 

 

New 
Click the arrow next to the New button and the following commands are displayed.  

 

 Click New from the menu displays the generate report dialog from which 
you can select which report/template to use or to open an existing 
report/template. 

 Click New blank report to start a new report with no text. 

 Click New from default template to create a report from the default 
template. Save a report as a default template by clicking File | Templates | 
Save as default template. Umetrics’ default template is used if no other 
template has been specified. 

Generate report bar additional buttons 
For info about the Placeholder buttons Update report and Remove all placeholders, 
see the Tools menu section. 

For info about the Grab plot or list button, see the Insert menu section. 
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For info about the Continue edit with button, see the File menu section. 

For info about the View in browser button, see the File menu section. 

Format bar 
The Format bar is the standard toolbar for formatting text with three additional 

buttons: Insert hyperlink , Insert image , and View in browser .  

For more, see the Insert menu and File menu sections in this chapter. 

Placeholders window 
The placeholder window is accessible through the menu View | Placeholders. 

The placeholders are organized into the following categories: 

 General 

 Model 

 Templates 

 

Inserting a placeholder 
To insert a placeholder in the report: 

1. Place the cursor in the desired position in the report. 

2. Mark the placeholder by clicking it in the Placeholders window. 

3. Click Insert. 

Placeholders window - General 
The general placeholders available are listed here with the expected result after 
clicking Insert and updating the placeholder. 

General HTML 

 Horizontal line - horizontal line. 

 Hard line break - line break as when pressing SHIFT + ENTER. 

General 

 Application name - 'SIMCA'. 

 Application version - 13'. 

 User name - the user name used to log in to Windows. 

 Computer name - the internal computer name. 

 Current date - today's date. 

 Current time - the time when updating the placeholder. 

 Project title - the name of the SIMCA project. 
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 Project file name - the SIMCA project name including extension, e.g. 
FOODS.usp. 

 Project path - the path to the SIMCA project file. 

 

Placeholders window - Model 
The model placeholders available are listed here with the result after clicking Insert 
and updating the placeholder. The placeholders refer to all included datasets. 

Numbers 

 Num. variables - number of variables included in the model when counting 
both X and Y. 

 Num. X variables - number of x-variables in the model. 

 Num. Y variables - number of y-variables in the model. 

 Num. excluded variables - number of excluded variables. 

 Num. observations - number of observations in the model. 

 Num. excluded observations - number of excluded observations. 

 Num. batches - number of batches in the model. Batch projects only. 

 Num. classes - number of classes. 

Text 

 Variable primary ID - lists all primary variable identifiers in the model. 

 X variable primary ID - lists the primary variable identifiers for x-variables 
in the model. 

 Y variable primary ID - lists the primary variable identifiers for all y-
variables in the model. 

 Excluded variable primary ID - lists the primary variable identifiers for 
excluded variables. 

 Included batch ID - lists the batch identifiers of the batches included in the 
model. Batch projects only. 
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 Excluded batch ID - lists the batch identifiers of excluded batches. Batch 
projects only. 

 Observation primary ID - lists the primary observation identifiers in the 
model. 

 Model name - lists the model name, e.g. M1. For batches, with the phase 
name, e.g. M1:chip. 

 Model title - lists the user entered model title. 'Untitled' if no title was 
entered. 

 Model type - lists the model type, e.g. PCA. For batches with the phase 
name, e.g. PLS-Class(chip). 

 Phase ID - lists the phase identifier of the active model. 

 Dataset names - lists the names of all datasets included in the model. 

Summaries 

 Dataset Import Log - the text from the import log. Can be viewed in 
SIMCA by opening the Dataset Properties, tab General. 

 Preprocessing Summary - the text in Data | Dataset Summary. Available 
for a filtered datasets. 

 Expanded terms - lists all expansions. 

 Lagged variables - lists all lags. 

 Transformed variables summary - lists the transformed variables and their 
transformation. 

 Scaled variables summary - lists the variables not centered and scaled to 
Unit Variance with their scaling. 

 Trimmed variables summary - lists the trimming performed in the workset. 

Results 

 Num. Components - lists the number of components extracted for the active 
model. 

 R2X, R2X(Cum), R2Y, R2Y(Cum), Q2, Q2(Cum) - lists the values for all 
components or cumulatively for the last component for the vectors. For 
details about the vectors, see the Function of component vectors section in 
Appendix A: Statistics. 

Note: The vectors are by default displayed for the last component. For how to 
display all components, see the Properties window 

Multi-plots 

 Auto-generated XVar plots - displays each x-variable in a separate line 
plot. 

 Auto-generated XObs plots - displays each observation in a separate line 
plot. Only the values for the x-variables are displayed. 

Using these placeholders it may take a long time to update the report. Press the ESC-
button to abort the multi plot update. 
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Placeholders window - Templates 
The Templates placeholders consist of model templates. 

Use the templates placeholders to insert a template into a report. 

 

Properties window 
The properties window is opened by clicking View | Properties. The properties for a 
placeholder are displayed when clicking the placeholder with the Properties window 
open. 

 
In the Properties window the following can be customized: 

 The Default plot size and format under Default Settings. 

 The Plot size and format for the current plot (placeholder) under 
Placeholder Properties. 

The format for plots is by default .jpg. The available formats are .png, .bmp, and .jpg. 

Placeholders for vectors can be modified to display a part of the vector or the entire 
vector. For instance, R2X is by default displayed for the last component. To display all 
components, type: 'R2X[{0}] =  {1}{separator: }<BR>' in the Data field. 

Note: The properties of the placeholder for the date can be changed by 
selecting it and using the Properties window. 
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Adding plots and lists to the report 
To add a plot or list to the report, click the desired position in the report and then use 
one of the following methods: 

 Right-click the plot or list window in SIMCA and click Add to Report. 

 On the View tab, in the Add group, click Add to Report. 

 Click the Grab Plot or List-button in the Generate Report window and 
click the plot or list. 

The plot or list is inserted into your report. 

Close project 
To close the current project and all its windows, click File | Close. 

Recent files list 
Recent files lists the most recently opened files.  

Clicking the pin to the right of the recently opened file makes the pin green and keeps 
that file in the recent file list even after it should have fallen off. 
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Project Options 
Options in SIMCA can be set at 3 levels: 

 Model Options – set at the model level and are local to that particular 
model. Some options can only be set in model options. New models inherit 
the options from the project level. For more about the model options, see the 
Model Options section in the Workset section of the Home chapter. 

 Project Options – set at the project level and are in effect for that project 
and all models created after applying changes. New projects inherit the 
factory settings options. To make new projects inherit the current project 
options settings, click the Save as General button in the General tab. 

 SIMCA Options - apply to the software. Changes in these options apply to 
all projects opened after the change. For more about the general options, see 
the SIMCA Options section later in this chapter. 

This section describes the Project Options dialog available as a button below the 
recent file list on the File tab. 

The Project Options dialog includes the tabs: Fit, Predictions, Distance to Model, 
Plot labels, Residuals/R2, Performance, Audit Trail and General.  

Fitting options 
The options available from the Fit page pertain to the fit of the model. 

 
 

All options are described in the table below: 

Option Description Default 

Cross 
validation 
rounds 

Each observation is left out once during the 
cross validation. The number in Cross 
validation rounds is the number of groups, that 
one by one is left out of the modeling and 
repredicted during the cross validation. 

7 
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Option Description Default 

Max 
iterations 

Maximum number of iterations until 
convergence when fitting the model. 

200 

Missing 
data 
tolerance 
(%) 

Threshold of missing values for observations 
and variables. The threshold applies to both the 
workset and the predictionset. 

The threshold is displayed in the Workset 
dialog and can be changed there for the specific 
model. 

50% 

Min number 
of non-
median 
values 

Minimum number of values that have to differ 
from the median. When a variable has fewer 
values differing from the median than entered in 
Min number of non-median values, SIMCA 
will suggest excluding the variable since it is 
considered to lack variance. 

3 

Confidence 
level on 
parameters 

Confidence level used when computing 
confidence intervals on the parameters. None, 
99%, 95% and 90% are available. 

95% 

Significance 
level 

Significance level used to compute the 
Hotelling’s T2 ellipse and the critical distance to 
the model. 

0.05 (95%) 

Default 
scaling 

Default scaling for X-block respective Y-block in 
the default workset. Changes here apply to the 
x-variables and y-variables defined as such in 
the default workset. 

UV 

Reconstruct 
wavelets 

When using the wavelet transform to compress 
the dataset variable wise (suitable for spectra 
such as NIR, or Raman etc.), SIMCA creates a 
new dataset and you can fit models to the 
compressed data. 

When variables have been compressed, the 
new variables are linear combinations of the 
original ones. Loading, coefficients, VIP or any 
plots displaying variables are difficult to interpret 
in the wavelet domain. Therefore it is possible to 
reconstruct not only the original variables, but 
also individual vectors such as 
loadings, coefficients, VIP, etc. 

By default 
the 
Reconstruct 
wavelets 
check box is 
selected, 
and all plot 
are 
displayed in 
the domain 
of the 
original 
dataset. 

Reset Clicking the Reset button returns all settings to 
the factory settings for this Project Options 
page. 

  

Note: To not display the Hotelling’s T2 ellipse or the D-Crit line, see the 
Limits and Line Style subsections in the Plot and list contextual tabs chapter. 
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Predictions presentation 
The options available from the Predictions page pertain to the presentation of the 
predictions. 

 

Transforming predictions 
When the y-variables have been transformed, by default the predictions are back 
transformed to the original units. Select the Transform predictions check box when 
you want to display the predicted Y in the transformed units. 

Scaling predictions 
To display the predicted Y in the same unit as the workset, select the Scale predictions 
check box. 

Trimming predictions as the workset 
When the workset has been trimmed or Winsorized, the predictionset can be trimmed 
or Winsorized in the same manner by selecting the Trim predictions as the workset 
check box. 

By default the predictionset is not trimmed nor Winsorized. 

Distance to the model plot options 
The options available from the Distance to Model page pertain to the presentation of 
the distance to model plots. 
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Normalized or absolute distances 
The distance to the model of X or Y, DModX or DModY, can be expressed as an 
absolute value or a normalized value i.e., in units of standard deviation of the pooled 
RSD of the model. 

The default is Normalized in units of standard deviation. 

Weighted by the modeling power 
When computing the distance to the model, SIMCA by default does not weight the 
residuals by the modeling power of the variables. Change this default by selecting the 
Weighted by the modeling power check box. The distance to the model will then be 
computed with weighted residuals. 

Selecting plot labels 
The options available from the Plot Labels page pertain to the presentation of labels in 
the plots. 

 
Select the identifier to be used as variable or observation label on all plots in the 
current project in the Select default variable/observation labels sections. Change the 
starting position and length as needed. 

To display a specific label type in the title of plots, select the identifier in the Title 
variable/observation labels box. 

These options are also available from the Properties dialog for the individual plots. 
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Selecting type of residuals and R2 
The options available from the Residuals / R2 page pertain to the presentation of 
residuals and R2 in plots. 

 

Raw or standardized residuals 
The normal probability plot of residuals is available on the Analyze tab by clicking 
Residuals N-Plot. This plot can be displayed both in original units and in standardized 
units. The standardized residuals are the unscaled residuals divided by their standard 
deviation. 

Select: 

 Raw – original units to display the unscaled residuals. 

 Standardized to display the standardized residuals (default). 

R2  
R2 is displayed in all summary plots but the OPLS/O2PLS Overview plot. 

Select: 

 R2 - explained variation to display the fraction of the Sum of Squares (SS) 
explained by the model (default). 

 R2 Adjusted - variance to display the fraction of variance explained by the 
model, SS adjusted for the degrees of freedom. 
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Performance improvement using data caching 
From the Performance page two types of caching is available: 

 Cache calculations in memory - by default selected and caches calculations 
to speed up the computations. 

 Cache dendrograms in the project file - by default selected and caches 
dendrograms to speed up regeneration of the dendrogram. 

Clear these check boxes if the project takes too much RAM. The software will then be 
slower but the memory consumption smaller. 

 

Administration of the audit trail 
The Audit Trail page holds settings and options pertaining to the audit trail. 

The audit trail can be turned on/off in SIMCA but for the audit trail to be 
automatically on or off for new projects it has to be turned on/off in the 
SIMCA import Options available on the File tab. 

An administrator can enable or disable the entire Audit Trail page and control the 
behavior of the Audit Trail, i.e., always on or off. 

As the administrator of the system, contact your Umetrics sales office for instructions 
on how to disable the Audit Trail page or search the knowledgebase at 
www.umetrics.com. 
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The options available from the Audit Trail page are described in the table below: 

Option/Button Description Default 

Log events to the 
Audit Trail 

When selected, the Audit 
Trail window logs all events 
in a session. 

For details about the audit 
trail, see the Audit Trail 
section in the View chapter. 

Note that to log all actions in 
the SIMCA import in the 
audit trail, you have to select 
Yes in the Log Events to 
the Audit trail in Options in 
the SIMCA import before 
opening the first dataset. 

By default the audit trail is 
disabled. 

Clear Audit Trail Clears the audit trail for the 
current project when clicked. 

  

Prompt new 
users to edit the 
extended user 
information 

When selected, new users 
are prompted to enter 
additional information. 

The Extended User Info is 
available in the More 
Options tab in File  | 
 SIMCA Options. 

By default not selected. 

Save Saves the audit trail to .xml 
when clicked. 
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General 
The General tab in Project Options allows you to save the current project options as 
global options or reset to factory settings. 

Save as General Options 
Changes in Project Options apply to the current project only. To use the current 
modified project options for new projects created in the future, click the Save as 
General button in the General tab, and click Yes to verify. 

 

Reset All Options 
To revert all changes in the Project Options dialog to the default (factory) settings, 
click the Reset All button in the General tab. 
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SIMCA Options 
The options available from SIMCA Options apply to SIMCA and not just the current 
project. 

The tabs available are General, Threading, Restore, Painter, and More Options. 
These pages are described in this section. 

SIMCA Options is available from the File tab, below the recent file list.  

General  
The General page includes default behavior when starting SIMCA, creating a new 
project, and fitting the model. 

 
All check boxes, starting from the top, are described in the table below: 

Option Description When Default 

Open last 
opened 
project on 
start-up 

Opens the last 
opened project 
when opening 
SIMCA. 

The project you worked with 
last is often the one you start 
off with. 

Clear this check box when 
working with very large 
projects, to avoid opening a 
project when planning to work 
with another. 

By 
default 
selected. 

Close the 
already 
open 
project 
when 
opening a 
new project 

The open project 
will be closed and 
the new created 
one will be the 
only open. 

When you want only one 
project open. 

Clear this check box if you want 
the current project to remain 
open. The new project is then 
opened in another instance of 
SIMCA. 

By 
default 
selected 

Show the 
summary 
plot while 
fitting 

When fitting a 
model, the 
summary plot is 
displayed. 

Clear the check box if you don't 
want to see the summary plot. 

By 
default 
selected. 
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Selecting multithreading 
In SIMCA certain calculations can use multithreading to speed up the calculations, if it 
detects that the computer has several processors or several processor cores. Threading 
can speed up calculations for large projects but will have little effect on small to 
medium sized projects. 

In the Threading page of the File | SIMCA Options dialog, threading can be turned 
on and off and the number of processors to use can be specified. 

 

Using multithreading 
In the Use multithreading section, select one of the following options: 

 Default – SIMCA checks if the computer has more than one processor and 
turns multithreading on if it does. In parenthesis the status is displayed as 
‘currently using…’ or ‘currently not using…’. 

 Always use multithreading – SIMCA uses multithreading without first 
checking for number of processors. 

 Never use multithreading – SIMCA does not use multithreading. 

Selecting number of threads 
In the Maximum number of threads section, select one of the following options: 

 Default - SIMCA threads using the number of processors found. That 
number is displayed in parenthesis. 

 Use x threads; enter the number of threads to use - This option is only viable 
when you want fewer threads than available processors to be used. 
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Restoring to default 
The Restore page in the SIMCA Options dialog can be used to restore SIMCA 
defaults by clicking the respective Restore buttons. 

 
The table describes the available restoring options. 

Restore Description Restoring is useful when 

Format 
Plot  

A file defining how all plots 
look, including fonts, 
colors, plot marks etc. 

See also the Switching 
plot formatting templates 
topic in the Layout 
chapter. 

The changes saved in the default 
plot template are no longer 
desired. 

Favorites A dockable window 
displaying shortcuts to 
plots and lists. 

The original Favorites items are 
desired. 

Windows 
Positions 

The positions of dialogs 
and windows are saved. 

A dialog ends up outside the 
screen, for instance when 
working with two screens and 
one screen is no longer available. 

Don't show 
again 
messages 

A Don't show again-
message is an information 
dialog with a Don’t show 
again check box that if 
selected hides the 
message the next time it 
could be displayed. 

You want to know what a Don't 
show again message said. 

 



User Guide to SIMCA 

80 

Selecting progress bar pictures 
The Painter page in the SIMCA Options dialog provides the option to display nothing 
or the work of a painter during fit of models. Under Progress Bar select your 
Preferred painter. 

Painters possible to select are Ando Hiroshige, Vincent van Gogh, William Turner, 
Diego Rivera and Pierre-Auguste Renoir. Selecting Random displays the work of all 
artists in random order. Selecting None turns this feature off. 

   
To create a collection of your own images to display on the progress bar, download the 
ArtBuilder from the support knowledge base at www.umetrics.com and follow the 
instructions included. 

More Options 
The More Options page displays and holds settings for default directories, plot 
options, printer options, tweaks, and the audit trail. 

 
In the table the options available in the More Options page are described. Each option 
can be changed by clicking the current entry and changing it. 
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Option name Description Default 

Default Directories 

Temporary 
Directory 

The path to the Temporary Directory, used by 
SIMCA to save temporary files, is displayed. 

A 
temporary 
directory in 
the 
Windows 
default 
temporary 
directory. 

Plugin Directory The path to the Plugin Directory, used by 
SIMCA to load plugins, is displayed. Plugins 
supported by SIMCA are generated variables, 
spectral filters, import, and item information. 

A plugin 
folder in 
the 
application 
data folder 
of the 
current 
user. 

Plot Options 

Remember 
coloring 

Remembers the coloring specified in Tools | 
Color by or in the Color tab of the Properties 
dialog, between plots. That is, after selecting a 
certain coloring in one plot, the next plot 
opened will use the same coloring scheme. 

Yes 

Remember 
sizing 

Remembers the sizing specified in Tools | Size 
by or in the Size tab of the Properties dialog, 
between plots. That is, after selecting a certain 
sizing in one plot, the next plot opened will use 
the same sizing. 

No 

Remember item 
selection 

Remembers the item selection specified by 
marking and clicking Hide on the Marked 
Items tab, or the Item Selection tab of the 
Properties dialog, between plots. That is, after 
making the item selection for one plot, the next 
plot opened will use the same item selection. 

No 

Remember label 
ID 

Remembers the label specified in Tools | 
Labels or on the Plot Labels tab in the 
Properties dialog. 

Yes 

Plot labels limit When the number of plot labels in a plot 
exceeds this number, no labels are displayed. 

500 

Automatically 
change active 
model 

The active model is automatically changed 
when clicking a plot created from that plot. 

No 

Plot engine Switch between GDI+ and Direct 2D. Direct 2D 
is not supported by Windows XP and Windows 
Vista might need an update.  

Direct2D 
when 
possible. 

Printer Options 
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Option name Description Default 

Print lists in 
color 

Colored lists will be printed in color on a color 
printer, or in different shades of grey on a 
regular printer. When Print lists in color is No 
the lists are printed black and white. 

Yes 

Tweaks 

Automatic find 
delay time 
(millisec.) 

When typing in an edit-field, for instance the 
Find field in the Workset dialog or the X 
Terms field when selecting XVar in the 
Plot/List | Scatter Plot dialog, SIMCA 
searches the list for a match. The time before 
starting this automatic find is defined in 
Automatic find delay time (millisec.). 

500 

Audit Trail 

Prompt for 
Extended User 
Info 

When set to Yes new users opening a project 
with audit trail turned on will be prompted to 
enter more user information than the default. 
The entered information can be viewed in 
Extended User Info in this dialog. 

No 

Extended User 
Info 

User entered information to be displayed 
alongside the default user information in the 
audit trail. 

<empty> 

Correlation Matrix 

Correlation 
matrix limit 

Increasing from the default allows displaying 
the correlations of more variables. 

32 

Exit  
To close SIMCA, click File | Exit. 
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SIMCA import 

Introduction 
When creating a new project or selecting to import another dataset, the SIMCA 
import opens allowing you to import from file, database or just paste the data in an 
empty spreadsheet. 

The first time you open the SIMCA import, the Open dialog for selecting a file is 
opened. 

The SIMCA import window consists of the ribbon, the quick access toolbar at the top, 
dockable windows and the Find toolbar. 
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File 
This section describes all features available from the File tab in SIMCA import. 

The following commands are available: New Spreadsheet, Open Workspace, Save 
Workspace, Save As, Print, and Close. The buttons Options and Cancel are 
available at the bottom of the tab. The right-side of the tab lists Recent files. 

 

New Spreadsheet 
The SIMCA import supports three types of import under New Spreadsheet:  

 From File - Opens a dialog where you can select file to import.   

 From Database. For more see the Importing data from a database 
subsection later in this chapter. 

 Blank - enables pasting in an empty spreadsheet. For details, see the Pasting 
dataset in import wizard subsection later in this chapter. 

Select any type of import by clicking File | New Spreadsheet | From File/From 
Database/Blank. Repeat until all data you want to import are available in SIMCA 
import. 

 

Note: The import type used is the default the next time you import. 
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Import from file 
When selecting to import from file, the Open dialog opens. This dialog is a standard 
dialog box for selecting file type, name and source address of the data file to import. 
The selected file type in the Files of type box is the default file type next time a file is 
imported. 

Note: The datasets in .usp files can be imported. 

In this dialog you can also select to downsize the dataset before reading by selecting 
the Downsize imported data check box, positioned bottom left. For details, see the 
Downsizing dataset before reading it subsection later in this chapter. 

File types supported 

In the Files of type list box, select your file type. SIMCA imports a number of file 
types. See the table. 

Supported Files is the default selected file type and results in that all files of the 
supported file types are listed. 

 

Note: For JCAMP-DX, NetCDF, Galactic SPC, and Brookside XML files, 
importing several files from the same folder, and merging without (exact) 
matching, is available by marking them and clicking Open. 

Downsizing dataset before reading it 

Reading large datasets may be time consuming. In the case where you plan to 
downsize the dataset, selecting to downsize before reading the dataset can reduce the 
time. 

To downsize the dataset before reading it: 

1. In the Open dialog, select the Downsize imported data check box, select 

the file, and then click Open.  

2. In the Downsize dialog: 

 In the Start after xx rows field, enter the last row to read before 
downsizing.  

 Enter the downsizing interval in the Keep every xx rows. 

3. Click OK when done. 



User Guide to SIMCA 

86 

 
Downsizing is also available after opening the file in SIMCA import. For more, see the 
Downsizing the dataset subsection later in this chapter. 

Importing data from a database 
To be able to use the database import utility in SIMCA, a data source and an interface 
to the data source already needs to be in place.  

There are three main interface types supported: 

 ODBC (Microsoft) 

 OPC (OPC Foundation) 

 SimApi’s.  

The SimApi is the API (Application Program Interface) connection that SIMCA-online 
needs to be able to connect to data sources. For instance OSIsoft PI and Siemens 
SIPAT have support for the SimApi interfaces.  

The database import supports several extraction methods:  

 Continuous - from a start time to an end time. 

 Batch - batches that exists in the system during a time interval. 

 Relational - a complete table in an ODBC data source. 

 SQL - an SQL query through the ODBC driver from the database vendor. 

In table 1, the different possible import combinations are shown. 

Table1: Different combinations of data connections and retrieval types supported. 

  Continuous Batch  Relational SQL 

ODBC  X X X X 

OPC  X       

SimApi  X X     

Since the configuration of some of these different combinations can be rather 
cumbersome, a SIMCA DataBase Settings file (*.sdbs) can store most parts of the 
configuration.  

For more information about the database settings file, see the SIMCA Database 
Settings file subsection later in this section. 



SIMCA import 

87 

Manage Data Sources 

In the Setup Data Sources page of the Database Import Wizard all data source 
connections are set up. 

 
Use the buttons above the data source list to: 

 Add new ( ),  

 Remove ( ) and  

 Test ( ) a data source connection.  

Data sources connection information is stored in the registry. There are three types of 
connections possible:  

 ODBC ( )  

 OPC ( )  

 SimApi ( )  

Unavailable connections appear gray. 

An example: The picture below displays an available SimApi data source, with three 
nodes, that is selected as one of the data sources to use when importing the data. 

 
When a settings file is available, it can be selected in the recent list, browsed to, or 
entered in the Database Settings file box.  
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ODBC - Add New Data Source 

To create an ODBC connection: 

1. Click Add new in the Setup Data Sources page. 

2. In the Add new data source dialog, select ODBC in Connection type box. 

3. Select the data source name (DSN) that you have set up in the Windows 
ODBC Data Source Administrator application.  

Note: Configuration of ODBC sources are driver specific, but can for 
instance contain log in information and server information. 

 

OPC - Add New Data Source 

To create an OPC connection: 

1. Click Add new in the Setup Data Sources page. 

2. In the Add new data source dialog, select OPC in the Connection type box. 

3. Browse to the network computer to connect to.  

4. Expand the network node to view all available servers on that computer. 
OPC servers with the historical data interface (HDA) are selectable.  
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SimApi - Add New Data Source 

To create a SimApi connection: 

1. Click Add new in the Setup Data Sources page. 

2. In the Add new data source dialog, select SimApi in the Connection type 
box. 

3. Browse for the SimApi DLL file.  

Note: The configuration is specific to each SimApi. 

 

Configure Data Source 

In the Configure Data Source page, the type of import (Continuous, Batch or 
Relational) and necessary tag (variable) definitions are specified. The Current 
configurations window to the right (see figure) will help and guide you through the 
configuration of the data source. 

The toolbar below consists of the following commands: collapse/expand node, 
continuous/batch/relational, sampling interval/set time stamp tag, set batch 
node/batch ID tag/start tag/stop tag. 

 
Figure A displays a SimApi that is set up as a Batch import with: 

 BAKERS YEAST BATCH as batch node ( ) 

 BAKERS YEAST as the process node ( )  

For the process node, the Batch ID ( ) has to be specified. 

The exclamation mark on the Data Source icon indicates that the configuration is 
incomplete. In the red text to the right we can see that the Sampling Interval to import 

data with has not been specified, and that the node EXPORT2 is not configured ( ). 

Before continuing the sampling interval has to be specified by clicking the Sampling 
Interval button. 
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Figure A. The Configure Data Source dialog for a batch import. 

 
Clicking the Sampling Interval button opens the Sampling Interval dialog. Enter the 
sampling interval to read data for the marked data source. 

Figure B: An OPC data source with two nodes set up correctly and an ODBC data 
source configured as a relational import. 

 

Select Tags to Import 

The tags, or variables, that will be imported are selected on the Select Tags to Import 
page. Also, the user has the possibility to set aliases on the tag names, group the tags in 

folders ( ) or add a data filter ( ) with a condition/logical expression on the tags 
that will be imported. 

In this page, SQL queries can be entered by adding a SQL query folder ( ). SQL 
(Structured Query Language) is a programming language to manage data in a database, 
however in Simpler we open the database as read only, which means that no alterations 
of the database will be introduced in the original database. 
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In figure C, the alias MyAlias was added to the tag (variable) “BATCH ID”. The same 
tag is also the batch identifier which can be recognized by its icon. The node 
“BAKERS YEAST” contains 8 tags and is a process node and the node “BAKERS 
YEAST BATCH” also contains 8 tags and is a batch node. 

Figure C. The Select Tags to Import page with alias specified. 

 
Bottom left in the dialog there is a text filter field enabling text search in the Available 
tags section of the dialog. The text filter searches in node names, in tag names and in 
aliases. 

In figure D, the word "BATCH" was used to filter the available tags and in the 
Selected tags for import part, two tags have been added. Note that these tags have the 
same name, but are different as they belong to different nodes. The tooltip for the tags 
contains node information. 

Figure D. The Select Tags to Import page after adding tags to import and with the text 
filter for "Batch". 
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Data Filters 

When adding a data filter, you have to specify a filter name, the logical expression for 
filtering and optionally a sampling interval. The data imported according to the filter 
are added to the SIMCA import in a new sheet named as the filter.  

If the Remove filtered tags check box is cleared, all data will be imported from the 
database and a new variable specifying which data, among these data, that satisfy the 
filter. 

When specifying the filter, each tag is referred to using the number in the dialog, not 
the name. When double-clicked, the tag number ends up in the Filter expression field. 

In the example in figure e, the filter selects data where the level of MOLASSES is 
below 4.75. Note also that time interval for this variable is different from the default. 

Figure e: The Add or edit a data filter dialog. 

 
After the filter has been added, tags have to be added under that filter. The added tags 
specify which data to extract using the filter.  

Figure f: Select Tags to Import dialog with tags added to the filter.  
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Select Observation Interval 

When the data import type is Continuous or Batch, the time interval for which to 
import observations and batches can be selected in the Select Observation Interval 
page.  

The selected Start and End times specify the time interval: 

 The observations are imported for in the Continuous case. 

 The batches are displayed for in the Batch case. Among the displayed 
batches, you can select to include all (default) or some by clearing the 
relevant check boxes.  

Clicking the padlock locks the time interval so that changing either of the Start or End 
times automatically changes the other keeping the time interval constant. Clicking the 
arrow moves the date and time in End to Start. This means that by clicking the 
padlock you can specify a new time interval, spanning the same time and starting 
where the last interval ended, by just clicking the arrow.  

In the example below there are several batches between the start and the end time and 
all are currently selected for import. 

To select only a few batches, clear the Select all batches check box and then select the 
batches to import.  
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Summary page 

The last page in the database import wizard, the Summary page, provides information 
about the import. In the Summary page you can save all configurations made into a 
new or existing settings file by clicking the Save button to the right of the Database 
Settings file field. 

The example below shows the Summary page for a batch import. No settings file was 
selected.  

To save the settings, click Save and enter the file name for the settings file. 

 

SIMCA Data Base Settings file 

The *.sdbs file will store the following settings: 

 Data Source Configurations 

 Aliases 

 Filter information 

 Tags 

 Folders 

 SQL queries 

Settings not stored in the settings file, but in the registry of the local machine are: 

 Data sources. 

 Start and stop time in the Select observation interval page (if applicable). 

 Recent SIMCA database settings files. 

Note: Batches found and/or selected in the Select observation interval page 
are not stored anywhere. 
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Compatibility tested 

The database import has been tested at Umetrics using the data source connectors listed 
in this subsection. 

ODBC Drivers Compatibility 

The following ODBC drivers have been tested: 

 SQL Server 6.01 

 PostgreSQL ANSI 9.0 

 MySQL ODBC Driver 5.1 

 Microsoft Excel/Access Driver 12.0 

 Aegis ODBC Driver 

OPC Compatibility 

The SIMCA import can only read data through the HDA 1.1 interface of the OPC 
Foundation specifications. To see the compatibility of each server, please visit the OPC 
Foundation web page (www.opcfoundation.org). 

SimApi Compatibility 

The following SimApi’s have been tested: 

 OPC SimApi2 

 OPC/ODBC SimApi2 

 PISimApi2 

 ODBC SimApi2 

Pasting dataset in SIMCA import 
To paste data in the SIMCA import: 

1. Click File | New Spreadsheet | Blank. If a dialog is opened when the 
SIMCA import is opened, click Cancel to exit the dialog but not the import.  

2. In the spreadsheet that opens, paste the data to import. 

Note: In the empty spreadsheet you can type new values using the keyboard. 

Importing another dataset 
To import another dataset in SIMCA import, click File | New Spreadsheet or on the 
Home tab, in the Import group, click Import Another.  

For details about how to continue, see the New Spreadsheet subsection earlier in this 
chapter. 

To merge with a dataset already open in SIMCA import, see the Merging 
Spreadsheets subsection later in this chapter. 



User Guide to SIMCA 

96 

Workspace 
In SIMCA import you can open and save workspaces. A workspace consists of one or 
more data spreadsheets formatted as currently specified. 

A workspace is saved as a .wusp and can be opened by the SIMCA import. 

To save a workspace, click File | Save Workspace. 

To open a workspace, click File | Open Workspace. 

Save As in SIMCA import 
The current spreadsheet can be saved by clicking File | Save As | Save Spreadsheet 
As. The file types available are .txt and .dif. 

It is also possible to create the SIMCA project from this menu item by clicking File | 
Save As | Finish Import. The SIMCA import is then closed and SIMCA opens. 

Print, Print Preview, and Print Setup 
The commands Print, Print Preview, and Print Setup are the standard printing 
functions available by clicking File | Print. 

Note: Plots are printed as viewed on the screen except when printing to a pdf 
writer. 

Close  
To close the current spreadsheet in SIMCA import, click the tab cross of that 
spreadsheet tab or click File | Close.  
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Options 
Clicking File | Options button opens the SIMCA import Options dialog. 

 
  

Header What and why Default setting 

Undo 
You can select to turn the Undo memory 
off to speed up spreadsheet actions 
involving a lot of data. 

On/Off is On. 

Undo Actions is 10. 

Audit Trail 

Turning the audit trail on in the SIMCA 
import makes the audit trail include 
changes done during import. Optionally 
more user info can be entered here. See 
the Audit Trail section for more. 

Log events to the Audit 
Trail is No. 

Extended User 
Information is empty. 

Missing 
Value 

See the Missing value representation 
subsection for details. 

Missing Value is empty. 

Create 
Default 
Workset 

When creating the SIMCA project a 
default workset can be created. When 
the default workset is not of interest, the 
creation of the default workset can be 
turned off. 

Create Default Workset 
is Yes. 

Default 
Directories 

By default the directory where you select 
a data file to import is used for storing 
the project. 

If you store your SIMCA project files in a 
location different from where you fetch 
data for import, select Yes. 

Enable different default 
directories is No 
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Missing value representation 
Missing values are represented by blank or space < >.  

You can select another value to also represent missing in Options dialog in the 
SIMCA import by entering it in the Missing Value field. 

Note: –99 is assumed to be a valid value and is therefore automatically 
changed to –99.0001. If -99 represents missing value, enter -99.0001 in the 
Missing Value field in Options dialog in the SIMCA import. 

For more, see the Conventions section in the Overview of SIMCA chapter. 

Quick Access Toolbar 
Standard editing commands Undo, Redo, Cut, Copy, and Paste are available from the 
Quick Access Toolbar in the SIMCA import. Any button in the SIMCA import can be 
added to this toolbar. 

 
For details about how to customize the Quick Access Toolbar etc, see the Quick 
Access Toolbar chapter earlier. 

Find toolbar  
The Find toolbar opens when pressing CTRL+F or when selecting it from the Quick 
Access Toolbar menu. 

 

 
Using the Find toolbar you can find cells matching a certain expression, numerical or 
text.  

To find: 

1. In the first drop down menu select  

 Containing (default),  

 Exactly Matching,  

 Not Containing, or 

 Not Matching that all apply to both text and values 
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 Less than,  

 Greater than,  

 Less than or Equal to,  

 Greater than or Equal to, or  

 Between which all apply to values. 

2. Enter the value or text in the first field.  

3. In the second drop down menu select: 

 Selection - to only search in the current selection. 

 Active Document - to search the current spreadsheet. 

 All Documents - to search all spreadsheets open in SIMCA 
import. 

4. If you want to replace, select the Replace check box and enter the new 
text/value in the Replace with field. When selecting the Replace check box 
two new buttons appear Replace and Replace All. Use these to replace once 
the items to replace have been found. 

5. Click the arrows to find from top left to right going down (down arrow) or 
from bottom right to left going up. 

6. Click the Mark All button to mark all cells that match. 

7. In Options select: 

 Wildcards to be able to use the wild characters ‘?’ to represent an 
unknown character or ‘*’ to represent unknown beginning or 
ending of the expression. 

 Regular Expressions to interpret the search string as a POSIX 
basic regular expression.  

 Match Case to match character case. 

Note: Wildcards or Regular Expressions can be selected, not both. Match 
Case can be selected in combination with Wildcards and Regular 
Expressions. 
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Home tab 
In the data spreadsheets open in SIMCA import, all identifiers, qualitative variables, 
time or maturity (y-variable for batch projects), and batch condition variables must be 
identified and specified. Optionally, regular projects can specify y-variables and 
classes defining the default workset. 

All column formatting can be performed either from using the ribbon or by clicking the 
column or row arrow. 

Note: A row, with slash </> as the leftmost character of the leftmost column 
of that row, is automatically marked as excluded by SIMCA. 
A column with slash </> as the leftmost character in the top cell, is 
automatically marked as excluded by SIMCA. 

 

Specifying identifiers 
Primary variable and observation identifiers (IDs) are used by SIMCA for the 
following tasks: 

1. To keep track of variables and observations. 

2. Variable and observation IDs are displayed in plots and lists. 

3. The Find function in the Workset dialog can search in the identifiers. 

4. In the Observations page of the Workset dialog the identifiers can be used 
to set classes. 

In the import spreadsheet the primary IDs, and batch and phase IDs for batch projects, 
must be specified. These IDs can be specified in the ribbon and in the row/column 
arrows; see the How to specify identifiers subsection next. 

Class IDs can also be specified resulting in classes in the default workset. For more, 
see the Class ID specification subsection later in this chapter. 

Note 1: IDs in plots are by default displayed using the first 10 characters. 

Note 2: SIMCA is case insensitive. 
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How to specify identifiers 
In the import spreadsheet the primary and secondary identifiers, and the batch and 
phase identifiers, can all be specified in as described in the table, after marking the 
relevant rows or columns. Batch and Phase IDs can only be specified in batch datasets. 

Description Illustration 

1. Click the 
relevant ID button 
in the Identifiers 
group. 

  

Marked column 

 

 
Marked row 

 

2. Select ID from 
the column 
respective row 
menu. 

   

Note: If no row is specified as primary variable ID, SIMCA automatically 
creates a primary variable ID as Var_1, Var_2, etc., when clicking Finish. 

  

Note: If no column is specified as primary observation ID, SIMCA 
automatically creates a primary observation ID as 1, 2, 3, etc., when clicking 
Finish. 
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Variable and observation ID description 
The identifiers, available in SIMCA, are described in the table. Variable IDs are found 
in rows and observation IDs in columns. 

ID Description Default 

Primary 
Variable ID 
(Identifier)  

The Primary Variable ID is required 
and needs to be unique. 

The primary variable ID row is colored 
dark green. 

The first row with 
unique entries is 
automatically specified 
as the Primary 
Variable ID. 

Secondary 
Variable ID  

Secondary variable identifiers are 
optional and colored in light green. 

No secondary variable 
IDs are automatically 
specified. 

Primary 
Observation 
ID  

The Primary Observation ID is 
required and needs to be unique.   

The primary observation ID column is 
colored dark yellow. 

The first column with 
unique entries is 
automatically specified 
as the Primary 
Observation ID. 

Secondary 
Observation 
ID  

Secondary observation identifiers are 
optional and colored light yellow. 

The second column is 
automatically specified 
as secondary 
observation IDs when 
the first column is 
numerical and the 
second text. 

Class ID Specifying the Class ID at import 
defines classes in the default workset. 

Only one column can be defined as 
Class ID. 

Class ID is only available for regular 
projects. 

No class identifiers are 
automatically specified. 

Batch and 
Phase ID  

When the dataset is a batch evolution 
dataset, batch identifiers and 
optionally phase identifiers have to be 
specified. These specify the start and 
end of batches and phases. 

Batch IDs are colored orange and 
Phase IDs light orange. 

Batch and Phase IDs are found in 
columns. 

There can only be one column defined 
as Batch ID and one defined as Phase 
ID. 

When there are 
columns named 'Batch 
ID' and 'Phase ID' 
these are automatically 
specified as batch and 
phase ID. 
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Class ID specification 
Specifying the Class ID at import defines classes in the default workset. 

Only one column can be defined as Class ID and it is only available for regular 
projects. 

Use one of the following methods to open the Class ID dialog: 

 Mark the column and then on the Home tab, in the Identifiers group, click 
Class ID.  

 Mark the column, click the column arrow, and then click Class ID. 

 
In the Split ID dialog, enter the start and length of the characters specifying the 
classes, or click OK to use the entire string. Length '-1' denotes 'until the end of the 
string'. 

 

Class pane 

After specifying a Class ID, the Class window is updated accordingly.  

Use the Class pane to Rename, Merge, Delete, and switch the order of the classes or 
excluding variables in certain classes. For more about these actions, see the Batch & 
Phase pane phase part subsection later in this chapter. 

Note: Deleting classes here will omit them in the import while excluding 
variables only exclude them in the default workset. 
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Batch and Phase ID specification 
To specify the batch and phase IDs: 

1. Mark the column and click Batch ID or Phase ID. 

2. Specify the position of the IDs by entering start character position and 
length. 

 
If the Batch or Phase IDs span several columns, use the Merge Column button in the 
Edit tab to concatenate them. 

Specifying a Batch ID updates the content of the Batch & Phase pane. This pane is 
parted in two when Phase IDs have been specified: a phase part and a batch part.  

Downsizing using conditional exclude 

When the file is large and contains many batches, conditional exclude can be used to 
downsize the number of batches. 

There are 2 types of conditional exclude available: 

Cond. exclude type Action by the user in the dialog 

Excluding all batches, all 
phases, or the selected 
phase in each batch with 
less than / more than the 
user entered number of 
observations. 

 
1. Select the first Exclude option. 

2. Select all batches, all phases, or one of the 
phases. 

3. Select with less than or more than. 

4. Enter the number of observations that defines 
the limit. 
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Cond. exclude type Action by the user in the dialog 

Excluding a user entered 
percentage of all batches at 
random / the longest / the 
shortest / ordered. 

 
1. Select the second Exclude option. 

2. Enter the percentage to use in the field. 

3. Select how to delete the entered percentage of 
batches by clicking at random/the 
longest/the shortest or ordered. 

Excluding/including rows or columns 
To exclude or include a column or row in the import wizard spreadsheet: mark it and 
click the Exclude or Include-button. 

Excluded rows and columns are colored gray. 

 

Specifying data properties 
For a regular project (non-batch), with no qualitative variables, it is necessary to 
include all variables (set them as x) but not necessary to specify y-variables. 
Specifying y-variables defines the default workset. 

With batch data, the x variable, y variables (time or maturity), and variables pertaining 
to the whole batch, such as batch conditions, X or Y (quality of the batch) all need to 
be specified in the SIMCA import. 

All about specifying data 
The table lists the Variable Types available in the SIMCA import, their description, 
the objective with specifying the type of variable, and the spreadsheet coloring after 
specification. 

Specifying variable types is done as follows: 

1. Mark the columns. 

2. Click the relevant button in the Variable Types group: 

 Quantitative 

 Qualitative 

 Date/Time 

 Batch Conditions - requires that the column is also Quantitative 
or Qualitative. 

 X Variables 
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 Y Variables  

Note: All data columns have to be specified as X Variables or Y Variables in 
addition to Quantitative/Qualitative or Date/Time.  

   

Button Description and objective Coloring 

Quantitative  Continuous variables. 

Imports a quantitative variable. 

The variable is 
colored white. 

Qualitative  Discrete variables that are split into 
dummy variables during the 
calculations. 

Imports a qualitative variable. 

The variable is 
colored turquoise.  

  

Date/Time 
Variable 

Specifies the selected variables 
according to the specified time format. 

For more, see the Formatting 
variable as Date/Time section later in 
this chapter. 

Date/time variables can be displayed 
on the x-axis showing time in the 
specified format. 

The variable is 
colored orange.  

Batch 
conditions  

  

Batch condition variables can be 
imported with the batch evolution 
dataset or as a separate dataset 
arranged as a batch level dataset. 

Makes batch conditions available for 
modeling in batch level models.  

The variable is 
colored light grey.  

X Variable All numerical variables, except the first 
column, are by default assumed to be 
x-variables. 

The x-variables are the explanatory 
variables. 

Includes the variable in the import. 

The variable is 
colored white.  

Y Variable Defines the default workset as PLS. 

The y-variables are the predictor 
variables. 

Specifies the default workset. 

The variable is 
colored light brown.  

Specifying time or maturity 
Batch evolution models, BEM, require a y-variable, time or maturity. Neglecting to 
specifying a y-variable results in that $Time, automatically created by SIMCA, is used 
as y. $Time = relative local batch or phase time (i.e. the time restarts at the beginning 
of each batch and phase) with a sampling interval of 1. 
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Formatting variable as Date/Time 
A variable specified as Date/Time at import can be used: 

 As a variable in the model. The date and time variable is then transformed 
into a regular value (float). 

 As x-axis in plots. The Date/Time variable is by default displayed in line 
plots, for instance the Score Line Plot and DModX. 

Specifying the Date/Time variable 

The autoformatting tries to recognize date/time variables and specify them as such. If 
the variable is not by default specified as date/time, follow the steps in the table: 

Step Description Illustration 

1. Select the variable in the 
spreadsheet by clicking its 
column number. 

With more than one variable in 
the same format, mark them all. 

 

2. Specify the variable type by 
clicking Date/Time. If the 
variable is specified as X it is by 
default excluded from the 
default workset, if specified as 
Y, it is default included. 

 

3. In the message box, the 
guessed date/time format is 
displayed if one is found. If 
SIMCA cannot find an 
appropriate date/time format the 
dialog in 4a is displayed. 
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Step Description Illustration 

4a 

  

Clicking No opens the Specify 
Date Format dialog. 

Enter the format for the 
date/time variable and click OK 
to reopen the dialog in step 3. 

Click the Show Details button 
to view the terminology, also 
displayed in the Date/Time 
formatting terminology 
subsection later in this section. 

 

4b Clicking Yes opens the Specify 
Time Unit dialog. 

In this dialog the format for 
storage is selected. The unit 
selected here is the smallest 
unit that is guaranteed to be 
displayed correctly. 

Worth noticing here is that: 

 Selecting to store the 
variable in seconds limits 
the number of days that 
data can be imported for 
and the accuracy of the 
saved value can be 
guaranteed. 

 Selecting to store the data 
in a larger unit than the 
imported format will result 
in rounding errors when 
displaying the date/time 
variable in the more 
detailed format. 

 

5 Clicking OK saves the format to 
use for parsing the variable. 

  

For reformatting after importing the dataset, see the Date/Time configuration in 
dataset properties subsection in the Data chapter. 

Date/Time formatting terminology 

The following format details are available when clicking Show Details: 

Column and row menus 
Formatting rows and columns, excluding, and merging can be done by marking one or 
more columns/rows and clicking the column or row arrow.  

A menu opens with the following commands for columns: Primary ID, Secondary 
ID, Class ID (regular projects only), Batch ID (batch projects only), Phase ID (batch), 
Batch & Phase ID (batch), Quantitative Data, Qualitative Data, Date/Time 
Variable, Batch Condition (batch), X Variable, Y Variable, and Exclude Column. 
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For rows the following commands are available: Primary ID, Secondary ID, Exclude 
Row, and Include Row. 

All of these commands are available from the buttons on the Home tab and are not 
described here. 

       

Importing batch conditions 
To import initial and final conditions, in SIMCA named batch conditions, and use 
them in a BLM, click File | Import dataset. After import the new dataset can be 
selected in the Workset dialog when the Create a batch level model check box is 
selected. 

When importing a dataset in a batch project and each batch only has one row, the data 
are assumed to be batch conditions. 

Note: Beware of how you name your batch condition variables to not confuse 
them with the score names generated from the BEM. That is, do not use names 
such as t(1)_2_20. 

Finish and create project 
After opening all datasets in the SIMCA import, click Finish to create the SIMCA 
project. 

 
In the dialog, select destination and enter project name. 
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Edit tab 
On the Edit tab, there are five groups: Indexes, Rows & Columns, Merge, 
Formatting, and Sort. This section describes the features available in these groups.  

Creating observation or variable index  
To create an index column or row, on the Edit tab, in the Indexes group, click 
Column or Row depending on which index you want to create.  

 

Rows and Columns 
The standard editing commands Insert Row, Insert Column, Delete (Clear, Entire 
Rows, Entire Columns etc.) and Shift are available in the Rows & Columns group in 
the Edit tab. 

Additionally Transpose and Downsize, described next in this section, are available 

 

Transpose  
To transpose the dataset, on the Edit tab, in the Rows & Columns group, click 
Transpose.  

Transposing the dataset removes all formatting. 

 

Downsizing the dataset 
To use a subset of the imported dataset: 

1. On the Edit tab, in the Rows & Columns group, click Downsize. 

2. In the Start after xx observations field, enter the starting observation. All 
observations, before and including this observation, remain included. 

3. In the Keep every 'xx' observations field, enter the interval to use when 
downsizing.  
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Downsizing is not available here for batch projects. For batch projects, downsizing is 
available as Conditional exclude in the Batches page in the SIMCA import. For more, 
see the Batch & Phase pane batch part subsection later in this chapter. 

Merge 

Split Column 
To split a column in two, mark the column and click the Split Column button in the 
Merge group.  

Splitting a column is useful when you have different information in the same column 
and would prefer them in separate columns. 

Merging columns 
To merge columns: 

1. Mark the columns. 

2. On the Edit tab, click Merge Columns.  

3. In the Merge Columns dialog, select the order in which the columns should 
be merged by marking and clicking the up and down arrows in the dialog. 

4. If the columns should be merged with a separator, click Separate the 
content in each column using and enter a separator. If the columns should 
be merged without separator, select Concatenate the columns without a 
separator. 

5. Click OK and the columns are merged and the original ones excluded. 
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Merging Spreadsheets  
You can import one or more files using the SIMCA import. When in SIMCA, datasets 
selected in the Workset dialog are merged by primary ID behind the scenes and 
merging is not necessary. 

If you want to merge data before creating the project, on the Edit tab, in the Merge 
group, click Merge Spreadsheets. 

The table lists a description of the steps. 

Step Objective and explanation  Action  

1. Importing the datasets. Click File | New 
Spreadsheet and import the 
datasets to merge in SIMCA 
import. 

2. Initiating the merge of two or more files 
in one single dataset. 

On the Edit tab, in the Merge 
group, click Merge 
Spreadsheets. 

3. Selecting the files to merge. In the Merge dialog, clear 
spreadsheet check boxes so 
that only the files to merge 
are selected. 

4. Sorting the files. Move the files using the 
arrows leaving the files in the 
desired order. 

5. Merging matching identifiers/index. 

When merging and matching by identifier, 
that identifier needs to be selected in the 
Merge By box.  

Selecting to merge by Index merges on 
row/column index.  

In the Merge By box, select 
Index or Primary ID. If no 
primary ID has been 
specified, only Index is 
available. 

6. Selecting direction to merge. This 
option determines how the merging is 
done, positioning the datasets next to 
each other in Side by Side or above and 
below in Top/Bottom. 

In the Direction box, select 
in which direction to merge, 
Side by Side or 
Top/Bottom. 

7. Selecting the form of the merged data. 

Destination: The destination file (first 
one in the dialog) specifies which 
observations/variables are included. 

Intersection: The observations/variables 
common to all selected datasets are 
included. 

Union: All observations/variables present 
in any of the datasets are included. 

In the Result box select 
whether the result is 
variables/observations 
according to the Destination 
file, the Intersection or the 
Union. 

8. Completing the merge. Click OK to merge the files 
as specified deleting the 
original spreadsheets.  
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Apply Formatting 
Formatting specified for a file previously imported can be applied to the current 
spreadsheet by clicking the Apply Formatting button and selecting the spreadsheet 
name. The files listed are those with matching variable and observation IDs. 

To autoformat (autocolor) the dataset, click Apply Formatting | Autoformat.  

Clear formatting by clicking the Clear Formatting button in the same group. 

The formatting features are available in the Formatting group on the Edit tab. 

Note: A row, with slash </> as the leftmost character of the leftmost column 
of that row, is automatically marked as excluded by SIMCA. A column with 
slash </> as the leftmost character in the top cell is automatically marked as 
excluded by SIMCA. 

Sort  
Sort Ascending and Sort Descending are available when marking one column only 
(click the column header). Clicking the button results in that the entire dataset is sorted 
according to the marked variable. 

 

View tab 
The information panes Issues, Audit Trail, Variables, Observations, Batch & Phase 
and Summary can be shown or hidden from the View tab. 

The Missing Value Map is also available here. See the Displaying the Missing Value 
Map section. 

Arranging windows cascaded or tiled is available by clicking Cascade, Tile 
Horizontally and Tile Vertically. All open spreadsheets are arranged accordingly. 

 

Issues pane in SIMCA import 
The Issues pane lists problems in individual sheets as well as between sheets. When 
there is an issue that the SIMCA import can resolve for you the Select Action column 
displays what the action will be when Resolve All is clicked. Hover over the issue to 
display more information in a tooltip. 

As long as there are unsolved issues, clicking Finish will not let you create a project. 
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Issues and actions in the Issues pane 
The table lists some common issues, the reason for the issue, possible ways to resolve 
and the result from the selected resolution. 

Note: Hover over the issue for more info. 

Issue Description 
Actions 
available 

Result after 
Resolve All 

No primary 
Obs ID 

No primary 
Var ID 

The ID has not been 
specified. 

None 
Clicking Resolve All 
or Finish both add 
unique primary IDs. 

Missing 
observation 
ID 

Missing 
variable ID 

Missing batch 
name 

Missing 
phase name 

There are missing 
values in the 
column/row specified as 
primary/batch/phase ID 

rename 

auto rename 

exclude 
row/column 

rename - opens a 
dialog allowing you to 
enter an ID. 

auto rename - adds a 
number to create 
unique IDs. 

exclude row - 
excludes the problem 
rows/columns. 

Primary 
observation 
ID is not 
unique 

Primary 
variable ID is 
not unique 

There is at least one 
duplicated primary ID. 

rename 

auto 
generate 

exclude 
row/column 

rename - opens a 
dialog allowing you to 
enter the new ID for 
the duplicate. 

auto generate - 
creates new 
observation/variable 
IDs for all. 

exclude row - 
excludes the 
rows/columns with 
duplicated IDs. 

No batch ID 
No batch ID was 
specified for the batch 
dataset. 

auto 
generate 

auto generate is 
available when a 
phase ID has been 
specified - creates 
batch ID using the 
phase ID.  

No phase ID 

No phase ID was 
specified for the batch 
dataset. Displayed 
when importing a 
dataset to a batch 
project with phases 

  
This has to be 
resolved by specifying 
a phase ID. 
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Issue Description 
Actions 
available 

Result after 
Resolve All 

Batch 
condition 
variable lacks 
primary 
variable ID 

A variable specified as 
batch condition lacks 
primary variable ID. 

rename 

auto rename 

exclude row 

rename - opens a 
dialog allowing you to 
enter an ID. 

auto rename - 
suggests an ID. 

exclude row - 
excludes the problem 
rows. 

More than 
one dataset 
have the 
name ... 

Each dataset in a 
project needs to have a 
unique name. All 
datasets are default 
named by the file name. 

rename 

Note here 
that clicking 
the Rename-
button to the 
left of the 
issue allows 
you to 
specify the 
new dataset 
name 

rename - adds a 
number making the 
dataset name unique. 

Unrecognized 
qualitative 
setting in 
variable 

For a project with one 
or more models, no new 
settings in a qualitative 
variable can be 
imported. To import a 
new setting, delete all 
models, including 
unfitted models before 
import. 

treat as 
missing 

exclude row 

exclude 
column 

treat as missing - 
replaces the new 
setting with missing. 

exclude row - 
excludes all rows with 
the new setting. 

exclude column - 
excludes the column. 

Variable type 
mismatch 

A variable must be of 
the same type in all 
datasets in a project. 
The Variable type 
mismatch warning 
appears when the same 
primary variable ID was 
specified for different 
variable types, e.g. 
quantitative/qualitative/d
ate time. 

    

Maturity is 
not specified. 
A variable 
called $Time 
will be 
generated 

No y-variable has been 
specified. 

None 
Clicking Resolve All 
or Finish both add 
the $Time variable. 
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Issue Description 
Actions 
available 

Result after 
Resolve All 

Non-
continuous 
batch IDs 

All data for a given 
batch must be 
continuous. 

auto rename 
(default) 

exclude row 

sort 

auto rename - adds a 
number to the batch 
IDs that are perceived 
to be out of order. 

exclude row - 
excludes the first row 
that appears out of 
order and continues 
until the batch IDs are 
in order. 

sort - sorts the batch 
IDs 

Non-
continuous 
phase IDs 

All observations in a 
phase must be 
consecutive within 
every batch. 

manual 
exclude 
(default) 

split batch 

exclude last 
in batch 

exclude first 
in batch 

manual exclude - 
results in nothing 
when clicking 
Resolve All. You 
have to decide what 
to do yourself. 

split batch - adds 
number to all batch 
IDs following the 
observation with the 
problem in phase ID. 

exclude last in batch - 
excludes all rows 
following the problem 
phase ID in that 
phase. 

exclude first in batch - 
excludes all rows 
preceding the row 
with the problem 
phase ID. 

Existing 
batch 
variable 
combination 

Datasets in the same 
project may only 
contain the same 
batches OR the same 
variables, not both. 

rename 
batches 
(default) 

manual 
merge 

rename batches - 
adds a number 
making the batch IDs 
unique. 

manual merge - 
results in nothing 
when clicking 
Resolve All. You 
have to decide what 
to do yourself. 
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Issue Description 
Actions 
available 

Result after 
Resolve All 

Existing Var. 
Obs. 
combination 

Datasets in the same 
project may only 
contain observations 
OR variables with the 
same primary IDs. 

rename 
observations 
(default) 

rename 
variables 

exclude row 

exclude 
column 

rename observations 
- adds a number to 
the primary IDs that 
are found matching, 
making them unique. 

rename variables - 
adds a number to the 
primary IDs that are 
found matching, 
making them unique. 

exclude row - 
excludes the rows 
with matching IDs. 

exclude column - 
excludes the columns 
with matching IDs. 

Conflicting 
batch ID 

Conflicting 
phase name 

Conflicting 
class name 

Identical primary 
observation IDs may 
not be associated with 
different 
batch/phase/class IDs. 

auto rename  

exclude row 

auto rename - adds a 
number making the 
IDs unique. 

Phases out of 
order 

The phases need to be 
in the same order for all 
batches.  

reorder 
phases 

  

reorder phases - 
orders the phases in 
the order of the 
phases in the Batch 
& Phase pane. 

Phases not in 
the same 
order in all 
datasets 

The phases need to be 
in the same order for all 
batches in all datasets.  

manually 
reorder 
phases 

The phases have to 
be reordered. You 
can do this easily for 
each dataset using 
the Batch & Phase 
pane. 

Invalid value 

String that is not in a 
row or column with 
identifiers or in a 
column defined as 
qualitative. 

treat as 
missing 

exclude row 

exclude 
column 

treat as missing - 
replaces the content 
of the cell with 
missing. 

exclude row - 
excludes all rows with 
the invalid values. 

exclude column - 
excludes the columns 
with the invalid 
values. 
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Issue Description 
Actions 
available 

Result after 
Resolve All 

Variable IDs 
cannot 
contain any 
of the 
following 
characters: $ 

Observation 
IDs cannot 
contain any 
of the 
following 
characters: $ 

$ is reserved for SIMCA 
created vectors. 

rename 

auto rename 

exclude 
column/row 

rename - opens a 
dialog allowing you to 
enter an ID. 

auto rename - adds a 
number to create 
unique IDs. 

exclude row/column - 
excludes the problem 
rows/columns. 

Incorrect 
date/time 
variable 
settings 

The content of the cell 
cannot be formatted as 
date/time. 

treat as 
missing 

exclude row 

exclude 
column 

treat as missing - 
replaces the content 
of the cell with 
missing. 

exclude row - 
excludes all rows with 
the invalid values. 

exclude column - 
excludes the columns 
with the invalid 
values. 

Unexpected 
phase ID 

The first dataset in the 
project does not have 
phases, then other 
datasets may not either.  

exclude 
exclude - excludes 
the column. 

Non printable 
character 

ASCII characters 1 - 31. 
exclude 

rename 

exclude - excludes 
the row/column. 

rename - opens the 
rename dialog. 

Audit trail  
The audit trail needs to be turned on before importing the first dataset to hold all 
information, see the Options subsection earlier in this section. 

Note: The Audit Trail is empty until clicking Finish when the Audit Trail 
starts logging information later displayed in the Audit Trail in SIMCA. 

For more, see the Audit Trail section in the View chapter. 

Variables pane 
The Variables pane lists the number of variables currently included, primary variable 
IDs of the currently included variables, variable type and % missing. 

Using the shortcut menu you can reach the same commands as in the Column and row 
arrow menus, for more see the Column and row arrow menus subsection earlier in 
this section. 
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Observations pane  
The Observations pane lists number of observations currently included, primary 
observation IDs of the currently included observations, and % missing. 

Using the shortcut menu you can reach the same commands as in the Column and row 
arrow menus, for more see the Column and row arrow menus subsection earlier in 
this section. 

Class pane 
After specifying a Class ID, the Class window is updated accordingly.  

Use the Class pane to Rename, Merge, Delete, and switch the order of the classes or 
excluding variables in certain classes. For more about these actions, see the Batch & 
Phase pane phase part subsection later in this chapter. 

Note: Deleting classes here will omit them in the import while excluding 
variables only exclude them in the default workset. 

 

Batch & Phase pane phase part  
With a batch project with phases, the phase part of the Batch & Phase pane lists: 

 Each phase. 

 The number of batches containing that phase (batches do not have to include 
all phases). 

 The number of variables in that phase (phases may have different variables). 

 The roles of the variables. 
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Note: When moving/deleting/rearranging phases in the Batch & Phase pane, 
nothing happens in the dataset spreadsheet until the dataset is imported to 
SIMCA. 

Excluding variables 
If the phases have different variables you can exclude variables in the following 
manner: 

1. Expand the node in each phase to list the variables. 

2. Mark the variables to exclude. 

3. Click the Exclude-button. 

This excludes the variables in the default workset. You can also configure the 
variables for each phase, after import, in the Workset dialog. 

Delete phases 
Delete a phase in a certain batch by marking and clicking the Exclude-button.  

 

Note: Deleting phases here will omit them in the import while excluding 
variables only exclude them in the default workset. 

Switching the order of the phases 
If phases are imported in the incorrect order, mark the phase and click the up or down 
arrow in the dialog. 
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Rearranging phases automatically 
Let SIMCA rearrange the phases automatically by clicking the Rearrange phases 
button. The phases will then be arranged in the order in the Batch & Phase pane.  

 

Merging phases 
To merge phases, mark two or more phases and click the Merge button. 

 
If you want to merge phases positioned in two different datasets, you first need to 
merge the datasets. See the Merging Spreadsheets subsection for more. 

Note: You can only merge consecutive phases. 

Assigning different time or maturity variable and renaming 
phases 
If you want to assign different time/maturity variables to the different phases and/or 
rename a phase, mark a phase, click Configure (last button in the Batch & Phase 
pane), and select the desired time/maturity from the Time/Maturity variable-box. 

 

Batch & Phase pane batch part  
The Batch & Phase pane Batches section displays batches, the phases present in each 
batch, and the number of observations in each phase for each batch. 

   
Expand the node to see all the phases in a batch with the number of observations in 
each phase. 
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Excluding batches or phases 
Exclude batches or a phase in a certain batch by marking and clicking the Exclude-

button . 

Summary pane 
The summary pane lists the following information for the current dataset: 

 Source - file name and path when data was imported from file. 

 Number of variables. 

 Number of observations. 

 Missing values. 

 Number of classes. 

 Number of phases. 

 Number of batches. 

Displaying the Missing Value Map 
To display an overview of a dataset with respect to missing values: 

 On the Data tab, in the Summary group, click Missing Value Map and then 
the desired dataset in SIMCA. 

 In SIMCA import, on the View tab in the Missing Values group, click the 
Missing Value Map. 

Missing values are colored while data present are white. 
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Home 

Introduction 
The Home tab holds the commands most commonly used when creating models and 
evaluating them. On the Home tab you can: 

 View the imported datasets - Dataset spreadsheet 

 View statistics and create a new model using the commands in the Workset 
group. 

 Fit the model - using the Fit model group. 

 View diagnostic and interpretation plots: Summary of Fit, Scores, 
Loadings, Hotelling’s T2Range, Distance to Model, Observed vs. 
Predicted, Coefficients and VIP. 

 

Dataset spreadsheet 
To open a dataset in a spreadsheet: 

 Click Dataset on the Home tab. 

 If there are more than one dataset, select the desired dataset by clicking the 
arrow in the lower part of the Dataset-button and clicking it. The datasets are 
displayed in the order they were imported. 

  

Shortcut menu in the dataset spreadsheet 
Open the shortcut context sensitive menu by right-clicking the spreadsheet. 
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The following commands can be available: Undo, Cut, Copy, Paste, Delete, Create | 
List/Plot, Create | XObs/YObs, Lock the First xx Columns/Rows, Add 
Observations/Variables, Sort Ascending/Descending, Add Secondary 
Observation/Variable ID, Quick Info | Variables/Observations, Zoom Out/In, 
Missing Value Map, Trimming Overview, Format Date/Time, Save List As, Print, 
and Properties. 

All commands are available from the ribbon and described in the chapter for the 
relevant tab. The following commands are dataset specific and not described 
elsewhere: 

1. Adding observations and variables. 

2. Adding secondary IDs. 

 

Adding observations and variables 
Adding a specified number of observations or variables in the dataset spreadsheet is 
available from the shortcut menu. 

To add observations or variables: 

1. Right-click the dataset spreadsheet and click Add Observations or Add 
Variables. 

2. In the Add Observations or Add Variables dialog, type the number of 
observations or variables to add. 

3. Click OK and note that empty rows or columns are added at the bottom or to 
the right in the dataset spreadsheet. 

4. Paste or type the values for the new observations or variables. 
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Note: Adding variables as a function of other variables or model results is 
available using Generate Variables. Generate Variables is available on the 
Data tab, in the Modify Dataset group.  

For information about adding variables as a function of other variables or model 
results, see the Generate Variables section later in this chapter. 

Adding secondary IDs 
Secondary IDs can be added directly in the dataset spreadsheet, by right-clicking and 
selecting Add Secondary Observation ID or Add Secondary Variable ID. Empty 
identifiers are added. Paste or type their content. 

Workset 
This section describes the features in the Workset group on the Home tab. 

The workset is all or a subset of the selected datasets, with specifications for 
scaling, transformations, variable roles, lags and expansions of variables. Observations 
can be grouped in classes for SIMCA classification or discriminant analysis. In batch 
projects with phases the observations are grouped in phases. 

When exiting the workset dialog, SIMCA creates an active model, linked to that 
workset. A workset is associated with every model. 

Content 
In the Workset group the following commands are available: 

1. Statistics | Workset Statistics displays the selected statistics for the current 
workset; Correlation Matrix displays the correlations for the variables 
included in the current workset. 

2. New opens the workset dialog with the settings of the default workset. 

3. New As | Mx opens the workset dialog using the settings of the selected 
model. 

4. Edit | Mx opens workset dialog of the selected model. 

5. Delete | Mx deletes the selected model and workset. 

6. Change Model Type lets the user select among the available model types. 

7. The Model Options dialog box launcher opens the Model Options dialog 
for the current workset, for editing and viewing. 
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Workset Statistics 
To display descriptive statistics for selected variables in the current workset, click 
Statistics | Workset Statistics.  

Note: When marking a CM, BEM or DA-model, the statistics are calculated 
over all classes/phases. 

The default Workset Statistics list displays N (number of observations), Missing 
values (%), Mean, and Standard deviation for the variables in the workset. 

To view more than the default statistics, open Properties and select what to display. 
The Properties dialog is described next. 

Workset Statistics Properties  
The Workset Statistics Properties dialog has two sections: Display and Use only. 

 

Display in Workset Statistics 

In the Display section, the statistics are listed. 

The available statistics are: N, Missing value (%), Min, Max, Min/Max, Mean, 
Median, Standard deviation, Std. dev/Mean, Skewness, Skewness test, and 
Kurtosis. 

By default the N, Missing value (%), Mean, and Standard deviation check boxes are 
selected. 

To display other or more statistics, select the desired check boxes. 

Use only in Workset Statistics 

The statistics are computed on the included observations in the active model, for the 
variables selected in the Use only list. The statistics are displayed for the transformed 
and trimmed variables when specified in the workset. 

By default all variables are included. 

To view the statistics of a selection of variables, mark the variables in the Use only list. 
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Correlation Matrix 
The correlation matrix is a spreadsheet that shows the pair-wise correlation between all 
variables (X and Y) in the current workset, scaled and transformed as the workset. 
Each variable is displayed on one row and one column in the correlation matrix, and 
the correlation between two variables is shown in the cell where the two variables 
intersect. By double-clicking a cell the corresponding scatter plot of the raw data is 
created. The value of the correlation coefficient represents the extent of the linear 
association between the two terms. The value of the correlation coefficient ranges from 
-1 to 1. When the correlation coefficient is close to zero there is no linear relationship 
between the terms.  

Note: When marking a CM, BEM or DA-model, the correlations are 
calculated over all classes/phases. 

To display the Correlation Matrix for the current model, click Statistics | 
Correlation Matrix.  

 

 

Coloring 
SIMCA uses a coloring scheme in ten levels (from dark color to white) to assist in the 
interpretation of the correlation matrix. The darker the color, the higher the absolute 
correlation. 

Limitation 
By default the correlation matrix is restricted to 32 variables, but this limit can be 
changed in the SIMCA Options dialog.  
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New workset 
To create a new workset from the settings of the default workset, click the New-
button. The Workset dialog opens. 

For more about the Workset dialog, see the Workset dialog section later in this 
chapter. 

Default workset 
When exiting the SIMCA import the default workset is created according to 
specifications during the import. For batch projects all datasets imported when creating 
the project are by default included while only the first dataset is included when 
creating a regular project. 

The properties that can be specified for the default workset are: 

 Selected datasets. 

 Variables as X, Y, or excluded. 

 Variable scaling but only for the X respective Y variables as groups, not for 
individual variables. 

 Observation class belonging. 

Note: No lags, expansions, or transformations can be saved in the default 
workset. 

Specifying the default workset 

The default workset can be specified as follows: 

 Datasets included: Select the desired datasets in the Select Data page in the 
Workset dialog and click Save as Default Workset. 

 Y-variables: Specify variables as Y in: 

o the SIMCA import or 

o the Workset dialog, Variables page, then click Save as Default 
Workset. Here the configuration of a batch project y-variable can 
also be saved. 

 Exclude variables: Specifying variables as Excluded in the Workset dialog, 
Variables page. 

 Scaling: Specifying X and Y variable scaling in File | Project Options, tab 
Fit, in the Default Scaling section. 

 Classes: Specifying class belonging 

o by specifying Class ID in the SIMCA import or 

o in the Dataset Properties, tab Observations. 
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New workset as model 
To create a new workset copying the settings from a selected model, click New As and 
select the desired model. 

New as model with class models 
With class models, the New As menu holds both wrapper CM and class models. 

 
Clicking New As |  

 CMxx opens the workset dialog with the variables of all classes and the 
same specification as model CMxx. 

 xx, opens the workset dialog with only the observations and variables of the 
selected class and the same specifications as model xx. Any change to 
variables, scaling or transformation of variables affects only that class 
(model). Clicking OK creates an unfitted model for the selected class in a 
new CMxx wrapper. 

New as model for batch projects with phases 
With batch project with phase models, the New As menu holds both wrapper BEM and 
phase models. 
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Clicking New As | 

 BEMxx opens the workset dialog with the variables of all phases (classes) 
and the same specification as model BEMxx. 

 Mxx, opens the workset dialog with only the observations and variables of 
the selected phase and the same specifications as model xx. Any change to 
variables, scaling or transformation of variables affects only that phase 
(model). Clicking OK creates an unfitted model for the selected phase in a 
new wrapper BEMxx. 

Editing the workset 
To edit the workset of a selected model, click the Edit-button and select the desired 
workset. If the model is fitted, it is replaced by the edited unfitted model. 

Editing a model is particularly useful when a transformation or scaling of a variable is 
necessary in one phase or one class only. 

Editing models with class models 
With class models, the Edit menu holds both wrapper CM and class models. 

Clicking Edit | 

 CMxx opens the workset dialog with the variables of all classes and the 
specification as model CMxx. 

 xx, opens the workset dialog with only the observations and variables of the 
selected class (model). Any change to variables, scaling or transformation of 
variables affects only that class. Clicking OK replaces the previous model 
with an unfitted model. 

Editing models for batch project with phases 
For a batch project with phase models, the Edit menu holds both wrapper BEM and 
phase models. 

Clicking Edit | 

 BEMxx opens the workset dialog with the variables of all phases (classes) 
and the specification as model BEMxx. 

 Mxx, opens the workset dialog with only the observations and variables of 
the selected phase (model). Any change to variables, scaling or 
transformation of variables affects only that model. Clicking OK replaces the 
previous model with an unfitted model. 
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Deleting the workset 
To delete a workset, click the Delete-button, and select the workset. Both the workset 
and the model associated with it will be deleted. 

 

Workset dialog 
After selecting to create a new workset, the Workset dialog opens with the current 
observations and variables and their attributes. 

Regular project Batch project 

  

The workset is organized in tabs, each holding a page. Clicking through the tabs opens 
the desired pages to change the attributes of the observations or variables. The 
available tabs are Select Data, Overview, Variables, Observations, Batch, 
Transform, Lag, Expand, Scale, and Spreadsheet. A description of each page 
follows later in this section. 

Note: The list on each of the Workset dialog pages can be copied by selecting 
the items to copy and then pressing CTRL+C. 

The first subsections describe features available on all or close to all pages. These 
features are: 

 Model type box - described in the Model types in the Workset dialog 
subsection next. Unavailable for batch evolution models, BEM. 

 Find feature - described in the Find feature in workset dialog subsection. 
Available on all pages but the Select Data, Overview and Spreadsheet 
pages. 
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 As model box - described in the As model subsection. Available on all pages 
but the Batch, Scale, and Spreadsheet pages. 

 Create partial models check box - described in the Partial models for 
batch level subsection. Available for batch level models only.  

The workset wizard, available for regular project, is described in the Simple mode 
workset wizard section later in this chapter. 

Note: Pressing ENTER or clicking OK, at any time, exits the workset. To 
continue defining the workset dialog, click another tab. 

   

Note: When marking a variable in one page, it remains marked in all pages 
when clicking another tab. 

Model type in the Workset dialog 
The default model type depends on the workset specifications. 

Click the Model type box to change the model type. 

Available model types in the Workset dialog 

The possible model types, in the Model type box, are: O2PLS, O2PLS-Class, 
O2PLS-DA, O2PLS-Hierarchical, OPLS, OPLS-Class, OPLS-DA, OPLS-
Hierarchical, PCA-Class, PCA-Hierarchical, PCA-X, PCA-X&Y, PCA-Y, PLS, 
PLS-Class, PLS-Hierarchical, PLS-DA and PLS-Tree. 

 

Default model type 

The default model type is set as follows: 

 PLS if there are continuous y-variables. 

 PLS-Class if there are continuous y-variables and observation classes 
defined. 

 PLS-DA if there is one qualitative y-variable. 

 PLS-DA if there are no y-variables and 6 or less classes. 

 PCA-Class if there are no y-variables and more than 6 classes. 

 PCA if there are no y-variables and no classes. 

 PLS-Hierarchical if variables have been assigned to blocks and there are y-
variables. 

 PCA-Hierarchical if variables have been assigned to blocks and there are no 
y-variables. 

Note: The previously selected model type is default in new worksets with the 
same workset specification. 
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Find feature in workset dialog 
The Find feature is available in all of the pages but the Select Data, Overview and 
Spreadsheet pages of the Workset dialog, although with some variations. 

There are two types of Find available from the arrow: searching independent of the 
Find field and the searching according to the entry in the Find field. 

 

Select All, Complement Selection, Select 

The first find options are independent of the Find field: 

 Select All (CTRL+A) marks all items in the list. 

 Complement Selection (CTRL+I) marks all unmarked items and deselects 
the previously marked. 

 Select opens a dialog with context sensitive options. Available in the 
Variables and Observations pages. 

For observations: 

 
For variables 
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Find in column 

The result from using Find starting with 'Find' depends on what is entered in the Find 
field. 

In the first section all IDs are displayed, and for the Transform and Scale pages also 
the displayed statistics. Default is to Find in ‘Primary ID’ Column. 

The second section defines how the search is done: Find Beginning With, Find 
Containing, or Find Exact. Default is Find Beginning With. 

Note: In the Transform and Scale pages the Find utility can search in the 
statistics columns too. 

Find field 

When typing in the Find field, the search is done according to the current settings, 
viewed by clicking the arrow. 

Wild card symbols '?', and '*' are allowed in specifying observations or variables 
names. For example “?LH*” selects observations or variables with names such as 
SLH2 or QLHSW, etc. 

To increase or decrease the time before the search starts after typing in the Find field, 
change the delay time in SIMCA Options. For more, see the SIMCA Options 
subsection in the File chapter. 

Note: The Find utility in SIMCA is cASe inSensiTiVE. 

As model 
The As model box is available on the Select Data, Overview, Variables, 
Observations, Transform, Lag, and Expand pages. They allow selection of the same 
settings as another model according to the table: 

Page Settings copied 

Select Data Dataset selection. 

Overview Variable settings according to Variables, Transform, Lag, 
and Expand below. 

Observation settings according to Observations below. 

Variables Variables and roles as the selected model. 

Observations Observations with the same class structure as specified in 
the selected model. 

Transform The same transformations for the same variables as the 
selected model. 

Lag Lag structure of the selected model. 

Expand Expanded terms as in the selected model. 
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Partial models for batch level 

For batch level datasets, partial models can be generated to predict the quality of the 
batch, or classify the batch before completion, by selecting the Create partial 
models… check box found at the bottom of the Workset dialog. 

 
There are two types of partial models, one according to phases and one according to 
completion: 

Steps Description with and without phases 

1. Select 
Create 
partial 
models… 
check box 
in the 
Workset 
dialog. 

With phases  
The check box just becomes selected. 

Without phases 
SIMCA opens the following dialog: 

  

In the Number field, type the number of partial models to create after 
Number. The variables are then parted according to maturity. Click OK. 

2. Click 
OK to exit 
the 
Workset 
dialog. 

With phases 
Automatically fits the models. The partial models are built sequentially 
from the phases.  

Without phases 
Automatically fits the models. The partial models are built from percent 
completion.  

3. View 
the result. 

With phases 

 

Without phases 
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Select Data page  
The Select Data page is available when there are more than one dataset available in the 
project. 

The Select Data page lists all datasets in the project for regular projects. For batch all 
batch evolution datasets are listed when the Create a batch level model check box is 
cleared and all batch level datasets are listed when the Create a batch level model 
check box is selected. 

When selecting more than one dataset, the datasets are merged by primary ID in the 
workset. The Primary ID match percentage is updated to indicate how well the 
primary IDs in the selected datasets correspond.  

To see how the merged datasets will be arranged during the calculations, click the 
Spreadsheet tab. Select workset as raw data in the View box if you want to view the 
data in original units. 

Overview page 
The Overview page displays the variables and observation lists with their respective 
attributes. 

Available from the Overview page are: 

 The variable list displaying the current role of each variable, X or Y, primary 
variable ID, transformations, expansions, scaling, scaling block, and lags. 

 The observation list displaying primary observation ID and when available, 
Class IDs, Batch IDs, and Phase IDs. 

 Shortcut menu both in the variable and observation lists with the same 
commands as in the Variables and Observations pages. For more, see the 
Variables page and Observations page subsections later in this chapter. 

 Missing value tolerance – to specify accepted percentage of missing in 
variables and observations, and checking missing values. 

 As model – for assigning X and Y etc. as another model. See the As model 
subsection, previously in this chapter for more. 

 Use Simple Mode - see the Simple mode workset wizard subsection later 
in this chapter. 

Variable list - Overview page 

The top part of the Overview page displays summarized variable information: 

 Variables: Number of included variables in the workset, X and Y. 

 Expanded terms: Number of expanded terms in Expand page. 

 Lags: Number of lags defined on the Lag page. 
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In the variable list, the X variables are listed first and Y variables last, and with the 
following information: 

1. Variable role displayed as an X or a Y to left of the variable ID. 

2. Primary Variable ID under Primary ID. 

3. Defined transformations under Transformation. 

4. E under Expansion indicates that the variable is expanded with 
cross, square, or cubic terms. 

5. Type of scaling under Scaling. 

6. Scaling block number, if the variable is part of block scaling under S. Block. 

7. L indicating that the variable is lagged under Lag. 

Lags and expansions appear at the bottom of the list. 

Observation list - Overview page 

Above the observation list the number of observations included is displayed. 

The observation list holds the observation primary ID and class belonging, or for batch 
projects batch, and when available, phase IDs. 

   

   
1. Primary Observation ID under Primary ID. 

2. Class of the observations under Class, if the observations are grouped in 
classes. 

3. Batch and phase IDs under Batch and Phase for batch projects. 

Missing value tolerance 

For the results of model fitting to be reliable, the workset should contain less than 50% 
missing values in observations or variables. This is the SIMCA default threshold for 
missing values for the workset and for predictions. 

The Missing value tolerance section is positioned at the bottom of the Overview 
page. It contains the default missing value tolerance for Variables and Observations 
and a Check Missing Values button. 

Missing values percentage exceeding tolerance 

When clicking the Check Missing Values button, or OK, the observations and 
variables missing values percentage is checked versus the tolerance limits. When the 
missing values percentage of a variable or observation exceeds the specified tolerance 
limit, SIMCA prompts for including or excluding the variable or observation.  

When no variables or observations exceed the missing value tolerance, the following 
message is displayed after clicking the Check Missing Values button: 
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Changing the missing value tolerance limit 

Change the tolerance limit displayed in the window of the workset by typing a new 
value in the Variable or Observation field. The new tolerance limit will only apply to 
the model generated by the current workset. 

To change the tolerance limit of missing values for new worksets and models, see the 
Project Options section in the File chapter. 

Variables with zero variance 

Variables are also checked for zero variance when clicking Check Missing Values or 
OK. SIMCA issues a message for including or excluding the variable with zero 
variance. When selecting to include such a variable it is given scaling weight 1. 

Variables page 
Use the Variables page, to view and configure the roles of the variables. 

Available from the Variables page are: 

1. Summary row listing Variables: 

 Included - Number of variables included in the workset, number 
of variables defined as X, number of variables defined as Y. 

 Excluded - Number of excluded variables. 

 Selected - Number of currently selected variables in the dialog. 

2. Variable list displaying the current role of each variable (X, Y, or -), primary 
variable ID, a Comment column, and a Dataset column when more than one 
dataset was selected in the Select Data page.  

3. Shortcut menu for selecting which variable IDs to display, Switch X & Y, 
and commonly used commands. For more about Switch X & Y, see the 
Switch X & Y subsection in the Change Model Type section later in this 
chapter. 

4. X – for assigning variables to the X-block. 

5. Y – for assigning variables to the Y-block. 

6. Exclude – for excluding variables. 

7. Class – for assigning variables to the classes specified in the Observations 
page. 

8. Blocks – for assigning variables to blocks for hierarchical modeling. 

9. Phases - for assigning variables to phases (batch evolution model only). 

10. Configure - for configuring the y-variable for the batch evolution model. 

11. Find – for finding variables. For more see the Find feature in Workset 
page subsection previously in this chapter. 

12. Save as Default Workset – for saving the current specification as default 
workset. 

13. As model – for assigning X and Y and excluding variables as another model. 
See the As model subsection, previously in this chapter for more. 
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Selecting roles by specifying X and Y 

To change the variable roles: 

1.       Select the variables. 

2.       Click the desired button X, Y, or Exclude. The list is updated accordingly. 

Note: Fitting a PLS, OPLS or O2PLS model with one qualitative Y is 
equivalent to fitting a PLS-DA, OPLS-DA or O2PLS-DA model with classes 
defined according to the qualitative variable. 

Switch X & Y 

Since O2PLS is bidirectional, it does not matter which variables are defined as X and 
which are defined as Y. But, in the model window the statistics are displayed in one 
direction.  

To view the statistics for the other direction: 

1. Click New as | Mxx and select the OPLS/O2PLS-model. 

2. On the Variables page, right-click and select Switch X & Y. Note that all 
variables previously defined as X are now defined as Y and vice versa. 

3. Click OK and fit the new OPLS/O2PLS-model. 
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Assigning variables to classes 

When observations have been grouped in classes, by default all the X and Y variables 
belong to all the classes. 

To assign variables to specific classes: 

1. Mark the variables. 

2. Select the class in the Classes box. 

The class number is displayed near the variable in the Class column. 

 

Assigning variables to blocks resulting in hierarchical models 

Variables can be assigned to variable blocks using the Blocks box. 

To assign variables to blocks: 

1. Mark the variables. 

2. Select the block number from the Blocks box. After selecting the first block, 
the Blocks list is incremented to include the next block number. 

The block number is displayed near the variable under the column Class. 

After defining the blocks the additional model types PCA-Hierarchical, and if y-
variables were specified, PLS-Hierarchical, OPLS-Hierarchical, and O2PLS-
Hierarchical are available. For more, see the Model type in the Workset dialog 
subsection earlier in this section. 
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Assigning variables to phases 

When batches have phases, by default the X and Y variables belong to the phases as 
specified at import. 

 
To assign a variable to different phases than specified by the default workset: 

1. Mark the variable. 

2. Select the desired phases using the phase check boxes in the Phases box. 

Note: Do not mark all variables that belong to a certain phase and select the 
phase. Making another selection overlapping with the first will replace the 
first phase setting for the intersection variables. 
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Configuring y-variables 

In a batch evolution model, the y-variable is a time or maturity variable. This time or 
maturity variable can be configured differently depending on batch and y-variable 
properties:  

 Smooth - Smooth out noise in a maturity variable so that it is strictly 
monotonically increasing or decreasing. 

 Shift - Shifts batches and phases to always start at 0. 

 Normalize - Batches are time normalized within each phase, giving all 
batches in a model identical length. 

To configure the y-variable, select it and click the Configure-button under Y Settings. 
The following dialog opens: 

 

Note: If the model should be used for on-line, never select the Normalize 
check box in the Configure Y-Settings dialog. 

Selecting variable type 

When selecting to create a batch project, the y-variable type is Time or Maturity. 

In the case where the project has batches but you want to just fit regular PLS models, 
with Y not being time or maturity, select Normal (create a non-batch project) in the 
Select variable type box. 



Home 

143 

Selecting variable options 

A combination or none of the three available options may be used for configuring y. In 
cases where a y-variable relating to Batch age, starting at 0 at batch start, is available 
no further y configuration is necessary. General recommendations for use of the three 
options are described in the table. 

Option Description Technical 
details 

Use Do not 
use 

Smooth Smoothes out 
irregularities in the y 
variable. This will 
ensure that the 
variable is strictly 
monotonically 
increasing or 
decreasing, per batch 
and phase. 

Smoothing 
by fitting a 
constrained 
quadratic 
polynomial, 
using a 
piece wise 
least 
squares 
algorithm. 

When the y-
variable is a 
maturity. 

When the y-
variable is 
time. 

Shift Shifts all values so that 
every batch and phase 
starts at 0. 

Shifting by 
subtracting 
the start 
value of 
each batch 
from all 
values. 

Default 
setting, few 
exceptions. 

When there 
is missing 
data at 
beginning of 
batches and 
the y 
variable is 
Batch age. 

Normalize Normalizes all batches 
to the same length. 
The y-values in every 
batch and phase are 
normalized into the 
interval given by the 
median start and 
endpoints of the 
batches. 

Normalizing 
by applying 
a linear time 
warping 
function. 

Rarely, 
when batch 
end is 
chemically 
or 
biologically 
driven. 

For online 
monitoring 
models. 

Save as Default Workset 

To change the default workset roles of the variables, from what was specified at 
import, specify the X, Y or excluded as desired and click Save as Default Workset. 
This specification defines the default workset when clicking New in the Workset 
group on the Home tab. 

Save as Default Workset saves which datasets were selected. Deleting a dataset 
included in the default workset results in a default workset using the other included 
datasets.  

For more about specifying the default workset, see the Default workset subsection 
earlier in this chapter. 

Observations page 
The Observations page displays all observations for the current workset and is used 
for including and excluding observations and grouping observations in classes. 
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Available from the Observations page are: 

1. Summary row listing: 

 Observations: Total number of observations in the project, both 
included and excluded. 

 Included: Number of included observations. 

 Selected: Number of currently selected observations in the dialog. 

2. Observation list displaying  for included and  for excluded 
observations, primary observation IDs, class number or name under Class, 
and for batch projects Batch and Phase numbers under the respective 
headers.  

3. Shortcut menu – for selecting which observation IDs to display and the 
commands Include, Exclude, Set Class, and Select All. 

4. Include – for including excluded observations. 

5. Exclude – for excluding included observations. 

6. Find – for finding observations. For more see the Find feature in workset 
dialog subsection previously in this chapter. 

7. Find class – for finding observations already assigned to a specific class. 

8. Set class – for assigning observations to a class number or entered name. 

9. Class from obs ID – for assigning classes from an available observation 
identifier. 

10. More – for creating classes from variable or score values. For more, see the 
Creating classes from variables or scores values subsection later in this 
section. 

11. As model – for including, excluding, and assigning classes according to an 
existing model. For more, see the As model subsection previously in this 
chapter. 

Note: The observations have to be included to be assigned to and part of a 
class. 
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Including and excluding observations 

To include or exclude observations: 

1. Select the observations. 

2. Click the Include or Exclude-button. 

For more about including and excluding observations, see the Excluding marked 
items subsection in the Marked Items tab section in the Plot and list contextual tabs 
chapter. 

Grouping observations in classes using Set class 

To group observations in classes using Set class: 

1. Select the observations by marking or by using Find. 

2. Specify the class by using either of the following methods: 

 Clicking the Set button found after the Set class field. The class 
number is automatically incremented. 

 Typing the class name in the Set class field and clicking Set. 

 Selecting an observation ID in the Class from obs ID and clicking 
Set. 

 

Automatic creation of classes from Observation ID 

To automatically create classes from observations ID, primary or secondary: 

1. Select the observation ID in the Class from obs ID box and click Set.  

 
2. In the Set Class from Observation ID dialog, enter the starting position and 

length of the string (number of characters) to be used for the creation of 
classes. 
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Creating classes from variables or scores values 

To create classes from values of a variable or score vector from an existing model, 

click the More button . The following window opens: 

   
After selecting a variable or a score vector, the min, max, mean, and std. dev. fields 
are automatically updated. 

Find observations between section 

To search for observations within a given range: 

1. Click Variables or Scores. 

2. Select the variable or score in the Variable or Score box. 

3. Under Find observations between, type the limits defining the range for the 
variable or score vector. 

To assign the selected observations to a class, use Set class arrow and click the Set 
button in the Observations page. 

Auto-generate classes section 

A set of classes can be generated automatically from variable or score values. 

To generate classes automatically: 

1. Click Variables or Scores. 

2. Select the variable or score in the Variable or Score box. 

3. Select number of classes from the Num. classes box. 

4. Select Equal 

a. Range – Splitting the range of the selected variable or scores in the 
desired number of classes. Note that this option may lead to 
different size classes. 

b. Size – Splitting the group equally in the desired number of classes, 
after sorting the variable. Note that this option may lead to 
observations with identical values ending up in different classes. 

5. Click the Set button in the More window. 
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Auto-generating classes according to qualitative setting 

When selecting a qualitative variable in the Variable box, clicking the Generate-
button automatically creates one class for each qualitative setting. 

   

Observations page for batch evolution models 

For batch evolution models the Observations page is stripped of all class setting 
functionality. This means that observations belonging to one phase cannot be 
reassigned to a different phase. 

The Observation page can be used for viewing the observations, searching for 
observations using the More-button or Find features, and to exclude or include single 
observations. 

To exclude entire phases or batches, or crop the phases, use the Batch page. 

Batch page 
The Batch page displays all batches and phases and is used for including, excluding, 
and cropping batches and phases for batch evolution models, BEM. For batch level 
models, BLM, the tab is there but no functionality is available. 

Available from the Batch page are: 

1. Summary row listing: 

 Batches - total number of batches in the project. 

 Included - Number of included batches in the current workset. 

 Phases - Number of phases in the project. 

2. Batch and phase lists displaying batch respective phase IDs and a Status 
column. For batches, the Status column is updated with Exclude when 
batches are excluded. For phases, the Status column states Included for 
included phases and the number of observations currently included in the 
phase. This column is updated when phases are cropped or excluded.  

3. Shortcut menu with selected commands, also available as buttons. 

4. Find – for finding batches or phases. For more see the Find feature in 
workset dialog subsection previously in this chapter. 
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Under Batches 

5. Include – for including excluded batches. 

6. Exclude – for excluding batches. 

Under Phases 

7. Crop/Exclude – for excluding observations phase-wise according to 
specified criteria. 

8. Uncrop/Include - for reversing the cropping. 

9. Include All under Phases – for including all phases. 

10. Exclude – for excluding phases. 

11. Crop Information – for viewing a summary of the performed cropping. 

   

Note: When editing the workset (clicking Edit in the Workset group) and 
selecting a phase (class) model, the workset dialog displays only the selected 
model and the Batch page is not available. 

Including and excluding batches 

Below the batch list, the buttons Include and Exclude enable including and excluding 
batches. 

To exclude or include a batch: 

1. Select the batch in the Batch list. 

2. Click the Exclude or Include button. The Status column is updated and 
states Excluded for the excluded batches and nothing for the included. 

Note: Excluding batches excludes them from all phases. 

Including and excluding entire phases 

Below the phase list, the buttons Uncrop/Incl and Exclude enable including and 
excluding entire phases. 
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To exclude a phase: 

1. Select the phase in the Phase list. 

2. Click the Exclude button. The Status column is updated and states 
Excluded for the excluded phases. 

To include all phases, mark all phases and click the Uncrop/Incl button. The Status 
column is updated and lists the number of observations in the respective phases. 

Cropping phases 

Crop a phase by excluding as specified in the Crop dialog. 

Note: Batches with no phases are treated as having one single phase and can 
be cropped in the Batch page. 

To crop a phase: 

1. Select the phase in the Phase list. 

2. Click the Crop/Exclude-button. 

3. Specify the desired cropping according to the table. 

The different cropping options are described in the table. 

  Option Description Example and 
result 

1. Exclude the first x 
observations in all 
batches in this 
phase. 

Excludes x 
observations, starting 
from the beginning of 
each batch, in the 
marked phase. 

Entering ‘3’ excludes the 
3 first observations in all 
batches for the marked 
phase. 

2. Exclude the last x 
observations in all 
batches in this 
phase. 

Excludes x 
observations, starting 
from the end of each 
batch, in the marked 
phase. 

Entering ‘3’ excludes the 
3 last observations in all 
batches for the marked 
phase. 

3. Exclude all 
observations 
satisfying the 
following condition: 

If variable VAR1 is 
LOGICAL 
EXPRESSION 
VALUE1 and 
VALUE2. 

Excludes the 
observations satisfying 
the condition defined 
by: 

 The variable. 

 The logical 
expression 
among ‘<’, ‘>’, 
‘<=’, ‘>=’, and 
‘outside’. 

 The limiting 
value or for 
‘outside’ values. 

If variable ‘bottom temp.’, 
is ‘<’, ‘60’ excludes all 
observations with a value 
smaller than 60 in 
variable ‘bottom temp.’ 

Note that the result from 
cropping all phases with 
this type of cropping can 
be achieved with 
trimming too. 

4. Downsize, use only 
every x observation. 

Downsizes the phase 
to only use every x 
observations. 

Entering ‘3’ excludes 2/3 
of the observations in the 
phase, keeping 
observation number 1, 4, 
7, 10, 13 etc. 
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Note: The check boxes can be selected independently and all together. 

 

Crop Information 

After cropping, clicking the Crop Information button displays a summary of the 
performed cropping per phase and per cropping. This means that for each time OK is 
clicked with cropping defined, the applied cropping details are displayed per phase in 
the Crop Information window. 

Transforming variables 
The Transform page displays all variables with current transformation and statistics. 
The Transform page is used to apply transformations to selected variables. 

Available from the Transform page are: 

1. Summary row listing number of included variables and number of selected 
variables. 

2. Variable list displaying variable role (X or Y), primary variable ID, 
Skewness, Min/Max, Min, Max, Transform, and the constants C1, C2, and 
C3. For more about the Transform, C1, C2, and C3 columns see the 
Applying transformations subsection later in this section.  

3. Shortcut menu with the commands  for selecting which variable labels to 
display, Set Transform, Select All, and Quick Info. 

4. Find – for finding variables. For more see the Find feature in workset 
dialog subsection previously in this chapter. 

5. Quick Info – for opening the Quick Info window. For more see the Quick 
Info subsection in the View chapter. 

6. As model – for transforming all variables as transformed in another model. 
See the As model subsection, previously in this chapter for more. 

7. Specify transformation – for defining a transformation and applying it to 
the selected variables. 

8. Auto transform selected variables as appropriate – to automatically 
transform the variables in need of logarithmic transformation. 

Note: When batch data have phases, transformations of variables can be done 
for each phase by editing the phase model (edit by marking the phase model 
and on the Home tab, in the Workset group, clicking Edit). 
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Skewness or Min/Max colored red 

When the value in Min/Max or Skewness is colored in red, a transformation is 
probably desired. 

 
For more about the criteria used, see the Transform page criteria section in 
Appendix A: Statistics. 

Quick Info in Transform page 

With the Quick info window open when applying transformations, the statistics and 
plots displayed in the Quick Info are updated. This enables you to view the before and 
after plots and statistics immediately. 

To open the Quick Info window, click the Quick Info button. 

For more about the Quick Info window, see the Quick Info subsection in the View 
chapter. 
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Applying transformations using Specify transformation 

To apply a transformation: 

1. Select the variables to transform in the list. 

2. Select a transformation in the Specify transformation box. Under the 
selected transformation, the formula of the selected transformation appears 
next to Formula. The default values for the constants appear in the C1, C2, 
and C3 fields. 

3. Change from the default constants as appropriate. 

4. Click the Set-button. The columns Transform, C1, C2, and C3 in the 
variable list are updated accordingly. 

5. Repeat 1- 4 as needed to transform all the desired variables. 

Note: The transformation is applied when clicking the Set button. Clicking 
OK without having clicked the Set button does not apply the selected 
transformation. 

Transformations available 

The following transformations are available: 

Transformation Formula 

None Default 

Lin C1X+C2 

Log Log10(C1X+C2) 

Negative Log -Log10(C1X+C2) 

Exp 
e

C1X+C2 

Logit Log10((X-C1)/(C2-X)) 

Power 
(C1X+C2)

C3 

C3 = [-2,-1,-0.5,-0.25,0.25,0.5,1,2,] 

Automatic transformation 

Automatic Log transformation according to certain criteria is available by following 
the steps: 

1. Select the desired variables in the variable list. 

2. Optionally select the If one variable in the X or Y block needs 
transformation, transform all selected variables in that block check box 
to have all variables in the same metric. In summary, when the check box is 
selected all variables are Log transformed if one meets the criteria for 
automatic transformation. 

3. Click the Transform button. The software checks if any of the selected 
variables need a Log transformation and if so applies it. 

The criteria used to decide if a log transform is needed is described in the Transform 
page criteria section in Appendix A: Statistics. 
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Lagging variables 
When the X or Y-matrix is expanded with lagged variables, this allows the study of the 
influence of the process variables at L time units earlier in the process at time t. 

All variables, included or excluded, can be lagged and included in the model. 

Available from the Lag page are: 

1. Lags field – for defining lagging structure. 

2. The lists displaying variable role and primary variable ID for Available and 
Lagged variables.  

3. Shortcut menu with commonly used commands. 

4. Arrow button between the fields to add lagged variables. 

5. Find – for finding variables. For more, see the Find feature in workset 
dialog subsection previously in this chapter. 

6. Remove and Remove All – for removing lag variables. 

7. As model – for adding lagged variables as in another model. For more, see 
the As model subsection previously in this chapter. 

 

Lag specification 

A variable can be lagged with several different lags, e.g., 2, 4, 12, 24 and 36. 

In Lag specification, enter the desired lags by typing. Use ‘–‘ to specify a range, for 
example 1-5 means lags 1 to 5. After defining a lag structure, that structure can be 
selected by clicking the Lags arrow. 

Adding the lagged variables 

To create the lagged variables: 

1. Enter the lag structure in the Lags field. 

2. Mark the variables in the Available variables list. 

3. Click the arrow . The lag variables are added in the Lagged variables 
list, according to the selected lag structure. 

To remove any of the new lagged variables, mark it and click Remove. 
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Expanding variables 
The Expand page allows changing the default linear model by expanding the X matrix 
with squares, cross, and cubic terms. 

Available from the Expand page are: 

1. Summary row listing number of included variables, selected variables, 
expanded terms, and selected expansions. 

2. Variables list displaying the included variables, including lag variables, and 
their roles.  

3. Expanded terms list displaying the created expansions. 

4. New term field and => buttons for defining expansions. For more see the 
Adding expansions using the ‘New term’ field subsection later in this 
chapter. 

5. Shortcut menu for selecting which variable IDs to display and commonly 
used commands. 

6. Cross, Square, Sq & Cross, and Cubic-buttons between the fields to add 
expansions. For more see the Adding terms using the buttons subsection 
later in this chapter. 

7. Find – for finding variables. For more see the Find feature in workset 
dialog subsection previously in this chapter. 

8. Remove and Remove All – for removing expansions.  

9. As model – for adding expansions as in another model. See the As model 
subsection, previously in this chapter for more. 

 

Term names 

The names for expanded term are 'primary variable ID' x 'primary variable ID', i.e. 
x1*x1 for squares, x1*x2 for cross terms, and x1*x1*x1 for cubic terms. These names 
will appear on all plots and lists. 

Scaling of expanded terms 

All expanded terms are displayed in the Scale page. For more, see the Scaling of 
expanded terms subsection in Appendix A: Statistics. 
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Adding terms using the buttons 

The x-variables, including lagged variables, are displayed in the Variables list. 

To add an expansion, select the desired variables and click a button: 

Adding terms using the ‘New term’ field 

Any term, including up to three of the available variables, can be added using New 
term. 

To add three factor interactions: 

1. Add a term (and see that it ends up in New term) by: 

a. Double-clicking a term OR 

b. Selecting a term and click the left arrow =>. 

2.  Repeat 1. until the three factor interaction is displayed in New term. 

3. Click the rightmost => arrow to add the term. 

To empty the New term field, click the Clear button. 

Note: The New term field is useful when the term you want to add includes 
three terms but is not cubic. 

Scaling variables 
Usually with all variables of the same type or an assortment of different measurements, 
centering and auto scaling to unit variance is warranted. This is the SIMCA default 
and if this is your choice, no changes in the Scale page are necessary. The SIMCA 
default can be changed in Project Options, see the Fitting options subsection in the 
Project Options section in the File chapter for more. 

Customizing the scaling is available from the Scale page in 4 manners: 

1. Using the Set Scaling section. 

2. Importing scaling weight and center values from file by clicking the Read 
Scaling button. 

3. Defining the scaling weight and center values from secondary variable ID by 
clicking the Scale from Sec. ID button. 

4. Defining the scaling weight and center values by entering them manually in 
the dialog by clicking the Custom Scaling button. 

When using customized scaling (2-4 above), variables with values left blank for the 
scaling weight use the calculated standard deviation from the data to calculate the 
weight. Similarly, variables with values left blank for the center use the calculated 
mean of the variable as center. 

Note: To display the current scaling weight and center values after using 
Read Scaling or Scale from Sec. ID, click the Custom Scaling button. 
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Centering or not centering 

Normally, variables are centered by subtracting their averages or other reference 
values. Centering by subtracting the average is the SIMCA default. 

Occasionally, for example when working with difference data, you may be interested 
in the variation of the variables around zero (0), hence you do not want to center 
specific variables. Use one of the customization methods listed above to accomplish 
this. 

Note: The scaling weights of all variables, except those with base type Freeze 
or Frozen, are recomputed when changing the selection of observations. 

Show statistics 

Selecting or clearing the Show statistics check box displays or hides the average and 
standard deviation of every variable. 

Note: When using Read Scaling, Scale from Sec. ID, or Custom Scaling the 
values displayed under Avg and Std. Dev. are the calculated average and 
standard deviation values, not the values that will be used when scaling the 
variables. 

To read about the scaling of expanded terms, transformed variables, lagged variables, 
variables in classes, scaling after re-selecting observations, and calculation of the 
scaling weight, see the Scaling section in Appendix A: Statistics. 

Scaling using the Set Scaling section 

To change the scaling base type from the Set Scaling section: 

1.  Select the variables. 

2.  Select the base type in the Type box. 

3.  Click Set next to the Type box. 

The new scaling type is displayed in the Type column. 
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Scaling base weight types available 

The following scaling base types are available from the Type box: 

Base 
weight 
type  

Description 

None  No centering or scaling (ws = 1). 

  

UV Variable j is centered and scaled to "Unit Variance", i.e. the base 
weight is computed as 1/sdj, where sdj is the standard deviation of 
variable j computed around the mean.  

UVN Same as UV, but the variable is not centered. 

The standard deviation is computed around 0. 

Par Variable j is centered and scaled to Pareto Variance, i.e. the base 
weight is computed as 1/sqrt(sdj), where sdj is the standard deviation of 
variable j computed around the mean. 

Pareto scaling is in between no scaling and UV scaling and gives the 
variable a variance equal to its standard deviation instead of unit 
variance. 

ParN Same as Par, but the variable is not centered 

The standard deviation is computed around 0. 

Ctr The variable is centered but not scaled (ws = 1) 

Freeze The scaling weight of the variable is frozen and will not be re-computed 
when observations in the workset change or the variable metric is 
modified after the freezing. 

Block scaling 

Block-wise scaling is warranted when a data table contains several types (blocks) of 
variables, with different numbers of variables in each block. Block-wise scaling allows 
each block to be thought of as a unit and to be given the appropriate variance, which is 
less than if each variable was auto scaled to unit variance. 

Block scaling scales down the importance of the variables so that the whole block has 
(Kblock) variance, or unit variance, 

where Kblock is the number of variables in the block. 
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Defining the block scaling 

To block scale: 

1. Mark the variables in the first block. 

2. Select the block weight. 

3. Click the Set button found to the right of the blocking options. 

4. Mark other variables. 

5. Change the block number and optionally the block weight. 

6. Click the Set button found to the right of the blocking options. 

7. Repeat 4-6 until all blocks have been defined. 

Block scaling types available 

The following block scaling types are available: 

where Block = number of variables in the block 

Note: X and Y variables cannot be grouped in the same scaling block. 

Modifier 

Scaling variables up or down relative to their base weight is done using the Modifier. 

To scale variables up or down relative to their base weight: 

1. Mark the variables. 

2. Enter the value in Modifier. 

3. Click Set. 

To reset the modifier to 1: 

1. Mark the variables. 

2. Enter ‘1’ in Modifier. 

3. Click Set. 

Reading scaling from file 

Centers and scaling weights can be imported from file and used to scale the variables. 

Importing scaling from file for regular projects 

For regular projects, i.e. non batch data, the file must have the following rows: 

 Variable IDs. 

 Center values. 

 Scaling weights. 
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Importing scaling from file for batch projects with phases 

Specifying different scaling than the default for the variables in the different phases 
and applying them simultaneously to all phases, is available using Read Scaling. 

For batch projects with phases, centers and scaling weights for each phase can be 
defined in the Read Scaling wizard spreadsheet. 

The imported file must have the following column and rows: 

 Phase ID column. 

 Variable names row. 

 Center values rows, one for each phase. 

 Scaling weights rows, one for each phase. 

To see the different base weight types resulting from customized scaling, see the 
Scaling base weight types with customized scaling section later in this chapter. 

Note: When using Read Scaling to specify the scaling for all phases 
simultaneously, either click Edit | BEMxx or New in the Workset group. 
Using Read Scaling when editing a phase will apply the scaling to that phase 
only. This is the case for class models too. 

Read Scaling wizard 

To import a file holding scaling weights and center values follow the steps that follow: 

Step Action and illustration 

1. Select the scaling file. Click Read Scaling and select the file containing the 
weights and/or centers. 
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Step Action and illustration 

2. Specify weights and 
centers. 

For batch projects with 
phases, weights and 
centers need to be specified 
for all phases. 

In the Import Scaling Data dialog, in turn mark the 
rows with primary variable IDs, weights, and centers 
and click the Variable IDs, Weights and Center-
buttons. 

SIMCA automatically recognizes the words ‘mean’ or 
‘center’ and ‘weight’ when present in a column and 
marks these rows as center and weights. 

Variables that are not included in the list are centered 
and scaled UV. Variables with blank values for the 
center use as center the computed mean from the 
data and variables with blank for scaling weights are 
scaled UV. 

Note: When the batch project has phases, weights 
and centers have to be specified for each phase. 

Click Next. 
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Step Action and illustration 

3. Specifying weight 
properties. 

In the Summary page, specify how to use the 
weights and click Finish. 

View the table next for a description of the options in 
the Summary page. 
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Weight definition for imported scaling 

This table describes the options in the Import Scaling Data wizard Summary page. 

Weight selected Description Example 

The standard deviation 
of the variable. SIMCA 
will use the inverse of 
the values as scaling 
weights.  

The values specified as 
Weights in the 
spreadsheet are inverted 
and used as scaling 
weight. 

If the Weights value for 
variable ‘V1’ in the 
spreadsheet is ‘3’, then 
the scaling weight, ws = 
1/3. 

The inverse of the 
standard deviation of 
the variable. SIMCA 
will use the values as 
the scaling weights.  

The values specified as 
Weights in the 
spreadsheet are used as 
scaling weight. 

If the  Weights value for 
variable ‘V1’ in the 
spreadsheet is ‘3’, then 
the scaling weight, ws = 
3. 

% of the center values. 
SIMCA will use the 
inverse of the % center 
values as scaling 
weights.  

The values specified as 
Weights in the 
spreadsheet are the 
percentage values that, 
multiplied with the center 
values, results in the 
standard deviation, SD (the 
inverse of the scaling 
weight). 

When Centers are 
specified in the 
spreadsheet, the SD used 
is the percent (weight 
value) of the center. 

For variables with the 
Centers left blank, the 
calculated mean is used as 
center and the standard 
deviation (SD) used is the 
specified percentage of the 
center or the calculated 
SD, whichever is greater. 

If the Weights are blank, 
this option defaults to using 
the SIMCA calculated 
weight. 

With center value: If the 
Weights value for 
variable ‘V1’ in the 
spreadsheet is ‘3’ and 
the Centers value is ’10’, 
then the scaling weight, 
ws = 1/(0.03*10). 

Without center value: If 
the Weights value for 
variable ‘V1’ in the 
spreadsheet is ‘3’ and 
the Centers value is 
blank, then the scaling 
weight used is the 
smaller of 

ws = 1/(0.03*calculated 
center) 

ws = 1/(the calculated 
SD). 

Use xx % of the center 
values as standard 
deviation when 
calculating the weight. 

The values defined as 
Weights in the 
spreadsheet are ignored. 
The entered percentage of 
the center values is used 
as standard deviation and 
inverted before used as 
standard deviation. 

If xx entered is ‘5’, the 
center value is ‘10’. The 
standard deviation, SD = 
0.05*10. The scaling 
weight, ws = 1/SD = 2. 

Note: When using Read Scaling to specify the scaling for all phases 
simultaneously, either click Edit | BEMxx or New in the Workset group. 
Using Read Scaling when editing a phase will apply the scaling to that phase 
only. 
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Scaling from numerical secondary variable ID 

Scaling from secondary variable IDs is available when secondary variable IDs are 
numerical. The variable IDs must contain scaling weights or center values. 

Note: When batch data have phases, scaling from Secondary IDs can be done 
for each selected phases, by editing the phase model. 

To see the different base weight types resulting from customized scaling, see the 
Scaling base weight types with customized scaling subsection later in this chapter. 

Scale from Sec. ID dialog 

To scale and/or center from secondary variable IDs, follow the steps: 

1. Select the variables to scale. 

2. Click the Scale from Sec. ID button.    

3. In the dialog that opens, select the secondary variable ID that contains the 
standard deviations or scaling weights in the Weight box. Selecting 1 (no 
scaling) results in no scaling. 

4. In The weight is section, the default is The standard deviation of the 
selected variables. This means that the inverted values in the variable ID 
will be used as scaling weights. To use the specified weight values in the 
secondary ID as scaling weight, select The inverse of the standard 
deviation for the selected variables. 

5. In the Center box, select the secondary ID that holds the center values or 0 
(center around zero). 

6. Selecting the Use x % of the center as standard deviation when 
calculating the weight check box results in that the entered percentage of 
the center values is used as standard deviation and inverted before used as 
scaling weight. When selecting this check box the other Weight options are 
unavailable. For more details, see the second table in the Read Scaling 
wizard subsection earlier in this chapter. 

 



User Guide to SIMCA 

164 

Custom Scaling dialog 

It is sometimes necessary to specify the center and the scaling weight of variables to be 
different than computed from the data. By clicking the Custom Scaling button, the 
scaling weight of the variables can be specified as follows: 

1. Select the variables to scale. 

2. Click the Custom Scaling button.    

3. In the dialog that opens, enter the standard deviation or scaling weight in the 
Weight field. Leaving blank results in using the calculated scaling weight. 

4. In The entered weight is section, the default is The standard deviation of 
the selected variables option. This means that the inverted values in the 
variable ID will be used as scaling weights. To use the specified weight 
values in the secondary ID as scaling weight, select The inverse of the 
standard deviation for the selected variables option. 

5. In the Center field, enter the center value to use. Leaving blank results in 
using the calculated mean as center. 

6. Selecting the Use x % of the center as standard deviation when 
calculating the weight check box results in that the entered percentage of 
the center values is used as standard deviation and inverted before used as 
scaling weight. When selecting this check box the other Weight options are 
unavailable. For more details, see the second table in the Read Scaling 
wizard subsection earlier in this chapter. 

   

Scaling base weight types with customized scaling 

After changing the scaling using Read Scaling, Scale from Sec. ID, or Custom 
Scaling the following scaling base types are available: 

Base 
weight 
type 

Description Weight and center 
specification 

Frozen The center and the scaling weight 
of the variable are specified 

Weight and Center values that 
are not weight=1 and center=0. 
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Base 
weight 
type 

Description Weight and center 
specification 

FrozenC The scaling weight is specified, 
but not the center (value is left 
blank). The center is computed 
from the data. 

Weight values (not=1) but 
Center is left empty. 

Not possible for Scale from 
Sec ID. 

FrozenN The scaling weight is specified 
and no center is selected, 
(centering is done around 0). 

Weight values (not=1) and 
Center = 0. 

UVF The center is specified, but not 
the scaling weight, the standard 
deviation is computed from the 
data and ws=1/standard 
deviation. UVF is UV scaled using 
a new center value. 

Weight values left empty, 
Center values specified. 

Not possible for Scale from 
Sec ID. 

NoneF The center is specified and no 
scaling is selected (ws=1) 

Weight = 1, Center values 
specified. 

%Mean The center is not specified but the 
entered percentage of the center 
is used as standard deviation 
when calculating the weight. 

No center or weight values 
specified. The Use x % of the 
center as standard deviation 
when calculating the weight 
check box selected and the 
desired percentage entered. 

%Frozen The center is specified and the 
entered percentage of the center 
is used as standard deviation 
when calculating the weight. 

Center specified but not weight 
values. The Use x % of the 
center as standard deviation 
when calculating the weight 
check box selected and the 
desired percentage entered. 

The calculation of the scaling weight is described in Scaling weight calculation 
subsection in Appendix A: Statistics. 

Spreadsheet 
The Spreadsheet page, in the Workset dialog, displays the currently included 
variables and observations, including lagged and expanded variables.  

Available in the Spreadsheet page are: 

 Quick Info-button – for viewing variables and observations. 

 Reset limits-button – for removing trimming and Winsorizing. 

 View box – for selecting scaled or original units. When editing a batch 
model, average batch and aligned vectors are available. 

 Trim Information-button – for displaying the performed trimming. 

 Workset list displaying all variable and observation IDs and values. 

 Shortcut menu – for copying, locking columns, opening the Quick Info, 
zooming out, saving list to file, and printing. 
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The Spreadsheet list displays the data and all variable and observation IDs of the 
currently included variables and observations. 

Quick Info in the Workset dialog spreadsheet 

The Quick Info window displays overview information about the marked variables or 
observations, depending on whether selecting Quick Info | Variables or Quick Info | 
Observations. 

Open the Quick Info window by: 

 Clicking the Quick Info button and selecting Variables or Observations. 

 Right-clicking the spreadsheet and selecting Quick Info | Variables or 
Observations. 

Trim-Winsorizing the workset 

When trimming or Winsorizing the workset, it only affects the current workset and 
does not touch the dataset. 

The Trim-Winz Var and Trim-Winz All buttons are available in the Quick Info 
Variables window when workset as raw data is selected in the View box, that is, 
when the variables are displayed in original units. 

Trimming and Winsorizing is done on the selected variables across all phases and 
batches. 

Note: When editing a phase model, trimming is unavailable. 

For more about the Quick Info window, see the Quick Info section in the View 
chapter. 

Removing the trimming and Winsorizing in the workset 

Removing the trimming or Winsorizing for the current workset can be done by: 

 Clicking the Undo trimming button in one of the trimming Winsorizing 
dialogs. 

 Clicking the Reset limits button next to the Quick Info button. 
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Trimming and Winsorizing information 

After trimming or Winsorizing, clicking Trim Information displays a summary of the 
performed trimming/Winsorizing. 

   

View workset in scaled or original units 

The View box contains the two options workset and workset as raw data and when 
editing a phase or batch model the additional options: average batch, and aligned 
time/maturity vector. 

 
By default, workset is selected in the View box, meaning that the variables are 
transformed, scaled, and centered according to the current workset specification. 

To display all variables and observations in original units, select workset as raw data. 

Average batch and aligned time/maturity 

To view the average batch or aligned time or maturity vector for a BEM with phases, 
mark a phase model and click Edit in the Workset group. In the Spreadsheet page of 
the Workset dialog select average batch or aligned time/maturity vector in the 
View box. When editing a BEM (with phases) or BLM the additional batch options 
are unavailable. 

Note: With phases, these calculations are done for every phase, since the 
alignment is done by phase. 

Creating unfitted models 
New unfitted models are created when exiting the Workset dialog by clicking OK. 

Unfitted models in wrappers 

When the Model type is PCA/PLS/OPLS/O2PLS-Class SIMCA generates unfitted 
class models, one for each class with the wrapper CMxx. The numbering of the CM 
models is sequential. 

For batch projects with phases, when clicking OK SIMCA generates unfitted PLS 
class models, one for each phase with the wrapper BEMxx.  
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Note: Changes in the class or phase model are not remembered by the 
wrapper model CM respective BEM. This means that if you for instance 
exclude a batch in a phase model, that batch will be included if you click 
Workset | New As Model and click the BEM. 

Simple mode workset wizard 
The workset dialog is opened in simple mode the very first time you open the Workset 
dialog in SIMCA. After that the dialog remembers whether to open in simple mode or 
advanced mode.  

The simple mode workset wizard contains the following pages: 

1. Start page – displays a short description of the workset wizard. 

2. Select Data page - displays the available datasets when there is more than 
one. See also the Select Data subsection earlier in this chapter.  

3. Variables page – for assigning roles and applying automatic transformation. 

4. Observations page – for excluding, including, and assigning classes. 

5. Summary page – displays a summary of the active model and allows 
changing from the default fitting type. 

To switch between simple and advanced mode, click the Use Advanced Mode and 
Use Simple Mode respectively.  

Note: Simple mode is only available for regular projects. 

Simple mode start page 
The first page of the workset wizard describes the features of the workset wizard. 

To not display this introductory page the next time the simple mode workset opens for 
this project, select the Don’t show this page again check box. 

Click Next. 
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Variables page in simple mode 
In the Variables page, the following is available: 

1. A summary line displaying currently included and excluded variables. 

2. The variable list displaying the current role of each variable (X, Y, or ' -'), 
variable IDs, and a Comment column. 

3. X-button – for assigning variables to the X-block. 

4. Y-button – for assigning variables to the Y-block. 

5. Exclude-button – for excluding variables. 

6. Find and select field – for finding variables. For more see the Find feature 
in Workset page previously in this chapter. 

7. Save as Default Workset button – for saving the current specification as 
default workset. 

8. As model – for assigning X and Y and excluding variables as an existing 
model. See the As model section, previously in this chapter for more. 

Clicking Next opens the Observations page of the wizard. 

 

Variable list 

The variable list displays the current role, variable IDs, and Comment. The Comment 
column displays the current transformation. The only transformation available in 
Simple Mode is the Log transform. 

The following can be added in Advanced Mode and is then displayed in Simple 
Mode: 

 Transformation other than Log displayed in Comment. 

 Lagging displayed in Comment. 

 Class belonging displayed in Class. 

The context sensitive menu, opened by right-clicking the variables list, holds the 
following commands: X, Y, Exclude, Select All (CTRL+A), and Variable Label, 
where the last enables displaying the desired variable IDs. 
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Selecting roles by specifying X and Y 

To change the variable roles: 

1.       Select the variables. 

2.       Click the desired button X, Y, or Exclude. The list is updated accordingly. 

Note: Fitting a PLS, OPLS or O2PLS model with one qualitative Y is 
equivalent to fitting a PLS-DA, OPLS-DA or O2PLS-DA model with classes 
defined according to the qualitative variable. 

Automatic transformation 

Automatic Log transformation according to certain criteria is available by following 
the steps: 

1. Select the desired variables in the variable list. 

2. Optionally select the If one variable in the X or Y block needs 
transformation, transform all selected variables in that block check box 
to have all variables in the same metric. In summary, when the check box is 
selected all variables are Log transformed if one meets the criteria for 
automatic transformation. 

3. Click the Transform button. The software checks if any of the selected 
variables need a Log transformation and if so applies it. 

The criteria used to decide if a log transform is needed is described in the Transform 
page criteria section in Appendix A: Statistics. 

Save as Default Workset 

To change the default workset roles of the variables, from what was specified at 
import, specify the X, Y or excluded as desired and click Save as Default Workset. 
This specification defines the default workset when clicking New in the Workset 
group on the Home tab. 

Save as Default Workset saves which datasets were selected. Deleting a dataset 
included in the default workset results in a default workset using the other included 
datasets.  

For more about specifying the default workset, see the Default workset subsection 
earlier in this chapter. 
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Observations page in simple mode 
The Observations page functionality is identical to the Observations page in the 
Advanced Mode with the following exception: there is no More button so assigning 
classes from variables or scores is unavailable here. 

For details about the Observations page, see the Observations page section 
previously in this chapter. 

Click Next to open the Summary page. 

 

Summary page in simple mode 
The Summary page displays a summary over the specification done in the workset 
wizard, including the model type that will be fitted. 

 
Click Finish to close the wizard and automatically fit the model or models. 

Change Model Type 
The default model type after exiting the workset dialog is determined by the selected 
model type in the Model Type box in the Workset dialog. 
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To change from the default model type, click Change Model Type and click a new 
model type in the gallery that opens. 

For example after fitting a principal component model of the responses (PCA-Y), 
click Change Model Type and select PLS to fit a PLS model. SIMCA creates a 
new unfitted model, with type PLS. 

An unfitted model can only be a Non Hierarchical Base Model. 

Note: SIMCA creates a new unfitted model every time a new model type is 
selected. 

 
The Change Model Type button is found in the Workset group on the Home tab. 

Model types available 
The available model types from Change Model Type are, in the order of the gallery: 

Model type Description 

Overview 

PCA-X Fits a PC to the X variables. 

PCA-Y Fits a PC to the Y (responses) variables. 

PCA-X&Y Fits a PC to all included variables (X and Y). 

Regression 

PLS Fits a PLS model. 

Available when both X and Y variables were defined in the workset. 
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Model type Description 

OPLS Fits an OPLS model with the additional objective to model and 
interpret variation in X that is orthogonal to Y, which needs to be 
modeled to achieve the best possible prediction and interpretation 

Available when both X and Y variables were defined in the workset. 

O2PLS Fits an O2PLS model with the additional objective to model and 
interpret variation in X that is orthogonal to Y. 

The orthogonal variation can be further divided into two parts; the 
OPLS part and the PCA part. The PCA part consists of structured 
variation that does not affect the prediction but can be interesting to 
study to further improve the interpretation of complex multivariate 
data.  

Available when X and at least two Y variables were defined in the 
workset. 

Discriminant Analysis 

PLS-DA Fits a PLS model using SIMCA created dummy Y variables, one for 
each class. 

Available after grouping observations in two or more classes. 

OPLS-DA Fits an OPLS/O2PLS model using SIMCA created dummy Y 
variables, one for each class. See OPLS above. 

Available after grouping observations in two or more classes.  

O2PLS-DA Fits an O2PLS model using SIMCA created dummy Y variables, 
one for each class. See O2PLS above. 

Available after grouping observations in three or more classes.  

Class Models 

PCA-Class Fits PC models for the X block, one for each class, with a wrapper 
CM. 

Available after grouping observations in classes or variables in 
blocks. 

PLS-Class Fits PLS models, one for each class, with a wrapper CM. 

Available after grouping observations in classes, or variables in 
blocks, and both X and Y variables are included. 

OPLS-Class Fits OPLS models, one for each class, with a wrapper CM. See 
OPLS above. 

Available after grouping observations in classes, or variables in 
blocks, and both X and Y variables are included. 

O2PLS-Class Fits O2PLS models, one for each class, with a wrapper CM. See 
O2PLS above. 

Available after grouping observations in classes, or variables in 
blocks, and both X and at least two Y variables are included. 

Clustering 

PLS -Tree  Fits several PLS models grouped as branches in a tree.  
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Note: DA models are fitted to the X variables only. The Y-variables 
(responses), when present, are ignored. 

  

Note: All results of the fit of a PC model (PCA-X and PCA-Y), such as SS 
explained are labeled as X (i.e. R2X). 

  

Note: A PLS, OPLS or O2PLS model with one qualitative y-variable is 
equivalent to PLS-DA, OPLS-DA and O2PLS-DA respectively. 

Model window for OPLS and O2PLS models 
The Model Window corresponding to OPLS and O2PLS displays summary statistics 
related to the model. Components that capture variation found in both X and Y are 
denoted Predictive. Components that capture variation only found in X are denoted 
Orthogonal in X(OPLS). Components that capture variation only found in Y are 
denoted Orthogonal in Y(OPLS).  

The OPLS model is based on the OPLS algorithm. The O2PLS model is based on the 
similar O2PLS algorithm, but in addition there is a PCA step. PCA is used after 
convergence of the O2PLS algorithm, to exhaust the E and F residual matrices from all 
remaining systematic variation. This yields the additional Orthogonal in X(PCA) and 
Orthogonal in Y(PCA) components.  

The method underlying a certain Orthogonal component is indicated in the name of the 
component in the Model Window.  

Note: The model window for OPLS models displays, if existing, three types of 
components: Predictive, Orthogonal in X, Orthogonal in Y. Additionally, The 
model window for O2PLS displays, if existing, Orthogonal in X and 
Orthogonal in Y components estimated by PCA. 
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Figure 2. The Model Window for an O2PLS model with 7 predictive, 3 Orthogonal in 
X and 6 Orthogonal in Y components (a 7+3(1+2) +6(1+5) O2PLS model).  

 
The Model Window displays: 

Section Description Component types 

Model Summarizes the model, 
showing the cumulative 
R2X, R2, Q2, and R2Y. 

  

Predictive The Predictive section 
where the first row 
summarizes the predictive 
components in the model 
followed by a listing of 
each predictive 
component. 

The predictive loading vectors are p 
for the X-block and q for the Y- block. 
The predictive score vectors are t for 
the X-block and u for the Y-block. In 
the figure above there are 7 
components for p, q, t and u. 

Orthogonal 
in X (OPLS) 

The Orthogonal in 
X(OPLS) section where 
the first row summarizes 
the orthogonal 
components in the X 
model followed by a listing 
of each orthogonal in X 
component. The 
orthogonal in X 
components show the 
variation in X that is 
uncorrelated to Y. 

The orthogonal in X(OPLS) loading 
vectors are po for the X-block and so 
for the Y-block. The orthogonal in X 
(OPLS) score vector is to for the X-
block.  

In the figure above there is one 
orthogonal in X(OPLS) component. 
This means that the po[1], so[1], and 
to[1] vectors are the orthogonal in 
X(OPLS) vectors. 
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Section Description Component types 

Orthogonal 
in X (PCA) 

The Orthogonal in X(PCA) 
sections where the first 
row summarizes the 
orthogonal components in 
the X model followed by a 
listing of each orthogonal 
in X component. The 
orthogonal in X 
components show the 
variation in X that is 
uncorrelated to Y 

The orthogonal in X(PCA) loading 
vectors are po for the X-block and so 
for the Y-block. The orthogonal in X 
(PCA) score vector is to.  

The orthogonal in X(PCA) 
components are extracted after the 
orthogonal in X(OPLS) components, 
and their relational order is indicated 
through the shared nomenclature. 

In the figure above there are two 
orthogonal in X(PCA) components. 
This means that the po[2], po[3], 
so[2], so[3], to[2] and to[3] vectors 
are the orthogonal in X(PCA) vectors 

Orthogonal 
in Y (OPLS) 

The Orthogonal in Y 
(OPLS) sections where the 
first row summarizes the 
orthogonal components in 
the Y model followed by a 
listing of each orthogonal 
in Y component. The 
orthogonal in Y 
components show the 
variation in Y that is 
uncorrelated to X. 

The orthogonal in Y(OPLS) loading 
vectors are r for the X-block and qo 
for the Y-block. The orthogonal in Y 
(OPLS) score vector is uo for the Y 
block.  

In the figure above there is one 
orthogonal in Y(OPLS) component. 
This means that the r[1], qo[1], and 
uo[1] vectors are the orthogonal in 
Y(OPLS) vectors. 

Orthogonal 
in Y (PCA) 

The Orthogonal in Y (PCA) 
sections where the first 
row summarizes the 
orthogonal components in 
the Y model followed by a 
listing of each orthogonal 
in Y component. The 
orthogonal in Y 
components show the 
variation in Y that is 
uncorrelated to X 

The orthogonal in Y(PCA) loading 
vectors are r for the X-block and qo 
for the Y-block. The orthogonal in Y 
(PCA) score vector is uo for the Y 
block.  

The orthogonal in Y(PCA) 
components are extracted after the 
orthogonal in Y(OPLS) components 
and their relational order is indicated 
through the shared nomenclature. 

In the figure above there are five 
orthogonal in Y(PCA) components. 
This means that the r[2]-r[6], qo[2]-
qo[6], and uo[2]-uo[6] vectors are the 
orthogonal in Y(PCA) vectors. 

The table columns are: 

 Component - Component index.  

 R2X - Fraction of X variation modeled in that component, using the X 
model.  

 R2X(cum) - Cumulative R2X up to the specified component.  

 Eigenvalue - The minimum number of observations (N) and X-variables 
multiplied by R2X, that is, min(N,K)*R2X.  

 R2 - Fraction of Y variation modeled in that component, using the X model.  

 R2(cum) - Cumulative R2 up to the specified component.  
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 Q2 - Fraction of Y variation predicted by the X model in that component, 
according to cross-validation.  

 Q2(cum) - Cumulative Q2 up to the specified component.  

 R2Y - Fraction of the Y variation modeled in that component, using the Y 
model.  

 R2Y(cum) - Cumulative R2Y up to the specified component  

 EigenvalueY - The minimum number of observations (N) and Y-variables 
multiplied by R2Y, that is, min(N,M)*R2Y.  

 Significance – Significance level of the model component. 

For more, see the OPLS/O2PLS - Orthogonal PLS modeling section in Appendix 
A: Statistics. 

Model Options 
The Model Options hold model specific options. Most options are inherited from the 
Project Options. 

Note: Model options cannot be changed for a wrapper model, only for the 
individual class or phase models. 

To open the Model Options: 

 Click the Model Options dialog dispatch launcher in the bottom right corner 
of the Workset group, on the Home tab. 

 Click the Options button in the Model Window. 

 Right-click the model, either in Project Window or in Model Window, and 
click Model Options. 

Model Options contain the following pages: 

 Model – for setting confidence and significance levels, and selecting whether 
to use cross validation when fitting. 

 Distance to Model – for selecting in which domain the distance to model 
should be displayed. 

 Coefficients – for selecting type of coefficient to display by default. 

 Residuals / R2 – for selecting residual and R2 type to display by default. 

 Predictions – for selecting to display the predictions in scaled and 
transformed units and whether to trim the predictions as the workset. 

 CV-groups – enables customized assignment of the cross validation groups. 

 More Options – displays and allows change of the used T2 Center and 
Eigenvalue similarity level.  

Note: Changes in Model Options are only valid for the current model. 
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Model page in Model Options 
The Model page displays: 

 Use cross validation when fitting box. 

 Confidence level on parameters current setting. 

 Significance level for DModX and Hotelling’s T2 current setting. 

 Reset All button. 

 

Cross validation when fitting 

By default, cross validation is used when fitting to decide whether a component is 
considered significant or not. 

To fit components without cross validation, clear the Use cross validation when 
fitting check box. 

Autofit is unavailable when the Use cross validation when fitting check box is 
cleared. 

Confidence level on parameters 

The confidence level used when computing confidence intervals on the parameters is 
by default 95%. 

To change from the default select 90%, 99%, or None in the Confidence level on 
parameters box. 

Significance level for DModX and Hotelling’s T2 

The significance level used when computing the critical limits for DModX and the 
Hotelling's T2 ellipse is 0.05 (95% confidence). 

To use a different significance level than 0.05, type a value between 0 and 1 (not 
exactly 0 or 1 but between) in the Significance level for DModX and Hotelling's T2 
field. 

To not display the limits select None in the Limits page in Properties. For details, see 
the Limits subsection in the Plot and list contextual tabs chapter.  
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Reset All button 

To reset the options of the Model, Distance to Model, Coefficients, Residuals/R2, 
and Predictions pages to the project options, click the Reset All button. 

Distance to Model page in Model Options 
The Distance to Model page displays: 

 Normalized in units of standard deviation. 

 Absolute. 

 Weighted by the modeling power. 

 

Normalized or absolute distances 

The distance to the model (DModX and DModY) can be expressed as an Absolute or a 
Normalized value, where the normalized is in units of standard deviation of the pooled 
RSD of the model. 

By default, the Normalized in units of standard deviation option is selected. 

To change from the default, click Absolute. 

Weighted by the modeling power 

When computing the distance to the model (DModX), the residuals are by default not 
weighted by the modeling power of the variables. 

To change from the default, select the Weighted by the modeling power check box. 

For details, see the MPow weighted residuals DModX section in Appendix A: 
Statistics. 

Coefficients page in Model Options 
The Coefficients page displays the available types of coefficients: Scaled & 
Centered, MLR, Unscaled, and Rotated and the Resolve coefficients for 
hierarchical top level models check box. 

 

Scaled and Centered 

With Scaled & Centered selected, the coefficients displayed are for scaled and 
centered X and scaled Y (as specified in the workset). This is the SIMCA default. Use 
these coefficients to interpret the influence of the x-variables on Y. Coefficients of 
different responses (y-variables) are also comparable as the y-variables are normalized 
(scaled). 
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MLR 

With MLR selected, the coefficients displayed are the PLS coefficients when: 

 Y is unscaled and uncentered, 

 X is scaled and centered, and 

 the second centering and scaling of the cross terms and squares has been 
removed. 

Unscaled 

With Unscaled selected, the coefficients displayed are the coefficients when X and Y 
are unscaled and uncentered. 

Rotated 

With Rotated selected, the coefficients are rotated so they correspond as much as 
possible to the pure spectral or other profiles. For more see the Coefficients rotated - 
CoeffRot subsection in Appendix A: Statistics. 

Resolve coefficients for hierarchical top level models 

To automatically resolve coefficients of hierarchical top level models, select the 
Resolve coefficients for hierarchical top level models check box. 

Note: For hierarchical models, Resolve Coefficients is available from the 
Layout tab when the Coefficient Plot or Coefficient Overview Plot is active.  

Residuals / R2 page in Model Options 
The Residuals / R2 page displays the available types of residuals and R2. 

 

Residuals 

The Standardized residuals are displayed by default. The standardized residuals are 
the unscaled residuals divided by their standard deviation. 

To display the residuals in original, unscaled units, click Raw – original units.  

R2 

R2 – explained variation is selected by default. R2 is the fraction of the Sum of 
Squares (SS) explained by the model. 

R2 adjusted is the fraction of variance explained by the model (SS adjusted for the 
degrees of freedom). 

To display the adjusted R2, click R2 Adjusted – variance.  
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Predictions page in Model Options 
The Predictions page displays the following check boxes: 

 Transform predictions. 

 Scale predictions. 

 Trim predictions as the workset. 

   

Transform predictions 

When the y-variables have been transformed, by default the predictions are back 
transformed to the original units. 

To display the y-variables in transformed units, select the Transform predictions 
check box. 

Scale predictions 

When the y-variables have been scaled, by default the predictions are rescaled to the 
original units. 

To display the y-variables in the same units as the workset, select the Scale 
predictions check box. 

Trim predictions as the workset 

When the workset has been trimmed or Winsorized, the predictionset can be trimmed 
or Winsorized in the same manner by selecting the Trim predictions as the workset 
check box. 

By default the predictionset is not trimmed or Winsorized. 

Note: When selecting the Trim predictions as the workset check box, all 
predictions found on the Predict tab are displayed trimmed. 

CV-Groups page 
The default is to assign every Nth observation to the same group, where the default N 
is defined in the Fit page in Project Options. To change from the default, use the 
Model Options, CV-Groups page to specify the assignment of cross validation 
groups. 

To access the CV-Groups page, the model has to be unfitted. For fitted models, this 
page can be opened but all functionality is unavailable. 

There are four sections in the CV-Groups page: 

 Number of cross validation groups. 

 What should the assignment of cross validation groups be based on? 

 How should observations be grouped using the selected data above? 

 CV Groups list. 
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All points are described in the subsections that follow. 

Note: Clicking Apply updates the cross validation groups. Neglecting to click 
Apply before clicking OK will default back to the original cross validation 
groups. 

 

Number of cross validation groups 

The number of cross validation groups decides the size of the excluded observation 
group during component computation. With the default number of cross validation 
groups (7) a 7th of the observations is excluded during each cross validation round. 

To change from the default, type a number in the Number of cross validation groups 
field. 

Note: When clicking Apply with the Group observations with the same value 
in the same group check box selected, the Number of cross validation groups 
field is automatically changed to the number of unique entries. 

Cross validation group assignment 

There are 4 types of assignments available under What should the assignment of 
cross validation groups be based on and 3 types of grouping options under How 
should observations be grouped using the selected data above. 

In this table the options found under What should the assignment of cross validation 
groups be based on? are described: 

In this table the options found under How should observations be grouped using the 
selected data above? are described: 

Option Description of assignment 

Group similar observations 
in the same group 

Groups observations with values numerically close by 
first sorting the selected vector (score, variable, or 
observation secondary ID), and then parting the 
vector in the number of cross validation groups and 
setting the first part as CV group 1, the second part 
as CV group 2 etc. 
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Option Description of assignment 

Group dissimilar 
observations in the same 
group 

Groups observations with values numerically distant 
by sorting the selected vector and assigning groups 
as in Assign every Nth observation to the same 
group (default). For details, see the first row in this 
table. 

Group observations with the 
same value in the same 
group 

Groups observations with exactly the same value or 
text by sorting the selected vector, counting the 
number of unique entries, creating CV groups, one 
for each unique entry, and then assigning the 
observations to the respective groups. 

Note that when clicking Apply with this option, the 
Number of cross validation groups is automatically 
changed to the number of unique entries. 

Note: Configuring cross validation groups must be done before the model is 
fitted. 

Cross validation group examples 

In this table the available combinations, with examples, are described: 

No. Grouping type Example 

Assign every Nth observation to the same group (default) 

1. No grouping type 
available. 

With 7 cross validation groups, the first cross 
validation group will hold observations number 7, 
14, 21 etc. The second CV group will hold 
observations 1, 8, 15, the third 2, 9, 16 etc. 

Assign observations based on the score from model Mxx 

2. Group similar 
observations in the 
same group 

With 70 observations sorted according to the 
value in t[1], and 7 cross validation groups, the 
10 observations with the smallest score values 
are assigned to CV group 1, etc. 

3. Group dissimilar 
observations in the 
same group 

With 70 observations sorted according to the 
value in t[1], and 7 cross validation groups, the 
first CV group will hold observations with sort 
order number 7, 14, 21 etc. The second CV 
group will hold observations 1, 8, 15, the third 2, 
9, 16 etc. as in 1. 

4. Group observations 
with the same value in 
the same group 

The observations are sorted according to the 
value in t[1]. CV groups are created, one for each 
unique value. Generally this combination of 
options will lead to the leave-one-out solution. 

Assign observations based on variable V1 
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No. Grouping type Example 

5. Group similar 
observations in the 
same group 

With 70 observations sorted according to V1, and 
7 cross validation groups, the 10 observations 
with the smallest values are assigned to CV 
group 1, etc. 

6. Group dissimilar 
observations in the 
same group 

With 70 observations sorted according V1, and 7 
cross validation groups, the first CV group will 
hold observations with sort order number 7, 14, 
21 etc. The second CV group will hold 
observations 1, 8, 15, the third 2, 9, 16 etc. as in 
1. 

7. Group observations 
with the same value in 
the same group 

The observations are sorted according to V1. CV 
groups are created, one for each unique value. 

Assign observations based on observation ID 

8. Group similar 
observations in the 
same group 

The selected secondary observation ID is sorted. 
Then the entire vector is parted in the entered 
number of groups, for instance 7. This means 
that, with 70 observations and 7 cross validation 
groups, the 10 observations with the lowest ID 
values/text values are assigned to CV group 1, 
etc. 

9. Group dissimilar 
observations in the 
same group 

With 70 observations sorted according to the 
selected observation ID, and 7 cross validation 
groups, the first CV group will hold observations 
with sort order number 7, 14, 21 etc. The second 
CV group will hold observations 1, 8, 15, the third 
2, 9, 16 etc. as in 1. 

10. Group observations 
with the same value in 
the same group 

The observations are sorted according to the 
selected observation ID. CV groups are created, 
one for each unique value. 

Cross validation group list 

Under CV Groups all included observations are listed in the order of the dataset. 

The No column lists the internal numbering, Name lists the primary observation ID, 
and Group lists the current cv group assignment. 

Clicking the Apply-button updates the CV Groups list Group column according to 
the selected options. 

 

Note: Configuring cross validation group must be done before the model is 
fitted. 
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More Options  
The More Options page contains advanced options that should generally not be 
altered. The page displays and allows change of the following: 

 T2 Center - used when calculating T2Range and should only be changed to 
'0' when planning to import the model in MODDE. In all other cases it 
should remain at -99 to use the calculated center. 

 Eigenvalue similarity level - is used in the autofit rules for PC modeling. 
The default is 0.05 and should generally not be changed. 
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Fit model 
You can fit the model using Autofit, Two First components, Add component, and 
Remove component in the Fit model group. 

 

Autofit 
SIMCA extracts as many components as considered significant when clicking Autofit 
in the Fit model group, on the Home tab.  

When the active model is a wrapper model, BEM or CM, clicking Autofit opens the 
Specify Autofit dialog allowing you to autofit all models in the wrapper.  

Autofit is only available when using cross validation. 

Specifying how to fit the class or phase models 
In the Specify Autofit dialog the list displays all class/phase models, all unfitted 
models default selected, and Autofit is the planned fit method. For fitted models, the 
current number of components is listed under Components and the models are not 
selected. 

 To not fit a model, clear the corresponding check box by clicking it or 
selecting the row and clearing the Include check box. 

 To fit a certain number of components, select the corresponding rows, enter 
the wanted number in the No. of Components field and click the Set button. 

 To autofit a model that has already been fitted, select the model and click the 
Autofit button. 

Clicking OK closes the dialog and all the selected class models are fitted as specified. 
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Component significant according to cross validation rules 
For regular (non-batch) PLS models, a component is significant if it is cross validated 
according to rule 1 or rule 2. 

For PC models, a component is significant if it is cross validated according to rules 1, 2 
or 3. 

For OPLS model, a component is significant if it is cross validated according to rule 1 
or rule 2. 

For O2PLS models, a component is significant if it is cross validated according to rules 
1, 2 or 3. 

For details about the cross validation rules, see the Cross validation section in 
Appendix A: Statistics. 

Two First Components 
To compute the two first components of the model, click Two First in the Fit model 
group, on the Home tab. 

Two First is unavailable: 

 after the two first components have been computed. 

 for OPLS/O2PLS models with more than one y-variable. 

Note: With a wrapper model marked, clicking Two First adds the two first 
components to all models in the wrapper. 

Add component 
To compute the next model component, on the Home tab, in the Fit model group, 
click Add. 

The component, irrespective of its significance, is added to the model if possible. 

For OPLS and O2PLS models with more than one y-variable you can select which type 
of component to add from the respective galleries. For OPLS the O2PLS specific PCA 
orthogonal components are unavailable. 

 

Note: With a wrapper model marked, clicking Add adds the next component to 
all models in the wrapper. 
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Remove component 
When the model has been overfitted, removing components one by one is available by 
clicking Remove in the Fit model group on the Home tab. 

Remove is available when the model has one or more components. 

For OPLS and O2PLS models with more than one y-variable you can select which type 
of component to remove from the respective galleries. 

 

Note: With a wrapper model marked, clicking Remove deletes the last 
component for all models in the wrapper. 

Diagnostics & Interpretation 
The Diagnostics & Interpretation group holds the plots and lists commonly used 
after fitting a model. 

Overview button in the Diagnostics & Interpretation 
group 
The first button in the Diagnostics & Interpretations group is the Overview button. 
When clicked it opens the following plots and tiles them: 

 X/Y Overview  

 Score Scatter  

 Loading Scatter 

 DModX 

For BLM the following plots are displayed: 

 X/Y Overview  

 Scores BCC 

 Loadings Sources of Variation Plot 

 DModX BCC 
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Summary of Fit 
The summary plots and lists are found by clicking the Summary of Fit button arrow. 
The available plots and lists are: Summary of Fit, X/Y Overview, X/Y Component, 
OPLS/O2PLS Overview, Component Contribution, Summary of Fit List, and X/Y 
Overview List. 

   

The summary plots by default display R2. To display R2 adjusted instead, right-
click the plot, click Properties, click the R2 tab, and change as desired. 

For more about the Properties dialog, see the Tools tab section in the Plot and 
list contextual tabs chapter. 

Note: For OPLS and O2PLS models, the summary plots and lists only display 
statistics for the predictive components for models with more than one 
predictive component. 

For model statistics for the orthogonal components, see the Model window for 
OPLS and O2PLS models subsection earlier in this chapter. 

Summary of Fit plot 
The Summary of Fit plot displays the cumulative R2 and Q2 for the X-matrix for 
PCA and for the Y-matrix for PLS/OPLS/O2PLS, after each extracted component. 
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Summary of Fit plot for OPLS 
For an OPLS or O2PLS model with more than one predictive component, the 
Summary of Fit plot displays the cumulative R2 and Q2 for the Y-matrix modeled by 
X. For OLS and O2PLS models the components are labeled P, for predictive. 

Figure 2. Summary of fit plot showing the progression of R2 and Q2 for the Y-matrix 
modeled by X.  

 
For a model with only one predictive component, the Summary of Fit plot displays 
how the R2 and Q2 for the Y-matrix evolve (progress) as 1+0, 1+1, 1+2 including the 
predictive component and each added orthogonal component to the overall explanation 
of the Y-variance. 
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X/Y Overview plot 
The X/Y Overview plot displays the individual cumulative R2 and Q2 for every X 
variable with a PCA model and every Y variable with a PLS model. 

 

X/Y Component plot 
The X/Y Component plot displays the R2X or R2Y and Q2X or Q2Y cumulative, 
per component for the selected X variable with a PCA model or Y variable for a 
PLS model. 

To switch which variable is displayed, on the Tools tab, in the Data group, use the 
Y Variable box or use Properties. For more about the Properties dialog, see the 
Plot and list contextual tabs chapter.  
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OPLS/O2PLS Overview plot 
The OPLS/O2PLS Overview is a newly developed plot, which provides a graphical 
summary of the predictive and orthogonal sources of variation in the model. Being an 
extension of the conventional Summary of Fit plot of SIMCA, this column plot is 
both stacked and color coded in accordance with the predictive and orthogonal 
variance structures (Figure 3). 

Figure 3. The OPLS/O2PLS Overview plot.  

 
The green color corresponds to the joint X/Y variation. The blue color indicates 
orthogonal variations in X or Y respectively, estimated in terms of the OPLS/O2PLS 
algorithm. The red color represents orthogonal variations in X or Y, estimated by PCA 
subsequent to the convergence of the OPLS/O2PLS algorithm. 

Component Contribution plot 
The Component Contribution plot for every fitted X, with a PCA model, or Y, 
with a PLS model, the plot displays R2X or R2Y and Q2 for a selected component. 
The selected component number is displayed in the legend. 

To change component, on the Tools tab, in the Data group, click the Component 
box. Alternatively open Properties, and click the Component tab. For more about 
the Properties dialog, see the Tools section in the Plot and list contextual tabs 
chapter.  
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Summary of Fit List 
The Summary of Fit List displays, for each component and for the total X (PCA) or Y 
(PLS/OPLS/O2PLS) matrix: 

 R2. 

 R2 cumulative. 

 Q2 – Significant components are colored green. 

 Q2 limit. 

 Q2 cumulative. 

An example for a PCA model: 

   
An example for a PLS model: 

   
For details about the displayed vectors, see the tables in the X/Y Overview List 
section next. 

Note: For OPLS models with one predictive component this list displays the 
progression vectors. 
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X/Y Overview List 
The X/Y Overview List displays a number of vectors. For PCA models the vectors are 
specific for the X block and for PLS/OPLS/O2PLS models for the Y block. 

X/Y Overview List for PCA models 

For PCA models the X/Y Overview List displays the following for each X variable: 

Vector Description 

Q2VX(Cum) The cumulative predicted fraction (cross-validation) of the variation 
of X. 

Stdev(X) Standard deviation of X in original units, and transformed if X is 
transformed. 

RSD(X) Residual standard deviation of X in original units (transformed if the 
variable is transformed) 

Stdev(X)WS Standard deviation of X scaled as specified in the workset (normally 
scaled to unit variance, UV). 

RSD(X)WS Residual Standard Deviation, scaled as specified in the workset 
(normally scaled to unit variance, UV). 

DFR Degrees of freedom of the X residuals. 

N Non missing observations in X. 

An example for a PCA model: 

   

 

X/Y Overview List for PLS/OPLS/O2PLS models 

For PLS models the X/Y Overview List displays the following for each y-variable: 

Vector Description 

R2Y  The cumulative fraction of the variation of the y-variable 
explained after the selected component. 

R2 YAdj  The cumulative fraction of the variation of the y-variable, 
adjusted for degrees of freedom, explained after the selected 
component (Cumulative Variance explained). 

Q2Y (Cum)  The cumulative predicted fraction (cross validation) of the 
variation of Y. 

Stdev (Y)  Standard deviation of Y in original units, and transformed if Y 
is transformed. 
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Vector Description 

RSD (Y)  Residual standard deviation of Y in original units (transformed 
if the variable was transformed). 

Stdev(Y)WS   Standard deviation of Y scaled as specified in the workset 
(normally scaled to unit variance, UV). 

RSD(Y)WS   Residual standard deviation scaled as specified in the 
workset (normally scaled to unit variance, UV). 

DFR  Degrees of freedom of the Y residuals. 

N Non missing observations in Y. 

An example for a PLS model: 

 

Note: For OPLS/O2PLS models, the X/Y Overview List only displays 
statistics for the predictive components. 

Scores 
The tt and uu plots of the X- and Y-scores of, for example, dimensions 1 and 2 (i.e. t1 
vs. t2, and u1 vs. u2), can be interpreted as windows into the X- and Y-spaces, 
respectively. These show how the X space (X conditions) and response values are 
situated with respect to each other. These plots show the possible presence of 
outliers, groups, and other patterns in the data. 

There are four types of score plots available from the Scores gallery: Scatter, Line, 
Column, and 3D. 

 
The tu plots (t1 vs. u1, t2 vs. u2, etc.) display the relation between X and Y. The degree 
of fit (good fit corresponds to small scatter around the straight line), indications of 
curvature, and outliers can also be seen.  

The tu plots are found on the Analyze tab, in the Analysis group, by clicking Inner 
Relation. 
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Score Scatter Plot 
To display the scores in a 2D scatter plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Scores.  

The default scatter plot is displayed, t1 vs. t2 (PCA, PLS) or t1 vs. to1 (OPLS with 
1+1 for instance).  

When displaying a two-dimensional score plot displaying t, SIMCA draws the 
confidence ellipse based on Hotelling's T2, by default at significance level 0.05. 
Observations situated outside the ellipse are considered to be outliers. For 
example, in the default score scatter plot displayed below it is evident that 
observation 208 is an outlier. 

 

Ellipse modifications 

To hide the ellipse, or change the confidence level of the ellipse, click the Limits 
tab in the Properties dialog and change as desired. For more see the Limits 
subsection in the Tools tab section in the Plot and list contextual tabs chapter. 

To change the default confidence level use Model Options or Project Options. 

For more about the ellipse, see the Hotelling’s T2 subsection in Appendix A: 
Statistics. 

Color by 

To color by a variable, or scores etc, click the Color by button in the Tools tab or 
the Color tab in the Properties dialog. For more see the Coloring from Properties 
subsection in the Tools tab section in the Plot and list contextual tabs chapter.  
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Score plot Properties 

 

In the Scores page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Clear the Scale proportionally to R2X check box for OPLS and O2PLS 
if warranted. For more about this option, see the R2X subsection in the 
Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools section in the Plot and list contextual tabs chapter. 

Note: When the dataset contains numerical IDs, they can be selected and 
plotted on either axis. 

Removing ellipse in score plot 

There are two ways of removing the ellipse in the Score Scatter Plot: 

 Not display it by opening Format Plot, under the Limits and Regions node, 
click Ellipse and select Line Style None and Fill Type No fill. 

 Hide it in the Limits page in the Properties dialog. For more, see the Limits 
subsection in the Tools tab section in the Plot and list contextual tabs 
chapter. 
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Score Line Plot 
To display the scores in a line plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Scores, and then click Line.  

The default line plot of t1 is displayed.  

 
With a one-dimensional score line plot, e.g. ta vs. Num, the score plot displays 
confidence intervals corresponding to the 2 and 3 sigma limits, i.e., 2 and 3 
standard deviations of the vector are displayed by default. Here the plot is 
identical to the Shewhart control chart with no subgroups. 

 

In the Scores page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Clear the Scale proportionally to R2X check box for OPLS and O2PLS 
if warranted. For more about this option, see the R2X subsection in the 
Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 
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Note: When the dataset contains numerical IDs, they can be selected and 
plotted on either axis. 

Score line plot for batch evolution models 

Displaying the scores as a line plot in combination with DModX allows you to detect 
batches with upsets. These plots use the non-aligned batches. 

The limits are computed from the variation of the t’s as single vectors, as for steady 
state data. Batches outside the limits or different from the average behavior should be 
examined further, for example by displaying contribution plots. These batches should 
be removed from the workset if they are outlier batches. 

 
See also the DModX plot for BEM subsection later in this chapter. 

The significance level can be changed by clicking the Limits tab in the Properties 
dialog.  
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Score Column Plot 
To display the scores in a column plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Scores, and then click Column.  

The default column plot of t1 is displayed. 

 

With a column plot displaying one vector, jack-knifing is used to calculate 
standard errors displayed as error bars at the end of each column. 

 

In the Scores page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Clear the Scale proportionally to R2X check box for OPLS and O2PLS 
if warranted. For more about this option, see the R2X subsection in the 
Plot/List chapter.  

Jack-knifing is used to calculate standard errors displayed as error bars at the end 
of each column. The confidence level of the standard errors can be customized in 
the Limits page.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 
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Score Scatter 3D Plot 
To display the scores in a 3D scatter plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Scores, and then click 3D.  

The default scatter plot is displayed, t1 vs. t2 vs. t3 (PCA, PLS) or t1 vs. to1 vs to2 
(OPLS with 1+2 for instance).  

 

 
In the Scores page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Clear the Scale proportionally to R2X check box for OPLS and O2PLS 
if warranted. For more about this option, see the R2X subsection in the 
Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 

Note: When the dataset contains numerical IDs, they can be selected and 
plotted on any axis. 
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Marking in 3D scatter plot 

In the 3D plot, hold down the CTRL-button to mark several points. 

To mark two groups, in order to create a group contribution plot, mark the first group 
then click a point after releasing the CTRL-button (so that the first group is Previously 
Marked Values) then mark the second group while pressing the CTRL-button. Open 
the Marked Items window to see the observations included in each group. 

Note: Avoid marking the single point again as it will then be unmarked. 

Zooming in 3D plot 

To zoom, scroll using the mouse wheel. Alternatively, press the CTRL-button while 
holding down the right mouse button and moving the mouse. 

Rotating 3D plot 

To rotate a 3D scatter plot or a Response Surface plot, hold down the left mouse 
button and move the mouse in the direction to turn it. To keep the plot rotating, release 
the mouse button while turning. To not have the plot continue rotating, stop turning 
before releasing the mouse button. 

Resetting the rotation 

To reset the rotation to default, right-click the plot and then click Reset rotation.  

Moving the 3D plot in its window 

To move the plot, hold down the right mouse button and move the mouse in the 
direction to move. Moving the plot is useful after having zoomed when wanting to see 
other areas of the plot. 
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OPLS specific score plots 
There are four OPLS/O2PLS specific score plots, each displaying different 
components of the model.  

If there are two or more of the score type in the model, the plots are scatter plots of the 
first two components. If there is only one component of the type available, the 
resulting plot is a column plot. By default the plotted score vectors are scaled 
proportionally to R2X, the variance explained by each component. 

The OPLS/O2PLS specific score plots are:  

 Pred X – X-score vectors t1 and t2 of the predictive components.  

 Pred Y – Y-score vectors u1 and u2 of the predictive components.  

 Orth X – X-score vectors to1 and to2 of the orthogonal in X components.  

 Orth Y – Y-score vectors uo1 and uo2 of the orthogonal in Y components.  
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Loadings 
Loading plots display the correlation structure of the variables. That is, they show 
the importance of the x-variables in the approximation of the X matrix. 

There are four types of loading plots: Scatter, Line, Column, or 3D. 

 

Note: The score and loading plots complement each other. The position of 
objects in a given direction in a score plot is influenced by variables lying in 
the same direction in the loading plot. 

The available loading vectors for PCA, PLS, OPLS and O2PLS models are 
described in the table in the Observations and Loadings vectors subsection in 
Appendix A: Statistics. 

Loading 
vector 

Short description 

c PLS only. 

Displays the correlation between the Y variables and the X scores 
T(X). 

Weights that combine the Y variables with the scores u, so as to 
maximize their correlation with X.  

Y variables with large c's are highly correlated with T(X). 

p Displays the importance of a variable in approximating X as TP’. 

pc 

  

PLS only. 

Combination of the p and c vectors. 

c(corr) PLS only. 

Available after selecting Correlation Scaled in the loading dialog. 

c scaled as correlations resulting in all points falling inside the circle 
with radius 1. 

p(corr) Available after selecting Correlation Scaled in the loading dialog. 

p scaled as correlations resulting in all points falling inside the circle 
with radius 1. 

pc(corr) PLS only. 

Available after selecting Correlation Scaled in the loading dialog. 

Combination of the p(corr) and c(corr) vectors. 

w PLS only. 

Weights that combine the X variables (first dimension) or the residuals 
of the X variables (subsequent dimensions) to form the scores t. 
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Loading 
vector 

Short description 

w* PLS only. 

Weights that combine the original X variables (not their residuals as 
with w) to form the scores t. 

w*c PLS only. 

Combination of the w* and c vectors. 

Plotting both the X-weights, w*, and Y-weights, c, in the same plot 
displays the correlation structure between X and Y. Interpretation of 
how the X and Y variables combine in the projections, and how the X 
variables relate to the Y variables, is possible. 

Loading Scatter Plot 
To display the loadings in a 2D scatter plot, on the Home tab, in the Diagnostics 
& Interpretation click Loadings, and then click Scatter.  

The default scatter plot is displayed, p1 vs. p2 (PCA), w*c1 vs. w*c2 (PLS) or 
pq1 vs. poso1 (OPLS with 1+1 for instance).  

To change what is displayed, open the Properties dialog by clicking the plot and 
then Properties in the mini-toolbar. 

 

In the Loadings page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Display loadings vectors p, c, or pc scaled as correlations: select the 
Correlation scaled check box. The correlation scaling done is the same 
as in the Biplot. For more, see the Biplot subsection later in the Analyze 
chapter. 

 Clear the Normalize to unit length check box. Normalize to unit length 
check box is default selected for OPLS and O2PLS. For more about this 
transformation, see the Normalize subsection in the Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 
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Note: When the dataset contains numerical IDs, they can be selected and 
plotted on either axis. 

Loading Scatter Plot PCA 

Variables with the largest absolute values of p1 or/and p2 dominate the projection. 
Variables near each other are positively correlated; variables opposite to each other are 
negatively correlated. 

 

Loading Scatter Plot PLS 

Variables with large w* or c values are situated far away from the origin (on the 
positive or negative side) in the plot. 

X variables with large values in w* (positive or negative) are highly correlated with U 
(Y). 

 
The default coloring of the loading scatter plot is by Terms.  
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Loading Line Plot 
To display the loadings in a line plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Loadings, and then click Line.  

The default line plot is displayed, p1 (PCA), w*c1 (PLS) or pq1 (OPLS).  

To change what is displayed, open the Properties dialog by clicking the plot and 
then Properties in the mini-toolbar. 

The following dialog opens: 

 

In the Loadings page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp boxes, 
and click Add Series.  

 Modify the items on the axes. 

 Display loadings vectors p, c, pc, pq, po, poso, scaled as correlations: select 
the Correlation scaled check box. The correlation scaling done is the same 
as in the Biplot. For more, see the Biplot subsection later in the Analyze 
chapter. 

 Clear the Normalize to unit length check box. Normalize to unit length 
check box is default selected for OPLS and O2PLS. For more about this 
transformation, see the Normalize subsection in the Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 

Note: When the dataset contains numerical IDs, they can be selected and 
plotted on either axis. 
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Loading Line Plot PCA 

Variables with the largest absolute values of p1 dominate the projection. 

 

Loading Line Plot PLS 

Variables with large w* or c values are situated far away from the origin (on the 
positive or negative side) in the plot. 

X variables with large values in w* (positive or negative) are highly correlated 
with U (Y). 

 



Home 

209 

Loading Column Plot 
To display the loadings in a column plot, on the Home tab, in the Diagnostics & 
Interpretation group, click Loadings and then Column.  

The default column plot is displayed, p1 (PCA), w*c1 (PLS) or pq1 (OPLS).  

To change what is displayed, open the Properties dialog by clicking the plot and 
then Properties in the mini-toolbar. 

 

In the Loadings page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp boxes, 
and click Add Series.  

 Modify the items on the axes. 

 Display loadings vectors p, c, pc, pq, po, poso, scaled as correlations: select 
the Correlation scaled check box. The correlation scaling done is the same 
as in the Biplot. For more, see the Biplot subsection later in the Analyze 
chapter. 

 Clear the Normalize to unit length check box. Normalize to unit length 
check box is default selected for OPLS and O2PLS. For more about this 
transformation, see the Normalize subsection in the Plot/List chapter.  

With a column plot, jack-knifing is used to calculate standard errors displayed as error 
bars at the end of each column. The confidence level of the standard errors can be 
customized in the Limits  page.  

The other tabs are general and described in detail in the Properties dialog section in 
the Tools tab section in the Plot and list contextual tabs chapter. 
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Loading Column Plot PCA 

Variables with the largest absolute values of p1 dominate the projection. 

 

Loading Column Plot PLS 

Variables with large w* or c values are situated far away from the origin (on the 
positive or negative side) in the plot. 

X variables with large values in w* (positive or negative) are highly correlated 
with U (Y). 
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Loading Scatter 3D Plot 
To display the loadings in a 3D scatter plot, on the Home tab, in the Diagnostics 
& Interpretation group, click Loadings, and then click 3D.  

The default 3D scatter plot is displayed, p1 vs. p2 vs. p3 (PCA), w*c1 vs. w*c2 
vs. w*c3 (PLS) or pq1 vs. poso1 vs. poso2 (OPLS with 1+2 components for 
instance).  

To change what is displayed, open the Properties dialog by clicking the plot and 
then Properties in the mini-toolbar. 

 

In the Loadings page of the Properties dialog you can select to: 

 Display more or other series: make the selection in Item and Comp 
boxes, and click Add Series.  

 Modify the items on the axes. 

 Display loadings vectors p, c, pc, pq, po, poso, scaled as correlations: 
select the Correlation scaled check box. The correlation scaling done is 
the same as in the Biplot. For more, see the Biplot subsection later in the 
Analyze chapter. 

 Clear the Normalize to unit length check box. Normalize to unit length 
check box is default selected for OPLS and O2PLS. For more about this 
transformation, see the Normalize subsection in the Plot/List chapter.  

The other tabs are general and described in detail in the Properties dialog section 
in the Tools tab section in the Plot and list contextual tabs chapter. 

Note: When the dataset contains numerical IDs, they can be selected and 
plotted on any axis. 
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Loading Scatter 3D Plot example 

Variables with the largest absolute loading values dominate the projection. Variables 
near each other are positively correlated; variables opposite to each other are 
negatively correlated. 

   
For how to mark, zoom, rotate, move the plot in its window, color and size the 3D plot, 
see the Score Scatter 3D Plot section earlier in this chapter. 

OPLS specific loadings 
There are three OPLS and O2PLS specific loading plots, each displaying different 
components of the model.  

If there are two or more components for the loading type to display, the displayed plot 
is a scatter plot. If there is only one component, the resulting plot is a column plot.  

By default the plotted loading vectors are scaled to unit length.  

 Pred X-Y: X-Y-loading vectors pq1 and pq2 of the predictive components.  

 Orth X: X-loading vectors poso1 and poso2 of the orthogonal in X 
components.  

 Orth Y: Y-loading vectors qor1 and qor2 of the orthogonal in Y 
components.  
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Hotelling’s T2Range 
The Hotelling's T2Range can be displayed as two plot types, Line and Column, by 
clicking Hotelling's T2 in the Diagnostics & Interpretation group on the Home tab. 

The Hotelling's T2Range plot displays the distance from the origin in the model plane 
(score space) for each selected observation. The plot shows the T2 calculated for the 
range of selected components, i.e., 1 to 7, or 3 to 6. 

Default is to display from the first to the last component. For OPLS and O2PLS 
models the range is locked to from the first predictive to the last orthogonal in X. To 
change the range of components, right-click the plot and select Properties, and then 
click the Component tab. y 

 

For all other pages in Properties, see the Properties dialog subsection in the 
Tools tab section in the Plot and list contextual tabs chapter. 

The Hotelling's T2 subsection in Appendix A: Statistics describes how the 
Hotelling's T2 is calculated. 

Limits in Hotelling’s T2Range 
Values larger than the yellow limit are suspect (0.05 level), and values larger than the 
red limit (0.01 level) can be considered serious outliers. 

A large T2-range value for a given observation, i.e., a value far above the critical limits, 
indicates that the observation is far from the other observations in the selected range of 
components in the score-space. Hence, this is likely to be an outlying observation that, 
if included the workset, may pull the model in a detrimental way. 
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Distance to Model 
Distance to Model is an estimate of how far from the model plane, in the X or Y 
space, the observation is positioned. 

The distance to the model can be displayed in absolute and normalized units. By 
default the distance to model plot is displayed in normalized units after the last 
component with limit for significance level 0.05. To change from the defaults, use 
Model Options or Project Options. The significance level can be changed in the 
Limits page in the Properties dialog. For more, see the Limits subsection in the Tools 
tab section in the Plot and list contextual tabs chapter.  

There are two plots displaying the distance to the model, DModX and DModY, 
available on the Home tab in the DModX gallery: 

 Under the DModX header, click Line or Column to display DModX in that 
plot type. 

 Under the DModY header, click Line or Column to display DModY in that 
plot type. 

Overview of calculation of distance to the model 
The RSD of an observation in the X or Y space, is proportional to the observation 
distance to the hyper plane of the model in the X or Y space. SIMCA computes the 
observation distances to the model, in the X space (DModX) or Y space (DModY). 

DModX can also be weighted by the modeling power by selecting the Weighted by 
the modeling power check box in the Distance to Model page in Model Options or 
Project Options. 

For details about the calculations of the distance to the model, see the Distance to 
Model section in Appendix A: Statistics. 

Distance to the model in the X-block 
The distance to the model in the X space, DModX, is by default displayed in 
normalized units. 

Larger DModX than the critical limit indicates that the observation is an outlier in the 
X space. 
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Distance to the model in the Y-block 
The distance to the model in the Y space, DModY, is by default displayed in 
normalized units. 

A large DModY value indicates that the observation is an outlier in the Y space. 

 

DModX plot for batch evolution models 
The D-Crit is computed as for steady state data and from an F distribution. Hence it is 
very sensitive to tails. Batch data are usually dynamic, and some variables increase or 
decrease with time. Hence, batches will often be outside the DModX limit at the 
beginning or the end of the evolution. To detect abnormal batches, look for batches far 
above the average of the high points.  

 
To exclude batches in a plot, first select the batch using Batch marking mode, the 
whole batch will be marked, then use the Exclude tool (red arrow), on the Marked 
Items tab, to exclude the batch. 

When batches have phases, the batch will be excluded from all the class (phase) 
models and a new unfitted batch model, with all class models, generated. You can 
mark several batches holding the CTRL key, and then exclude them. 

See also the Batch Control Charts section later in this chapter. 
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Observed vs. Predicted 
The Observed vs. Predicted plot, displayed by clicking Observed vs. Predicted in 
the Diagnostics & Interpretation group, on the Home tab, displays the observed 
values vs. the fitted or predicted values for the selected response, after the last 
component. 

To switch to another y-variable use the Tools tab (X-Axis YVar box in the Data 
group) or the Properties dialog (Select Y-variable tab). For more, see the Switching 
components, batches, and models subsection respective the Select Y Variable 
subsection in the Tools tab section in the Plot and list contextual tabs chapter.  

 

Coefficients 
From the PLS model SIMCA computes PLS regression coefficients for each Y 
variable. These express the relation between the Y variables and all the terms in the 
model. By default, the regression coefficients relate to the centered and scaled data, 
CoeffCS, and are computed from all extracted components. 

Note: All coefficients are cumulative. 

 
For PLS/OPLS/O2PLS models two plots and one list are available on the Home 
tab by clicking Coefficients: 

 Plot - column plot displayed with uncertainty bars for the selected y-
variable. 

 Overview Plot - column plot displaying all y-variables. 

 List - displayed for all y-variables with uncertainty estimates. 

For hierarchical top models, the Resolve Coefficients check box is available in the 
Show group on the Layout tab when the Coefficient Plot or Coefficient 
Overview Plot is active. 
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Coefficient types 
The coefficient plots can be displayed for Scaled and centered, MLR, Unscaled, and 
Rotated coefficients. The confidence intervals are only available for coefficients of 
scaled and centered data.  

Displaying the Rotated coefficients is relevant when the X block is spectral data. The 
rotated coefficients express the pure spectra as it relates to each y-variable. 

To switch coefficient type, click the plot and in the mini-toolbar click Properties. 
Click the Coefficients tab, and then click the desired coefficient type. 

For all other pages in Properties, see the Properties dialog subsection in the 
Tools tab section in the Plot and list contextual tabs chapter. 

For details about the different coefficient types, see the Coefficients subsection in 
Appendix A: Statistics. 

For hierarchical top models, the Resolve Coefficients check box is available in the 
Show group on the Layout tab when the Coefficient Plot or Coefficient 
Overview Plot is active. 

Coefficient Plot 
The Coefficient Plot by default displays the coefficients referring to scaled and 
centered data for a given response, with confidence intervals derived from jack-
knifing. The confidence level of these limits can be modified in the Properties 
dialog. For more, see the Limits subsection in the Tools tab section in the Plot 
and list contextual tabs chapter. 

 

Note: For hierarchical top models, the Resolve Coefficients check box is 
available in the Show group on the Layout tab when the Coefficient Plot or 
Coefficient Overview Plot is active. 
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Use the Properties dialog to switch coefficient type. 

 

Coefficient Plot for hierarchical top level models 
In hierarchical top level models, coefficients refer to the upper level variables, 
usually scores of the base level models. For the interpretation of the upper level 
model, it is desirable to be able to translate the upper level coefficients to 
coefficients of the individual variables of the base models. 

For hierarchical top models the Coefficient Plot by default displays the top level 
coefficients. To resolve to the base model coefficients, on the Layout tab, in the 
Show group, select the Resolve Coefficients check box. 

To change this default to display the resolved coefficients, see the Coefficients 
page in Model Options subsection in the Workset section earlier in this chapter. 

Note: Only linear terms are resolved. If the top model contains expanded 
terms (interaction, squares etc.) these terms are not resolved. 
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Coefficient Overview Plot 
The Coefficient Overview Plot displays the coefficients, referring to scaled and 
centered data, for every response as bar graphs side by side. 

 

Coefficient List 
The Coefficient List default displays the coefficients referring to scaled and 
centered data for all responses, with confidence interval derived from jack-knifing. 
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VIP 
Interpreting a PLS model with many components and a multitude of responses can be a 
complex task. A parameter which summarizes the importance of the X-variables, both 
for the X- and Y-models, is called the variable influence on projection, VIP. VIP is a 
weighted sum of squares of the PLS weights, w*, taking into account the amount of 
explained Y-variance in each dimension. Its attraction lies in its intrinsic parsimony; 
for a given model and problem there will always be only one VIP-vector, summarizing 
all components and Y-variables. One can compare the VIP of one term to the others. 
Terms with large VIP, larger than 1, are the most relevant for explaining Y. 

The VIP values reflect the importance of terms in the model both with respect to Y, i.e. 
its correlation to all the responses, and with respect to X (the projection). With 
designed data, i.e. close to orthogonal X, the VIP values mainly reflect the correlation 
of the terms to all the responses. VIP values are computed, by default, from all 
extracted components. 

The VIP plot is available on the Home tab, in the Diagnostics & Interpretation 
group, by clicking VIP. 

Note: The VIP plot is cumulative. 

VIP Plot 
The VIP plot displays the VIP values as a column plot sorted in descending order 
with confidence intervals derived from jack-knifing. 

 
To display an unsorted VIP plot (useful in spectroscopy and chromatography), create 
the VIP plot in the following manner: 

1. On the Plot/List tab, click Column. 

2. In the Select data type box select Observations and Loadings. 

3. In the Item box select VIP. 

4. Click Add Series, and then OK. 

The plot is displayed with jack-knife uncertainty bars. The confidence level of these 
limits can be modified in the Properties dialog. For more, see the Limits subsection in 
the Tools tab section in the Plot and list contextual tabs chapter. 
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Data 

Introduction 
This chapter describes all commands on the Data tab. 

On the Data tab the following commands are available: 

1. Merge datasets observation or variable wise. 

2. Split the selected dataset variable wise. 

3. Transpose dataset making the current columns rows and vice versa. 

4. Delete Dataset to remove datasets from the project. 

5. Generate Variables from variables in the dataset or from results of fitted 
models. 

6. Local Centering allowing importing local centering and then viewing it. 

7. Spectral Filters: Derivative, MSC, SNV, Row Center, Savitzky-Golay, 
EWMA, Wavelet Compression, Wavelet Denoising, OSC, etc. as individual 
filters, or chained in any combination. 

8. Time Series Filters: Wavelet Compression and Wavelet 
Denoising/Decimation of PLS Time series. 

9. Dataset Summary displaying the properties of the selected dataset including 
Filter tab after filtering. 

10. Trimming Overview available after trimming or Winsorizing. 

11. Spectra plot displaying XObs for all observations in the selected dataset. 

12. Hierarchical base model resulting in hierarchical dataset according to 
selection. 

   

Merge 
Merging of two datasets is available by clicking Merge in the Modify Dataset group 
on the Data tab. 
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In this dialog, datasets can only be merged by matching primary IDs. The resulting file 
will include the union of the available variables and observations. 

   
To merge: 

1. In the First dataset (destination) box select the dataset that should end up 
on top or to the left.  

2. In the Second dataset (source) box select the dataset that should end up at 
the bottom or to the right. 

Note: Datasets created by SIMCA (filtered datasets, batch level datasets etc.) 
cannot be merged. 

Split dataset 
Datasets can be split in two by clicking Split in the Modify Dataset group on the Data 
tab. 
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In the Split Dataset dialog: 

1. Select the Dataset to split. 

2. Enter a dataset name in the New dataset field.  

3. In the Available Variables mark the variables to split out to the new dataset 
and click the >>-button. 

4. Click OK to create the new dataset splitting the specified variables from the 
original dataset. 

Note: Datasets created by SIMCA (filtered datasets, batch level datasets etc.) 
cannot be split. 

Note: This feature is also available last in the Spectral Filters wizard after 
excluding some variables. 

Transpose 
Transposing of datasets is available by clicking Transpose in the Modify Dataset 
group on the Data tab. 

When clicking Transpose a message is displayed stating that when transposing the 
dataset the following changes happens: 

 All dependent datasets will be deleted. 

 The current predictionset will be deleted. 

 All dependent models will be deleted. 

 Qualitative variables will lose their descriptors, that is, will no longer be 
qualitative variables but the descriptors will be replaced by integers 
according to their order. 

 

Note: Datasets created by SIMCA (filtered datasets, batch level datasets etc.) 
cannot be transposed, nor can batch evolution datasets. 
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Delete Dataset 
Delete datasets by clicking Delete Dataset in the Modify Dataset group on the Data 
tab. Any dependent datasets, predictionsets and models are automatically deleted. 

 

Note: The first imported dataset cannot be deleted. 

Generate Variables 
New variables can be generated by using a function, an expression with operators, or 
model results, in the formula field on the first page of the Generate Variables wizard. 
Function names are case insensitive and the result of a function can be passed as an 
argument to other functions. The result of an expression must yield a matrix with one 
or more columns where the columns will become new variables. 

Note: To generate new observations, first transpose the dataset, then use the 
Generate Variables feature, and finally transpose the dataset again. 

In the subsections that follow, the Generate Variables wizard, user generated 
functions, creation of new variables from other datasets, and generating variables in 
batch projects are covered. 

Generate Variables wizard 
Creating new variables as functions of existing ones, or from the results of fitted 
models, is available on the Data tab, in the Modify Dataset group, by clicking 
Generate Variables. All new variables are appended to the right of the last column of 
the selected dataset. 
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To add generated variables: 

Step Description Illustration 

1. Start generating variables by 
clicking Generate Variables. 

 

2. Select dataset, in the dialog 
listing the available datasets. 

When only one dataset is 
available, this dialog is not 
opened. 

 

3. In the Generate Variables 
wizard enter the expression 
defining the new variable(s). 
Click the question mark button 

 to read about the operators 
and functions available. Click 
Next. 

Note: Power, multiplication, 
and division cannot be applied 
to a set of variables and 
another set of variables. The 
first operand can be a constant, 
a variable or a set of variables, 
but the second and following 
operands must be a single 
variable or a constant. 

 

4. The new variables are 
displayed with their formula, 
statistics and Quick info plots. 

By default the new variables 
are named according to their 
recipe. To change the names, 
see point 5, otherwise go to 
point 6. 
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Step Description Illustration 

5. Change the names as desired, 
either manually or by clicking 
the Change Name button 
available when marking the 
current variable name. In 
Change Variable ID select 
Use Recipe (default) or 
Specify (name followed by 
number). When selecting 
Specify (name followed by 
number) a sequential number 
is automatically added after the 
name specified in the Name 
field. Click OK. 

 

6. Click Finish to exit the wizard 
or Finish Generate More to 
reopen the Generate 
Variables wizard and continue 
at point 3. 

When clicking Finish after 
adding variables to the dataset, 
if there are more datasets, 
SIMCA will display a dialog 
enabling adding the variables 
to other datasets also. 

 

User generated functions 
You can generate your own special functions to preprocess the data by creating a DLL 
and put it into a directory called Plugins. 

In File | SIMCA Options | More Options specify or view the path of the Plugin 
Directory. 

These functions can be any mathematical formula provided they return a matrix. 

For example, the DLL might contain the following functions: 

 MATRIX* LowPassFilter(MATRIX* pMatrix, float 
fValue); 

 MATRIX* HighPassFilter(MATRIX* pMatrix, float 
fValue); 

 MATRIX* FIR(MATRIX* pMatrix, int iWindowType, 
int iFilterLength, ... 

To use these functions in SIMCA, simply type f: and the name of the function. The f: 
is to differentiate user provided functions from SIMCA functions. 

The functions can be nested. For example you may type in Generate Variables: 

f:LowPassFilter(f:HighPassFilter(v1, arg1), arg2) 

This will apply a high pass filter with arg1 and then a low pass filter with arg2 on 
variable number 1 in the dataset. 

For detailed information, contact your Umetrics sales office. 
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New variables from other dataset 
You can generate new variables from any existing SIMCA datasets. 

SIMCA accepts the following syntax: 

Dint1: v[int2: int3] 
Variables number int2 to int3 in dataset int1. 
This expression is only valid if the current dataset has the same number of observations 
as dataset number int1 

Examples: 

D2:v[3,6,8:11] 
Generates variables 3,6,8,9,10,11 from dataset 2. 

Note: Dataset number 1 is the first dataset. New variables are always 
appended at the end of the selected dataset. 

Generating variables in batch projects 
With batches all functions operating on the whole vector (variable) are implemented 
batch by batch within a phase. When batches have phases, the default is to apply the 
function to all phases. If you want the function to operate on a variable in only selected 
phases, you must use the phase function and specify the desired phases. 

The phase specific functions are described in the ?-help in the Generate Variables 
wizard in SIMCA, but here follows some specifics. 

Note: For batch level datasets, Generate Variables can only add variables to 
batch condition datasets, not to the dataset created by SIMCA. 

Batch specific syntax 
The syntax is as follows: 

Function Phase (set-of-variables, integer-set) 

Where: 

 Function is the selected function to apply. 

 Phase signifies that the function should be applied phase wise 

 Set-of-variables is any matrix resulting from other functions or a set of 
variables. 

 integer-set is a set of one or more numbers, representing the phase numbers. 
Enclose the numbers with square brackets if you want to specify more than 
one phase. For example: [1, 3, 5:10] means phases 1, 3 and 5 to 10. 

Applying a function to some phases 
When the function operates on some phases only, the default is to leave the values of 
the variables as they are for the omitted phases. 

If you want to have missing values for the variable in the omitted phases, or a specific 
value for example 0, you must add the text misval or the fvalue at the end of the 
function. 
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For example: 

Function Phase (set-of-variables, integer-set, misval) will set the variable to missing 
in the omitted phases.   

While Function Phase (set-of-variables, integer-set, 0) will set the variable to 0 in the 
omitted phases. 

Setting the values to 0 in the omitted phases, allows you to apply different functions to 
the same variable in different phases, 

For example: 

Low Pass (Phase (v1, 2, 0)) + HiPass (Phase (v1, [1,3], 0)) will generate a new variable 
by applying a Low Pass filter to variable v1 in phase 2 and a Hi Pass filter to variable 
v1 in phase 1 and 3. 

Generate Variables for batch level without batch conditions 

When you have no batch condition datasets but want to generate variables 
built on the batch level dataset you first need to create a batch condition 
dataset. Create this batch condition dataset as follows: 

1. Copy the batch ID of the batch level dataset. 

2. File | Import Dataset. 

3. Select an empty spreadsheet (in SIMCA import File | New Spreadsheet | 
Blank. 

4. Paste the batch ID and specify it as batch ID. 

5. Type a variable name and leave all cells blank. 

6. Specify the first row as primary variable ID: 

7. Verify that the Issues pane will exclude all rows and columns that lack batch 
ID or primary variable ID and click Resolve All. 

8. Click Finish to import the dataset. Now use this dataset to add the generated 
variables to by selecting the dataset in the Generate Variables dialog. Note 
that you have to use the dataset number to refer to the other dataset. See 
dataset numbers in the Plot/List dialogs. 

Local Centering 
Local centering is useful when applying run-to-run control and changing set points. 

With local centering one models the variation of the: 

 Batch around its specified center in a phase for batch projects. 

 Variable, or part of variable with for instance classes, around the specified 
center. 

The imported local centering values are applied to all selected datasets when fitting the 
model and when making predictions. 
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Importing local centering 
To import local centering: 

1. On the Data tab, in the Modify Dataset group, click Local Centering | 
Import.  

2. Select the file containing the specifications for local centering of the 
variables. 

3. In the dialog, format according to the below: 

 Var ID is the primary variable as a row, specifying the variables to 
center. 

 Center ID is the Secondary Observation ID/Class ID/Batch ID 
as a column, specifying the observations to center. Using a 
secondary observation ID to specify which observations to center 
together can be useful when the dataset has classes. When using 
the Batch ID as center ID, the column may hold each batch ID 
only once, or once per phase. Specifying batch ID is necessary for 
batch evolution datasets where you want to specify the local 
centering per batch.  

 Phase ID as a column with each phase ID only available once per 
batch. Specifying Phase ID is necessary for batch projects with 
phases.  

 Centers, used for the subtraction, as data in the spreadsheet. 

 

Note: The local centering specification specifies the values to subtract from 
the selected variables.   
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Clicking Next opens the Local Centering Summary page. 

 

Local centering of the predictionset 
The predictionset dataset uses the imported local centering when available.  

See also the Local centering missing subsection. 

Local centering missing 
After local centering has been imported, variables that lack local centering value are 
treated as follows: 

Batch project 

When the local centering was applied according to Batch ID, but no local centering is 
available for some batches, the locally centered variables of that batch are locally 
centered using the average of the local centering values of all batches included in the 
workset.  

If you want to import the original values for a certain batch, specify local centering as 
'0' for that batch/variable combination. 

When local centering is missing for predictions, the average of the workset batches for 
that variable is used in the local centering. 

Regular project 

When the local centering was applied according to Center ID, but no local centering is 
available for some classes, the observations are not centered at all; their original value 
is used. 

View imported local centering 
The imported local centering values can be displayed by clicking Local Centering | 
View. If View is unavailable, no local centering has been imported. 

Note: Local centering is only saved if the variable is available in one of the 
imported datasets. 
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Spectral Filters 
To apply spectral filters observation wise, on the Data tab, in the Filters group, click 
Spectral Filters. The three filter methods Derivatives, MSC and SNV are available 
by clicking the arrow. 

Clicking Spectral Filters opens the following dialog: 

 
The filters listed in this dialog are described in the subsections that follow. A short 
background is available in Appendix B: Preprocessing. 

To specify which filter or chain of filters to use: 

1. Click the desired filter in the Available list. 

2. Click the => button. 

3. Repeat 1-2 until the Selected list displays the desired filters. 

4. If there are more than one dataset in the project, select the desired dataset in 
the Source box. 

5. Click OK and the wizard of each filter opens successively and the filters are 
applied in the order specified in the Spectral Filters dialog. 

6. After completed filtering, a new filtered dataset is created, leaving all 
original variables in the original dataset. Optionally excluded variables can 
be split out to a separate dataset by selecting the Split out new variables to 
a new dataset check box on the last page of the wizard. For more about 
splitting datasets, see the Split subsection previously in this chapter.  

SIMCA also supports user written filters. For more information, contact your Umetrics 
sales office. 

Filtering limitations 
The following limitations are present for filtering: 

 Only one of the wavelet filters can be included in a chain. All other filters 
can be applied in any order or combination. 

 No filtering is available for filtered converted projects. 

 Qualitative variables cannot be filtered and are automatically excluded and 
cannot be included. 

 Projects with local centering data cannot be filtered. 

 Only one dataset at a time can be filtered. To filter two datasets, first Merge 
them. 
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First, Second, and Third Derivatives 
Applying derivatives transforms the dataset from the original domain to the first, 
second, or third derivate. For more, see the Derivatives section in Appendix B: 
Preprocessing. 

When selecting Derivatives in the Spectral Filters dialog and clicking Next, the first 
page of the derivatives wizard opens displaying lists of variables and observations. 

   

Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 
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Specifying parameters for derivation 
Specify the parameters for the derivation in the Derivation specification section by 
following the steps described here. Note that marking an observation updates the 
graphs displaying the Original data (spectra) and the Derivated data with the current 
settings. 

1. Select Derivative order: 1st, 2nd, or 3rdderivative. 

2. Select Polynomial order: Quadratic or Cubic. 

3. Enter the number of points to include in the sub-models in the Points in each 
sub-model field. This number is default 15 and has to be odd and >5. 

4. Optionally enter the Distance between each point. 

5. Click Next. 

Note: The filtered dataset is created without the edge effects leaving the first 
and last window size/2 variables empty (default first and last 7 variables). 

 

Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 
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Multiplicative Signal Correction – MSC 
When applying Multiplicative Signal Correction, each observation (spectra) xi is 
“normalized” by regressing it against the average spectrum. For more see the 
Multiplicative Signal Correction (MSC) subsection in Appendix B: Preprocessing. 

When selecting MSC in the Spectral Filters dialog and clicking Next, the first page of 
the MSC wizard opens displaying lists of variables and observations. 

 

Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 

Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 
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Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

Standard Normal Variate – SNV 
When applying the SNV filter, each observation (spectra) is “normalized” by 
subtracting the mean and dividing with the standard deviation. 

For more, see the Standard Normal Variate (SNV) section in Appendix B: 
Preprocessing. 

Note: In the Workset dialog, select the filtered dataset and then specify the 
workset for the calibration model. 

SNV wizard 
When selecting SNV in the Spectral Filters dialog and clicking Next, the first page of 
the SNV wizard opens displaying lists of variables and observations. 

 

Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 
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Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

Row Center 
Applying the Row Center filter subtracts the row mean from each row value. 

When selecting Row Center in the Spectral Filters dialog and clicking Next, the first 
page of the Row Center wizard opens displaying lists of variables and observations. 

 

Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. Click Next. 
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Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

Savitzky-Golay 
Applying the Savitzky-Golay filter removes noise by applying a moving polynomial 
to the data. For more, see the Derivatives section in Appendix B: Preprocessing. 

When selecting Savitzky-Golay in the Spectral Filters dialog and clicking Next, the 
first page of the Savitzky-Golay wizard opens displaying lists of variables and 
observations. 
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Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 

Specifying parameters for Savitzky-Golay 
Specify the parameters for the filtering in the Filter specification section by following 
the steps described here. Note that marking an observation updates the graphs 
displaying the Original data (spectra) and the Filtered data with the current settings. 

1. Select Polynomial order: Quadratic or Cubic. 

2. Enter number of points to include in the sub-models in the Points in each 
sub-model field. This number is default 15 and has to be odd and >5. 

3. Click Next. 

Note: The filtered dataset is created without the edge effects leaving the first 
and last window size/2 variables empty (default first and last 7 variables). 
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Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

EWMA 
Filter removing noise by applying an exponentially weighted moving average to the 
data. 

When selecting EWMA in the Spectral Filters dialog and clicking Next, the first page 
of the EWMA wizard opens displaying lists of variables and observations. 
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Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 

Specifying lambda for EWMA 
Enter the desired lambda for the filtering in the Lambda field. Leaving the Lambda 
field empty results in using the estimated lambda. 

Note that marking an observation updates the graphs displaying the Original data 
(spectra) and the Filtered data with the current settings. 
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Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

Wavelet Compression Spectral – WCS 
The wavelet transform of a signal x(t) decomposes the signal x(t) into sets of 
coefficients by frequency band. These bands are on a logarithmic scale, and decrease 
by the power of 2 from the Nyquist frequency to the lowest frequency in the signal. To 
compress the signal, all small coefficients are removed and the transformed signal 
compressed. To denoise the signal, all small coefficients are removed and the data is 
transformed back to the original domain. 

For more, see the Wavelet compression or de-noising of signals section in Appendix 
B: Preprocessing. 

Note: With compression, reconstruct is done when the Reconstruct wavelets 
check box is selected in the Fit page of the Project Options. This is the SIMCA 
default. 

Digitized spectra 
When the dataset consist of digitized spectra (i.e. NIR, NMR, and Raman etc.) each 
observation in the X matrix is the spectrum of a sample, and the wavelet transform and 
denoising of the matrix X is done row wise. 
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WCS wizard 
When selecting Wavelet Compression in the Spectral Filters dialog and clicking 
Next, the first page of the WCS wizard opens displaying lists of variables and 
observations. 

 

Selecting variables, observations, and to transform - WCS 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
are specified according to the default workset. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To transform variables prior to the wavelet transformation, select the 
Change transformation check box. By default the variables are not 
transformed. See the Selecting variable transformations in spectral 
filtering subsection next. 

4. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

5. Click Next. 
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Selecting variable transformations in spectral filtering 
With the Change transformation check box selected, clicking Next opens the Select 
transformations page. 

Apply transformations before the compression by: 

1. Marking the variables to transform. 

2. Selecting the transformation: Linear, Log, NegLog, Logit, Exponential, or 
Power and clicking the Set-button. 

3. Clicking Next. 

 
For details about the transformations available, see the Applying transformations 
section in the Workset section of the Home chapter. 

Selecting wavelet options 
The page for wavelet options holds options for detrending, wavelet function, wavelet 
order, exclusion criteria, and compression method. This page is the same for WDS and 
WCS. 
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In the page for selecting wavelet options: 

1. In the Detrend mode box the default is None. Click the box to select Mean 
or Linear. Mean signifies removing the mean while Linear signifiers 
removing the best linear fit. 

2. In the Wavelet function box the default is Daubechies. Click the box to 
select Beylkin, Coiflet, Symmlet, Biorthogonal1, Biorthogonal2, 
Biorthogonal3, Biorthogonal4, Biorthogonal5, or Biorthogonal6. For 
details about the wavelet functions, see the Wavelet families section in 
Appendix B: Preprocessing. 

3. In the Wavelet order box, select the wavelet order. The default is the lowest 
available. The wavelet order differs depending on the wavelet function 
selected. Find the orders available for each wavelet function in the wavelet 
table. 

4. Select the method of exclusion of wavelets coefficients by selecting Energy 
retained to be By variance or By detail level. 

5. Click the desired decomposition and Compression method, DWT or Best 
basis. DWT, discrete wavelet transform, is recommended for low frequency 
signals and Best Basis for high frequency signals. With By detail level, 
DWT is the only available compression method. 

6. Click Next. 

Wavelet function Wavelet order 

Beylkin N/A 

Coiflet 2, 3, 4, 5 

Daubechies 4, 6, 8, 10, 12, 20, 50 

Symmlet 4, 6, 8, 10 

Biorthogonal1 1, 3, 5 

Biorthogonal2 2, 4, 6, 8 

Biorthogonal3 1, 3, 5, 7, 9 

Biorthogonal4 4 

Biorthogonal5 5 

Biorthogonal6 8 
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Wavelet compression/denoising By variance 

When compressing/denoising the signal by the percent of variance explained, SIMCA 
computes and displays the percentage of the variance explained by the wavelet 
coefficients of the target vector, sorted in order of importance. 

1. Use the plot to decide the number of coefficients to keep. The default is to 
keep the coefficients that accounts for 99.5% of the variance. 

2. Optionally change from the default by clicking another option under Select 
by energy retained (sum of squares). 

3. Click Next. 

 
Compression/denoising By variance is done either using compression method DWT 
or Best Basis. For details about DWT and Best Basis, see the Wavelet compression 
or de-noising of signals section in Appendix B: Preprocessing. 

Wavelet compression/denoising By detail level 
The compression/denoising By detail level is performed by excluding all the detail 
coefficients corresponding to selected scales (levels) of the target vector. DWT is the 
only available compression method. 

The wavelet transform is first done on the target vector and the results are displayed as 
a table. After selecting the wavelets coefficients or the scales to be removed, the same 
transformation is performed on each X observation vector. 
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Selecting wavelet coefficients 
When selecting By detail level to compress/denoise the X block by removing detail 
levels, SIMCA decomposes the target X to its detail coefficients at every scale. The 
left table displays for every detail level (scale) the number of coefficients and the 
percentage of the sum of square (energy), not including the DC component. 

To exclude levels from the denoised X-block: 

1. Select the undesired levels in the Selected list. 

2. Click <= to remove. 

3. Click Next. 

 

Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

WCS dataset properties 
When variables have been compressed, the new variables are linear combinations of 
the original ones. Loading, coefficients, VIP or any plots displaying variables is 
difficult to interpret in the wavelet domain. A property of the wavelet transform is the 
fact that it is possible to reconstruct not only the original variables, but also 
individual vectors such as loadings, coefficients, VIP etc. 
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By default the Reconstruct wavelets check box is selected (in Project Options), and 
all plots, including quick info plots observation wise, are displayed in the domain of 
the original dataset. 

Use the Workset commands, as usual, to specify the workset for the model. 

Wavelet Denoise Spectral – WDS 
Wavelet Denoise Spectral, WDS, is similar to Wavelet Compression Spectral, 
WCS. The difference is that after the removal of the wavelet coefficients, the X block 
is transformed back to the original domain for WDS while WCS remains in the 
transformed domain but can be reconstructed. 

Note: The denoised dataset is transformed back to the original domain. 
Therefore reconstruction is not available. 

  

Note: In a WDS transformed dataset, use the Workset commands, as usual, to 
specify the workset for the model. 

Digitized spectra 
When the dataset consist of digitized spectra (i.e. NIR, NMR, and Raman etc.) each 
observation in the X matrix is the spectrum of a sample, and the wavelet transform and 
denoising of the matrix X is done row wise. 

WDS wizard 
When selecting Wavelet Denoising in the Spectral Filters dialog and clicking Next, 
the first page of the WDS wizard opens displaying lists of variables and observations. 
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Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. Click Next. 

Selecting wavelet options 
The page for wavelet options holds options for detrending, wavelet function, wavelet 
order, exclusion criteria, and compression method. This page is the same for WDS and 
WCS. 

 
In the page for selecting wavelet options: 

1. In the Detrend mode box the default is None. Click the box to select Mean 
or Linear. Mean signifies removing the mean while Linear signifiers 
removing the best linear fit. 

2. In the Wavelet function box the default is Daubechies. Click the box to 
select Beylkin, Coiflet, Symmlet, Biorthogonal1, Biorthogonal2, 
Biorthogonal3, Biorthogonal4, Biorthogonal5, or Biorthogonal6. For 
details about the wavelet functions, see the Wavelet families section in 
Appendix B: Preprocessing. 

3. In the Wavelet order box, select the wavelet order. The default is the lowest 
available. The wavelet order differs depending on the wavelet function 
selected. Find the orders available for each wavelet function in the wavelet 
table. 

4. Select the method of exclusion of wavelets coefficients by selecting Energy 
retained to be By variance or By detail level. 

5. Click the desired decomposition and Compression method, DWT or Best 
basis. DWT, discrete wavelet transform, is recommended for low frequency 
signals and Best Basis for high frequency signals. With By detail level, 
DWT is the only available compression method. 

6. Click Next. 

Wavelet function Wavelet order 

Beylkin N/A 

Coiflet 2, 3, 4, 5 
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Wavelet function Wavelet order 

Daubechies 4, 6, 8, 10, 12, 20, 50 

Symmlet 4, 6, 8, 10 

Biorthogonal1 1, 3, 5 

Biorthogonal2 2, 4, 6, 8 

Biorthogonal3 1, 3, 5, 7, 9 

Biorthogonal4 4 

Biorthogonal5 5 

Biorthogonal6 8 

Wavelet compression/denoising By variance 
When compressing/denoising the signal by the percent of variance explained, SIMCA 
computes and displays the percentage of the variance explained by the wavelet 
coefficients of the target vector, sorted in order of importance. 

1. Use the plot to decide the number of coefficients to keep. The default is to 
keep the coefficients that accounts for 99.5% of the variance. 

2. Optionally change from the default by clicking another option under Select 
by energy retained (sum of squares). 

3. Click Next. 

 
Compression/denoising By variance is done either using compression method DWT 
or Best Basis. For details about DWT and Best Basis, see the Wavelet compression 
or de-noising of signals section in Appendix B: Preprocessing. 
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Wavelet compression/denoising By detail level 
The compression/denoising By detail level is performed by excluding all the detail 
coefficients corresponding to selected scales (levels) of the target vector. DWT is the 
only available compression method. 

The wavelet transform is first done on the target vector and the results are displayed as 
a table. After selecting the wavelets coefficients or the scales to be removed, the same 
transformation is performed on each X observation vector. 

Selecting wavelet coefficients 
When selecting By detail level to compress/denoise the X block by removing detail 
levels, SIMCA decomposes the target X to its detail coefficients at every scale. The 
left table displays for every detail level (scale) the number of coefficients and the 
percentage of the sum of square (energy), not including the DC component. 

To exclude levels from the denoised X-block: 

1. Select the undesired levels in the Selected list. 

2. Click <= to remove. 

3. Click Next. 

 

Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 

 

Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 
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Orthogonal Signal Correction – OSC 
OSC uses a PLS model, to remove from X, information that is orthogonal to Y. Results 
are displayed as ordinary PLS plots, i.e. scores, loading. These plots are interpreted as 
regular PLS plots, with the difference that the patterns displayed are orthogonal to, 
rather than correlated to, Y. 

Note: The OSC filter is prone to overfit and may give results that are too 
optimistic. The OPLS/O2PLS approach provides more realistic results and 
separates orthogonal variation from predictive variation in a single model. 

When selecting OSC in the Spectral Filters dialog and clicking Next, the first page of 
the OSC wizard opens displaying lists of variables and observations. 

Note: Serious outliers in the score plot need to be removed before OSC, as 
they may bias the corrected data X. 

   

Selecting variables, observations, to transform, and to scale 
- OSC 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, specify the Y variables and mark and Exclude 
unwanted variables. All variables are specified according to the default 
workset. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To transform variables prior to the OSC, select the Change transformation 
check box. For more, see the Selecting variable transformations in 
spectral filtering subsection next. 
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4. To change the scaling of the variables, select the Change scaling check box. 
By default, all the X variables are centered and the Y variables are centered 
and scaled to unit variance UV. For more, see the Selecting scaling in 
spectral filtering subsection later in this chapter. 

5. To specify variables and observations according to a fitted model, select the 
model in the As model box. 

6. Click Next. 

Selecting variable transformations in spectral filtering 
With the Change transformation check box selected, clicking Next opens the Select 
transformations page. 

Apply transformations before the compression by: 

1. Marking the variables to transform. 

2. Selecting the transformation: Linear, Log, NegLog, Logit, Exponential, or 
Power and clicking the Set-button. 

3. Clicking Next. 

 
For details about the transformations available, see the Applying transformations 
section in the Workset section of the Home chapter. 

Selecting scaling in spectral filtering 
With the Change scaling check box selected, clicking Next opens the Select scaling 
page. 

To change scaling: 

1. Mark the variables. 

2. Click the desired scaling button: None, Pareto, Unit Variance, or Center. 

3. Click Next. 
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Computing the OSC model 
SIMCA computes the first component of the OSC model, and displays the angle 
between t and Y for that component, the Sum of Squares (SS) remaining in the X 
block, and the Eigenvalue. 

When the angle is 90 degree, OSC has reached orthogonality. 

 To compute the next component, click Next Component. Usually two 
components are recommended. 

 When done, select the number of components to retain in the Components 
to use field. 

 Click Next. 

   

Creating the filtered dataset 
The last page completes the creation of the filtered dataset. 

 Enter the Dataset name. 

 Select to split out unfiltered variables to a new dataset by selecting the Split 
out unfiltered variables to a new dataset check box if desired. 

 Click Finish. 
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Note: To create a model using both filtered and original data, both datasets 
have to be selected in the Select Data page in the Workset dialog. 

OSC dataset 
With an OSC dataset, use the menu Plot/List to examine the OSC model by: 

1. Selecting a plot type.  

2. Selecting the OSC-dataset in the Data box. 

3. Selecting Variable and Scores or Observations and Loadings in the Select 
data type box. 

4. Adding the series to plot. 

 
  

Vector Description 

OSC-p "Loadings of the X variables in the OSC model.  

These best approximate X together with scores that are 
orthogonal to Y." 

OSC-t X scores t of the OSC model. They summarize X and are 
the best combination of the X's that are orthogonal to Y. 

OSC-w Loading weights of the X variables or their residuals (higher 
dimensions) in the OSC model. These weights are selected 
to make t orthogonal to u. 

OSC-w* Loading weights of the X variables (not their residuals) in 
the OSC model. X variables with large w* are little 
correlated with u and (Y). 

Fitting a calibration model 

To fit a calibration model, create a new workset and select both the OSC dataset and 
the original dataset, or the split dataset, to access the y-variables. Any scaling or 
transformation specified during the filtering needs to be specified in the workset.  

To fit the PLS calibration model to the OSC data, click Autofit. 
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Using OSC with a batch level dataset 
When you have quality variables in a batch level dataset, and want to use a PLS model, 
you may want to use OSC to preprocess your data. After using OSC, SIMCA creates a 
new OSCed batch level dataset. 

To OSC preprocess the predictionset, select the batch evolution predictionset. 
Preprocessing is then done automatically.  

Chaining filters 
Apply several filters in combination by clicking Spectral Filters on the Data tab and 
adding the desired filters. The filters can be applied in any order although each filter 
can be applied only once. 

Note: If wavelet compression is performed before OSC filtering, the former 
usually needs to keep 99.9 of the variance. 

 
To define the chain of filters: 

1. Click a filter in the Available list. 

2. Click the => button. 

3. Repeat 1-2 until the desired chain of filters is displayed in the Selected list. 

4. Click OK and the wizard of each filter opens successively and the filters are 
applied in the order specified in the Spectral Filters dialog. 

Predictionsets and filtered datasets 
When the model is built on a filtered dataset, the predictionset may not be filtered. The 
predictionset is automatically signal corrected/denoised as the filtered dataset. 

Use the Predict tab commands, as usual. 

Note: The predictionset needs to include all variables of the original dataset 
the filtered dataset was created from. 
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Time Series Filters 
The following time series filters are available by clicking Time Series Filters on the 
Data tab: Wavelet Compress Time Series (WCTS) and Wavelet 
Denoising/Decimation (WDTS). These filters are applied variable wise. 

   
A short background is available in PLS wavelet compression of time series section in 
Appendix B: Preprocessing.   

Wavelet Compress Time Series – WCTS 
With continuous process data (time series), you may want to compress the data to 
reduce the number of observations. 

The wavelet transform of time series focuses on the selected target response Y, with 
the objective to achieve a parsimonious representation of the signal Y, while keeping 
all the information. 

Note: The dataset must hold at least one y-variable to wavelet compress time 
series, as the compression is designed for PLS models. 

The Wavelet Compress Time Series differs from Wavelet Compress Spectral in that 
compression is done variable wise and not observation wise and that WCTS requires a 
y-variable. 

Note: With compression, reconstruct is done when the Reconstruct wavelets 
check box is selected in the Fit page of the File | Project Options. This is the 
SIMCA default. 

Compression method 
The X and Y blocks are first mean centered and scaled to UV and then transformed, 
using DWT or Best basis, to the wavelet domain. After compression the mean of 
every variable and original variance are added back to the wavelet coefficients of that 
variable. 

WCTS wizard 
To compress the data by reducing the number of observations, in the Dataset tab, click 
Time Series Filters | Wavelet Compress Time Series. The first page of the WCTS 
wizard opens displaying lists of variables and observations. 
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Selecting y-variables and observations - WCTS 
To apply the filter to the dataset, on the first page of the wizard: 

1. In the Variables list, specify the Y variables and mark and Exclude 
unwanted variables. With many y-variables they must be positively 
correlated, and the most important one should be selected as target on the 
next page. All variables are specified according to the default workset. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. 

4. Click Next. 

Note: Specifying several uncorrelated y-variables or anti-correlated y-
variables as Y will give poor results. In such cases first do a PCA and select 
only a group of positively correlated y-variables to be compressed together. 

Selecting wavelet options 
The page for wavelet options holds options for detrending, wavelet function, wavelet 
order, exclusion criteria, compression method, and target variable. This page is the 
same for WCTS and WDTS. 
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In the page for selecting wavelet options: 

1. In the Detrend mode box the default is None for WDTS. Click the Detrend 
mode box to select Mean or Linear. Mean signifies removing the mean 
while Linear signifiers removing the best linear fit. For WCTS the Detrend 
mode box is unavailable and the selected detrending mode is Mean.  

2. In the Wavelet function box the default is Daubechies. Click the Wavelet 
function box to select Beylkin, Coiflet, Symmlet, Biorthogonal1, 
Biorthogonal2, Biorthogonal3, Biorthogonal4, Biorthogonal5, or 
Biorthogonal6. For details about the wavelet functions, see the Wavelet 
families section in Appendix B: Preprocessing. 

3. In the Wavelet order box, select the wavelet order. The default is the lowest 
available. The wavelet order differs depending on the wavelet function 
selected. Find the orders available for each wavelet function in the table in 
the Selecting wavelet options - WCS subsection earlier in this chapter. 

4. Select the method of exclusion of wavelets coefficients by selecting Energy 
retained type By variance or By detail level. 

5. Click the desired decomposition and Compression method, DWT or Best 
basis. DWT, discrete wavelet transform, is recommended for low frequency 
signals and Best Basis for high frequency signals. With By detail level, 
DWT is the only available compression method. 

6. In the Select target variable box select which of the variables to use as 
target variable. 

7. Click Next. 

Wavelet compression By variance - WCTS 
When compressing the signal by the percent of variance explained, SIMCA computes 
and displays the percentage of the variance explained by the wavelet coefficients of the 
target vector, sorted in order of importance. 

1. Use the plot to decide the number of coefficients to keep. The default is to 
keep the coefficients that account for 90% of the variance. The same 
coefficients are kept for all y-variables. 

2. Optionally change from the default under Select by energy retained (sum of 
squares). 

3. Click Next. 
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Compression/denoising By variance is done either using compression method DWT 
or Best Basis. For details about DWT and Best Basis, see the Wavelet transform 
section in Appendix B: Preprocessing. 

Wavelet compression/denoising By detail level 
The compression/denoising By detail level is performed by excluding all the detail 
coefficients corresponding to selected scales (levels) of the selected target vector. 
DWT is the only available compression method. 

The wavelet transform is first done on the target vector (average variable) and the 
results are displayed as a table. After selecting the wavelets coefficients or the scales to 
be removed, the same transformation is performed on each X observation vector. 

Selecting wavelet coefficients 
When selecting By detail level to compress/denoise the X block by removing detail 
levels, SIMCA decomposes the target X to its detail coefficients at every scale. The 
left table displays for every detail level (scale) the number of coefficients and the 
percentage of the sum of square (energy), not including the DC component. 

To exclude levels from the denoised X-block: 

1. Select the undesired levels in the Selected list. 

2. Click <= to remove. 

3. Click Next. 
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Creating the new dataset 
On the last page of the WCTS wizard: 

 Enter the Dataset name. 

 Click Finish. 

 

WCTS dataset properties 
The X and Y matrices are compressed by extracting only the selected number of 
significant coefficients, or detail level coefficients, in both the X and Y block, column 
wise. 

Observation identifiers with Best Basis 

With Best Basis selected, the observations in the new project are labeled $ WTS-
Scale–Position (e.g., $WTS-6-15). 

Scale is the block index of the packet table. It represents the frequency resolution of 
the signal, i.e., the number of times it has passed through the Low pass and Hi pass 
filters. This means that when the scale value equals 1 the signal has passed once 
through the filters. The scale ranges from 1 to log2 (N), where N=length of the signal 
(padded if N was not power of 2). Frequency resolution and time resolutions are the 
inverse of each other. 

Position is the position of the coefficient within the block. The position index ranges 
from 1 to N, and is related to the frequencies in the signal. Here 1 is the lowest and N 
is the highest frequency. 

Predictionset 

Predictionsets will not be wavelet transformed, and can be used as they are in the 
original domain. 
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Wavelet Denoising/Decimation – WDTS 
The Wavelet Denoising/Decimation differs from Wavelet Denoise Spectral in that 
compression is done variable wise and not observation wise. 

After the removal of the wavelet coefficients, the X variables are transformed back to 
the original domain. 

After transforming all the variables to the wavelet domain, the denoising is done by 
performing the inverse wavelet transform with either the selected coefficients or the 
coefficients from the selected details. All other coefficients are set to 0. 

Decimation 
Decimation is a re-sampling of data after removal of the high frequencies, by selecting 
every second or fourth or eighth, etc. observations. This is useful when the sampling 
interval is much faster than the time constant of the system. 

The decimation is performed on the dataset after it is transformed back to original 
units. Decimation is only available by a value that is power of 2. 

WDTS wizard 
To compress the data by reducing the number of observations, on the Data tab, in the 
Filters group, click Time Series Filters | Wavelet Denoising/Decimation. The first 
page of the WDTS wizard opens displaying lists of variables and observations. 

 

Selecting the variables and observations to transform 
To apply the filter to the dataset, on the first page of the wizard: 
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1. In the Variables list, mark and Exclude unwanted variables. All variables 
specified as X in the default workset are by default included, while those 
specified as Y are by default excluded. Qualitative variables cannot be 
filtered. 

2. In the Observations list, mark and Exclude the observations to exclude from 
the filtering. All observations are by default included. 

3. To specify variables and observations according to a fitted model, select the 
model in the As model box. Variables in the model specified as Y are 
automatically excluded. 

4. Click Next. 

Selecting wavelet options 
The page for wavelet options holds options for detrending, wavelet function, wavelet 
order, exclusion criteria, compression method, and target variable. This page is the 
same for WCTS and WDTS. 

 
In the page for selecting wavelet options: 

1. In the Detrend mode box the default is None for WDTS. Click the Detrend 
mode box to select Mean or Linear. Mean signifies removing the mean 
while Linear signifiers removing the best linear fit. For WCTS the Detrend 
mode box is unavailable and the selected detrending mode is Mean.  

2. In the Wavelet function box the default is Daubechies. Click the Wavelet 
function box to select Beylkin, Coiflet, Symmlet, Biorthogonal1, 
Biorthogonal2, Biorthogonal3, Biorthogonal4, Biorthogonal5, or 
Biorthogonal6. For details about the wavelet functions, see the Wavelet 
families section in Appendix B: Preprocessing. 

3. In the Wavelet order box, select the wavelet order. The default is the lowest 
available. The wavelet order differs depending on the wavelet function 
selected. Find the orders available for each wavelet function in the table in 
the Selecting wavelet options - WCS subsection earlier in this chapter. 

4. Select the method of exclusion of wavelets coefficients by selecting Energy 
retained type By variance or By detail level. 

5. Click the desired decomposition and Compression method, DWT or Best 
basis. DWT, discrete wavelet transform, is recommended for low frequency 
signals and Best Basis for high frequency signals. With By detail level, 
DWT is the only available compression method. 

6. In the Select target variable box select which of the variables to use as 
target variable. 

7. Click Next. 
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Wavelet denoising By variance - WDTS 
When denoising the signal by the percent of variance explained, SIMCA computes and 
displays the percentage of the variance explained by the wavelet coefficients of the 
target vector, sorted in order of importance. 

1. Use the plot to decide the number of coefficients to keep. The default is to 
keep the coefficients that accounts for 99.5% of the variance. 

2. Optionally change from the default under Select by energy retained (sum of 
squares). 

3. Click Next. 

   
Compression/denoising By variance is done either using compression method DWT 
or Best Basis. For details about DWT and Best Basis, see the Wavelet transform 
section in Appendix B: Preprocessing. 

Wavelet compression/denoising By detail level 
The compression/denoising By detail level is performed by excluding all the detail 
coefficients corresponding to selected scales (levels) of the selected target vector. 
DWT is the only available compression method. 

The wavelet transform is first done on the target vector (average variable) and the 
results are displayed as a table. After selecting the wavelets coefficients or the scales to 
be removed, the same transformation is performed on each X observation vector. 
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Selecting wavelet coefficients 
When selecting By detail level to compress/denoise the X block by removing detail 
levels, SIMCA decomposes the target X to its detail coefficients at every scale. The 
left table displays for every detail level (scale) the number of coefficients and the 
percentage of the sum of square (energy), not including the DC component. 

To exclude levels from the denoised X-block: 

1. Select the undesired levels in the Selected list. 

2. Click <= to remove. 

3. Click Next. 

 

Creating the new dataset - WDTS 
On the last page of the WDTS wizard: 

 Enter the Dataset name. 

 Optionally enter the number to decimate. This option is available when By 
detail level was selected in the Selecting wavelet options page. For more, 
see the Applying decimation subsection next. 

 Click Finish. 
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Applying decimation 
Decimation is available when using By detail level. The objective is to select a subset 
of the observations by keeping every second or fourth or eighth etc. observation. 

Decimation is only available by a value that is power of 2. For example select 4, every 
4th observation will be used. Leaving the decimation = 1 will include all observations. 

The following decimation is recommended: 

 After removing D1, decimate by 2. 

 After removing D1 and D2, decimate by 4 

 After removing D1, D2, and D3, decimate by 8 etc. 

Note: Decimation is done after the WDTS transformation. 

WDTS dataset properties 
The dataset is compressed by extracting only the selected number of significant 
coefficients, or detail level coefficients, column wise. 

In the WDTS transformed project, use the Workset commands, as usual, to specify the 
workset for the model. 

Predictionset 

Predictionsets will not be wavelet transformed, and can be used as they are in the 
original domain. 
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Dataset Summary 
The Dataset Summary, or Properties dialog, holds information about the selected 
dataset including number of variables and observations, where the data was imported 
from, missing values, variable types etc. 

To open the dialog: 

 On the Data tab, in the Summary group, click Dataset Summary. 

 Right-click the open dataset spreadsheet and click Properties. 

In the dataset properties dialog there are always three tabs Variables, Observations 
and General.  

For batch evolution datasets the following tabs are additionally available: 

 Batches tab – always. 

 Phases tab – when there are phases. 

For filtered datasets the Filter tab is additionally available. 
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General page in dataset Properties 
The General page displays the number of variables and observations, number of 
batches and phases for batch projects, and the Import Log. 

   

Observations page 
To display the observations and assigning them to classes for the default workset, click 
the Observations tab. After assigning classes in here, the classes are by default 
assigned in all new worksets. 

To view secondary IDs, right-click the list, and select the desired ID. 

To assign observations to a class: 

1. Mark the observations manually or using Find. 

2. Type the class name in the Class field or use class numbers. 

3. Click Set. 

4. Repeat 1-3 until done. 

5. Click Apply or OK. 

   

Note: Assigning classes is unavailable in batch projects. 
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Variables page 
To display the variables and their roles (i.e. what's X and what's Y), click the Variable 
tab. 

To change the variable type, open the Workset dialog, modify as desired, and then 
click the Save as Default Workset button. 

   

Date/Time configuration in Dataset Properties and Dataset 
Summary 
A variable that has been specified as Y Date/Time Variable or Date/Time Variable 
can be reformatted by right-clicking the variable in the dataset spreadsheet, and then 
clicking Format Date/Time. See step 4 in the table. 

Reformatting can also be done, as well as other Date/Time variable settings, in 
Dataset Properties dialog described in the table, opened by clicking Dataset 
Summary in the Summary group on the Data tab. 

In the Date/Time configuration section there are three buttons. The No Default 
button is always available while the Edit Format (described in the table) and Set As 
Default, buttons are available when a date/time formatted variable is selected in the 
list. 

Clicking the Set As Default-button sets the selected Date/Time variable as the default 
variable to display in line plots and scatter plots with one series. 

Clicking the No Default-button will revert to using Num in the places where 
Date/Time is by default displayed when available. 

Note: Editing the format only affects how the variable is displayed, not how it 
is saved. 
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Step Dialog 

1. Open the Dataset 
Properties dialog and click 
the Variables tab. 

2. Mark the date/time variable. 

3. Click the Edit Format- 
button in the Date Time 
configuration section. 

 

4. In the Specify Date 
Format dialog, enter the 
new format. 

  

 

Phases 
The Phases page displays all phases in the dataset with the number of observations and 
batches in that phase. Under Comments, view the current y-variable for each phase. 

Clicking the + sign displays the variables included in the respective phases. 
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Batches 
The Batches page displays all batches with the number of observations included in 
each batch. 

 
When there are phases, clicking the + sign displays the phases included in the 
respective batch. 

Clicking the Batch - Phase or Phase - Batch buttons switches what is displayed 
between: 

 Batches with the phases displayed when clicking the + sign when the mode 
is Batch-Phase. 

 Phases with the batches displayed when clicking the + sign when the mode is 
Phase-Batch. 

Filter summary 
The Filter page holds details about the performed filtering in the selected preprocessed 
dataset. A preprocessed dataset is a dataset created by spectral filtering (Data | 
Spectral Filters) or time series filtering (Data | Time Series Filters). The Filter page 
is available in the dataset Properties dialog. 

To display the Filter page click: 

 On the Data tab, in the Summary group, click Dataset Summary and in the 
Properties dialog click the Filter tab. 

 Right-click the filtered dataset spreadsheet and select Properties. 
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In the example here, the current dataset is the result of having filtered and decimated a 
time series dataset, and the Filter page displays the following: 

   

Trimming Overview 
The Trimming Overview is available after trimming or Winsorizing the dataset. 

To get an overview of the trimming performed, open the Trimming overview. 

The Trimming overview is available by: 

 On the Data tab, in the Summary group, clicking Trimming Overview. 

 Right-clicking the dataset spreadsheet and selecting Trimming Overview. 

The Trimming Overview displays a summary of the trimmed or replaced values. 
Trimmed values replaced by missing appear in magenta (pink), Winsorized values 
appear in green. 

Note: The trimming-Winsorizing effects only the selected observations and 
variables. 
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Displaying the Missing Value Map 
To display an overview of a dataset with respect to missing values: 

 On the Data tab, in the Summary group, click Missing Value Map and then 
the desired dataset in SIMCA. 

 In SIMCA import, on the View tab in the Missing Values group, click the 
Missing Value Map. 

Missing values are colored while data present are white. 

   

Spectra 
With spectral data, it is particularly useful to display XObs of all observations in a line 
plot, the Spectra plot. 

Open the Spectra plot on the Data tab, in the Summary group. 

 

See also the Color subsection in the Tools tab section in the Plot and list contextual 
tabs chapter for details about coloring the line plot. 



Data 

273 

Hierarchical models 
After fitting a model, the scores, residuals, and predicted y of that model can be used as 
variables in another model.  

Models using scores, residuals, or predicted y from another model are named 
hierarchical top models. The model providing the score/residual/predicted y variables 
is named hierarchical base model. 

To create the hierarchical variables to use in another model, use one of the two 
methods: 

 With the model marked in the Project Window, on the Data tab, in the Base 
Model section click Hierarchical Base Model and select check boxes as 
desired. 

 Right-click the model in the Project Window, click Hierarchical Base 
Model and select the check boxes as desired. 

A new dataset named $MxHierarchical is created holding: 

 The scores of all extracted components, when selecting Scores. 

 The residuals of all the variables, when selecting the residual check boxes. 

 The predictions for all y-variables when selecting Y Pred. 

Models including the hierarchical dataset are marked T (hierarchical Top model), and 
the Base models are marked B in the Project Window. 
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Hierarchical models with OPLS or O2PLS 
When the fitted model is an OPLS or O2PLS model, the following additional 
hierarchical terms can be added: 

 Y-Orthogonal residuals - the residuals after subtracting the predictive part 
of the model (X-TP'). Only available for OPLS and O2PLS models with at 
least one Y-Orthogonal component. 

 Y-Related residuals - the residuals after subtracting the Y-orthogonal part 
of the model (X-ToPo'). Only available for OPLS and O2PLS models with at 
least one Y-Orthogonal component. 

 Y-Orthogonal scores - the scores that are orthogonal to Y (To). Only 
available for OPLS and O2PLS models with at least one Y-Orthogonal 
component. 

 

Hierarchical models with blocks 
After assigning variables to blocks (see Assigning variables to blocks subsection in 
the Workset chapter), the hierarchical model types PCA-Hierarchical, and if y-
variables were specified, PLS-Hierarchical, OPLS-Hierarchical and O2PLS-
Hierarchical are available. 

Selecting one of the hierarchical model types results in: 

 Fitting one model for each block positioned in a CM wrapper. 

 Setting each model as hierarchical base model creating the hierarchical 
scores datasets. 

Hierarchical base models reverts to non hierarchical 
A hierarchical base model reverts to a regular Non Hierarchical when:  

 Adding components 

 Changing the model title 

 Clicking Non Hierarchical 

This results in that the B is removed and the hierarchical dataset is deleted. 
Consequently the hierarchical top models are deleted and the former base model has to 
be designated as a Hierarchical Base Model again to recreate the hierarchical top 
models. 
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Batch 

Introduction 
The Batch tab holds the batch specific features and is unavailable for regular projects. 
The following features are available: 

 Batch control charts (BCC) plots and lists, both for the model and for 
predictions. 

 Batch plots illustrating smoothing and alignment. 

 Creation of batch level and hierarchical batch datasets. 

 Batch variable importance plot. 

 
The Batch modeling in SIMCA section, in the Introduction to multivariate data 
analysis chapter, describes the batch evolution and batch level model types. 

Batch Control Charts 
For batch evolution models, batch control charts are available on the Batch tab. The 
available batch control chart types are: 

 Scores 

 Variable  

 DModX 

 Hotelling’s T2 

 Observed vs. Time/Maturity 

 List 

All plots are available both in the Analysis Control Charts and the Prediction 
Control Charts groups, the buttons in the latter with the addition of PS in the button 
name.  

Each plot type is described later in this section. 

The batch control charts by default display the first batch in the workset. For batch 
projects with phases the active phase (class) is used. When the BEM is marked when 
clicking a BCC all phases are displayed. 
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Note: For any batch control chart with a batch outside the displayed control 
limits, you can display the Out of Control plot by clicking Out of Control 
Summary in the Change Type group on the Tools tab. For more, see the Out 
of Control plot (OOC) subsection in the Plot and list contextual tabs chapter. 

Batch control chart background 
When batches have different length, alignment of the batch variables, scores, DModX, 
etc., is done by cutting or continuing with the last value so that all batches have the 
same length as the median batch length. This subsection describes the batch control 
chart calculations using, as example, the scores. 

Note: With batches that vary in length more than 20% to 30%, you should use 
a maturity variable as Y. 

The scores of the active model(s) are chopped up, aligned and reorganized so that the 
scores of one batch form one row vector (t1 followed by t2, followed by t3, etc.) in a 
matrix ST. This matrix has N rows (one per batch) and x J (AJ) columns from the A 
score vectors and the J "time points" per batch. 

When batches have phases, the alignment is done by phases using their respective 
Maturity or Time variable. 

Time Normalized is equivalent to a linear time warping. 

From the matrix ST, SIMCA calculates the averages and standard deviations (SD) of 
the scores, (average trace of normal batches and control intervals as the averages  2, 
and  3 SD). 

The batch control charts for Variables, DModX, Hotelling's T2, and Obs vs. 
Time/Maturity are calculated in the same manner. 

Batch control chart plot and list customization 
Batch control charts can be customized using the Properties and Format Plot dialogs. 
This section describes the Properties dialog for batch control charts. For more about 
Format Plot, see the Plot and list contextual tabs chapter. 

Open the Properties dialog by clicking the plot and clicking Properties in the mini-
toolbar 

In the Properties dialog for the BCCs the following tabs are available: 

 Select Batch and Phase 

 Limits and Averages 

 Component. 

 Select Variable for the Variable BCC. 

Note: The Select Batch and Phase page is available for the Batch Control 
Chart List. 

Each tab is described in the subsections that follow. 
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Selecting Batch and Phase 
On the Select Batch and Phase page: 

 In the Select phase box select one phase or All phases. 

 In the Unselected list, select the batches to display and click the => button. 

 In the Selected list, mark available batches to no longer display and click the 
<= button. 

 Select or clear the Align batches check box (by default both workset and 
predictionset batches are displayed unaligned) to display the batches aligned 
or unaligned. After clearing, select what to display on the X-Axis: YVar, 
YVarDS, or Num. Or for the batch control charts created from the 
Predictions menu: YVarPS, YVarDSPS, or Num. YVar and YVarPS are 
the time/maturity variable treated as in the workset; YVarDS and 
YVarDSPS are the time/maturity variable in original units (as in the 
respective datasets). 

Note: Batch Control Charts displaying All Phases use Num on the x-axis. 

 

Limits and Averages 
On the Limits and Averages page: 

 In the Control limits box, select which limits to display. Default is to display 
Average Batch and when appropriate +3 std. dev and -3 std. dev. Available 
limits are by default -3, -2, -1, Average Batch, 1, 2, 3 standard deviations. 

 To display the standard deviation over all batches and phases, select the 
Display steady state limits using the overall standard deviation check 
box. This option is available for the Variable BCCs displaying one phase, 
and enables monitoring of steady state variables. 

 In the For this plot box in the Averages section, select 

a. do not remove the average – to display the limits and values on 
the original scale. 

b. remove the average – to remove the average from limits and 
batches leading to a centered plot with y=0 as average batch. 
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c. remove the average and normalize the values – to remove the 
average and normalize limits and batches leading to a plot with 
y=0 as average batch and horizontal limits. 

 

Adding limits 

To add control limits, click the arrow next to the Control limits box and click Custom 
Limits. 

 
  

In the Custom Limits dialog, enter the limits to display in Control Limits, with 
<space> parting the limits. 

Note: The new entered limits replace the old. This means that typing ‘1.5’ in 
Limits results in that – and +1.5 std. dev will be the only available limits. 

 
To restore the default limits, click the arrow next to the Control limits box and click 
Reset Custom Limits to Default. 
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Component 
On the Component page, select for which component to display the batch control 
chart. The Component page is not available for the Variable BCC. 

 

Select Variable 
On the Select Variable page, select which variable to display in the Variable BCC.  

 

Excluding batches 
An entire batch can be excluded from the model by selecting the batch in a plot using 
the Batch Marking Mode. 

To exclude a batch from the model: 

1. Open a plot displaying batches, such as a batch control chart. 

2. On the Tools tab, in the Highlight group, click Select | Batch Marking 
Mode. 

3. In the plot click the batch. 

4. On the Marked Items tab, in the Modify Model group, click Exclude. 

5. New unfitted models are created. 

For details on the tools, see the Select plot items - Marking tool section in the 
Marked Items tab section in the Plot and list contextual tabs chapter. 

See also the Including and excluding batches subsection in the Batch page section in 
the Home chapter. 
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Score Batch Control Chart 
Open the Scores BCC by clicking it in the Analysis Control Chart group on the 
Batch tab. This plot displays the workset batches.  

To see predictions, click Scores PS BCC in the Prediction Control Chart group.  

The limits that are displayed by default are the Average Batch and -3 and +3 std. dev. 

   

Variable Batch Control Chart 
Open the Variable BCC by clicking it in the Analysis Control Chart group on the 
Batch tab. This plot displays the workset batches.  

To see predictions, click DModX PS BCC in the Prediction Control Chart group. 

The limits that are displayed by default are the Average Batch and -3 and +3 standard 
deviations. 

 
By selecting the Display steady state limits using the overall standard deviation 
check box, in the Properties dialog, Limits and Averages page, you can select to 
have the limits computed from the standard deviation of the variable as computed or 
specified in the workset. 
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DModX Batch Control Chart 
Open the DModX BCC by clicking it in the Analysis Control Chart group on the 
Batch tab. This plot displays the workset batches.  

To see predictions, click DModX PS BCC in the Prediction Control Chart group.  

The limits that are displayed by default are the Average Batch and +3 std. dev. 

   

Hotelling’s T2Range Batch Control Chart 
Open the Hotelling’s T2 BCC by clicking it in the Analysis Control Chart group on 
the Batch tab. This plot displays the workset batches.  

To see predictions, click Hotelling's T2PS BCC in the Prediction Control Chart 
group. 

The limits that are displayed by default are the Average Batch and T2Crit(95%) and 
T2Crit(99%). 
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Observed vs. Time/Maturity Batch Control Chart 
Open the Observed vs. Time/Maturity BCC by clicking Obs vs. Time/Maturity BCC 
in the Analysis Control Chart group on the Batch tab. This plot displays the workset 
batches.  

To see predictions, click Obs vs. Time/Maturity PS BCC in the Prediction Control 
Chart group. 

The limits that are displayed by default are the Average Batch and -3 and +3 std. dev. 

 

Batch Control Charts List 
The List BCC displays a number of vectors for the active model or phase. 

Open the BCC List by clicking it in the Analysis Control Chart group on the Batch 
tab. This plot displays the workset batches.  

To see predictions, click List PS BCC in the Prediction Control Chart group. 

 
Default is to display the list for unaligned batches. All t, YPred, and DModX vectors 
are then displayed unaligned while the averages and standard deviations are displayed 
aligned.  

Note: The t, YPred, and DModX vectors referring to the specific batches are 
displayed alongside the YVarDS vector to the far right in the list. 

To display the list for aligned batches, open Properties, and select the Align batches 
check box.  
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All vectors available from the BCC List are listed in the table. 

General name Description Example 

Mx.t[‘comp’] 
(Aligned) (Avg) 

The average over all 
batches of the aligned score 
vectors, for each 
component. 

M3.t[1] (Aligned) (Avg) 

Mx.t[‘comp’] 
(Aligned) (Std. 
Dev.) 

The standard deviation over 
all batches of the aligned 
score vectors, for each 
component. 

M3.t[1] (Aligned) (Std. Dev.) 

Mx.t[‘comp’] 
(Aligned): ‘batch’ 

The aligned score vector for 
the listed batch, for each 
component. 

Note: This vector is only 
available when the Align 
batches check box is 
selected. 

M3.t[1] (Aligned): 1 

Mx.YPred[‘last 
comp’](‘y’)(Aligned) 
(Avg)  

The average over all 
batches of the aligned 
predicted y vectors, for the 
last component. 

M3.YPred[2](timeb)(Aligned) 
(Avg)  

Mx.YPred[‘last 
comp’](‘y’)(Aligned) 
(Std. Dev.)  

The standard deviation over 
all batches of the aligned 
predicted y vectors, for the 
last component. 

M3.YPred[2](timeb)(Aligned) 
(Std. Dev.)  

Mx.YPred[‘last 
comp’](‘y’)(Aligned): 
‘batch’  

The aligned predicted y 
vector for the listed batch 
and last component. 

Note: This vector is only 
available when the Align 
batches check box is 
selected. 

M3.YPred[2](timeb)(Aligned): 
1  

Mx.DModX[‘last 
comp’] (Aligned) 
(Avg) 

The average over all 
batches of the aligned 
DModX vectors, for the last 
component. 

M3.DModX[2] (Aligned) 
(Avg) 

Mx.DModX[‘last 
comp’] (Aligned) 
(Std. Dev.) 

The standard deviation over 
all batches of the aligned 
DModX vectors, for the last 
component. 

M3.DModX[2] (Aligned) (Std. 
Dev.) 

Mx.DModX[‘last 
comp’] (Aligned): 
‘batch’ 

The aligned DModX vector, 
for the listed batch and last 
component. 

Note: This vector is only 
available when the Align 
batches check box is 
selected. 

M3.DModX[2] (Aligned): 1 
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General name Description Example 

Mx.YVarDS(‘y’): 
‘batch’ 

The original y-vector for the 
listed batch. 

Note: This vector is only 
available when the Align 
batches check box has 
been cleared. 

M3.YVarDS(timeb): 1 

Mx.t[‘comp’]: ‘batch’ The unaligned score vector 
for the listed batch, for each 
component. 

Note: This vector is only 
available when the Align 
batches check box has 
been cleared. 

M3.t[1]: 1 

Mx.YPred[‘last 
comp’] (‘y’): ‘batch’ 

The unaligned predicted y 
vector for the listed batch 
and last component. 

Note: This vector is only 
available when the Align 
batches check box has 
been cleared. 

M3.YPred[2] (timeb): 1 

Mx.DModX[‘last 
comp’]: ‘batch’ 

The unaligned DModX 
vector for the listed batch 
and last component. 

Note: This vector is only 
available when the Align 
batches check box has 
been cleared. 

M3.DModX[2]: 1 

Batch control charts for new batches 
To monitor the evolution of new batches, use the buttons in the Prediction Control 
Chart group on the Batch tab, after specifying the predictionset in the Specify 
Predictionset group on the Predict tab. 

The data from each new batch are inserted into the batch evolution model, giving 
predicted values of the scores, TPS. In addition, predicted Y and DModX values are 
computed. These results can now be plotted in the appropriate control charts, with 
limits derived from the workset model. 

The batch control charts indicate whether the batch is starting and running normally or 
not. If the values are outside the normal ranges, contribution plots based on the x-
values or the residuals indicate which variables together are related to the deviations. 

The new batches are by default displayed unaligned in the predicted batch control 
charts. 

Use the Data group, in the Tools tab, to select a different phase, different batches, etc. 
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For details about creating contribution plots for entire batches, see the second table in 
the Drill down contribution plots available subsection in the Marked Items tab 
section in the Plot and list contextual tabs chapter. 

For details about the Properties dialog, see the Batch Control Chart plot and list 
customization subsection previously in this chapter. 

For details about the limits, see the Calculating limits to build control charts 
subsection in the Introduction to MVA chapter. 

For info about the out of control plot, see the Out of Control Summary Plot (OOC) 
subsection in the Tools tab section in the Plot and list contextual tabs chapter. 

Create BLM 
To be able to create a batch level model, BLM, you first have to create a batch level 
dataset, BL DS. The BL DS then resides in the same project as the batch evolution 
dataset.  

Batch level models, BLM, created using the BL DS, are positioned in the same BM as 
the BEM the BL DS was created from. 
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Create the BL DS by clicking Create Batch Level in the Dataset group on the Batch 
tab. The Create Batch Level Dataset wizard opens. 

 

Selecting what to base the batch level dataset on 
On the first page of the Create Batch Level Dataset wizard, you must select what to 
base the batch level dataset, BL DS, on. The BL DS can be created using the options 
described in the table. Note that all check boxes can be selected and multiple BL DS 
are then created simultaneously.  

  Options Action Result after 
Next/Finish 

1. Create BL DS from 
scores. 

Select the Scores from 
the active model or 
group of models check 
box. 

A dataset containing 
scores is created after 
Finish. 

The variables are aligned 
using the time/maturity 
variable. 

2. Create BL DS from 
original variables. 

Select the Raw data as 
specified in the 
workset of the active 
model check box. 

A page for selecting 
variables for each phase. 
See Selecting BEM 
variables for BL DS 
section. Finish creates 
the dataset. 

The variables are aligned 
using the time/maturity 
variable. 

3. Create BL DS from 
statistics of the 
original variables. 

Select the Raw data 
statistics as specified 
in the workset of the 
active model check 
box. 

A page for selecting 
which statistics to include 
in the new dataset. 
Finish creates the 
dataset. 

4. Create a BL DS 
containing duration 
and endpoint. 

Leave the Create 
duration and endpoint 
in a separate dataset 
check box selected. 

A BL DS is created 
holding the duration and 
endpoint variables for all 
phases in the current 
BEM. 
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  Options Action Result after 
Next/Finish 

5 For missing phases, 
display missing. 
Alternatively display 
average batch for 
missing phases. 

Under Advanced, leave 
the Use average batch 
for missing phases 
check box cleared to 
create a BL DS 
displaying missing value 
for missing phases. 
Select the check box to 
display average batch 
values for missing 
phases. 

In the created BL DS, 
batches with missing 
phases will display 
missing or average batch 
depending on this option. 

6. Include secondary 
variable IDs from the 
BE DS to the BL DS. 

Available when 
there are secondary 
variable IDs in the 
BE DS. 

Under Advanced, 
select the Include 
secondary variable 
IDs check box. 

The BL DS spreadsheet 
displays the secondary 
variable IDs from 
the BEM. 

7. Specify the BL DS 
name. 

In the Name field, type 
the desired BL DS 
name. 

A BL DS is created with 
the specified name. 

Selecting BEM variables for BL DS dialog 
When clicking Raw data as specified in the workset of the active model, to 
construct the BL DS with different variable selection depending on the phase, clicking 
Next opens a dialog box enabling custom settings for each phase. Projects without 
phases are treated as having one phase. 
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The original variables in the model and those excluded are available for selection for 
each phase.   

Variable Description Comment 

Raw Data Original variables. Click the + to select a subset of 
the original variables in the 
phase. 

Raw Data for 
Excluded 
Variables 

Original variables not 
included. 

Click the + to select a subset of 
the original variables not 
included in the phase. 

Select/clear the desired check boxes and click Next/Finish. 

Raw Data Statistics Types dialog 
When selecting Raw data statistics as specified in the workset of the active model, 
clicking Next opens a dialog box for selecting which statistical variables to create in 
the new BL DS. 

 
The statistical variables, listed in the table, are calculated for each variable in each 
phase. 

Name in Raw 
Data Statistics 
page 

Name in BL DS 
spreadsheet 

Description 

Min MIN Minimum value. 

Max MAX Maximum value. 

Mean AVG Average value. 

Median MEDIAN Median value. 

Std. Dev. SD Standard deviation. 

Robust Std. Dev. RSD RSD = IQR/1.075 
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Name in Raw 
Data Statistics 
page 

Name in BL DS 
spreadsheet 

Description 

Interquartile IQR IQR = IQR[1] - IQR[3]. That is, 
the third interquartile 
subtracted from the first 
interquartile. 

Slope SLOPE Slope of the variable. 

Select the desired check boxes and click Finish. 

Batch condition datasets 
Batch condition variables are variables pertaining to the whole batch used in BLM. 
These may be starting conditions or final (result) conditions.  

A batch condition variable can be a continuous variable or discrete (qualitative). 

If batch conditions were imported in the BE DS, they are available in a separate batch 
level DS (batch conditions dataset, BC DS) created at import. For how to specify batch 
conditions during import of the BE DS, see the Specifying data properties subsection 
in the SIMCA import chapter. 

For how to import batch conditions separately, see the Importing batch conditions 
subsection in the SIMCA import chapter. 

Batch level datasets and missing values 
When creating batch level datasets, BL DS, from original variables, and there are 
missing values, SIMCA interpolates all missing values. Missing values can still be 
present first or last, as no extrapolation is done. 

When batches are missing phases, this is usually due to the fact that these phases/steps 
are not needed for those particular batches. In SIMCA there are two options: 

 Replacing these phases/steps with missing when creating the BL DS. This is 
the default in SIMCA. Note that this may cause bias in the results.  

 Replacing the missing phases/steps by the average values of these 
phases/steps in the workset (batches that yielded good results). This is the 
way SIMCA treated missing phases pre 13 and by some viewed as the best 
way to ensure that these phases will not bias unfavorably the predicted 
quality. 
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Sources of Variation plot 
In batch level models it is useful to display the contribution and loading plots as line 
plots over time rather than column plots at every time point. Therefore the Sources of 
Variation plot is the default loading and contribution plot for all BLM with one or 
more score or raw variables. The Sources of Variation plot contains the exact same 
data as a loading or contribution plot would show. Instead of having the variable 
number on the x-axis, the maturity of the batch is used. This gives a better view of how 
the process variables relate to each other at different stages in the process.  

For projects with phases, this plot is displayed showing all phases. 

BLM with batch conditions 
Variables without maturity, i.e. batch conditions, cannot be shown in Sources of 
Variation plots. When the BLM contains batch conditions it can be useful to view the 
plot as a regular column plot too.  

To switch the Sources of Variation plot to a column plot, on the Tools tab, in the 
Change Type group, click Column. A normal loading plot can always be created from 
the Loading plot gallery, in the Diagnostics & Interpretation group on the Home tab, 
by selecting one of the standard options. 

Contribution plots in column form may be selected on the Marked Items tab, in the 
Drill Down group, by clicking Column in the comparison plot gallery. 
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BLM loading and contribution plots example 
How to change between a Sources of Variation and a column plot is described in the 
table. This example uses a loading plot, but is applicable for contribution plots as well.  

Step Illustration 

1. On the Home tab, click 
Loadings.  

 
This plot displays how the selected variables 
variation over time differs from the average of 
batches or from another batch. 

  

2. To transform to the 
column plot, on the Tools 
tab, in the Change Type 
group, click Column. 

 

3. To transform to the Sources of Variation plot, on the Tools tab, in the Change 
Type group, click Sources of Variation. 

4. To switch phases or displayed variables in the contribution plot open Properties 
and: 

 click the desired phase in the Select phase box. 

 add to the Selected list the variables to display. 
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Time/Maturity group plots 
The two plots Observed vs. Smoothed Y and Unaligned vs. Aligned are found in the 
Time/Maturity group on the Batch tab. 

 

Observed vs. Smoothed Y plot 
The Observed vs. Smoothed Y plot displays the original maturity variable alongside 
the maturity variable as configured in the workset. This plot is displayed for each phase 
and is very illustrative when the maturity variable has been smoothed. 

To open the Observed vs. Smoothed Y plot, click it in the Time/Maturity group on 
the Batch tab. 

   
Use Properties to select a different batch. 
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Unaligned vs. Aligned plot 
To visualize the alignment of batches, i.e., how much a batch was stretched or shrunk 
to the median length of the workset batches: 

1. On the Batch tab, in the Time/Maturity group click Unaligned vs. Aligned 
Plot. 

2. In the dialog select the model in the Data box, vector in the Item box, and 
batch in the Batch box, and when applicable variable and component. Click 
OK. 

 
The resulting plot displays how well the aligned line follows the unaligned line. 
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Creating hierarchical models for batch level datasets 
When there are batch level datasets (BL DS) present, hierarchical batch models can 
automatically be created by clicking Create Hierarchical Batch Models in the 
Dataset group on the Batch tab.  

 
The types of hierarchical base models possible are:  

 One model for each phase and component – available when the variables in 
the BL DS are scores and the BEM has phases. 

 One model for each component – available when the variables in the BL DS 
are scores but the BEM has no phases. 

 One model for each phase in the BEM – available when the BEM has phases. 

 Sequential models covering a part of completion of the batches – available 
when the BEM does not have phases. 

When there are more than one BL DS, a dialog allowing you to select which datasets to 
use is opened.  

Note: You can only select datasets created from the same BEM. 

Create Hierarchical Batch Models dialog 
The Create Hierarchical Batch Models dialog has two interfaces, one where the 
BEM that the BL DS was created from has 2 or more phases and one where the BEM 
has one or no phases. 

The interface with one or no phases: 
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The interface with two or more phases: 

 
When creating the hierarchical batch models, the following options are always 
available: 

 Calculate at least x component(s) for each base model. This option forces 
extraction of x components when possible. 

 Center/UV scale all score variables in base and top level models. The 
default is Center. Selecting UV scale scales all score variables in the base 
model, if there are score variables, to unit variance, leaving all other 
variables Center scaled. Also all top level model score variables are scaled 
to unit variance when UV scale is selected. 

Note: The selection of Center or UV scale only affects the default scaling of 
the score variables. All other variables are default scaled to unit variance. 
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Create Hierarchical Batch Models results 
The resulting models from a few examples of using Create Hierarchical Batch 
Models are described in the table: 

Characteristics Dialog settings Description of 
resulting models  

1.   

5 phases in the 
BEM, each with two 
components. BL DS 
from scores. 

 

10 autofitted (but at least 
one component) base 
models – one for each 
phase and component – 
with all variables scaled 
Ctr. 

The variables included in 
each base model are the 
score variables related to 
each phase and 
component. 

One hierarchical top 
model holding the 
hierarchical score 
variables scaled Ctr. 

2. 

5 phases in the 
BEM, each with two 
components. BL DS 
from scores. 

 

5 autofitted (but at least 
two components) base 
models – one for each 
phase – with all variables 
scaled UV. 

The variables included in 
each base model are the 
score variables. 

One hierarchical top 
model holding the 
hierarchical score 
variables all scaled UV. 

3. 

5 phases in the 
BEM, each with two 
components. BL DS 
from original data. 

 

5 autofitted base models 
– one for each phase – 
with all variables scaled 
UV. 

The variables included in 
each base model are the 
original variables. 

One hierarchical top 
model holding the 
hierarchical score 
variables scaled Ctr. 
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Characteristics Dialog settings Description of 
resulting models  

4. 

5 phases in BEM, 
each with two 
components. BL DS 
from summary 
variables (raw data 
statistics). 

 

5 autofitted base models 
– one for each phase – 
with all variables scaled 
UV. 

The variables included in 
each base model are the 
summary variables. 

One hierarchical top 
model holding the 
hierarchical score 
variables scaled Ctr. 

5. 

No phases in the 
BEM, two 
components. BL DS 
from scores. 

 

4 autofitted (but at least 
one component) models 
– each covering 25% of 
the batch completion 
according to the 
maturity. 

The first model covers 0-
25%, the second 25%-
50% etc. 

The base model 
variables are scaled UV. 
One hierarchical top 
model holding the 
hierarchical scores 
scaled UV. 

6. 

No phases in the 
BEM, two 
components. BL DS 
from scores. 

 

2 autofitted base models 
– one for each 
component. 

The variables included in 
each base model are the 
score variables. 

All score variables in the 
base and top models are 
Ctr scaled. 
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Characteristics Dialog settings Description of 
resulting models  

7. 

No phases in the 
BEM, two 
components. BL DS 
from original data. 

 

4 autofitted (but at least 
one component) models 
– each covering 25% of 
the batch completion 
according to the 
maturity. 

The first model covers 0-
25%, the second 25%-
50% etc. 

All variables in the base 
model are UV scaled. 
One hierarchical top 
model holding the 
hierarchical score 
variables scaled Ctr. 

8. 

No phases in the 
BEM, two 
components. BL DS 
from only summary 
variables. 

No hierarchical batch models can be created since there are: 

1. No score variables. 

2. No phases. 

3. No components related to the batch level variables 

4. No maturity variable to create sequential models. 

Hierarchical top level model 
All the hierarchical base models are fitted while the hierarchical top level model is 
created using the scores of the base models. This last model is unfitted for editing of 
the model by for instance including other variables, such as quality variables as Y. 
However, selecting to include another dataset resets to default workset resulting in that 
centering, if default done by SIMCA, must be redone manually. 
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Batch Variable Importance Plot 
The Variable Importance Plot (also named Batch VIP), available for batch level 
models created from a scores dataset, displays the overall importance of the variable 
over the whole evolution on the final quality of the batch. With phases, the plot 
displays the importance of a variable by phase. With a PLS model, the Batch VIP 
displays one plot for each y-variable with a column per selected phase. 

 
To open the plot: 

1. On the Batch tab, in the Variable Summary group, click Variable 
Importance Plot. 

2. In the Batch Variable Importance dialog, select the phases for which to 
display the Batch VIP. With no phases, the Batch VIP is displayed for the 
BEM used to create the batch level dataset the model was built on. 

3. Click OK. 

   

Note: The Variable Importance Plot, Batch VIP, plot is only available when 
scores in the scores BL DS are selected as X in the BLM. 
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Analyze 

Introduction 
This chapter describes all commands on the Analyze tab. 

The Analyze tab displays the analysis features not common enough to end up on the 
Home tab. 

Content 

The following commands are available on the Analyze tab: 

1. Biplot to display the scores and loadings in the same plot. 

2. Inner Relation to illustrate the goodness of fit. 

3. S-plots to display the S-plot, S-line or SUS Plot. 

4. Contribution plots to display the influence on each variable when 
comparing a point or group of points with the center, another point, or a 
group of points. 

5. RMSECV to indicate predictive power. 

6. Y-Related Profiles to display the pure profiles of the underlying spectrum 
for OPLS and O2PLS models. 

7. Residuals N-Plot to display the residuals on a normal probability scale. 

8. Permutations to display a measure of the overfit. 

9. CV-ANOVA to display the cross validated ANOVA table. 

10. CV Scores to display a cross validated complement to the regular score plot. 

11. HCA for cluster analysis. 

12. PLS-Tree for cluster analysis highlighting subgroup formations in latent 
variables. 
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Biplot 
The loading vectors p, c and pc and the score vector t can be displayed Correlation 
Scaled leading to the vectors p(corr), c(corr), pc(corr) and t(corr). Additionally poso 
and pq for OPLS and O2PLS can be displayed correlation scaled, poso(corr) and 
pq(corr). The selected correlation scaled loading vector can be displayed together with 
the correlation scaled score vector in a Biplot where all points end up inside the 
correlation circle of radius 1. 

Open the plot by clicking Biplot in the Analysis group on the Analyze tab. The Biplot 
is available for all fit methods. 

Note: The weights w and w*, cannot be displayed as correlations, as the u 
vectors are not orthogonal. 

In the Biplot here pc(corr) and t(corr) are displayed for the first and second 
components. 

 
The default coloring for the loading vector is by Terms and is found in the Color tab 
in the Properties dialog. For coloring of the score vector an additional tab Score 
Color is available. For details about coloring see the Coloring from Properties 
subsection in the Tools tab section in the Plot and list contextual tabs chapter. 

In the Properties dialog, in addition to the Label Types tab referring to the labels on 
the loading vectors, there is a Score Labels tab which refers to the labels on the scores. 
The default is to not display labels on the observations. 

Colors in the Biplot 
In the Biplot, the different points are by default colored by Terms coloring x-
variables, y-variables, cross, square, cubic, lags and observations in different colors. 

The color scheme is the same as for the regular Loadings Scatter Plot. 

The colors and symbols can be changed in the Format Plot dialog, Styles node.  
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Inner Relation Plot 
For a PLS model the Y space can be explored by plotting u1 vs. u2 and interpreting it 
in the same way as the t1 vs. t2 plot.  

When plotting a t vector vs. a u vector for the same component, the goodness of the fit 
is illustrated.  

Open the plot by clicking Inner Relation in the Analysis group on the Home tab. 

 

S-plots 
S-plots menu holds the three plots: S-plot, S-line and SUS-Plot.  

 
The S-plots provide visualization of the OPLS/OPLS-DA predictive component 
loading to facilitate model interpretation. The plots are only available for OPLS models 
with one y-variable and OPLS-DA models with two classes. 

S-plot  
The S-plotTM is used to visualize both the covariance and the correlation structure 
between the X-variables and the predictive score t[1]. Thus, the S-plot is a scatter plot 
of the p[1] vs p(corr)[1] vectors of the predictive component [Wiklund, et al., 
Analytical Chemistry, 2008]. With Pareto and Ctr scaling this plot often takes the 
shape of the letter 'S'. X-variables situated far out on the wings of the S combine high 
model influence with high reliability and are of relevance in the search for e.g. 
biomarkers that are up- or downregulated.  
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In the example below, the triangle has a high p(corr) which means a very high 
reliability while the square has a high model influence partly due to its high variance in 
the dataset. 

 

S-line plot 
The S-line plot is tailor-made for NMR spectroscopy data. It visualizes the p(ctr)[1] 
loading colored according to the absolute value of the correlation loading, p(corr)[1]. 
Thus, the S-line plot is conceptually similar to the STOCSYTM plot pioneered by the 
Nicholson group at Imperial College, London, UK [Cloarec, et al., Analytical 
Chemistry, 2005]. However, it should be noted that the coloring principle is slightly 
different between the two plots.  

The plot below displays the predictive loading in a form resembling the original 
spectra, colored according to p(corr). The top end of the color scale visualizes the 
NMR shifts that influence the separation of the groups.  

Figure. The S-line for an OPLS-DA model. 
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SUS-Plot 
The SUS-plot is a scatter plot of the p(corr)[1] vector from two separate OPLS models 
[Wiklund, et al., 2008]. If two OPLS models have similar profiles (they capture similar 
relationships between the X-variables and the single Y-variable) the X-variables will 
line up along the diagonal running from the lower left corner to the upper right corner. 
Such variables represent the Shared structure among the two compared OPLS models. 
Conversely, X-variables that are not located along this thought diagonal, e.g. in the 
upper left corner, represent structures that are Unique to either of the two models 
compared. 

SUS is an acronym for Shared and Unique Structures.  

In the plot below, in the lower left corner, the variable with plot mark triangle is a 
Shared variable. It has a negative correlation of the same size in both models meaning 
that it is down regulated, i.e. lower in the genetically modified samples compared with 
the control in both models. The square (at 6 o'clock) is a Unique variable for M2 as the 
p(corr) for M1 is 0. The opposite is true for the pentagon variable which is Unique for 
M1 and has a p(corr) close to 0 for M2. 

 

Contribution plots 
Contribution plots are used to understand why an observation differs from the 
others in an X score (t), in DModX, in DModY, in Hotelling's T2Range, or in the 
observed vs. predicted Y plot. 

The contribution plot displays the differences, in scaled units, for all the terms in 
the model, between the outlying observation and the normal (or average) 
observation, multiplied by the absolute value of the normalized weight. 
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Contribution plots for the model can be displayed from plots or by clicking 
Contribution, in the Analysis group, on the Analyze tab. 

 
For batch level models, it is often useful to display the variation of a variable from 
a selected phase in a contribution plot, as a line plot over time, rather than a 
column plot at every time point. Therefore the Sources of Variation Plot is by 
default displayed when creating the contribution plot from a plot when the BLM 
was created from scores or original data. For more, see the Sources of Variation 
Plot subsection in the Tools tab section in the Plot and list contextual tabs 
chapter. 

Scores/T2 Contribution plot 
To create the score contribution plot using the ribbon, on the Analyze tab, in the 
Analysis group, click Contribution | Scores/T2. The Contribution Scores dialog 
opens: 

 
In the dialog: 

1. Select the ID to display in the box positioned top right. 

2. Select the observation ID of a normal observation, a group of 
observations, or AVERAGE in the From Observation list. When 
selecting AVERAGE, this corresponds to a hypothetical observation 
with all its elements equal to the variable means. 

3. Select the observation ID of the suspect observation or group of suspect 
observations in the To Observation list. 

4. Select the weight parameter in the Weights box. If the point is outside in 
only one dimension, select a single weight. 
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5. Select the dimension of the scores of the outlying observation in the 
Comp 1 box and, if applicable, in the Comp 2 box. 

For details about the Find feature, see the Find feature in workset dialog 
subsection in the Workset section in the Home chapter. 

 

Weights available for Scores/T2 contribution 
The following weights listed in the table are available in the Weights box. 

Note: The absolute values for the weight vector are used. 

Weight Description 

Raw No weights are used. Displays the subtraction of the values in 
one observation minus the other in original units. 

Normalized No weights are used, but displayed in the units of the workset. 

p Using the selected dimension (of the outlying observation), 
the p loadings for that dimension are used as weights. 

pp Using the two selected dimensions (of the outlying 
observation), the corresponding linear combinations of the p 
vectors are used as weights. 

PRange Using all selected dimensions, the corresponding p vectors 
are used as weights. Use this option for Hotelling’s T2Range. 

w* Using the selected dimension (of the outlying observation), 
the w* vector of that dimension is used as weights.  

w*w* Using the two selected dimensions (of the outlying 
observation), the corresponding linear combinations of the w* 
vectors are used as weights. 

CoeffCS The weights are the absolute values of the PLS scaled and 
centered regression coefficients, for the selected y-variable, 
after the selected dimension. 

VIP The weights are the VIP values after the selected component.  
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Weight Description 

W*Range Using all selected dimensions, the corresponding w* vectors 
are used as weights. Select this option for Hotelling’s 
T2Range.  

RX The weights are the square root of the fraction of the Sum of 
Squares (SS) of every term explained by the model, after the 
selected dimension listed as R2VX(cum). PCA only. 

Hotelling's T2Range outlier 
When an observation is an outlier in a Hotelling's T2Range plot, use Contribution 
Scores, select AVERAGE in the From Observation list and the suspect 
observation in the To Observation list. Select the weights PRange for a PC 
model and W*Range for a PLS model. Select the range of the Hotelling’s 
T2Range plot and click OK. 

Note: Group contribution is not available from the Hotelling’s T2Range plot. 

Distance to Model X Contribution plot 
To create the DModX contribution plot using the ribbon, on the Analyze tab, in the 
Analysis group, click Contribution | Distance to Model X. The Contribution 
DModX dialog opens: 

   
In the dialog: 

1. Select the ID to display in the box positioned top right. 

2. Select the observation ID of the observation(s) with a large DModX in the 
list. 

3. Select the weight parameter in the Weights box. 

4. With weight RX, select the number of components to use. Default is to use 
all components of the active model. 
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The Contribution plot displays the scaled residuals of every term in the model, for 
that observation multiplied by the absolute value of the weight parameter. 

 

Weights available for DModX contribution 
The following weights listed in the table are available in the Weights box. 

Note: The absolute values for the weight vector are used. 

Weight Description 

Normalized No weights are used, but displayed in the units of the workset. 

RX The weights are the square root of the fraction of the Sum of 
Squares (SS) of every term explained by the model, after the 
selected dimension listed as R2VX(cum). This is the default. 

Abs(CoeffCS) 

  

The weights are the absolute values of the PLS scaled and 
centered regression coefficients, for the selected y-variable, after 
the selected dimension.  

VIP The weights are the VIP values after the selected component.  
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Distance to Model Y Contribution plot 
Create the DModY contribution plot using the ribbon, on the Analyze tab, in the 
Analysis group, click Contribution | Distance to Model Y. The Contribution 
DModY dialog opens: 

   
In the dialog: 

1. Select the ID to display in the box positioned top right. 

2. Select the observation ID of the observation(s) with a large DModY in the 
list. 

3. Select the weight parameter in the Weights box. 

4. With weight RY, select the number of components to use. Default is to use 
all components of the active model. 

The contribution plot displays the Y scaled residuals for that observation multiplied by 
the absolute value of the weight parameter. 

   
This plot is unavailable for PCA. 
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Weights available for DModY contribution 
The following weights listed in the table are available in the Weights box. 

Note: The absolute values for the weight vector are used. 

Weight  Description  

Normalized No weights are used, but displayed in the units of the workset. 

RY  

  

The weights are the square roots of the fraction of the Sum of 
Squares (SS) of every Y explained by the model, after the selected 
dimension listed as R2VY(cum). This is the default. 

Y Predicted Contribution plot 
Create the YPred contribution plot using the ribbon, on the Analyze tab, in the 
Analysis group, click Contribution | Y Predicted. The YPred Contribution dialog 
opens: 

 
In the dialog: 

1. Select the ID to display in the box positioned top right. 

2. Select the observation ID of a normal observation, group of observations, or 
AVERAGE in the From Observation list. When selecting AVERAGE, this 
corresponds to a hypothetical observation with all its elements equal to the 
variable means. 

3. Select the observation ID of the suspect observation or group of observations 
in the To Observation list. 

4. Select the weight parameter in the Weights box. There is one weight: 
CoeffCSRaw. 

5. Select the y-variable the observation is an outlier for in the Variable box and 
the number of components to use in the Comp 1 box. 
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The Contribution plot displays the differences, in scaled units, for all the terms in the 
model, between the deviating observation and the normal (or average) observation, 
multiplied by the normalized regression coefficient (Centered and Scaled) i.e., divided 
by the length of the coefficient vector (i.e. square root of sum of squares of the 
coefficients for all the terms in the model.) 

   

This plot is unavailable for PCA models. 

Weights available for YPred contribution 
The following weights listed in the table are available in the Weights box. 

Note: The YPred contribution plot can only be created from menu. When 
creating contribution plots from observed vs. predicted plots the displayed 
plot is a Score contribution. 

Weight Description 

CoeffCSRaw 

  

The weights are the values of the scaled and centered regression 
coefficients, for the selected Y variable, after the selected 
dimension.  
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Contribution plot for hierarchical top level models 
In hierarchical top models, the contribution plot refers to the top level variables, 
usually scores of base models. The background is shaded to separate variables 
from the different models. 

For hierarchical top level models the Contribution plot displays the top level 
contributions. Double-click a variable to display the individual underlying variable 
contributions. 

   

Combined Contribution plot for batch level model 
The Combined Contribution plot can be created for batch level models created 
from score variables, by following the steps described: 

1. Open the contribution plot of interest. 

2. Mark the score variables. 

3. On the Marked Items tab, in the Drill down group, click Combined 
Contribution. 
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The plot is resolved to a sorted batch evolution contribution plot displaying 
original variables. 

 

   

Contribution plot from plot 
Contribution plots can be created from plots displaying observations, that is, 
scores, Hotelling’s T2Range, DModX, DModY, and Observed vs. Predicted plots. 

To display a contribution plot not using the menus, use one of the following methods: 

 Select the observations and click the relevant comparison plot in Drill down 
group on the Marked Items tab. 

 Double-click the point or column. 

 Select the observations, right-click the selection, and click Create | 
Contribution Plot. 

Note: Group contribution is not available from the Hotelling’s T2Range plot. 

For more about the Drill down plots, see the Create from selection and Drill down 
section in the Marked Items tab section in the Plot and list contextual tabs chapter. 
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Example of contribution plot directly from plot 

In the example here, observation 208 was double-clicked in the score plot resulting in 
that the contribution plot comparing observation 208 to the average was displayed. 
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Coefficient Y-Related Profiles plot 
When the fitted model is OPLS or O2PLS, the Y-Related Profiles plot can be 
displayed. The Y-Related Profiles are the coefficients rotated so that they display 
the pure profiles of the underlying constituents in X. 

This plot is only available when the number of significant predictive components 
is equal to the number of y-variables. 

 
Y-Related Profiles is available in the Analysis group on the Analyze tab. 

For more, see the OPLS/O2PLS - Orthogonal PLS modeling section in 
Appendix A: Statistics. 
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RMSEcv plot 
RMSECV can be regarded as an intermediary to RMSEE and RMSEP, as it applies to 
the workset (as does RMSEE) but indicates predictive power (as does RMSEP). The 
RMSEE, RMSEP and RMSECV values are listed at the bottom of plots wherever these 
parameters are applicable.  

In the plot, we can see that the 3rd component results in a higher RMSEcv-value, 
which is why the autofit will retain only two components. 

 
The RMSEcv plot is available on the Analyze tab, in the Analysis group.  

 For more about RMSEcv, see the RMSEE, RMSEP and RMSECV  subsection in 
the Appendix A: Statistics chapter. 
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Residual normal probability plot 
The residuals are the difference between fitted and observed values and exist both 
for the X block (residual matrix named E) and the Y block (residual matrix named 
F). 

In the Residuals N-Plot, available in the Analysis group on the Analyze tab, the 
residuals for the Y block are displayed. Consequently the plot is unavailable for 
PCA models. 

For transformed responses, all values are, by default, in the original (back 
transformed) units. To display them in transformed units, select the Transform 
predictions check box in the Predictions page in Model Options or in Project 
Options to apply the change to future models only. 

The residuals displayed in the residuals normal probability plot can be expressed 
as: 

 Raw residuals – The Y-residuals in original units. 

 Standardized residuals – The standardized residuals are the scaled Y-
residuals divided by the residual standard deviation (RSD). This is the 
SIMCA default. 

 
The Y-residuals are plotted on a cumulative normal probability scale. This plot makes 
it easy to detect the following: 

 Normality of the residuals – If the residuals are normally distributed the 
points on the probability plot follow close to a straight line. 

 Outliers – One or more points are below and to the right of the normal line, 
or above and to the left of the normal line, usually greater than + or – 4 
standard deviations. 

To switch to another y-variable use the Y-variable box in the Data group on the 
Tools tab, or use the Properties dialog.  
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Permutation plot 
Use the Permutation plot to check the validity and the degree of overfit for the 
PLS model. 

Open the Permutation Plot dialog by clicking Permutations in the Validate 
group on the Analyze tab.  

 

In the dialog: 

1. Select the y-variable to make the calculations for in the Select Variable 
box. 

2. Enter the number of permutations in the Number of permutations to 
use field. Default is 20. 

3. Select the Recalculate permutations check box in the case where the 
calculations have been done but you want to recalculate. 

 

When clicking OK in the dialog, the order of the y-variable is randomly 
permuted the specified number of times, and separate models are fitted to all the 
permuted y-variables, extracting as many components as was done with the 
original Y matrix. 

The Permutation plot then displays the correlation coefficient between the 
original y-variable and the permuted y-variable on the x-axis versus the 
cumulative R2 and Q2 on the Y-axis, and draws the regression line. The intercept is 
a measure of the overfit. 
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CV-ANOVA 
The CV-ANOVA is a diagnostic tool for assessing the reliability of PLS, OPLS, 
and O2PLS models. 

For more see the CV-ANOVA section in Appendix A: Statistics. 

 

CV Scores plot 
The scatter plot of the cross-validated score vectors is analogous to the scatter plot of 
regular score vectors, but indicates how sensitive a model is to the exclusion of an 
observation of the workset.  

Open the CV Scores plot to display the cross-validated complement to the regular 
scores plot. Investigate the stability of single points as well as groups by displaying the 
two plots side by side. 

Small changes between the regular score plot and the corresponding cross-validated 
score plot, indicates a model that is stable towards the inclusion or exclusion of the 
observations of the workset. 

In the example below, we start with the regular score plot and mark samples in each 
group close to 0, that is, close to being assigned to the wrong class. In the CV Scores 
plot we see that the B5_1 sample is still on the correct side of the 0-line while the 
AWT samples end up on the wrong side. If and when we have samples that cross over 
to the other side, this indicates that their class assignment is uncertain. 
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HCA 
The HCA dendrogram, available in the Clustering group on the Analyze tab, is a tree 
diagram used for showing the clusters generated by hierarchical cluster analysis of the 
data. 

For more about hierarchical cluster analysis, see the Cluster Analysis (CA), 
dendrograms, Hierarchical CA (HCA), PLS section in Appendix A: Statistics. 

 
The heights of the clusters are proportional to the distance between the clusters. That 
is, when the vertical lines are tall the clusters are far apart, and when they are short the 
clusters are close together. 

See also the PLS-Tree section later in this chapter. 

Clustering of observations (matrix rows) 
For the clustering of observations, the HCA can be applied to either a score matrix T 
(recommended) or a data matrix X.  

HCA can be started as follows: 

 Click HCA, in the Clustering group on the Analyze tab, and select the 
desired data series, i.e., the basis for the clustering (specific loadings or 
specific observations). 

 With a score scatter plot (2D or 3D) open, on the Tools tab, in the Change 
Type group, click the Other plot dialog dispatch launcher. This cluster 
analysis is calculated using the vectors displayed in the plot. 

 With a score scatter plot (2D or 3D) open, mark points, right-click and click 
Create | Plot, Dendrogram. This cluster analysis is calculated using the 
vectors displayed in the plot but only the selected items. 
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When clicking HCA the Hierarchical Cluster Analysis dialog opens. 

With, for example, a PCA model with 6 components, the default clustering basis 
consists of the 6 scores, by default added in the Selected list. In the case where the 
active model was not fitted, the original x-variables are by default available in the 
Selected list. 

 
When clicking OK the cluster analysis starts. HCA uses the default similarity criterion 
(Ward) and sorting principle (Size), both changeable in the HCA page in the 
Properties dialog. For more, see the HCA options subsection later in this chapter.  

When the calculations are finished, the resulting dendrogram is displayed. 

 
Clicking on the Select plot items marking tool, and clicking Group Dendrogram 
Clusters displays a horizontal line with which the resolution of the dendrogram is 
specified, and thereby the number of clusters. 

After selecting the position of the horizontal line and clicking once, the dendrogram 
and all open scores and similar plots are colored according to the groupings. For more 
about the marking tool, see the Group Dendrogram Clusters marking tool 
subsection later in this chapter. 
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After marking, classes can be created according to this marking. For more, see the 
Creating class models from plot marking subsection later in this chapter. 

 
The groups found by the HCA and colored in the dendrogram are colored accordingly 
in all open plots displaying observations, and are also listed in the Marked Item 
dockable window, opened by selecting the Marked Items check box on the View tab.  

The marked items list can be copied and pasted to e.g., Excel or Word, either group-
wise or the whole list. See also the Clustering of variables (matrix columns) 
subsection next. 

With the colored dendrogram or the colored score plot active, clicking Create | Class 
Models in the Modify Model group on the Marked Items tab, initiates one model per 
class so that data can be further analyzed. For more, see the Creating class models 
from plot marking subsection in the Plot and list contextual tabs chapter. 
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Clustering of variables (matrix columns) 
For the clustering of variables, the HCA is applied to a loading matrix P 
(recommended) or a data matrix in this domain. The clustering of variables is similar to 
clustering of observations. Details about coloring, marking etc, are not described here, 
see the Clustering of observations (matrix rows) subsection earlier in this chapter. 
See also the PLS-Tree section later in this chapter. 

HCA can be started as follows: 

 Click HCA, in the Clustering group on the Analyze tab, and select the 
desired data series, i.e., the basis for the clustering (specific loadings or 
specific observations). 

 With a loading scatter plot (2D or 3D) open, on the Tools tab, in the Change 
Type group, click the Other plot dialog dispatch launcher. This cluster 
analysis is calculated using the vectors displayed in the plot. 

 With a loading scatter plot (2D or 3D) open, mark points, right-click and 
click Create | Plot, Dendrogram. This cluster analysis is calculated using 
the vectors displayed in the plot but only the selected items. 

When clicking HCA the Hierarchical Cluster Analysis dialog opens. To investigate 
clustering in variables, in the Select data type box select Observations and Loadings 
and add the series. 

   
A PCA-model with 7 components was the active model, results in that the clustering 
basis consists of the 7 loadings. Clicking OK starts the cluster analysis and results in a 
dendrogram. 

   



Analyze 

325 

The groups found by the HCA and colored in the dendrogram are colored accordingly 
in all open plots displaying variables, and are also listed in the Marked Item dockable 
window, opened by selecting the Marked Items check box on the View tab.  

HCA options 
In the Calculator type section the two methods to calculate the distances between 
clusters are available. Ward is by default selected. Select Single linkage by clicking it. 
For more about these methods, see the Cluster Analysis (CA), dendrograms, 
Hierarchical CA (HCA) section in Appendix A: Statistics. 

In the Sort section, the sorting methods Size, Height, and Index are listed. For more 
about the Sort section, see the Clustering algorithm parameters subsection later in 
this chapter. 

To flip the dendrogram, select the Mirror tree check box. 

   
See also the PLS-Tree section later in this chapter. 

Group Dendrogram Clusters marking tool 
The Group Dendrogram Clusters marker tool displays a slider (line) running 
horizontally across the plot enabling the marking of clusters. This slider is moved up 
and down by the mouse. 

Adjusting it to a vertical position corresponds to the selection of as many groups as the 
number of vertical line intersections. This means that by moving the slider up and 
clicking the plot, the data are divided in fewer clusters and by moving it down and 
clicking the plot, the data are divided in more clusters. 

The current clusters are color coded. 

When the Group Dendrogram Clusters is not the selected marker tool, clicking the 
dendrogram plot selects all observations or variables in the clicked branch. 
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Creating a PLS-DA or OPLS-DA model from plot 
marking 
To create a PLS-DA or OPLS-DA model from a dendrogram plot (HCA): 

1. Mark in the dendrogram plot so that the desired groups are displayed in 
different colors. 

2. On the Marked Items tab, in the Modify Model group, click Class | Create 
PLS-DA Model or Create OPLS-DA Model. 

Class | Create PLS-DA Model and Create OPLS-DA Model are available when two 
(or more groups) are marked in a plot displaying observations. 

Creating class models from plot marking 
To create classes from a dendrogram plot (HCA): 

1. Mark in the dendrogram plot so that the desired groups are displayed in 
different colors. 

2. On the Marked Items tab, in the Modify Model group, click Class | Create 
Class Models. 

Class | Create Class Models is available when two (or more) groups are marked in 
any plot displaying observations.  

PLS-Tree 
The PLS-Tree is a hierarchical clustering tool designed to highlight sub-group 
formation in latent variable space. The PLS-Tree is useful for detecting subtle 
clustering occurring in higher dimensional data spaces. 

To read about the background to PLS-Trees and cluster analysis, see the Cluster 
Analysis (CA), dendrograms, Hierarchical CA (HCA), PLS-Trees section in 
Appendix A: Statistics and the HCA section earlier in this chapter.  

Initializing a PLS-Tree 
Before running a PLS-Tree estimation, the user must specify the data in terms of a 
workset: 

 X and Y, 

 observations, 

 transformation, 

 scaling and centering, 

 etc. 

Note: There must be at least one Y-variable and at least one X-variable since 
the models comprising the PLS-Tree are PLS models. 
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PLS-Tree wizard - removing outliers  
With a PLS model active (mark it in the project window), start the PLS-Tree by 
clicking PLS-Tree in the Clustering group on the Analyze tab. Note that the PLS 
model can be unfitted or previously fitted. 

A wizard is started with its first page shown here. This first page allows the user to 
exclude obvious outliers based on scores, DModX, and Hotelling’s T2. 

 

Clustering algorithm parameters 
After clicking Next, the Algorithm Parameters page appears, where the PLS-Tree 
parameters are specified. The default values are chosen to be reasonable in situations 
when knowledge about the given problem is scarce. 

The performance of the PLS-Tree can be influenced by means of two adjustable 
algorithm parameters. These parameters are called A and B and run between 0 and 1 
and regulate how the PLS models are split. 

A sets the balance between the score t1 and the Y. The closer the value for A is to zero, 
the more weight is attributed to the score t1. 

B takes into account the group size of the resulting clusters. The closer the value for B 
is to zero, the less important it becomes to have equal group sizes in the dendrogram. 

This means that a division along t1 is sought that minimizes the within group variation 
and hence maximizes the between group differences in t1 and Y. 
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Other parameters that can be adjusted are: 

 Minimum number of observations in each model - by default 5. This 
number has to be > 4. 

 Maximum depth of the PLS-Tree - by default 4. 

 Number of components in each model - by default Autofit. 

For large datasets the Autofit option takes a long time, and a ‘1’ for single component 
models is recommended. Also, for large datasets the minimum size and the maximum 
depth can be increased from 5 and 4 to, say, 10 and 7, respectively. 

In the Sort section the sorting of the resulting dendrogram can be changed. 

 Size - positions the clusters with the most observations to the right. 

 Height - positions the clusters with highest bar to the right. 

 Index - positions the clusters with the lowest index number to the left. 

To flip the Dendrogram, select the Mirror tree check box. 

PLS-Tree resulting dendrogram 
Clicking Finish in the last page of the PLS-Tree wizard starts the PLS-Tree 
calculations. 

After a while, a tree (dendrogram), an uncolored score plot, and the PLS-Tree model 
window displaying all PLS-Tree models, are opened.  

The Group Dendrogram Clusters marker tool is automatically active when a 
dendrogram is the active plot. Adjusting it to a vertical position corresponds to the 
selection of as many groups as the number of vertical line intersections. In this 
example 5 groups were selected. 

Note: The heights of the clusters are by default proportional to the number of 
observations in the clusters. 



Analyze 

329 

 
After selecting the position of the horizontal line and clicking once, the dendrogram 
and all open scores and similar plots are colored according to the colored groups. For 
more about the marking tool, see the Group Dendrogram Clusters marking tool 
subsection later in this chapter. 

After marking, classes can be created according to this marking. For more, see the 
Creating class models from plot marking subsection later in this chapter. 

The Marked Items dockable window, opened by selecting the Marked Items check 
box in the View tab, displays the members of the colored groups. 

For the interpretation of the individual models, mark them as active (one at a time) and 
investigate in the usual way. 

Group Dendrogram Clusters marking tool 
The Group Dendrogram Clusters marker tool displays a slider (line) running 
horizontally across the plot enabling the marking of clusters. This slider is moved up 
and down by the mouse. 

Adjusting it to a vertical position corresponds to the selection of as many groups as the 
number of vertical line intersections. This means that by moving the slider up and 
clicking the plot, the data are divided in fewer clusters and by moving it down and 
clicking the plot, the data are divided in more clusters. 

The current clusters are color coded. 

When the Group Dendrogram Clusters is not the selected marker tool, clicking the 
dendrogram plot selects all observations or variables in the clicked branch. 
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PLS-Tree model window and partial models 
Any model can be further modified and investigated by making the model active either 
in the project window or – recommended – the PLS Tree model window. 

 
As always, we recommend a score plot, loading plot, and DModX plot for each 
interesting model, augmented by coefficients and VIP. 

Finally, any partial PLS model in a tree can be the starting point for a new tree. Hence, 
a prudent strategy for a large dataset would be to first develop a tree with depth of, say, 
3, then selecting the one or two most promising/interesting models as starting points 
for additional levels (sub-models) of just those branches, etc. In this way the user keeps 
some control of the number of models and branches, and hence avoids the 
incomprehensible mess resulting from letting any clustering loose on a large dataset 
with unrestricted depth of the tree. 
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Predict 

Introduction 
This chapter describes all commands on the Predict tab. 

Use the Predict tab to: 

1. Specify a prediction dataset. 

2. Classify observations with respect to a model and display the result in plots 
and lists. 

3. Predict results for new observations with respect to a model and display the 
result in plots and lists. 

Note: All vectors with the suffix PS are predicted vectors.  

All predictions are made using the active model and current predictionset. When a 
predictionset has not been specified, SIMCA uses the first dataset as predictionset. 

Content 

The commands and groups available on the Predict tab are listed here. 

 Specify Predictionset group: Specify, As Dataset, As Workset, 
Complement Workset (Complement WS Batches for batch projects), 
Class, Delete Predictionset. 

 List group: Prediction List. 

 Plots group: Y PS, Score PS, Hotelling's T2PS, DModX PS, Control 
Charts PS, Contribution PS, Time Series PS. 

 Classification group: Coomans' Plot, Classification List, Misclassification 
Table 
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Specify Predictionset 
In the Specify Predictionset group the following buttons are available: 
Specify, As Dataset, As Workset, Complement Workset, Class, and Delete 
Predictionset. 

 

 

Note: With a lagged variables model, the predictionset must have the same 
sampling interval as the workset used to develop the model. The first 
Maximum lag number of observations is incomplete and should therefore be 
discarded. 

To build a predictionset, by combining observations/batches from different datasets or 
removing observations/batches from the predictionset, click Specify. 

The Specify Predictionset dialog displays the currently selected predictionset. 
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The table lists the functionality of the page and how to use it. 

Functionality Description 

Source list box  Select from which source the observations in the 
Available observations/batches list should originate. 
The available sources are: 

 Datasets – the currently available datasets. 

 Workset complement – the observations/batches 
in the selected datasets not included in the workset 
of the active model, that is, the observations/batches 
not used to fit the model. 

 Class – the observations of the selected class. 
Available with class models and batch models with 
phases. 

 As Workset – the observations in the active model. 

 Predictionset – the currently available 
predictionsets with the current predictionset default 
selected. 

To combine observations from different datasets, click the 
Source box, click the desired dataset, and add the 
observations. Repeat selecting another dataset in the 
Source box. 

Predictionset Name 
field  

Enter the name for the new predictionset in the 
Predictionset Name field.  

Note: Entering/leaving a name of an already existing 
predictionset overwrites that predictionset without warning.  

Available 
observations/batches 
list  

In the Available observations/batches list, all 
observations/batches in the currently selected dataset in 
the Source box are displayed. The number of 
observations/batches, in the selected dataset, is listed. 

To specify the predictionset, select the 
observations/batches and click the => to find them in the 
Included observations/batches list. 

Find feature  The Find feature works as in other dialogs. For details, 
see the relevant parts of the Find feature in workset 
dialog section in the Workset chapter. 

Included 
observations/batches 
list  

In the Included observations/batches list, the 
observations/batches of the current predictionset are 
displayed. If no predictionset was selected, the 
observations/batches in the first dataset are displayed. 

Show Observations 
check box 

In a batch project, the batches are by default displayed. To 
display the underlying observations, select the Show 
Observations check box. 

Remove-buttons  After selecting observations in the Included 
observations/batches list, clicking Remove removes 
them from the predictionset specification. Clicking 
Remove All removes all, independent of selection. 
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As Dataset 
To select an entire dataset as predictionset, click As Dataset and click the dataset 
name. The Prediction List spreadsheet opens displaying the selected dataset with 
predictions using the active model. 

Clicking As Dataset displays a menu with two headers:  

 Dataset where all datasets are listed. 

 Predictionset where all specified predictionsets are listed. If you have not 
specified any predictionsets only the default predictionset is listed here, 
which is the first imported dataset.  

In the predictionset the primary observation IDs/batch IDs are saved. This means that 
if you have two datasets with the same primary observation IDs/batch IDs but different 
variables, predictionsets created from these datasets define the same predictionset.  

Note: The predictionset uses all variables for each included observation/batch 
whichever dataset the observation or batch was selected from.  

As Workset  
To select the observations/batches included in the active model as predictionset, click 
As Workset, . The Prediction List spreadsheet opens displaying the 
observations/batches of the selected model with predictions using the active model. 

Complement Workset 
To select the observations in the selected datasets not included in the workset of the 
active model as predictionset, click Complement Workset. The Prediction List 
spreadsheet opens displaying the observations with predictions using the active model. 

For batch evolution models, the command is named Complement WS Batches.  

For instance, if you have excluded batches from the workset, you can specify them as a 
predictionset by using this menu. 

Class 
To select the observations included in a class as predictionset, click Class, and click 
the class name. The Prediction List spreadsheet opens displaying the observations of 
the selected class with predictions using the active model. 

This command is available for class and phase models. 

Delete Predictionset 
All predictionsets, but the current one, can be deleted.  

Predictionsets hold references to the selected observations or batches. Deleting a 
predictionset thus only removes the references and does not affect the datasets. 



Predict 

335 

Batch predictionset 
For batch projects, only batch evolution datasets, BE DS, are available to select as 
predictionsets, even if the active model is a BLM.  

When specifying a BE DS as predictionset and the active model is a batch level model, 
BLM, the predictionset is automatically rearranged to a batch level predictionset 
behind the scenes. 

For batch evolution models, when the active model is a phase model, the Prediction 
List displays only the batches belonging to that phase. 

The predictionset for the BLM is limited to the batches and observations included in 
the BEM the BLM was created from. This means that to specify batches excluded in 
the BEM as predictionset, you have to mark the BEM and on the Predict tab, in the 
Specify Predictionset group, click Complement WS Batches. Then mark the BLM 
and open the plots on the Predict tab. 

Note: The Specify Predictionset dialog by default displays batches. To view 
the observations in the batches, and exclude observations, select the Show 
Observations check box. 

Predictionset for filtered datasets 
For models built on filtered data, only original datasets are available to select as 
predictionsets.  

When specifying a dataset as predictionset and the active model was built from filtered 
data, the predictionset is automatically filtered in the same way. 

Missing values in the predictionset 
The threshold of missing values is by default 50%. When the number of missing values 
in an observation or a variable exceeds the specified threshold, SIMCA displays a 
warning message. The threshold default can be changed in File | Project Options. 

Prediction List 
To open the Prediction List, click it in the List group on the Predict tab. 

In this list the model membership probability (PModXPS+) and distances to the model 
(DModXPS, DModXPS+) values are colored red when the observation has a 
probability (PModXPS+) value smaller than the limit (default 0.05). 

   
The columns displaying Primary ID, Secondary IDs, Y variables, and X variables are 
always displayed in the Prediction List, along with the default result columns. To 
select to display other columns, right-click the spreadsheet, and then click Properties. 
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Properties in Prediction List 
In the Properties dialog, select the prediction results to display by selecting the 
corresponding check boxes. 

Results for all fit methods 

1. Model membership probability – PModXPS+ 
Displayed for the last component and lists the probability that the 
observation belongs to the model. With a 95% confidence level, observations 
with a probability of membership less than 5% (i.e. less than 0.05) are 
considered to be outliers and not belonging to the model. The PModXPS+, 
DModXPS, and DModXPS+ values are colored red when the observation is 
outside the critical limit. 

2. Distance to model (DModXPS) 
By default SIMCA displays the normalized distance to the model, i.e., 
standard deviation of the residuals divided by the pooled RSD of the model. 
To change, open Project Options or Model Options. The PModXPS+, 
DModXPS, and DModXPS+ values are colored red when the observation is 
outside the critical limit. 

3. Distance to model + (DModXPS+) 
Combination of distance to the model (DModXPS) and the distance of its 
score to the normal score range of the model (when its predicted score is 
outside the model score range). The PModXPS+, DModXPS, and 
DModXPS+ values are colored red when the observation is outside the 
critical limit. 

4. Predicted Scores (tPS) 
The predicted scores, tPS, for all components. 

5. Workset / Testset membership (Set) 
A column labeling the observation as WS, the observation was part of the 
workset, or TS, the observation was not used to fit the model and belongs to 
the test set (predictionset). 

6. Confidence interval of tPS (+ C.I. tPS[1]) 

7. X predicted (XVarPredPS) 
A reconstructed variable as the appropriate part of TP’ from the 
predictionset. 

Results for PLS/OPLS/O2PLS models only 

The results in the columns shown for PLS/OPLS/O2PLS are always back transformed 
to original units independent of whether the Transform predictions and Scale 
predictions check boxes are selected in Model Options. 

1. Y predicted (YPredPS) 
Displays the predicted response value for all responses using the last 
component. 

2. Observed – Predicted (YVarPS – YPredPS) 
Displays the differences between the y-variable in the predictionset and the 
predicted y-variable for all responses. YPredPS using the last component. 

3. Standard error of Y (SerrLPS, SerrUPS) 
Displays the standard errors for the predicted Y values. The standard errors 
are displayed for all responses using the last component. For details about the 
computation, see Appendix A: Statistics. 
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4. Confidence interval of Y (+ C.I. YPredPS) 
Confidence interval computed from all the cross validation rounds and jack-
knifing. These confidence intervals can only be computed for predictionset 
observations, i.e., observations not used to fit the model. 

5. Calculate the variables from predicted tPS 
For hierarchical models the predicted Y derived from the predicted scores. 

 

Y PS plots 
The plots and lists displaying predicted responses are found on the Predict tab, in the 
Plots group, by clicking Y PS. The available plots and lists are: Scatter, Line, 
Column, and List. 

With transformed Y variables, the observed and predicted y-variables are, by default, 
back transformed to original units. To display the plot or list in transformed units, 
select the Transform predictions check box in Model Options and recreate the plot. 

Note: The Y PS plots and lists are only available for PLS, OPLS, and O2PLS 
models and their class models. 

RMSEP 
At the bottom of the plots, RMSEP (Root Mean Square Error of Prediction) is 
displayed. This is the standard deviation of the predicted residuals (errors). It is 
computed as the square root of ((obs-pred)2/N). 
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Y PS Scatter Plot 
To display observed vs. predicted y as a scatter plot, click Y PS | Scatter. 

An example of the plot follows: 

 

Y PS Line Plot 
To display the predictionset variable YVarPS and the predicted variable YPredPS 
versus Num, click Y PS | Line. 

An example of the plot follows: 

 



Predict 

339 

Y PS Column Plot 
To display Y Predicted as a column plot with confidence intervals, click Y PS | 
Column. 

The plot is displayed with jack-knife uncertainty bars. These limits can be modified in 
the Properties dialog. For more, see the Limits subsection in the Plot and list 
contextual tabs chapter. 

 

Y Predicted List 
The Y Predicted List displays for each y-variable: 

Vector Description 

YVarPS Measured or observed Y if present. 

YPredPS Predicted Y. 

   

Note: For discriminant models the Y Predicted List is identical to the 
Classification List. 
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Score PS plots 
There are four types of predicted score plots available by clicking Score PS: Scatter, 
Line, Column, and 3D. 

These plots and dialogs are very similar to those of the score plots found on the Home 
tab. For details about the dialog, see the Scores section in the Home chapter. An 
example of each plot type follows here. 

Predicted Score Scatter Plot 
To open the scatter plot displaying predicted scores, tPS, click Score PS | Scatter. 

 

Predicted Score Line Plot 
To open the line plot displaying predicted scores, tPS, click Score PS | Line. 
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Predicted Score Column Plot 
To open the column plot displaying predicted scores, tPS, click Score PS | Column. 

The plot is displayed with jack-knife uncertainty bars. These limits can be modified in 
the Properties dialog. For more, see the Limits subsection in Tools tab section the 
Plot and list contextual tabs chapter. 

 

Predicted Score 3D Plot 
To open the 3D scatter plot displaying predicted scores, tPS, click Score PS | 3D. 

   
For how to mark, zoom, rotate, move the plot in its window, color and size the 3D plot, 
see the 3D Score Scatter Plot section in the Home chapter. 
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Hotelling’s T2Range plot 
Predicted Hotelling's T2Range can be displayed in two plot types available by clicking 
Hotelling's T2PS | Line and Column. 

 
The Hotelling's T2Range plot displays the distance from the origin in the model plane 
(score space) for each selected observation. The plot shows the T2 calculated for the 
range of selected components, e.g., 1 to 7, or 3 to 6. 

Default is to display from the first to the last component. For OPLS and O2PLS the 
range is locked to from first predictive to last orthogonal in X component. 

To change the range of components, right-click the plot and select Properties, tab 
Component. 

Values larger than the green limit are suspect (95%), and values larger than the red 
limit (99%) can be considered serious outliers. 

See also the Hotelling’s T2Range section in the Home chapter.  

DModX PS 
Distance to Model is an estimate of how far from the model plane, in the X or Y 
space, the observation is positioned. 

The distance to the model can be displayed in absolute and normalized units. By 
default the distance to model plots are displayed in normalized units after the last 
component. 

Use Model Options or Project Options, to change units of the DMod plot.  

For details about the calculations of DModXPS, DModXPS+, DModYPS and D-Crit, 
see the Distance to the model section in Appendix A: Statistics. 
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DModX PS - Distance to Model X-Block 
To display the DModX for the predictionset, click DModX PS and under the DModX 
header click Line or Column.  

The plot by default displays DModXPS+ after the selected component with limit at 
significance level 0.05. 

To switch to the regular DModXPS, open the Properties dialog, click the DMod tab, 
and click Regular. 

 
DModXPS+, displayed in this plot, is a combination of the regular DModXPS and the 
distance to normal score range. For details, see the Distance to the model of new 
observations in the predictionset subsection in Appendix A: Statistics. 

DModY PS - Distance to Model Y-Block 
To display the DModY for the predictionset, click DModX PS, and under the DModY 
header click Line or Column.  

The plot displays DModYPS after the selected component. 
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Control Charts PS 
With a fitted model, the predicted scores, x and y-variables and their residuals can be 
displayed in control charts available by clicking Control Charts PS. 

 
To display a control chart: 

1. Select: 

a. The data source in the Data box. 

b. The vector to display in the Item box. tPS, XVarPS, XVarResPS, 
YVarPS, and YVarResPS are available. 

c. Variable and/or component in the Variable or Comp boxes when 
appropriate. 

2. In the Type of Control Chart box, select Shewhart, EWMA, CUSUM, or 
EWMA/Shewhart. 

3. Depending on the selected control chart, select the properties as desired. 

4. Clicking OK opens the control chart with limits computed from the workset. 

For details, see the Control charts section in the Plot/List chapter. 
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Contribution PS 
Contribution plots are used to understand why an observation differs from the others in 
an X score (t), in DModX, in DModY, in Hotelling's T2Range, or in the observed vs. 
predicted Y plot. 

The contribution plot displays the differences, in scaled units, for all the terms in 
the model, between the outlying observation and the normal (or average) 
observation, multiplied by the (absolute) value of the normalized weight. 

Contribution plots for the predictionset can be displayed from plots or by clicking 
Contributions PS. 

 
For BLM with one or more variables created from scores or original variables in 
the BEM, it is useful to display the variation of a variable from a selected phase in 
a contribution plot, as a line plot over time, rather than a column plot at every time 
point. For this purpose the Sources of Variation Plot is by default displayed 
when creating the contribution plot from a plot. For more, see the Sources of 
Variation Plot subsection in the Batch chapter. 

Scores/T2  
To create the score contribution plot for the predictionset using the buttons, click 
Contribution PS | Scores/T2. 

The Contribution Scores dialog that opens is identical to the one opened by 
clicking Contribution | Scores/T2 in the Analysis group on the Analyze tab. For 
more about this dialog and the available weights, see the Scores/T2 contribution 
plot section in the Analyze chapter.  
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Distance to Model X-Block Contribution plot 
To create the DModX contribution plot for the predictionset using the menus, 
click Contribution PS | Distance to Model X-Block. 

The Contribution DModX dialog that opens is identical to the one opened by 
clicking Contribution | Distance to Model X Block in the Analysis group on the 
Analyze tab. For more about this dialog and the available weights, see the 
Distance to Model X Block contribution plot section in the Analyze chapter. 

 

Distance to Model Y-Block Contribution plot 
With a PLS model, create the DModY contribution plot for the predictionset using 
the menus by clicking Contribution PS | Distance to Model Y-Block. 

The Contribution DModY dialog that opens is identical to the one opened by 
clicking Contribution | Distance to Model Y Block in the Analysis group on the 
Analyze tab. For more about this dialog and the available weights, see the 
Distance to Model Y Block contribution plot section in the Analyze chapter. 
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Y Predicted Contribution plot 
With a PLS model, create the YPred contribution plot using the menus by clicking 
Contribution PS | Y Predicted. 

The YPred Contribution dialog that opens is identical to the one opened by 
clicking Contribution | Y Predicted in the Analysis group on the Analyze tab. 
For more about this dialog and the available weights, see the Y Predicted 
contribution plot section in the Analyze chapter. 
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Contribution plot from plot 
Contribution plots can be created from plots displaying observations, that is, 
scores, Hotelling’s T2Range, DModX, DModY, and Observed vs. Predicted plots. 

To display a contribution plot not using the menus, use one of the following methods: 

 Select the observations and click the relevant comparison plot in Drill down 
group on the Marked Items tab. 

 Double-click the point or column. 

 Select the observations, right-click the selection, and click Create | 
Contribution Plot. 

Note: Group contribution is not available from the Hotelling’s T2Range plot. 

For more about the Drill down plots, see the Create from selection and Drill down 
section in the Marked Items tab section in the Plot and list contextual tabs chapter. 

Example of contribution plot directly from plot 

In the example here, observation 208 was double-clicked in the score plot resulting in 
that the contribution plot comparing observation 208 to the average was displayed. 
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Time Series PS 
The Time Series PS plots, display selected prediction vectors as series on the Y-axis 
and Num on the X-axis. The differences versus using the Plot/List | Line Plot is that 
Num, or Date/Time when available, is always plotted on the X-axis and the vectors 
available in the Item box are the prediction vectors only. 

To open a time series plot, click Time Series PS in the Plots group on the Predict tab 
(or Time Series in the Control Charts group on the Plot/List tab). 

In the Time Series Plot dialog, select the vectors to plot in the Item box and click the 
Add Series-button. 

To display all vectors scaled to range 0 – 1, select the Scale 0-1 check box. 

 

Time Series plot example 
The plot here displays the observed y-variable in the predictionset, YVarPS, and the 
predicted y-variable, YPredPS. 
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Coomans' Plot 
Use Coomans' plot to classify new observations with respect to two selected models. 

For each observation in the predictionset, the distance to each of the selected models is 
computed and plotted along with the selected models’ critical distances. 

To display Coomans' Plot: 

1. Specify the predictionset. 

2. On the Predict tab, in the Classification group, click Coomans' plot. 

3. In the Coomans' Plot dialog, select the two models to plot the DModXPS+ 
for. 

4. Optionally click the Color tab and select to color by classes. 

5. Click OK. 

 
In the Limits page you can select to hide the critical lines. In the DMod page you can 
select to display regular DMod. The other tabs are general and described in detail in 
the Properties dialog section in the Plot and list contextual tabs chapter. 
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Classification List for class models 
With class models you can automatically classify a predictionset with respect to all the 
class models by: 

1. clicking Classification List in the Classification group on the Predict tab,  

2. selecting the desired models, and clicking OK. 

 
The Classification List displays the observations of the predictionset as rows, and the 
class models probability of membership, PModXPS+, as columns. The model title in 
the second row identifies the class. 

Note: By default the primary observation ID is displayed. To display all 
observation IDs, on the Tools tab, in the Properties group, click Labels. For 
more see the Label Types for lists subsection in the Tools tab section in the 
Plot and list contextual tabs chapter.  

Coloring in the Classification List 
The values displayed in the Classification List are probabilities. 

The observations are colored such that probabilities: 

 > 0.10 are green (inside 90% confidence of the normal probability curve). 

 between 0.10 and 0.05 are orange (inside 95% confidence). 

 < 0.05 are white and the observation is deemed to be outside the class 
(outside 95% confidence). 
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Classification List for Discriminant Analysis models 
The Classification List for discriminant analysis models provides the predicted Y 
value for the dummy variables (0 or 1) used to direct the projection. 

The Classification List displays the observations of the predictionset as rows, and the 
original dummy variable in YVarPS and predicted dummy variable in YPredPS, as 
columns. 

Note: By default all observation IDs are displayed. To different IDs, on the 
Tools tab, in the Properties group, click Labels. For more see the Label 
Types for lists subsection in the Tools tab section in the Plot and list 
contextual tabs chapter.  

Coloring in the Classification List 
The values displayed in the Classification List for discriminant analysis models are 
the predictionset original values and predicted values. 

The observations are colored such that predicted values: 

 < 0.35 are white (do not belong to the class). 

 between 0.35 and 0.65 are orange (borderline). 

 above 0.65 are green (belong to the class). 

 
Membership of a class depends upon matching the value of the dummy variable, so a 
value close to one indicates membership of the workset class. In practice 0.5 is often 
used as a practical threshold in order to classify an observation as belonging to one 
class or another. 

Misclassification Table 
The Misclassification Table is available for all class models and discriminant analysis 
models. 

The Misclassification Table shows the proportion of correctly classified observations 
in the predictionset.  

If the class information is not available in the dataset that the predictionset was created 
from, the class information has to be defined. This is achieved by: 

 Using the Dataset Properties dialog, Observations page. See the 
Observations page subsection in Dataset Summary section in the Data 
chapter. 

 Specifying a Class ID while importing the file. See Class ID specification 
subsection in the Home tab section in the SIMCA import chapter. 



Predict 

353 

Misclassification Table for class models 
The Misclassification Table is available for all class models. 

With specified classes, the Misclassification Table summarizes how well the selected 
models classify the observations into the known classes. By default the Assign each 
observation only to the nearest class option is used (see the Properties dialog 
described in the Misclassification Table Properties subsection later in this section). 

   
The Misclassification Table is organized as follows: 

Column Content 

First column The class names, No class, Total, and Fishers probability.  

The Total row displays: the total number of observations in the 
predictionset, the average percentage correctly classified, and 
the number of observations classified to each class. 

Fishers probability is the probability of the table occurring by 
chance and is satisfied when p < 0.05 for 95% confidence. For 
more, see the Fisher's Exact test subsection in Appendix A: 
Statistics. 

Fishers probability is displayed when Assign each observation 
only to the nearest class is the selected option in Properties. 

Members The number of observations assigned to each class in the 
selected predictionset. At the bottom of the list Fisher's 
probability value is listed. 

Correct The percentage correctly classified for each class and at the 
bottom the average percentage. 

Individual 
classes 

The number of observations classified as belonging to the class 
on that row. 

The correct classifications are colored green while the incorrect 
are colored yellow. 

No class 
(PModX+<'limit') 

The observations that are not classified to any one of the 
available classes. 

Combined 
classes 

The observations that overlap between classes.    

When Assign all observations to classes above the limit is 
selected, all combinations of classes are displayed with number 
of overlapping observations. 

Note: All entries on the diagonal are observations that have been correctly 
classified. 



User Guide to SIMCA 

354 

In the above table, we can see that all the observations but 6 observations were 
correctly classified, one belonging to Ver was classified as Vir, and 5 belonging to Vir 
were classified as Ver. The reason for this is the closeness of the two classes, 
illustrated in the score plot here. 

 

Misclassification Table - Discriminant Analysis models 
The Misclassification Table is available for all discriminant analysis models. 

By default the observations are assigned to the nearest class only, using no threshold. 

To see the options available, see the Misclassification Table Properties subsection 
later in this section. 

   
For a description of the content of the table, see the Misclassification Table for class 
models subsection earlier in this section. 

Misclassification Table Properties 
The Misclassification Table Properties dialog contains options to change the way of 
classifying the observations. 

Use the Properties dialog to: 

 Select models in the Model(s) box. 

 Select how to classify the observations and probability level according to the 
method below. 
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Method for assigning observations 
Select whether to assign each observation: 

1. Only to the nearest class, with an optional PModX cut-off by clicking Assign 
each observation only to the nearest class. 

2. To all classes if they exceed the probability limit listed by clicking Assign 
observations to all classes above the limit. When there are overlapping 
classes, or classes close to each other, this may result in that observations are 
assigned to several classes. 

In the Do not assign observations with PModX below 'limit' to any class field, 
optionally enter the probability limit to use. 

A possible reason for entering a probability limit is in cases of unequally sized groups 
where the discriminating threshold may not be in the center of the projection. 

The default values in this field are: 

 '0' for Assign each observation only to the nearest class always. 

 '0.1' for Assign observations to all classes above the limit, when the 
models are class models 

 '0.65' for Assign observations to all classes above the limit, when the 
model is a DA-model. Another common value is '0.5'. 

Note: The fields remember the last entered value. 

 





 

357 

Plot/List 

Introduction 
This chapter describes the Plot/List tab features. 

The Plot/List tab allows plotting and listing input data such as observations and 
variable values, computed elements such as scaling weights, variable variances, etc, as 
well as results such as loadings, scores, predictions, etc, of all the fitted models. 

The plot types available on the Plot/List tab are:  

 The Standard Plots and list: Scatter, Scatter 3D, Line, Column, and List. 

 The Control Charts: Time Series and Control Charts.  

 The Custom plots: Histogram, Normal Probability, Response Contour, 
Response Surface, Wavelet Structure, Wavelet Power Spectrum and 
Step Response Plot. 

The plot types in the Standard Plots group are not described in this user guide, but the 
dialog interface is described in this chapter. 

Content 

This chapter describes the following plots Control Charts, Response Contour, 
Response Surface, Wavelet Structure, Wavelet Power Spectrum, and the Step 
Response Plot. 

   

Note: Using the Change Type group on the Tools tab, plots can be created 
from plots and lists, and lists can be created from plots and lists. 

Name conventions 
Some vectors have letters appended to them at the end of the item (vector) name. 
These indicate the source of the data, e.g. intermediate model results from cross 
validation rounds, statistics computed from all the cross validation rounds, or other 
information about the presented vector. 

Note: Vectors containing Y are available for PLS, OPLS, and O2PLS models 
but unavailable for PCA models. 
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See the table for the added endings and their description. 

Ending Description 

DS Any DataSet. Variables or observations in datasets are always the 
original raw variables with no role definition, or treatment. To access 
them, select the appropriate dataset in the Data box in the Plot/List 
dialog. 

PS The current PredictionSet. There is only one current predictionset at 
any time. Variables or observations in predictionsets are always the 
original raw variables with no role definition, or treatment. 

All items with the two letters PS are available when selecting a model in 
the Data box. All items without the two source letters are part of the 
selected model i.e., they pertain to variables or observations in the 
workset associated with the model. 

To plot or list variables from the predictionset directly, select the 
predictionset as data source in the Data box. 

cv Intermediate results such as scores, loadings, PLS weights, predicted 
values, etc., computed from a selected cross validation round. 

cvSE Jack-knife standard error computed for model results from all the cross 
validation rounds. 

St The vector is in standardized units, i.e. divided by its standard 
deviation. 

(trans) The vector is in transformed units according to the workset 
specification. 

(as WS) The vector is displayed in the same units as the workset, WS. This 
means that a variable scaled to unit variance in the workset is displayed 
in scaled and centered units, while a transformed variable is displayed 
in the transformed metric, scaled and centered. 

Cum The vector is cumulative over all components up to the listed one. 

Note: There are a number of vectors that are cumulative without 
displaying this ending. 

OOCSum The vector is an Out Of Control summary vector. 

Standard plot types and list dialog 
The standard plot types available on the Plot/List tab are Scatter, Scatter 3D, Line, 
Column, and List. 

A selection of the following pages is available in different Plot/List dialogs: Data 
Series, Label Types, Item Selection, Color, Transformation, Size, Limits, and 
Number Format. The Data Series and Transformation pages are described in the 
subsections that follow as they are unique for the Plot/List dialogs.  

For more about the other pages, see the Properties dialog subsection in Tools tab 
section in the Plot and list contextual tabs chapter. 
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Data Series page 
In the Data Series page the vectors (series) to be displayed in the selected plot or list 
can be selected. To make the vector available in the Item box, the appropriate data 
type and data source have to be selected. Some vectors require selecting a variable, 
component(s), or CV group and some can be displayed in transformed and scaled units. 

The list of currently added series is displayed in the Selected list. To remove series 
from the list, select them and click the Remove button, or click the Remove All 
button. 

By selecting the Scale 0-1 check box all series are scaled so that the maximum value is 
1 and minimum is 0. 

 

Note: When the dataset contains numerical IDs, they can be selected and 
plotted on any axis. 

Select data type 
Before selecting the data series for plotting, the appropriate data type has to be selected 
from the Select data type box. 

The available data types are: 

 Variables and Scores – vectors with one element per observation. 

 Observations and Loadings – vectors with one element per variable. 

 Function of component, F(Component) – vectors that apply per component. 

 Function of Lags, F(Lags) – vectors specific to a lagged model, such as 
pLag. 

 Aligned Vectors – aligned vectors available in batch control charts for batch 
evolution models. 

 Batch Vectors – Out Of Control (OOC) variables for the aligned vectors for 
batch evolution models. 
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Data source 
By default the active model is the selected data source. For computed elements such as 
scaled variable values, variable variances, model results, or intermediate results from 
cross validation, the data source can only be a fitted model, not a dataset. 

The data sources available in the Data box are: 

1. DS1 – dataset first imported. 

2. DS2, DS3 etc. – other datasets. 

3. PS – current predictionset. 

4. M1, M2 etc. – fitted models. 

To access items specific to another data source than the default, select the data source 
in the Data box. 

For instance, for datasets preprocessed using Orthogonal Signal Correction (OSC), the 
OSC scores and loadings are available after selecting the OSCed dataset in the Data 
box. 

Item 
In the Plot/List tab dialogs, all items from the selected data type and source are 
available in the Item box. 

Some vectors require selecting: 

 Variable from the Variable box. 

 Dimension from the Component box for some model results. 

 Cross validation round from the CV box for intermediate results from cross 
validation. 

Some items, such as DModX, are available for component 0, which correspond to 
scaled and centered data as specified in the workset (WS). 

For Hotelling's T2Range specifying the starting and ending components is required. 

Note: Vectors containing Y are available for PLS, OPLS, and O2PLS models 
but unavailable for PCA models. 

For a description of all vectors available for the Plot/List tab plot types, see the 
Vectors available in SIMCA section in Appendix A: Statistics. 

Scale and Transform 
When there are transformed variables in the model, many vectors can be displayed in 
the transformed metric. These same vectors can always be displayed scaled as the 
workset. Examples of such vectors are XVar and XVarRes. 

 Select the Transform check box, before clicking Add Series, to display the 
vector in the transformed metric. Or after adding the vector, in the Selected 
list, select Yes in the Transform column on the row of the vector. 

 Select the Scale check box before clicking Add Series, to display the vector 
in the metric of the workset. Or after adding the vector, in the Selected list, 
select Yes in the Scale column on the row of the vector. 
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For example, with Scale selected, a variable scaled to unit variance in the workset is 
displayed in scaled and centered units. If the variable was transformed, it is displayed 
in the transformed metric, scaled and centered. Hence, when selecting the Scale check 
box, the Transform check box is automatically selected. 

 

Note: When both the Scale and Transform boxes are cleared, the added 
vector is displayed in original (back-transformed) units. 

Scaling and Offset 
Specifying a Scaling value or Offset value is useful with Line and Time Series Plots 
when the selected vectors need to be visually separated. 

   

After adding the series, enter values in the Scaling and/or Offset columns in the 
Selected list. 

Transformation 
On the Transformation page the following data transformations are available: 

 Auto Correlation 

 Cross Correlation 

 Power Spectrum 

 Wavelet Coefficients 

 EWMA 

 Histogram 

 Normalize 

 R2X 
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Auto or cross correlation of variables or observations 
The auto and cross correlation are measures of dependence of adjacent observations 
and characterizes a time series or observation profile, in the time domain. 

For technical details, see the Auto and cross correlation of variables or observations 
section in Appendix B: Preprocessing. 

Spectral filtered wavelet data 

With a dataset that has been wavelet transformed and compressed variable wise (using 
Spectral Filters on the Data tab), the auto/cross correlation observation wise refers to 
the reconstructed observations, when the Reconstruct wavelets check box is selected. 

To display the auto/cross correlation in the wavelet domain clear the Reconstruct 
wavelets check box found in Project Options on the File tab. 

Applying Auto Correlation 

To apply auto correlation to a variable or observation: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select Auto Correlation in the Select transformation box. 

4. In the Detrend box the default is Mean. Select 

a. Linear to remove the best linear fit, or 

b. None to do nothing, or 

c. leave Mean to remove the mean. 

5. To change maximum lagging, type a new value in the Max Lag field. The 
auto correlation is default max lag L=30 or N/4, whichever is smaller, and 
can be displayed up to L=N. 
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Applying Cross Correlation 

To apply cross correlation to a variable or observation: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select Cross Correlation in the Select transformation box. 

4. Select the common vector to use cross correlation with by selecting data 
source in the Data box, vector in the Item box, and if applicable, variable in 
the Variable box, component in the Comp box, and cross validation group 
in the CV box. 

5. In the Detrend box the default is Mean. Select 

a. Linear to remove the best linear fit, or 

b. None to do nothing, or 

c. leave Mean to remove the mean. 

6. To change maximum lagging, type a new value in the Max Lag field. The 
auto correlation is default max lag L=30 or N/4, whichever is smaller, and 
can be displayed up to L=N. The plot displays the cross correlation for –L to 
+L. 
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Power Spectrum Density of variables or observations 
The power spectrum density (PSD) is the representation of the sequence x (t) in the 
frequency domain. The power spectrum is the square of the amplitude of the Fourier 
component at each frequency. 

The frequency domain representation is particularly helpful to detect irregular cycles 
and pseudo periodic behavior, i.e. tendency towards cyclic movements centered on a 
particular frequency. 

SIMCA uses the Welsch’s non-parametric method to estimate the PSD. 

For more information see the Power Spectrum Density section in Appendix B: 
Preprocessing. 

Spectral filtered wavelet data 

With a dataset that has been wavelet transformed and compressed variable wise (using 
Spectral Filters on the Data tab), the PSD observation wise refers to the reconstructed 
observations, when the Reconstruct wavelets check box is selected. 

To display the PSD in the wavelet domain, clear the Reconstruct wavelets check box 
found in Project Options on the File tab. 

Applying Power Spectrum 

To apply the Power Spectrum to an observation or a variable, either use the Plot/List 
dialog described here, or use the Quick Info: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select Power Spectrum in the Select transformation box. 

Change the options as warranted and click OK to create the plot. For more about these 
options see the Power Spectrum Options tab subsection in the Quick Info section in 
the View chapter. 

 



Plot/List 

365 

Wavelet Coefficients 
The wavelet transform of a signal X(t) is the representation of the signal in both the 
time and frequency domain. It is the scalar product between the signal x(t) and a 
mother wavelet function, stretched or compressed to create different scales (inverse of 
frequency), changing the window width. 

Because of the repeated re-scaling, the variable or observation is decomposed into its 
details at every scale; these are the wavelet transform coefficients. 

SIMCA uses the Discrete Wavelet transform, with orthogonal or biorthogonal wavelets 
and the fast Multi Resolution Analysis algorithm of S. Mallat. 

Select the variables or observations you want to wavelet transform and the range of 
observations or variables to include. 

Applying Wavelet Coefficients 

To apply the wavelet coefficients to an observation or a variable, either use the 
Plot/List dialog described here, or Spectral Filters in the Filter group on the Data 
tab: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select Wavelet Coefficients in the Select transformation box. 

4. Change from the default detrending, wavelet function, and wavelet order if 
warranted. For more details about these options, see Wavelet 
transformations section in Appendix B: Preprocessing. 
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EWMA 
The EWMA transformation can be used to smooth scores or variables in plots. 

As an example the following line score plot of t1 vs. t2 was transformed by EWMA 
and selecting subgroup 10. 

 

   
The EWMA transformed plot is easier to interpret. 
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Applying the EWMA transformation 

To apply the EWMA to an observation or a variable: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select EWMA in the Select transformation box. 

4. Enter the sample size in the Sample Size field. 

5. Select User Entered in the Lambda box and enter a value in the field, or 
leave Estimated. 

6. Select User Entered in the Target box and enter a value in the field, or 
leave Estimated. 

7. Select User Entered in the Standard Dev. box and enter a value in the field, 
or leave Estimated. 

8. Click OK. 

Histogram 
To transform an observation or a variable to a histogram: 

1. Select the desired vector on the Data Series page. 

2. Click the Transformation tab. 

3. Select Histogram in the Select transformation box. Click OK. 

Note: Histogram is available in the Transformation page when only one 
series was added. 

Histograms can also be created by clicking Histogram in the Custom Plots group on 
the Plot/List tab. 

Normalize in Transformation page 
OPLS and O2PLS loading plots are by default normalized to unit length (Normalize to 
unit length check box is selected in Properties). When creating loading plots on 
Plot/List tab, the Transformation page must be used.   

The Normalize transformation is only available for the vectors p, po, q, qo, so, and r 
when the model type is OPLS and O2PLS.  

The normalization will make the sum of squared vector elements equal to 1. One 
advantage with this is that the loading line plots of spectral data are much easier to 
interpret. Normalize transformed loading plots should be used in conjunction with R2X 
transformed score plots. 

R2X in Transformation page 
OPLS and O2PLS score plots are by default scaled proportionally to R2X (Scale 
proportionally to R2X check box is selected in Properties). When creating score 
plots on Plot/List tab, the Transformation page must be used.   

The R2X transformation is only available for the vectors t, to, u, uo, tPS and toPS 
when the model type is OPLS and O2PLS.  

The R2X transformation will make distances in the score plot correspond with the 
explained variation (R2X). R2X transformed score plots should be used in conjunction 
with normalized loading plots. 
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Control Charts 
Control Charts are available on the Predict and Plot/List tabs. 

The control charts from the Predict tab, will only display items from the predictionset. 
Opening the control chart from the Plot/List tab includes both the predictionset and 
workset vectors (items). 

The Control Chart group on the Plot/List tab holds both the Control Chart and the 
Time Series buttons whilst this section only documents the Control Chart. For more 
about the Time Series plot, see the Time Series PS section in the Predict chapter. 

What is a control chart? 
Control charts, also called statistical process control charts, constitute one of the major 
tools of “Total Quality Management”. They enable displaying the data measured on the 
process (or product) over time, and thereby detect process upsets, shifts, trends, etc., 
thus helping to improve the quality of the products. 

However, processes generate collinear multivariate data. Therefore, monitoring and 
charting each variable as if it is independent from the others (univariate control charts) 
may be highly misleading, and may actually lead to the degradation of the product 
quality. Multivariate control charts use all the process variables simultaneously, and 
also extract the information contained in their correlation structure. This allows 
tracking of the process over time, identify process points and regions where the process 
is operating normally, as well as when the process starts to go out of control. 

Because the scores (T and U) are linear combinations of the original variables, they are 
close to normally distributed as long as the process is stable. The scores are also much 
less noisy than the original variables since they have the characteristics of weighted 
averages. Hence, multivariate control charts are more reliable than univariate charts, 
and in addition much more informative. 

Multivariate control charts 
Multivariate control charts are model dependent, because the combination of all the 
variables to summaries are made via a multivariate model, here PCA, PLS, OPLS or 
O2PLS. 

PC models 

With a principal components (PC) model, the scores (T) are the best summary of all 
the process variables. Using the score values of one model dimension (t1, t2, etc.) as 
the control chart variable, yields a multivariate control chart based on all the process 
variables. The chart shows the position of the process along the direction of the 
specified model dimension. This chart can be used to track and follow the process as 
summarized by that dimension. 

PLS models 

With a PLS model, the X-scores (T) provide the best summary of the process variables 
that dominate the product qualities, and the Y-scores (U) provide the best summary of 
the product quality. Control charting the t-vectors or the u-vectors allows tracking the 
process using all the data. 
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OPLS and O2PLS models 

For OPLS and O2PLS models, the X-scores (T) provide the best summary of the 
process variables that dominate the product qualities, and the Y-scores (U) provide the 
best summary of the product quality. Control charting the t-vectors or the u-vectors 
allows tracking the process using all the data. 

In addition, the charting of To and Uo open up for analysis of the orthogonal 
information. 

Univariate control charts 
Univariate control charts are model independent, and can be plotted for a specified 
dataset. 

To display a univariate control chart with some observations excluded: create an 
appropriate model. Control charting a variable from the model displays only the 
observations of that model's workset. 

Note: To look at special details of a variable, create control charts of an 
individual variable. 

Control Chart dialog 
To open the Control Chart dialog, click Control Chart PS in the Plots group on the 
Predict tab or Control Chart in the Control Charts group on the Plot/List tab. 

 

Types of control charts 
There are four types of control charts available in the Type of Control Chart box: 
Shewhart, EWMA, CUSUM, and EWMA/Shewhart. 
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Selecting the vector to display in control chart 
To select the vector (item) to display in the control chart: 

Step Description Action Screen shot 

1 

 

In the Data box, the available 
data sources are listed. The 
data sources are the models 
(Mxx), datasets (DS1, DS2, 
etc) and the current 
predictionset (PS). 

Select the 
data source 
in the Data 
list box. 

 

2 In the Item box, the available 
items are listed: t, tPS, u, 
XVar, XVarPS, XVarRes, 
XVarResPS, YVar, YVarPS, 
YVarRes, and YVarResPS. 

Select the 
vector in the 
Item box. 

 

3 For univariate control charts 
the variables are listed in the 
Variable/X Terms/Y Terms 
box. For the X terms the 
expanded terms are also 
listed. 

Select the 
variable in 
the 
Variable/X 
Terms/Y 
Terms box. 

 

4 In the Comp box, the 
components for the selected 
vector are listed when the 
vector is a score or residual 
vector. 

Select the 
component 
to display the 
vector for in 
the Comp 
box.  

Note: To display multivariate control charts of t or u, and for items from the 
predictionset, you must select a model in the Data box. 



Plot/List 

371 

Shewhart 
Three types of Shewhart charts are available in SIMCA: 

 Individual (default) – where the sample size is 1. 

 Mean/Range – where the default sample size is 5 and can be changed as 
desired. 

 Mean/StdDev – where the default sample size is 5 and can be changed as 
desired. 

 

Individual 

To create the Shewhart control chart without subgroups: 

1. Click Control Chart. 

2. Select Shewhart in the Type of Control Chart box. 

3. Leave Individual (the default) selected in the Shewhart Type box, and then 
click OK. 

The resulting plot displays the Shewhart control chart with values for each 
observation of the selected vector, with the 2 and 3 sigma limits displayed. 

When plotting t or tPS, a plot of DModX or DModXPS is displayed beneath, with its 
critical distance. Observations outside the critical distance indicate process behavior 
different from the model. 

   

The plot footer displays: S(Mxx), S(UE) when defined, Target(Mxx) or Target(UE) 
when defined, R2X[a], 1 – R2X(cum)[last component] and Mxx – D-Crit[last 
component]. 
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To view the nomenclature and calculations of target and standard deviation, see the 
Nomenclature and notation and Target and Standard deviation subsections in 
Appendix A: Statistics. 

Mean/Range 

To create the Shewhart control chart of type Mean/Range: 

1. Click Control Chart. 

2. Select Shewhart in the Type of Control Chart box 

3. Select Mean/Range in the Shewhart Type box. 

4. Enter the desired sample size in the Sample size field (default 5), and then 
click OK. 

The resulting plot displays the control charts for the selected vector, with the target and 
upper and lower limits displayed. 

 
The plot footer displays: Target(Mxx) or Target(UE) when defined, LCL(x), 
UCL(x), S(Mxx), S(RAvg) or S(UE) when defined, RAvg(within, Mxx or S(UE) 
when defined), LCL(r) and UCL(r). 

To view the nomenclature and calculations of target and standard deviation, see the 
Nomenclature and notation and Target and Standard deviation subsections in 
Appendix A: Statistics. 
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Control limits and process range 

Control limits and estimates of the process range in the Shewhart Mean/Range 
control chart are computed as follows: 

 S(RAvg) = RAvg /d2, estimate of process standard deviation. 

 LCLx = Target - A2*RAvg 

 UCLx = Target + A2*RAvg 

 RAvg = Average range of subgroup (RAvg) 

 LCLr = D3*RAvg 

 UCLr = D4*RAvg 

 D3, D4, A2, d2 are from McNeese. Reference McNeese, W.H., Klein, R.A., 
(1991) Statistical methods for the process industries, Quality and 
Reliability/28, chapter 16 table 1, p. 224. 

Mean/Standard deviation 

To create the Shewhart control chart of type Mean/Standard deviation: 

1. Click Control Chart. 

2. Select Shewhart in the Type of Control Chart box 

3. Select Mean/StdDev deviation in the Shewhart Type box. 

4. Enter the desired sample size in the Sample size field (default 5), and then 
click OK. 

The resulting plot displays the control charts for the selected vector, with the target and 
upper and lower limits displayed. 

 
The plot footer displays: Target(Mxx) or Target(UE) when defined, LCL(x), 
UCL(x), S(Mxx), S(SAvg) or S(UE) when defined, SAvg(within, S(Mxx) or S(UE) 
when defined), LCL(s) and UCL(s). 
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To view the nomenclature and calculations of target and standard deviation, see the 
Nomenclature and notation and Target and Standard deviation subsections in 
Appendix A: Statistics. 

Control limits and standard deviation 

Control limits and estimates of the standard deviation are computed as follows: 

 S(SAvg) = SAvg/c4, estimate of the process standard deviation. 

 LCLx = Target - A3*SAvg 

 UCLx = Target + A3*SAvg 

 LCLs = B3*SAvg 

 UCLs = B4*SAvg 

 SAvg(within, M1 or S(UE)) = average of the standard deviations of 
subgroups, or, when the standard deviation is user entered, c4 multiplied by 
S(UE). 

 B3, B4, A3, c4 are from McNeese. Reference McNeese, W.H., Klein, R.A., 
(1991) Statistical methods for the process industries, Quality and 
Reliability/28, chapter 19 table 1, p. 272. 

EWMA – Exponentially Weighted Moving Average 
The EWMA, Exponentially Weighted Moving Average, control chart can be displayed 
both with sample size = 1 and sample size > 1. 

Open the EWMA control chart by clicking Control Chart on the Plot/List or Predict 
tabs, selecting EWMA in the Type of Control Chart box. 

 

EWMA with sample size = 1 

To create the EWMA control chart: 

1. Click Control Chart. 

2. Select EWMA in the Type of Control Chart box. 

3. Leave the default value = 1 in the Sample Size field, and then click OK. 

The resulting plot displays the selected vector, target and upper and lower limits in the 
EWMA control chart. 
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When plotting t or tPS, a plot of DModX or DModXPS is displayed beneath, with its 
critical distance. Observations outside the critical distance indicate process behavior 
different from the model. 

 
The plot footer displays: S(Mxx), S(UE) when defined, Lambda (estimated or user 
defined), Target(Mxx) or Target(UE) when defined, S(EWMA), UCL(EWMA), 
LCL(EWMA), 1 – R2X(cum)[last component]and Mxx – D-Crit[last component]. 

To view the nomenclature and calculations of target and standard deviation, or 
calculations of limits, see the Nomenclature and notation, Target and Standard 
deviation, respective Control limits and standard deviation subsections in 
Appendix A: Statistics 

EWMA with subgroups 

To create the EWMA control chart with subgroups: 

1. Click Control Chart. 

2. Select EWMA in the Type of Control Chart box. 

3. Enter a number > 1 in the Sample Size field and then click OK. 

The resulting plot displays the selected vector, target and upper and lower limits in the 
EWMA control chart. 

With sample size > 1 the EWMA is calculated as: 

yhatt+1 = yhatt + (Yt – yhatt) 

where t is time and yhat is predicted y. 
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The plot footer displays: S(Mxx), S(UE) when defined, Lambda (estimated or user 
defined), Target(Mxx) or Target(UE) when defined, S(EWMA), UCL(EWMA), 
LCL(EWMA) and SAvg(between, Mxx or S(UE) if entered). 

To view the nomenclature and calculations of target and standard deviation, or 
calculations of limits, see the Nomenclature and notation, Target and Standard 
deviation, respective Control limits and standard deviation subsections in 
Appendix A: Statistics. 

Control limits and standard deviation 

Control limits and estimates of the standard deviation are computed as follows: 

S(EWMA) = MSSD, Mean Square Successive Difference = SAvg * (/(2-)1/2 

The upper and lower control limits are computed as: 

UCL(EWMA) = Target + 3 * S(EWMA) 

LCL(EWMA) = Target – 3 * S(EWMA) 

where  is estimated (when not user entered) to minimize the error sum of squares. 
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CUSUM 
To create the CUSUM control chart: 

1. Click Control Chart. 

2. Select CUSUM in the Type of Control Chart box. 

3. Enter the desired number of groups in the Sample Size field, and then click 
OK. 

The resulting plot displays the target, CUSUM lines and limits for the selected vector. 

The CUSUM, CUmulative SUM, control chart can be displayed both with sample size 
= 1 and sample size > 1. 

 

 
The plot footer displays: S(Mxx), Target(Mxx) or Target(UE) when defined, S(UE) 
when defined, Action Limit (H) and Dead Band (K). 

To view the nomenclature, calculations of target and standard deviation, or calculations 
of limits, see the Nomenclature and notation and Target and Standard deviation 
topics subsections in Appendix A: Statistics, respective the Control limits… section 
later. 
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CUSUM plot content 

The series displayed in the plot are: 

 High CUSUM = Cumulative sum on the high side difference used to detect 
a deviation from the target on the high side. High CUSUM is set to zero 
when negative. 

 Low CUSUM = Cumulative sum on the low side difference used to detect a 
deviation from the target on the low side. Low CUSUM is set to zero when 
positive. 

 Dev from Target, deviation from target = average of subgroup – target. 

Reference McNeese, W.H., Klein, R.A., (1991) Statistical methods for the process 
industries, Quality and Reliability/28, chapter 21. 

Note: The plot displays the Low CUSUM with reversed sign (- Low CUSUM) 
so that all values are displayed as negatives. 

Control limits  

The control limits are computed as follows: 

 Action Limit (H) = 4.5 standard deviation, using S(Mxx) when sample size 
= 1 and SAvg when sample size > 1. 

 Dead Band (K) (or allowable slack) = standard deviation/2, using S(Mxx) 
when sample size = 1 and SAvg when sample size > 1. 

EWMA/Shewhart 
Click Control Chart, select Shewhart/EWMA in Type of Control Chart, and then 
click OK displays the Shewhart and EWMA lines, target and limits, all in the same 
plot. 

 
Note that the EWMA/Shewhart control chart is only available with sample size = 1). 
Consequently the Shewhart displayed is the Individual. 

Lambda, Target, and Standard Dev. can be User Entered or Estimated. See the 
Shewhart and EWMA sections earlier for more. 
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The plot footer displays: S(Mxx), S(UE) when defined, Target(Mxx) or Target(UE) 
when defined, S(EWMA), UCL(EWMA), LCL(EWMA) and Lambda (estimated or 
user defined). See the Shewhart and EWMA sections earlier for more. 

Response Contour 
The Response Contour displays the response surface contour plot for the selected y-
variable with the two selected x-variables on the axes, for a PLS model. 

To create a Response Contour plot: 

1. On the Plot/List tab, in the Custom Plots group, click Response Contour. 

2. Select the model in the Data box and the number of components to use in the 
Comp box. 

3. Select the y-variable to display in the Y-Variable box. 

4. Select the x-variables to display on the x-axes in the 1st axis and 2nd axis 
boxes. The range of the selected variables is displayed using Low and High 
settings fields. These are the values used to limit the surface. Change them as 
warranted. 

5. All x-variables not selected to be displayed on the axes, are held constant and 
listed in the Constant variables list, by default set at their average, Center. 
Change these settings as warranted by typing new values in the respective 
fields. 

6. Click OK or click the 3D Plot Options tab (described next). After clicking 
OK, the values of the constant factors are displayed near the plot. Changing 
these values updates the plot instantly. 
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Response Contour plot options 
Clicking the 3D Plot Options tab enables changing the following options: 

1. Resolution – 16, 32, 64, or 128. Resolution 32 is the default. 

2. Show contour level labels - clear the check box to hide the labels in the plot. 

 
See also the Contour subsection in the Layout tab section in the Plot and list 
contextual tabs chapter.  
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Response Surface Plot 
The Response Surface plot displays the response surface contour plot in a 3D grid, for 
the selected y-variable with the two selected x-variables on the x and y-axes and the y-
variable on the z-axis. The plot is only available for PLS, OPLS and O2PLS models. 

To create the Response Surface plot, on the Plot/List tab, in the Custom Plots group, 
click Response Surface. The dialog that opens is the same as the one for the Response 
Contour, see the Response Contour section preceding this section. 

   

Wavelet Structure 
In the Wavelet Structure plot the selected vector is decomposed using DWT into its 
approximations and details at every scale. By default, the details and approximations 
for the first four lowest scales, scales 1 to 4 (the first 4 highest frequencies bands), are 
reconstructed and plotted using the same time axis. The original signal is A0. This is 
very useful in order to understand the structure of a signal. 

Note: In SIMCA the scales or levels are the inverse of the frequencies. Hence, 
scale 1 (D1) corresponds to the highest frequency band in the signal and the 
highest scale corresponds to the lowest frequency in the signal. The mean (DC 
component) is not included. 
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The bar chart plot displays the percent of the total Sum of Squares of the signal (not 
including the DC component) contained in the details coefficients at every scale. Plots 
A1 to A4, and D1 to D4 are the reconstructed approximations and details coefficients 
at the scale 1 to 4. A0 is the original signal. 

Displaying Wavelet Structure plot 
To display the Wavelet Structure plot: 

1. Click Wavelet Structure. 

2. Select the vector to display. 

3. Click the Wavelet Options tab and select detrending, wavelet family, and 
wavelet order. For more, see the Wavelet Options subsection in the Data 
chapter. 

4. Click the Wavelet Details tab and select the levels to display. For more, see 
the Wavelet compression/denoising By detail level subsection in the Data 
chapter. 

5. Click OK. 

Wavelet Power Spectrum 
The wavelet power spectrum plot is a 3-D plot displaying the scaled power density (the 
normalized squared wavelet coefficients) of the signal as a function of both time and 
frequency. Note that the frequencies are in logarithmic band passes (displayed on the 
plot as multiple of 2) up to the Nyquist frequency (the highest frequency in the signal). 
The smallest even scale (i.e. 2) on the plot represents the highest frequency band, that 
is frequencies in the signal from ½ the Nyquist up to the Nyquist frequency. The 
highest even scale in the plot is the single lowest frequency in the signal. 

The DC component (average) when present is not included. 
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Displaying Wavelet Power Spectrum plot 
To display the Wavelet Power Spectrum: 

1. Click Wavelet Power Spectrum. 

2. Select the vector to display. 

3. Click the Wavelet Options tab and select detrending, wavelet family, and 
wavelet order. For more, see the Wavelet Options subsection in the Data 
chapter. 

4. Click OK. 

Wavelet Power Spectrum example 
The following plots display a signal, which is 20-Hertz in the first half, and 100-Hertz 
in the second half. The sampling frequency of the signal is 1024- Hertz (i.e. 1024 
points a second). 

In the Wavelet Power Spectrum, the 20-Hertz signal is displayed as continuous peaks 
across the first half of the time axis, on scale 10, i.e. frequency band between 16 and 32 
Hertz. The 100-Hertz signal occurs across the second half of the time axis, with peaks 
centered on scale 6, i.e. frequency band between 64 and 128-Hertz. 
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Step Response Plot 
The Step Response Plot Σvk is the sum or integral of the Impulse Response function vk 
of the system. These are the response of the system at times t and k >0 to a unit pulse 
input at time t =0. 

Hence 

Yt   = Σ vkXt-k    

k=0 to ∞ is the deviation from steady state at time t. 

Creating a finite impulse response model 
When clicking Step Response Plot, a wizard opens with 2-6 pages depending on the 
selections in the wizard. The pages up to and including the page specifying the lag 
structure define the FIR model. 

Selecting to create a new model 
On the first page of the Step Response Plot wizard, select to create a new model by 
clicking Create a new Finite Impulse Response model. Then click Next. 

 

Selecting y-variable and excluding variables or 
observations 
On the 2nd page of the Step Response Plot wizard: 

 Select the y-variable in the Variables list, and click the Y-button. 

 Exclude undesired variables and observations by selecting them and clicking 
the respective Exclude-buttons. 

 Optionally, select the Change transformation check box to transform 
variables. For more, see the Applying transformations subsection in the 
Workset section in the Home chapter. 

 Optionally select the Change scaling check box to change the scaling of 
variables. Then click Next, and customize the scaling using the None, 
Pareto, Unit Variance, and Center-buttons. 
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When done click Next. 

 

Specifying lag structure and fitting FIR model 
To specify the new models lag structure: 

1. The default Maximum number of lags is 45 or N-5 whichever is smaller. 
Specify a new maximum number of lags by typing a new value smaller than 
N-5. 

2. The default Lag Increment is 5 or Maximum number of lags/3 whichever 
is smaller. Specify a new lag increment by typing a new value smaller than 
Maximum number of lags/3. 

3. Click Next and SIMCA fits an FIR model with the selected y-variable and all 
x-variables with their lags as selected. 
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Displaying Step Response Plot 
On the last page of the Step Response Plot wizard: 

1. Select the x-variable to display in the Available X-variables list. 

2. In the Coefficients as a function of lag plot, mark the integration interval to 
display in the Step Response Plot. Leaving the plot as it is leads to 
displaying the entire integration. 

Note that the Plot Preview window displays the Step Response Plot and is updated 
when switching x-variables and integration intervals. 

When the FIR model is fitted the wizard displays the Impulse Response function of the 
selected x-variable. 

 
Click Finish when done to display the final Step Response Plot. In this plot the 
integration always starts at 0. 
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Using an existing finite impulse response model 
To use an existing Finite Impulse-Response model to display another Step Response 
Plot: 

1. Click Step Response Plot. 

2. Click Use an existing Finite Impulse Response model and select one of the 
models listed in the Available Finite Impulse-Response list. 

3. Click Next to open the last page of the wizard. For more about this page, see 
the Displaying Step Response Plot subsection previously in this section. 
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View 

Introduction 
This chapter describes all commands on the View tab. 

The following is available: 

 The Show/Hide group including all dockable windows, the Model Window 
and the Full Screen command. 

 The Add group including Add to Favorites and Add to Report.  

 The Window group including Cascade, Tile and Close of windows. 

 Optionally the Skins group if there are skins installed.  

 

Show/Hide 
In the Show/Hide group on the View tab you can select to show or hide the following: 
Audit Trail, Analysis Advisor, Favorites, Item Information, Marked Items, Model 
Window, Observations, Project Window, Quick Info, Variables, and the Status 
Bar. Clicking Full Screen minimizes the ribbon as when Minimizing the ribbon. 

 
All check boxes represent dockable windows except for the Model Window which is a 
regular window, and the Status Bar which is always positioned at the bottom of 
SIMCA and displays the plot coordinates of the cursor or the first part of the current 
tooltip.  

After selecting one of the dockable windows, you can move the window and dock it as 
desired. 

To auto hide the window when not using it click the Auto Hide button . The button 
changes to  and the window will slide away when not used and slide up on top of 
plots when clicked. 

The features in the Show/Hide group are described in this section. 
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Audit Trail 
The Audit Trail was implemented in SIMCA, in compliance with rules for keeping 
electronic records (21 CFR part 11). 

When turned on, the Audit Trail window logs all events in a session. A session starts 
with the creation or opening of a project and ends when the project is saved. When a 
project is reopened the current event logging is appended to the existing audit trail. 

In addition to logging events, SIMCA logs information about the user and date and 
time of the events. 

   

Turning on logging to the Audit Trail 
To turn on the logging to the Audit Trail: 

 Before selecting any datasets in the SIMCA import, click File | Options and 
select Yes in the Log events to the Audit trail box. The audit trail will then 
be turned on for this specific project and by default for all projects created 
thereafter. 

 For projects already open in SIMCA, click File | Project Options, click the 
Audit Trail tab, and then select the Log events to the Audit Trail check 
box. The audit trail will then log the events in this project that follow after it 
was turned on. This has no effect on projects created after. 

The administrator can lock the audit trailed turned on. For administration of the Audit 
trail, see the Administration of the audit trail subsection in the Project Options 
section in the File chapter. 

The audit trail logs the actions listed in the Logged in the Audit Trail subsection next. 

Logged in the Audit Trail 
The following actions are logged by the Audit Trail: 

Import and changes of the dataset during import/dataset creation: 

 name and path of imported file(s). 

 changes to the datasets done in SIMCA import, i.e. values changed, rows 
excluded etc. 

 settings for creating batch level dataset. 
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Creation/changing of a workset: 

 shows total number of X-variables. 

 number of expansions. 

 number of lags. 

 number of Y-variables. 

 number of observations. 

 model type. 

 number of excluded observations and variables. 

 number of transformed variables. 

 the datasets selected. 

Changes of the model, such as: 

 change in number of components. 

 hierarchical model type. 

 options. 

 deletion of a model. 

Creation/changes of datasets: 

 logs the old and new values when changing values. 

 logs the old and new value when changing observation or variable IDs. 

 deletion of observations and variables. 

 addition of observations and variables. 

 sorting. 

 splitting. 

 merging. 

 transposing. 

 deletion of datasets. 

 addition of variables using Generate variables on the Data tab. 

 logs when there is a change in predictionset. 

The data source name when the data comes from a database. 

Save and Save As (including the name of the new project). 

Registers when a digital signature in the Audit trail is incorrect. 

Clearing of the Audit trail (File | Project Options, Clear Audit trail). 

Turning on and off the Audit Trail. 

Changes in the Audit Trail extended user information. 
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Analysis Advisor 
The Analysis advisor explains all plots available on the Home tab. The Analysis 
Advisor window by default opens on the right side of the screen. 

 

Favorites 
Open the Favorites window by adding a plot or list to it, or by selecting the Favorites 
check box in the Show/Hide group on the View tab. 

 
The Favorites window contains plots. Clicking a plot opens the specified plot for the 
selected model in the current project. 

To move items or folders, grab and drag them.  
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The following commands are available from the Favorites shortcut menu: 

 Open when a single item is marked. 

 Open All Items in Folder when a folder is marked. 

 Treat Folder as Item when a folder is marked. Toggles treating the folder as 
an item on or off. 

 Rename folder or item. 

 Delete folder or item. 

 New Folder. 

 Export the Favorites configuration to file. 

 Import the Favorites configuration from file. 

 

Organizing in folders in Favorites 
Plots can be organized in folders in the Favorites window. There is one global folder 
available by default, Favorite Plots and Lists, and one local folder, Project 
Favorites.  

The default folders can be customized, and new global or local folders can be created. 

Favorites positioned in Project Favorites are saved with the current project and do not 
remain when another project is opened. 

Opening plots, items, and executing folders in Favorites 
Each item in the Favorites window can be opened by double-clicking it or by marking, 
right-clicking, and clicking Open. 

All items or commands in a folder can be opened, and the windows tiled, by marking 
the folder, right-clicking it and clicking: 

 Open All Items in Folder. 

 Treat Folder as Item and then double-clicking it. 

Renaming in Favorites 
Rename folders or items by: 

 Right-clicking the item and selecting Rename. 

Or 

 Marking the item and pressing F2. 
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Deleting from Favorites 
To delete a folder or an item, mark the item and: 

 Right-click and select Delete. 

 Press DELETE on your keyboard. 

Creating folders in Favorites 
It is convenient to group plots in folders, and automatically open all plots in the folder 
in sequence when often opening the same plots. 

To create a folder: 

1. Right-click in the Favorites window. 

2. Click New Folder and type a name for the folder. 

 

Exporting and importing Favorites configuration 
The Favorites window configuration can be saved as an .xml-file. 

To save the current favorites configuration to file: 

1. Right-click the Favorites window. 

2. Click Export. 

3. Enter the name and location in the Save As dialog; click Save. 

To import favorites from .xml-file: 

1. Right-click the Favorites window. 

2. Click Import. 

3. Browse for the file in the Open dialog; click Open. 

Note: Importing a favorites file overwrites the current file. 

Adding plots and lists to Favorites 
To add a plot or list to Favorites use one of the following methods: 

1. Right-click the plot or list, and then click Add to Favorites. 

2. With the plot or list active, press CTRL+D. 

3. With the plot or list active, on the View tab, in the Add group, click Add to 
Favorites. 
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Item Information 
The Item Information window displays all the information about the items that are 
marked in a plot. 

   

SMILES 

If you have SMILES code as a secondary Observation ID, and have the SMILES plug-
in DLL, the Item Information window displays the molecule. 

When marking several observations holding down the CTRL-button, the Item 
Information window only displays the chemical structure for the last marked 
observation. 

To see the structure of several observations, all points need to be marked in one go. 
When the points are not adjacent: 

1. Mark the points you want to see structure for. 

2. Right-click, select Create Plot or Create List. 

3. Mark all in observations in one scope (not holding CTRL-button) and the 
chemical structure is displayed for all observations in Item Information. 

For more information about SMILES, contact your Umetrics sales office. 
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Marked Items 
The Marked Items window displays all identifiers of the currently and secondary 
marked items. 

   
The Marked Items window can be used for many purposes. For instance: 

 To display the items, observations or variables, marked in a plot to visualize 
which items are actually marked. In plots with many items it can be difficult 
to see precisely which those items are. 

 To visualize the marked points in the Marked Items window when marking 
points to create a contribution plot. 

 To unmark (deselect) points, mark the points in the Marked Items window, 
right-click the marking, and click Unmark Items. 

 To view the groups in the dendrogram plot, opened by clicking HCA in the 
Clustering group on the Analyze tab. 

Marked Items window features 
There are a number of features available in the Marked Items window shortcut menu. 

With observations (left below) in Marked Items, the shortcut menu holds the 
commands: Unmark Items, Include, Exclude, Set Class, Select All, Clear All 
Marked, and Observation Label. 

 
With variables (right above) in Marked Items, the shortcut menu holds the 
commands: Unmark Items, X, Y, Exclude, Select All, Clear All Marked, and 
Variable Label. 
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Clicking Include, Exclude, Set Class, X, Y, or Exclude creates a new unfitted model 
unless there already is an unfitted model. If there already is an unfitted model the 
selected command is done for that model. 

When a new unfitted model is created, that model is created as a copy (as New As in 
the Workset group) of the model used when marking the items displayed in the 
Marked Items window. 

Select Result 

Unmark Items Unmarks the marked items in the Marked Items window 
both in the window and in all open plots and lists. 

Include Creates a new model including only the marked items. 

Exclude Excludes the marked items. 

Set Class Select No Class or a class. Organizes in classes. 

X Sets the marked variables as X. 

Y Sets the marked variables as Y. 

Select All Marks all items in the Marked Items window. 

Clear All Marked Clears all marking in the window and in all open plots and 
lists. 

Observation 
Label and 
Variable Label 

The Marked Items window lists all identifiers. Select to 
remove labels under Observation Label or Variable 
Label. 

Creating contribution plots using Marked Items window and 
tab 
The Marked Items window is useful when creating contribution plots, and especially 
group contribution plots. 

When creating a group contribution plot, the observations in the group marked first are 
displayed under Secondary Marked Values and the group marked last under Marked 
Values. 

When marking observations the Marked Items tab becomes available and active.  

To create a contribution plot, click the relevant button in the Drill down group. 

For more about creating contribution plots by marking in plots, see the Creating plots 
from plots section in the Marked Items tab section in the Plot and list contextual 
tabs chapter. 
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Model window 
The model window includes an overview of the model, the Workset and Options 
buttons, and displays a summary of the fit of the model with results for each 
component. 

 
The model window holds the following information about the model: 

Item Explanation 

Title Title of model. 

Type The model type used when fitting. 

Observations 
(N)  

Number of observations. 

Variables (K)  Total number of variables 

X  Number of variables as X (including expanded and lagged terms). 

Y  Number of variables as Y. 

Lagged Number of lagged variables. 

Expanded Number of expansions. 

Components The list of components and their statistics and properties. For 
more see the Model summary of fit subsection later in this 
section. 

Workset button 
Clicking the Workset-button displays the workset associated with the model. Note 
that if you click the Workset-button, edit the workset, and click OK, the model will be 
replaced by a new unfitted model. For more about the workset, see the Workset 
section in the Home chapter. 

Options button 
Clicking the Options button displays the Model Options dialog. For details, see the 
Model Options section in the Workset section in the Home chapter. 
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Model summary of fit 
The model window consists of a summary line for each component A of the 
model, starting with component 0 representing centering. 

The table describes all columns available for each component. 

Column 
header 

Description 

A The component number. 

R2X Fraction of Sum of Squares (SS) of the entire X explained by the 
current component. 

R2X (cum) Cumulative SS of the entire X explained by all extracted 
components. 

Eigenvalue Eigenvalue of the X matrix, R2X * min(K,N). 

R2Y Fraction of Sum of Squares of all y-variables explained by this 
component. 

R2Y (cum) The cumulative SS of all the y-variables explained by the 
extracted components. 

Q2 The fraction of the total variation of X (PC) and Y 
(PLS/OPLS/O2PLS) that can be predicted by the current 
component. 

Limit The cross validation threshold for that component. When Q2 > 
Limit the component is significant. 

Q2 (cum) The cumulative Q2 for all the x-variables (PC) and y-variables 
(PLS/OPLS/O2PLS) for the extracted components. 

Significance Significance of the component according to cross validation rules: 
R1, R2, U, R5, NS, N3, N4. For details about the cross validation 
rules, see the Cross validation section in Appendix A: 
Statistics. 

Iterations Number of iterations till convergence. 

Model window for OPLS and O2PLS models 
The Model Window corresponding to OPLS and O2PLS displays summary statistics 
related to the model. Components that capture variation found in both X and Y are 
denoted Predictive. Components that capture variation only found in X are denoted 
Orthogonal in X(OPLS). Components that capture variation only found in Y are 
denoted Orthogonal in Y(OPLS).  

The OPLS model is based on the OPLS algorithm. The O2PLS model is based on the 
similar O2PLS algorithm, but in addition there is a PCA step. PCA is used after 
convergence of the O2PLS algorithm, to exhaust the E and F residual matrices from all 
remaining systematic variation. This yields the additional Orthogonal in X(PCA) and 
Orthogonal in Y(PCA) components.  

The method underlying a certain Orthogonal component is indicated in the name of the 
component in the Model Window.  
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Note: The model window for OPLS models displays, if existing, three types of 
components: Predictive, Orthogonal in X, Orthogonal in Y. Additionally, The 
model window for O2PLS displays, if existing, Orthogonal in X and 
Orthogonal in Y components estimated by PCA. 

Figure 2. The Model Window for an O2PLS model with 7 predictive, 3 Orthogonal in 
X and 6 Orthogonal in Y components (a 7+3(1+2) +6(1+5) O2PLS model).  

 
The Model Window displays: 

Section Description Component types 

Model Summarizes the model, 
showing the cumulative R2X, 
R2, Q2, and R2Y. 

  

Predictive The Predictive section where 
the first row summarizes the 
predictive components in the 
model followed by a listing of 
each predictive component. 

The predictive loading vectors are 
p for the X-block and q for the Y- 
block. The predictive score vectors 
are t for the X-block and u for the 
Y-block. In the figure above there 
are 7 components for p, q, t and u. 

Orthogonal 
in X (OPLS) 

The Orthogonal in X(OPLS) 
section where the first row 
summarizes the orthogonal 
components in the X model 
followed by a listing of each 
orthogonal in X component. 
The orthogonal in X 
components show the 
variation in X that is 
uncorrelated to Y. 

The orthogonal in X(OPLS) loading 
vectors are po for the X-block and 
so for the Y-block. The orthogonal 
in X (OPLS) score vector is to for 
the X-block.  

In the figure above there is one 
orthogonal in X(OPLS) component. 
This means that the po[1], so[1], 
and to[1] vectors are the 
orthogonal in X(OPLS) vectors. 
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Section Description Component types 

Orthogonal 
in X (PCA) 

The Orthogonal in X(PCA) 
sections where the first row 
summarizes the orthogonal 
components in the X model 
followed by a listing of each 
orthogonal in X component. 
The orthogonal in X 
components show the 
variation in X that is 
uncorrelated to Y 

The orthogonal in X(PCA) loading 
vectors are po for the X-block and 
so for the Y-block. The orthogonal 
in X (PCA) score vector is to.  

The orthogonal in X(PCA) 
components are extracted after the 
orthogonal in X(OPLS) 
components, and their relational 
order is indicated through the 
shared nomenclature. 

In the figure above there are two 
orthogonal in X(PCA) components. 
This means that the po[2], po[3], 
so[2], so[3], to[2] and to[3] vectors 
are the orthogonal in X(PCA) 
vectors 

Orthogonal 
in Y (OPLS) 

The Orthogonal in Y (OPLS) 
sections where the first row 
summarizes the orthogonal 
components in the Y model 
followed by a listing of each 
orthogonal in Y component. 
The orthogonal in Y 
components show the 
variation in Y that is 
uncorrelated to X. 

The orthogonal in Y(OPLS) loading 
vectors are r for the X-block and qo 
for the Y-block. The orthogonal in Y 
(OPLS) score vector is uo for the Y 
block.  

In the figure above there is one 
orthogonal in Y(OPLS) component. 
This means that the r[1], qo[1], and 
uo[1] vectors are the orthogonal in 
Y(OPLS) vectors. 

Orthogonal 
in Y (PCA) 

The Orthogonal in Y (PCA) 
sections where the first row 
summarizes the orthogonal 
components in the Y model 
followed by a listing of each 
orthogonal in Y component. 
The orthogonal in Y 
components show the 
variation in Y that is 
uncorrelated to X 

The orthogonal in Y(PCA) loading 
vectors are r for the X-block and qo 
for the Y-block. The orthogonal in Y 
(PCA) score vector is uo for the Y 
block.  

The orthogonal in Y(PCA) 
components are extracted after the 
orthogonal in Y(OPLS) 
components and their relational 
order is indicated through the 
shared nomenclature. 

In the figure above there are five 
orthogonal in Y(PCA) components. 
This means that the r[2]-r[6], qo[2]-
qo[6], and uo[2]-uo[6] vectors are 
the orthogonal in Y(PCA) vectors. 

The table columns are: 

 Component - Component index.  

 R2X - Fraction of X variation modeled in that component, using the X 
model.  

 R2X(cum) - Cumulative R2X up to the specified component.  

 Eigenvalue - The minimum number of observations (N) and X-variables 
multiplied by R2X, that is, min(N,K)*R2X.  
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 R2 - Fraction of Y variation modeled in that component, using the X model.  

 R2(cum) - Cumulative R2 up to the specified component.  

 Q2 - Fraction of Y variation predicted by the X model in that component, 
according to cross-validation.  

 Q2(cum) - Cumulative Q2 up to the specified component.  

 R2Y - Fraction of the Y variation modeled in that component, using the Y 
model.  

 R2Y(cum) - Cumulative R2Y up to the specified component  

 EigenvalueY - The minimum number of observations (N) and Y-variables 
multiplied by R2Y, that is, min(N,M)*R2Y.  

 Significance – Significance level of the model component. 

For more, see the OPLS/O2PLS - Orthogonal PLS modeling section in Appendix 
A: Statistics. 

Observations window 
The Observations window displays the observations included in the workset of the 
active model. 

Right-clicking the window opens the shortcut menu holding the following commands: 
Include, Exclude, Set Class, Select All, and Observation Label. These commands 
work as described in the Marked Items section previously in this chapter. 

 

Project window 
The project window displays a list of all models with their respective model 
information. 

The model selected in the project window is the active model, displayed in the window 
caption (frame) both when displayed and when minimized. All plots created are 
created for the active model. 
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The project window is by default docked and can then only be minimized, not closed. 
To have the project window slide away after showing it, click the Auto Hide button so 
that it turns. See the Show/Hide subsection for details.  

To have the project window as a regular window, see the Customizing the Project 
window subsection. 

   

The list of models displays the following information about each model: 

Column  Description 

No. Workset number. Workset numbers are assigned sequentially. 
When the model is a batch model the workset number also holds 
the abbreviation BM for Batch Model. With class models, the 
workset number also holds the abbreviation CM for Class Model. 

Model Automatic model name. The models are named Mxx with xx 
being a sequential number starting at 1 

Type Fit method used to fit the model. 

A Number of components. 

R2X Sum of Squares of all the x-variables explained by the extracted 
components. 

R2Y For PLS, Sum of Squares of all the y-variables explained by the 
extracted components. 

Q2(Cum) Cumulative cross validated R2. 

SD(Y) Standard deviation of Y (not displayed by default). 

Date Date when the model was fitted. 

Time Time when the model was fitted (not displayed by default). 

Title Title of the model entered by the user. By default all models have 
the title 'Untitled'. 

Hierarchical Displays B or T when the model is a Base or Top hierarchical 
model. A model using the scores or residuals of other models as 
variables is a hierarchical top model. Hierarchical models are 
described in detail in the Analyze chapter. 
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Customizing the Project window 
To select which columns to display in the Project Window, click Customize from the 
shortcut menu. 

In the dialog that opens, select and clear as desired. 

 

Project Window shortcut menu 
From the shortcut menu of the Project Window the following commands are 
available: 

 Open - Opens the model window of the active model. 

 Edit Model x - Opens the workset for the model, see the Editing the 
workset subsection in the Workset section in the Home chapter. 

 New as Model x - Opens a copy of the workset for the model, see the New 
workset as model subsection in the Workset section in the Home chapter. 

 Change Model Title - Opens the Model Title dialog, see the Changing the 
model title subsection later in this chapter. 

 Delete - Deletes the active model, see the Deleting the workset subsection 
in the Workset section in the Home chapter. 

 Hierarchical Base Model, Non Hierarchical Base Model - Specifies the 
model as hierarchical/non hierarchical base model, see the Hierarchical 
models subsection in the Data chapter. 

 Generate Report - Opens the report generator, see the Appending to, 
inserting in, or replacing existing report subsection in the Generate 
Report section in the File chapter. 

 PLS-Tree Plot - Opens the PLS-Tree dendrogram, see the PLS-Tree 
resulting dendrogram subsection in the Analyze chapter.  

 Add to Report - Adds the project window to the report, see the Add to 
Report subsection in the Generate Report section in the File chapter. 

 Customize - Opens the Customize Project Window dialog, see the 
Customizing the Project window subsection later in this section. 

 Model Options - Opens the Model Options of the active model, see the 
Model Options subsection in the Workset section in the Home chapter. 
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Changing the model title 
The model title is by default 'Untitled'. To change the model title: 

1. Use one of the following methods: 

 With the Model Window open, type in the Title field. 

 With the Project Window open, right-click the model, and click 
Change Model Title. 

2. Enter the new model title and click OK.  

Quick Info 
The Quick Info window displays overview information about marked items in an open 
plot, list, or spreadsheet. When displaying the Quick Info of variables after marking in 
a dataset spreadsheet, trimming and Winsorizing is also available. 

A separate Quick Info window is available in the workset dialog, tab Spreadsheet. 
Trim-Winsorizing in the workset applies to the model only, not the dataset. For more, 
see the Spreadsheet in the Workset dialog subsection in the Workset section in the 
Home chapter. 

To open the Quick Info dockable window: 

 On the View tab, in the Show/Hide group, select the Quick Info check box 
OR 

 Right-click the dataset spreadsheet and click Quick Info.  
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Quick Info window description 
The Quick Info window has the following content: 

 Caption bar with the current item information including the type of item 
(variable/observation etc), Auto Hide, and Close.  

 Statistics section holding the statistics and optionally variable recipe when 
selected for display in Options. Default is to display N (number of items in 
the series), % Mis. Val. (percent missing values), Mean, and Std. dev. 
(standard deviation). 

 Selection of plots according to selection in Options. Default is to display the 
Frequency Histogram and Time Series plots. 

 Selection Bar if selected in Options. Default is to not display the Selection 
Bar. 

 Options button. 

 Trim-Winz Var and Trim-Winz All-buttons when the Quick Info is for 
variables. 

The quick info plots and the buttons Options, Trim-Winz Var, and Trim-Winz All 
are described in the subsections that follow. 

Quick info plots and interactive delete or replace 
Deleting an observation or variable, or changing the value of a selected cell, can be 
done interactively using the Quick Info window Time Series or Spectrum plot in the 
following manner: 

1. Mark points in the Time Series or Spectrum plot. The Remove or Replace 
the x Selected Observations/Variables dialog opens: 

 
2. Select 

a. Remove the variable/observation from the dataset to delete the 
marked variables or observations OR 

b. Replace the value in the cell in the dataset and type the new 
value in the New value cell, to replace. 

3. Click OK to take action. 

Note: The Remove or Replace dialog automatically opens when marking 
points in the Quick Info Time Series or Spectrum plots when the Trim-Winz 
Var dialog is closed. 

Quick Info Options button 
The selected settings in the Quick Info Options dialog define what is displayed in the 
Quick Info window. 
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Clicking the Options button opens the options dialog with the tabs Quick Info 
Options, Power Spectrum Options, and Correlation Options. The content of these 
tabs is described in the subsections that follow. 

Quick Info Options page 

To open the Quick Info Options dialog, click the Options button. 

 
Statistics section 

The first section under Display lists the statistics that can be displayed in the Statistics 
section of the Quick Info window and an option named Variable recipes. 

The available statistics are: N, Missing value (%), Min, Max, Min/Max, Mean, 
Median, Standard deviation, Std. dev/Mean, Skewness, and Kurtosis. 

The Variable recipe describes how a new generated variable was created. For 
example, after creating VAR16 as the product of variable v5 multiplied with the ratio 
of variable v10 and variable v1, clicking that variable displays the formula in the 
statistics section. 

 

Selecting Quick Info window plots 

Select to display any or all of the 4 following plots: 

1. Frequency histogram (default selected). 

2. Spectrum/Time series (default selected). 

3. Auto correlation. 

4. Power spectrum. 
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Displaying the selection bar 

The Selection bar is a Variable selection bar with a scrolling tool. Moving this tool 
allows moving in the dataset by emulating cursor movement. Above the scroll bar, the 
current variable is displayed in the Variable selection box. Use the Variable selection 
box or click the arrow-button to switch variables. 

 

Selecting items to include 

Under Use only on the right side of the window is a list of observations (for Quick 
Info of variables) or variables (for Quick Info of observations). Use this function to 
select which observations or variables to include. By default all the observations or 
variables are included. 

A Find feature is available to facilitate this task. Observations or variables may be 
selected by entering characters in the Find field. Wild card symbols '?', and '*' are 
allowed in specifying observations or variables identifiers. For example “?LH*” selects 
observations or variables with names such as SLH2 or QLHSW, etc. Click the 
Complement button to display the complement of the selected variables or 
observations. 

Note: The Find utility in SIMCA is cASe inSEnitiVE. 

To display another or more identifiers, right-click the list and select it. 

Selecting phases and batches for batch data 

With batch data, select to display the quick info window for all phases and batches or 
for a selection of phases and batches. 
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Select the phase and batches from the boxes positioned bottom right. Default is to use 
All Phases and All Batches. All statistics and plots will refer to the selected phases 
and batches. 

Power Spectrum Options page 

The Power Spectrum Density (PSD) is the representation of the sequence x (t) in the 
frequency domain. The power spectrum is the square of the amplitude of the Fourier 
component at each frequency. 

The frequency domain representation is particularly helpful to detect irregular cycles 
and pseudo periodic behavior, i.e. tendency towards cyclic movements centered on a 
particular frequency. 

For more, see the Power Spectrum Density section in the Appendix B: 
Preprocessing chapter. 

Note: With a dataset that has been wavelet transformed and compressed 
variables wise, using Data | Spectral Filters, the PSD observation wise refers 
to the reconstructed observations, when the Reconstruct wavelets check box is 
selected. 

 
The Power Spectrum Options tab includes the following options. 

Detrending 

The default is to detrend by removing the Mean. There are two more options: 

 Removing the best linear fit by selecting Linear or 

 Removing nothing by selecting None. 

Scaling 

Asymptotically Unbiased is the default scaling. Selecting Peaks estimates the heights 
of the original peaks. 

Selecting window type 

The default Window type is Hanning. 

To select another window type, click the Window type box and select Welsch or 
Bartlett. 

Selecting window length 

The default Window length is the smallest of 256 or ½ the length of X (t), padded, to 
the nearest length 2n, where n= integer, although always larger than or equal to 16. 

Select another length from the Window length box. 
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Overlapping segments 

The default is to not overlap the segments. 

To overlap, select the Overlapping segments check box. 

Scaling of the Y axis 

The scale of the y-axis is default in Decibel. 

To display the y-axis non transformed, clear the Amplitude in decibel check box. 

Selecting sampling frequency 

The output of the PSD is a vector of length = (window length)/2 +1. This is the scale of 
x if you have not entered a sampling frequency. 
The sampling frequency is used as a scaling multiplier to properly scale the frequency 
axis, with the highest frequency being the Nyquist frequency = Fs/2. It has no effect on 
the PSD. 
By default SIMCA assumes a sampling frequency of 1 and Fs/2=0.5 is displayed as the 
highest frequency. 

Correlation Options page 

The auto correlation is a measure of dependence of adjacent observations and 
characterizes a time series or observation profile, in the time domain. 

Note: With a dataset that has been wavelet transformed and with the 
Reconstruct wavelets check box selected, the auto correlation is displayed in 
the reconstructed domain. 

For more, see the Auto and cross correlation of variables or observations section in 
Appendix B: Preprocessing. 

 
The Correlations Options page includes the following options: 

Detrending 

The default is to detrend by removing the Mean. There are two more options: 

 Removing the best linear fit by selecting Linear or 

 Removing nothing by selecting None. 

Maximum number of lags 

The auto correlation is default computed up to lag L=30 or N/4 whichever is smaller. 

To change the number of lags, enter a new number in Max lag. 

Selecting plot type 

Default is to display the auto correlation plot as a column plot. 

To display it as a line plot, select Line in the Plot type box. 



View 

411 

Preprocessing the dataset using Trim-Winsorizing 
Trimming and Winsorizing is available for variables only. The Trim-Winz Var and 
Trim-Winz All buttons are available when one or more variables are marked. 

Trimming is cutting the upper and lower edges of the variables and replacing them by 
missing values.  

Winsorizing is cutting the upper and lower edges of the variables and replacing the 
removed values by new values. 

Note: Trimming or Winsorizing the dataset deletes all models that include the 
affected variables. 

The Trim-Winz Var and Trim-Winz All buttons are positioned bottom right in the 
Quick Info window: 

 
To Trim-Winsorize, click: 

 Trim-Winz Var to trim or Winsorize the marked variable. 

 Trim-Winz All to trim or Winsorize all variables in the dataset or a selected 
subset by using the Selected Variables page. 

Note: When a number of values are equal, none of them will be changed if not 
all of them fall outside the limits. 

  

Note: The details of the performed trim-Winsorizing are registered in the 
audit trail when the audit trail is turned on and in the Trimming Overview. 

Trim-Winz Var dialog 

The Trim-Winz Var dialog displays: 

 By section where you can select either the By values option or the By 
observation numbers option. The trimming and Winsorizing By values is 
applied to values found outside the defined limits. Observations found within 
the limits remain untouched. Trimming and Winsorizing By observation 
number is applied to the items found inside the defined limits and the items 
found outside the limits remain untouched. 

 Upper limit section – defines the upper limit including limit type, limit, 
optional new value, and new value type. 

 Lower limit section – defines the lower limit including limit type, limit, 
optional new value, and new value type. 

 Undo trimming button – resets the performed trimming or Winsorizing with 
the exception when selecting Deleting Obs. Deleting Obs. cannot be reset. 

 Apply button – performs the defined trimming or Winsorizing. The statistics 
are updated and displayed for the changed dataset. 

 Cancel button – cancels any unapplied trimming and closes the trim-Winz 
dialog. 
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Note: The Trim-Winz Var dialog remains open after clicking Apply to 
facilitate trim-Winsorizing of another variable.  

More about the upper and lower limit sections follows. 

 

Defining upper and lower limits By values 

The Upper limit and Lower limit sections are identical. To define the upper and lower 
limits By values follow the steps that follow: 

1. Under Metric select one of the options: 

a. Std Dev. to define and view the Cut-off value in robust standard 
deviation. The robust standard deviation is computed as the 
interquartile divided by 1.075. 

b. Value to define and view the Cut-off value as the real value. 

2. In the Cut-off value or Percentage fields, enter the value defining the cut 
off. When entering a value in the Cut-off value field, the Percentage field is 
automatically updated and vice versa. After defining the limit, note that the 
number of points affected is displayed in the Number of points field. 

3. Select what to do with the marked items by selecting one of the options 
available from the Replacement options menu, described in the table, and 
then click Apply. 
 



View 

413 

 

Replacement 
options 

New value Result and example 

Std. Dev. Number of robust 
standard 
deviations. 

Entering for instance 2 means that the 
limit is 2*robust standard deviation 
where the robust standard deviation is 
calculated as the interquartile/1.075. 

To view the actual number that will be 
used when replacing: 

1. Select Std Dev under Metric. 

2. Enter the number of standard 
deviations entered in the New 
value field, in the Cut-off value 
field. 

3. Click Value under Metric to 
automatically display the standard 
deviations value in real values in 
the Cut-off value field. 

Value The actual value 
to replace with. 

Enter the value ‘1’ replaces all marked 
values with ‘1’. 

To replace with missing, leave New 
value blank. 

Percent Percentage value. Replaces with the value at the entered 
percentage. 

To view the actual number that will be 
used when replacing: 

1. Select Value under Metric. 

2. Enter the percentage value 
entered in the New value field, in 
the Percentage field. The Cut-off 
value field is then updated to 
display the real value. 

Last good value No entry. Valid with Time Series and defined as 
the last value (in time) of this variable 
that was inside the limit. 

Delete Obs No entry. Irretrievably deletes the observations 
from the dataset. 

Note: When switching between displaying the limit in Std Dev. and Value the 
Cut-off value field is updated automatically. That is, if the limit is the value 
10, clicking Std Dev. automatically displays the corresponding value for 
standard deviations. 
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Defining upper and lower limits By observation numbers 

When selecting By observation numbers the fields available are the upper and lower 
limits, the Replacement options box and the New value field. 

1. In the Cut-off value fields, enter the observation numbers defining the lower 
and upper limits for the observations to trim or Winsorize. 

2. Select how to trim or Winsorize the marked items by clicking the arrow and 
selecting one of the items. For details, see table in the previous section 
Defining upper and lower limits By values. 

3. Click Apply. 



View 

415 

Trim-Winsorizing from Quick Info plot By values 

When trimming or Winsorizing interactively By values, the area outside the marking 
will be affected. 

To trim-Winsorize directly from the Quick Info plots Frequency Histogram or Time 
Series: 

1. Click the Trim-Winz Var button. 

2. Select the By values option to mark an area according to the value.  

3. In the histogram, vertically mark the area of the plot. Alternatively, in the 
time series plot, horizontally mark the area of the plot to keep. The area 
becomes white and the area outside the cut off limits becomes yellow. The 
Trim-Winz Var dialog is updated according to the marking displaying the 
cut-off values, percentages, and the number of marked data points. 

 
4. In the Replacement options boxes select how to replace and if applicable 

enter a value in the New value fields. 

5. Click Apply. 
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Trim-Winsorizing from Quick Info plot By observation numbers 

When trimming or Winsorizing interactively By observation numbers, the marked 
area will be affected. 

To trim-Winsorize directly from the Quick Info plot Time Series: 

1. Click the Trim-Winz Var button. 

2. Select the By observation numbers option to mark an area according to 
observation number. 

3. Vertically mark the area of the plot to trim or Winsorize. The area becomes 
yellow and the area outside the limits remains white. The Trim-Winz Var 
dialog is updated according to the marking displaying the limits, percentages, 
and the number of marked data points.  

 
4. Click Apply. 

Trim-Winz All dialog 

Trim-Winz All is used with large datasets where it would be impractical to trim one 
variable at a time. 
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To trim-Winsorize all variables at the same time: 

1. In the Upper limit and Lower limit sections select the Metric to cut by: Std 
Dev., Value, or Percent. 

2. In Cut-off value field enter the value to trim or Winsorize by. Anything 
outside these limits will be affected in the trim-Winsorizing. 

3. In the Replacement options box, select the metric or how to replace the 
affected values: Std.Dev., Value, Percent, Last Good Value, or Delete 
Obs. When the selected replacement type is Std.Dev., Value, or Percent 
enter values in the New value field. For more, see the table in the Defining 
upper and lower limits By values subsection previously in this chapter. 

4. Click OK. 

Trim-Winsorizing all variables example 

For example, to Winsorize the upper and lower 1% of the dataset and have the values 
above and below the 1% replaced by the values at 1%, the dialog should look as 
follows. 

 
Click OK and the following message is displayed: 
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Trim – Winsorizing a selection of variables 

To trim-Winsorize a selection of variables at the same time: 

1. Make the selections in the Trim-Winz All dialog as described in the Trim-
Winz All dialog subsection previously in this chapter. 

2. Click the Options button and select the desired subset of variables. 

3. Click OK. 

   

Trimming – Winsorizing using limits and values from secondary 
IDs 

When using Trim-Winz All, limits and new values can be defined from variable 
secondary IDs. 

Note: When selecting cut-off values or new values from secondary IDs, the 
corresponding fields in the main dialog become unavailable. 

1. In the Trim-Winz All dialog, click the Options button. 

2. Click the Limits tab. 

3. There are four sections: Upper limit, New upper value, Lower limit, and 
New lower value. Under each section select one of the options: 

a. Defined in main dialog to define the limit or new value in the 
Trim-Winz All dialog. 

b. Secondary Variable ID and then select the secondary ID holding 
the cut-off values or new values. 
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4.  Click OK. 

5. Select type metric of the cut-off-value and optional limits and new values – 
In the Trimming-Winsorizing dialog, the Cut-off value and New value 
fields specified by a secondary variable ID are unavailable. The Metric and 
Replacement options always have to be specified as well as values left with 
Defined in main dialog selected. 

For info on how to add secondary IDs to the dataset, see the Adding secondary IDs 
section in Dataset spreadsheet section in the Home chapter. 

Trim-Winsorizing using secondary ID example 

In this example the dataset holds two secondary variable IDs named 
PERCENTCutOffAndNewValueLOWER and VALUECutOffAndNewValueUPPER. 
PERCENTCutOffAndNewValueLOWER contains the lower cut-off value and new 
lower value in percent, 2%. VALUECutOffAndNewValueUPPER contains the upper 
cut-off values and new values in actual values. 

 
To use the secondary IDs as limits and new values: 

1. Click the Options-button, and then the Limit tab. 

2. Select the IDs as shown in the dialog and click OK. 
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3. In the Trim-Winz All dialog: 

 For the upper limit, select Value both as Metric and in the 
Replacement options box. This specifies to the Quick Info to 
interpret the Upper limit and New upper value from the 
secondary ID as values. 

 For the lower limit, select Percent both as Metric and in the 
Replacement options box. This specifies to the Quick Info to 
interpret the Lower limit and New lower value from the 
secondary ID as percent. 

 
4. Click OK and a summary message is displayed. 
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Variables window 
The Variables window displays the variables included in the workset of the active 
model. 

Right-clicking the window opens the shortcut menu holding the following commands: 
X, Y, Exclude, Select All, and Variable Label. These commands work as described in 
the Marked Items subsection previously in this section. 

   

Full Screen 
To maximize the plot area, leaving only the minimized ribbon and the plot area, on the 
View tab, click Full Screen. To return to normal, again click Full Screen. 

Add to Favorites 
Clicking Add to Favorites adds the active plot or list to the Favorites window. For 
more, see the Favorites section earlier in this chapter. 

Add to Report 
Clicking Add to Report adds the active plot or list to the HTML Report. For more, see 
the Generate Report section in the File chapter. 

Window group 
The Window group contains the regular window commands Cascade, Tile, and Close 
Window. Clicking the dialog box launcher opens the Arrange Windows dialog. 
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Plot and list contextual tabs 

The features available in the Plot and List, contextual tabs are context sensitive 
appearing when applicable.  

The Plot contextual tabs Tools and Layout become available when opening a plot and 
display the features applicable to the active plot. 

The List contextual tab Tools becomes available when opening a list and displays the 
features applicable to the active list. 

Marking in a plot or list opens the Marked Items contextual tab. 

The contextual tabs include features like: 

 The tools: Select, Zoom, Zoom Out, and Highlight Series. 

 The properties: Color by, Size by, etc. 

 The Change Type group features: Scatter, Column, List, Sources of 
Variation, Out of Control etc. 

 The layout features: loading and saving of templates, show/hide header, 
footer, legend etc. 

 After marking items: Exclude, Include, Labels, etc. 
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Mini-toolbar - format plot 
The mini-toolbar is available to customize the attributes of the plot. By default the 
mini-toolbar is displayed when you click and then move the cursor northeast. When 
right-clicking the mini-toolbar is displayed above the shortcut menu.   

By clicking an item, line, symbol, text, etc., you can change attributes such as line 
width, symbol type, color of a category, font in a text box, etc. 

 

 

Note: When clicking a symbol or column, that symbol or column is marked 
and the mini-toolbar for marked items appears. 

Features available when clicking in plots are described in the table. 

Click in plot area Mini-toolbar features – left to right 

An empty area in the plot 
area. 

Format Plot dialog, Properties dialog and zooming. 

A symbol. Symbol style, size and color for the marked symbol 
only. To change for all symbols in a series, use the 
legend. 

A line. Format Plot dialog, line width, style, and color of that 
specific line. 

A column. Color for the marked column only. To change for all 
columns in a series, use the legend. 

A limit. Format Plot dialog, line width, style, color and fill 
color of that specific line. The last button allows 
saving the current settings as default for the limit 
type. 

Note: After marking in a plot and making a change using the mini-toolbar, a 
new series named Custom is created in the Styles node in the Format Plot 
dialog, allowing further modification of the marked group.  

Features available when clicking in the legend are described in the table. 

Click in legend Mini-toolbar features – left to right 

Symbol 
Format Plot dialog, hide series, symbol style, size 
and color.  

Line 
Format Plot dialog, hide series, line width, style, and 
color of that specific line. 

Column Format Plot dialog, hide series, color. 

Color after category coloring Format Plot dialog, color. 
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Click in legend Mini-toolbar features – left to right 

Color with continuous 
coloring 

Format Plot dialog, color 1 (start color), color 2 (end 
color). 

Features available when clicking in a text box are described in the table. 

Click in text box Mini-toolbar features – left to right 

Any text box (header, footer, 
axis title, etc.) 

Format Plot dialog, hide selected, font face, font 
size, grow font, shrink font, bold, italic, font color and 
save as default style.   

In the figure below both the legend mini-toolbar and the marking mini-toolbars are 
displayed. To the right is the Color by feature floating after being torn off. 

 

Managing the mini-toolbar 
The mini-toolbar is always displayed above the shortcut menu, but you can specify 
when you want to see it after clicking or marking in plots. 

To hide the mini-toolbar that is displayed when marking: 

 Click the x in the mini-toolbar or 

 Click the cogwheel in the mini-toolbar that shows above the shortcut menu 
and clear Show mini-toolbar on selection. 

To hide the mini-toolbar that is displayed when clicking an item in a plot or in the 
legend without marking, click the cogwheel in the mini-toolbar that shows above the 
shortcut menu and clear Show mini-toolbar. 
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Tools tab 
The Tools contextual tab holds:  

 The Change Type group with Scatter, Line, Column, List, and optionally 
Out of Control Summary/Sources of Variation/Merge List. 

 The Data group with Model, Comp, Batch etc depending on open plot/list 
or window. 

 The Properties group with Color by, Labels, and Size by. 

 The Highlight group with the Select tool, Find, and highlight Series. Sort 
is also positioned in this group. 

 The zooming tools. 

 

Change Type 
In the Change Type group you can select to display the open plot or list as another 
plot type or create a list. When changing between the regular plot types the plot 
window is reused. 

The possible buttons are: 

 Scatter - Changes the current plot into a scatter plot. 

 Line - Changes the current plot into a line plot. 

 Column - Changes the current plot into a column plot. 

 List - Creates a list of the content of the current plot. For Dendrogram see 
the Create List for the HCA dendrogram subsection. See also the 
Creating lists subsection in the Marked Items tab section.  

 Out of Control Summary Plot (OOC) - described in the Out of Control 
Summary Plot (OOC) subsection in this section.  

 Batch Control Chart is available for the Out of Control Summary Plot 
and displays the batches displayed in the OOC plot in a batch control chart. 

 Sources of Variation Plot - described in the Sources of Variation Plot 
subsection in this section. 

 Merge List - available for the dendrogram plots.  

 Other plots dialog dispatch launcher - opens the Create Plot dialog 
described in the Creating plots subsection in the Marked Items tab section. 

Note: With any plot or list open you can create another plot or list using the 
same data by clicking Create | Plot on the shortcut menu. 
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Out of Control Summary Plot (OOC) 
The Out of Control Summary Plot, OOC plot, displays a normalized column plot for 
each batch that deviates from the limits in the current batch control chart, by 
integrating the area outside the selected limits, for the selected phase and component. 
The Y axis is in units of percent of the area outside the limits. 

The Out of Control Summary (OOCSum) for all the vectors is always computed on 
aligned vectors. 

Creating the out of control summary plot 
To open the OOC plot for the open batch control chart, on the Tools tab, click Out of 
Control Summary Plot. 

 
After creating the OOC plot you can recreate the batch control chart holding only the 
batches that were out of control by, clicking Batch Control Chart on the Tools tab. 

 

OOC plot example 
From the batch control chart the Out of Control Summary Plot was created. 
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In the Out of Control Summary Plot above, batch 28 has 20% of its area outside the 
limits. 

Creating Out of Control Summary Plot from Plot/List tab 
The OOCSum vectors can be plotted and listed from the Plot/List tab by: 

1. Clicking a plot type. 

2. Selecting Batch Vectors in the Select data type box. 

3. Adding the desired OOCSum vector. 

See also the Batch Vectors - Out Of Control Summary subsection in Appendix A: 
Statistics. 

Contribution plot from OOC plot 
Double-click any batch column in the Out of Control Summary Plot to display its 
contribution plot. 

Double-clicking a variable in the contribution plot opens the variable batch control 
chart. 
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Sources of Variation plot 
In batch level models it is useful to display the contribution and loading plots as line 
plots over time rather than column plots at every time point. Therefore the Sources of 
Variation plot is the default loading and contribution plot for all BLM with one or 
more score or raw variables. The Sources of Variation plot contains the exact same 
data as a loading or contribution plot would show. Instead of having the variable 
number on the x-axis, the maturity of the batch is used. This gives a better view of how 
the process variables relate to each other at different stages in the process.  

For projects with phases, this plot is displayed showing all phases. 

BLM with batch conditions 

Variables without maturity, i.e. batch conditions, cannot be shown in Sources of 
Variation plots. When the BLM contains batch conditions it can be useful to view the 
plot as a regular column plot too.  

To switch the Sources of Variation plot to a column plot, on the Tools tab, in the 
Change Type group, click Column. A normal loading plot can always be created from 
the Loading plot gallery, in the Diagnostics & Interpretation group on the Home tab, 
by selecting one of the standard options. 

Contribution plots in column form may be selected on the Marked Items tab, in the 
Drill Down group, by clicking Column in the comparison plot gallery. 

BLM loading and contribution plots example 

How to change between a Sources of Variation and a column plot is described in the 
table. This example uses a loading plot, but is applicable for contribution plots as well.  

Step Illustration 

1. On the Home tab, click 
Loadings.  

 
This plot displays how the selected variables 
variation over time differs from the average of 
batches or from another batch. 
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Step Illustration 

2. To transform to the 
column plot, on the Tools 
tab, in the Change Type 
group, click Column. 

 

3. To transform to the Sources of Variation plot, on the Tools tab, in the Change 
Type group, click Sources of Variation. 

4. To switch phases or displayed variables in the contribution plot open Properties 
and: 

 click the desired phase in the Select phase box. 

 add to the Selected list the variables to display. 

Create List for the HCA dendrogram 
With the HCA dendrogram plot open, click List to display all clusters and the 
calculated distances.  
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Create List for PLS-Tree 
With the PLS-Tree dendrogram plot open, clicking List, creates a list displaying 
details about the PLS-Tree sub-models. 

 

Merge List for HCA dendrogram 
With the HCA dendrogram open, Merge List is available in the Change Type group 
on the Tools tab. 

 
This command creates a list of the calculations behind the dendrogram. 
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Data group 
The Data group holds information about the active plot or list. These combo boxes 
allow you to switch between models, components, variables etc. 

 
  

Property 
available 

Description 

Model The model of the current window. Lists all models in the project. 

X-Axis 
Comp, Y-
Axis Comp, 
Z-Axis 
Comp. 

The component displayed on 1D, 2D, and 3D plots, such as Score 
Line Plot, Score Scatter Plot, and Score Scatter 3D Plot. 

Comp Component in the plot. 

Available for cumulative plots and DMod plots. 

X-Variable Lists all x-variables in the active model with the displayed x-
variables check boxes selected when more than one variable is 
displayed. 

Y-Variable Lists all y-variables in the active model with the displayed y-
variables check boxes selected when more than one y-variable is 
displayed. 

Observations Lists all observations in the active model, dataset, or predictionset 
with the displayed observations check boxes selected when more 
than one observation is displayed. 

Batch Displays all batches in the active model or predictionset with the 
currently displayed batches check boxes selected. When all check 
boxes are selected, All Batches is displayed in the Batch box. 

Some of the boxes in the Data group can be accessed using keystrokes. For more, see 
the Switching components, batches, and models subsection after this section. 
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Switching components, batches, and models 
Switching components on the plot axes, batches displayed, and model for the active 
plot is available using keystrokes shortcutting to the Tools tab, Data group. 

For regular projects, switch: 

 Components on the Y-axis by pressing the UP and DOWN arrow keys. 

 Components on the X-axis by pressing the LEFT and RIGHT arrow keys. 

 Models by pressing the PAGE UP and PAGE DOWN keys. 

For batch projects, in the batch control charts switch: 

 Components on the Y-axis by pressing the UP and DOWN arrow keys. 

 Batches by pressing the LEFT and RIGHT arrow keys. 

 Phases (models) by pressing the PAGE UP and PAGE DOWN keys. 

The active window and property bar are updated according to the changes. 

Properties group 
The Properties group, on the Tools tab, contains the commonly used Properties 
dialog features: Color by, Labels, and Size by. 

Note: Only a selection of coloring types is available from Color by. The Color 
page in Properties contains more coloring options.  

The Properties dialog is opened by clicking the dialog box launcher in the Properties 
group on the Tools tab. 

 

Color by on the Tools tab 
Color by is available for plots displaying observations or variables.  

Available are for example:  

 Default coloring - all points are colored the same color. 

 Color by Observation ID/Variable ID - the available secondary IDs are 
available.  

 Color by Variable - for observation plots the variables of the included 
datasets are listed. 

 Color by Batches - for batch control charts. 

 Color by Classes - for observation scatter plots where the model has more 
than one class specified. 

Note: Color by can be torn off and docked by pulling the dotted part. 
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Color by torn off from the ribbon and floating. 

 

Label Types for plots 
On the Tools tab, you can select the label type for the symbols in the current plot by 
clicking Labels in the Properties group. 

 
In the Properties dialog for plots, in the Label Types page, the labels to use as Point 
Label, Axis Label, and Title label can be specified. 

To specify a Point Label: 

1. Select the primary or secondary identifiers in the Use label box. 

2. Enter the character in the label to start with in the Start field. 

3. Enter the number of characters to use in the Length field. 

To specify an Axis Label: 

1. Select the primary or secondary identifiers in the Use label box. 

2. Enter the character in the label to start with in the Start field. 

3. Enter the number of characters to use in the Length field. 
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To specify the Title labels: 

1. Click the Title labels box. 

2. Select the desired variable ID. 

Note: The variable ID selected in the Title labels box is displayed in all 
applicable headers, footers, legends, and axis labels. 

 

Label Types for lists 
On the Tools tab, in the Properties group, you can select to Display all labels or a 
specific label in the list using Labels.  

 
In the Properties dialog for lists, in the Label Types page, the following options are 
available: 

1. Displaying a specific ID by selecting Use identifier and 

a. Selecting an identifier in the list. By default the primary ID. 

b. Enter the character in start with in the Start field. By default 1. 

c. Enter the number of characters to use in the Length field. By 
default 10. 

2. Selecting Display all identifiers resulting in displaying all available 
identifiers in their full length. 
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Size by 
The plot marks of all scatter plots, both 2D and 3D, can be sized according to a 
selected vector. Additionally, all scatter plots of vectors of the type variables and 
scores can be enlarged when the observation is found outside the D-Crit of DModX or 
DModXPS. 

Sizing is available on the Tools tab, in the Properties group, by clicking Size by. 
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Sizing by a vector 

When selecting to Size by Vector, the Properties dialog opens and all applicable 
vectors are available.  

For instance, for a score plot, all vectors found with data type Variables and Scores in 
the Plot/List | Scatter dialog are available. 

When clicking OK, the size of the plot marks will be smaller or larger than the default 
plot mark depending on the value for the specific observation or variable in the 
selected vector. 

 

Enlarging when outside D-Crit 

When clicking Size by | Enlarge when outside D-Crit, all observations with DModX 
outside D-Crit are enlarged. 

 
Enlarge when outside D-Crit is only available for plots displaying observations. 

To shrink or enlarge all plot symbols, use Symbol Style page in Format Plot. 

Properties dialog 
All plots and lists have a context sensitive Properties dialog. Many of the pages in this 
dialog are general and available for several plot types. These pages are described in 
this section. Other pages are plot specific and are therefore described in connection 
with the description of the plot. 

The table describes the different ways to open the Properties dialog. 
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Open Properties by Screenshot 

Clicking the plot (in an area where there 
is no points) and clicking Properties in 
the mini-toolbar  

Clicking the dialog box launcher in the 
Properties group on the Tools tab 

 

Right-clicking the plot and clicking 
Properties from the shortcut menu. 

 

The property pages described in this section are: 

 Color 

 Label Types for plots - earlier in this section. 

 Label Types for lists - earlier in this section. 

 Size - earlier in this section. 

 Item Selection 

 Limits 

 Components 

 Select Y Variable 

 Number Format 

Color in the Properties dialog 

With all plots displaying variables or observations, the plot symbol, line, or column 
can be colored as described in the table, by clicking Color by on the Tools tab. 
Clicking More options opens the Properties dialog with the Color tab open. Here all 
coloring types for the active plot are available. 

Note: When coloring a line plot, the connecting line when the line changes 
color starts with one color and gradually turns into the other. However, when 
a point in a line plot does not have a connecting line on either side, the plot 
mark of that point is displayed. 
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This table describes the coloring types available in the Color page and how to specify 
after selecting the respective coloring in the Coloring type box. 

Note: The color of the classes/batches/categories etc can be changed in 
Format Plot, Styles, Category Coloring. 

Color by Action 

Batches Plots created for batch evolution models can be colored by Batches.  

When coloring by Batches, each batch is then assigned a color that it 
keeps independent of which batches are displayed in the plot. 

Classes When classes are present in the plot, the observations are by default 
colored by Classes. 

To change the colors of the individual classes, use the legend mini-
toolbar, or Format Plot, Styles, Category Coloring. 

Density When a plot has many observations, coloring by Density (density 
function) is sometime useful. 

When coloring by Density, the plot marks are colored according to 
how many points are positioned close to them. This means that, using 
the automatic color scheme, a point with many points close is colored 
red while a point with few points close is colored blue. 

Available for plots displaying variables or observations. 

To change the start and end colors, use the legend mini-toolbar or 
Format Plot, Styles, Coloring. 

Identifiers To color by Identifier: 

1. Select the identifier in the Choose the ID to color by box. By 
default the first secondary ID is selected. 

2. In the Start and Length fields enter values to specify which 
characters in the ID to use. 

Available for plots displaying variables or observations. 

To change the color, use the legend mini-toolbar or Format Plot, 
Styles, Category Coloring. 

Observation 
Classes 

When classes have been specified, each line of the XObs, YObs and 
Spectra plots can be colored by the class belonging of the observation. 

Observation 
Identifiers 

Each line of the XObs, YObs and Spectra plots can be colored by the 
observation ID. For how to specify, see the Identifiers description 
above. 

Observation 
Vectors 

Each line of the XObs, YObs and Spectra plots can be colored by an 
observation vector. For how to specify, see the Vector (continuous) 
description below. 

Marked 
Groups 

When observations are marked, you can color by Marked Groups. 

When coloring by Marked Groups the observations in the first group 
are displayed in one color, the observations in the second group in 
another color, etc. 

Available for plots displaying variables or observations and especially 
useful after marking using the Group Dendrogram Clusters tool.   
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Color by Action 

Models and 
Predictions 

Prediction plots can be colored by Models and Predictions. This 
means that observations belonging to different models are colored in 
different colors and the observations that are not part of a model are 
colored in yet another color. 

Useful in the Coomans' plot. 

Patterns To color by parts of identifiers, by Patterns: 

1. Select the identifier in the Choose the ID to color by box. By 
default the first secondary ID is selected. 

2. Select Begins with, Contains, Ends with, or Equal to in the 
Pattern box. 

3. Enter the characters to color by. 

4. Click the Add Pattern button. 

5. Repeat 1-4 until done. 

Available for plots displaying variables or observations. 

Predictions Observations that are part of the workset are colored in one color, and 
observations that are only part of the predictionset are colored in 
another color. 

Terms Plots displaying variables can be colored by Terms. This results in that 
all types of terms (original X, expanded terms square, cross, cubic, 
etc.) are colored in different colors. 

Color by Terms is the default for the loading scatter plot. 

Variable 
Classes 

When variables have been assigned to blocks, use Variable Classes 
to color these blocks. 

Vector 
(Categories) 

To color by Categories: 

1. Select data source and variable in the Data respective Item 
boxes. Note here that both model terms and variables are 
available. 

2. Optionally enter the desired number of groups in the Split range 
field. 

3. Click the Add Category button. 

4. The range of the added categories can be modified by clicking 
the category and modifying the fields beneath the Remove All 
button. 

Note: To color by batch conditions or hierarchical variables, select that 
dataset in the Data box. To color by model results, select the model in 
Data and the vector in Item. 

Vector 
(Continuous) 

To color by Vector (Continuous), select data source and variable in 
the Data respective Item boxes. Note here that both model terms and 
variables are available in Item. 

Note: To color by batch conditions or hierarchical variables, select that 
dataset in the Data box. To color by model results, select the model in 
Data and the vector in Item. 



Plot and list contextual tabs 

441 

 

SIMCA by default remembers the selected coloring when opening the next plot. 
For more, see the More Options subsection in the SIMCA Options section in the 
File chapter. 

Item Selection 

To remove some items from the current plot or list: 

1. Mark the points in the plot. 

2. Click Hide on the Marked Items tab. 

As a result the Item Selection page in the Properties dialog is updated accordingly.  

The Item Selection page displays the Selected and Unselected items. Removing and 
adding items from the current plot or list can also be done here. 

1. Select the items in the Selected list. 

2. Click <= to move them to the Unselected list. 

To display a different identifier, select another ID by clicking the ID box. 

 
For more about the Find feature, see the Find feature in workset dialog subsection in 
the Workset section in the Home chapter. 

Limits 

The Limits page enables customizing the displayed confidence intervals, limits, or 
ellipse. 
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The following plots have a Limits page in their Properties dialog for the described 
limits: 

Plot Limit Option 

Score 
Scatter Plot, 
2D and 3D 

Hotelling's 
T2 ellipse 

T2 Ellipse box with: Display (default) and Hide. 

Significance level field with default value 0.05. 

 

Score Line 
Plot 

Standard 
deviation 
lines 

SD Limits box with: Display (default) and Hide. 

Customize SD Limits field with the default -3 -2 0 2 
3. 

Note that all limits inside the range -3 to 3 are 
colored in green, and all outside red. 

'0' represents the average. 

 

Score and 
Loading 
Column 
plots, 
Coefficient 
Plot, and 
VIP. 

Jack-
knifing 
uncertainty 
bars on the 
columns 

Confidence level box with: Default (the setting in 
Model Options),  None (to not display the error 
bars), 99%, 95%, and 90%. 

 

Hotelling's 
T2Range 

95% and 
99% T2Crit 

T2Crit Limits box with: Display (default) and Hide. 

 

Distance to 
model 

D-Crit D-Crit Limit box with: Display (default) and Hide. 

Significance level field with default value 0.05. 
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Plot Limit Option 

Y Predicted 
Column Plot 

Jack-
knifing 
uncertainty 
bars on the 
columns 

YPredPS Confidence Interval box with: Display 
(default) and Hide. 

 

Coomans' 
Plot 

D-Crit D-Crit Limit boxes with: Display (default) and Hide. 

 

 

Components in Properties 

For a number of plots, the Properties dialog has a Components page. 

Use this page to select for which components to display the plot. 

For instance, selecting another component than Last Component for the Coefficient 
Plot will display the plot cumulative including the selected component. 

For the Hotelling's T2Range Plot, both the From component and To component has 
to be selected. 

Note: When adding a plot to Favorites or the report, Last Component is often 
preferable.  

Select Y Variable 

The Coefficient Plot, Residual Normal Probability Plot, Observed vs. Predicted 
Plot, and all Y Predicted plots found in the Y PS gallery on the Predict tab, are all 
displayed for one y-variable at a time. By default the plots are displayed for the first y-
variable. 
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To switch to another y-variable in the plot use one of the following methods: 

 Click the Y-Variable box in the Data group on the Tools tab, and select 
the desired y-variable. 

 Right-click the plot, click Properties, click the Select Y Variable tab, 
and select the new variable in the Select Y Variable box. 

Number Format 

Selecting the number format type and precision applies only to lists. 

 
The available format types in the Type box are: 

 Default - displaying the numbers in decimal format with the number of 
digits stated in the Precision box but leaving ending zeros hidden. 

 Exponential - displaying the exponential format using the stated Precision. 

 Decimal - displaying the number of decimals stated in the Precision box. 

The values can be displayed using 1-6 digits. This is selectable in the Precision box. 

Select - Marking tool 
The Select-button is used to select which type of marking to use. 

Click the small arrow below the button and click the type of marker from the menu. 
The available marking types are: 

 Free-form selection: Allows marking to take any shape. 

 Rectangular selection: Allows marking in a rectangular shape. 

 Select along the X-axis: Marks as a vertical bar. 

 Select along the Y-axis: Marks as a horizontal bar. 

 Batch Marking Mode: Marks all observations belonging to the selected 
batch. Using the Exclude button after marking an entire batch excludes the 
selected batch from all the models (phases). A new BM model is 
automatically generated with a BEM holding a PLS model for each phase. 

 Group Dendrogram Clusters: Available for an open Dendrogram and 
displays a horizontal line with which the resolution of the dendrogram is 
specified, and thereby the number of clusters. For more, see the Group 
Dendrogram Clusters marking tool subsection in the Analyze chapter. 
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Note: The Batch Marking Mode is an on/off switch to marking entire batches 
instead of points. The marking type is still Free-form selection, Rectangular 
selection etc. 

The table displays the available commands from the Select plot items tool. 

Menu Available for 

 

Regular project standard plots. 

 

Batch evolution models standard plots. 

 

Dendrogram plots open in any project. 

Note: To keep the marked points marked, while marking new points, hold 
down CTRL. The marked points then belong to the same group of marked 
items. 

Deselecting/unmarking points 
To deselect points in a plot, click a white area in the plot. 

To deselect points in a list, mark the first row. 

See also the Marked Items tab section later in this chapter. 

Displaying properties of the item 
When positioning the cursor on an item in a plot, the marker behaves as a pointer and 
displays the name and coordinates of the observation or variable.  
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Creating contribution plots 
With any marker: 

1. Double-click an observation in a score plot for instance. The contribution 
plot opens, comparing the variables of the selected observation to the 
average of all the observations in the workset. This plot indicates why the 
selected observation is different from the average. 

2. Click the first observation, and then double click the second observation. The 
resulting contribution indicates why the first observation differs from the 
second. 

For more about creating contribution plots, see the Creating plots from plots section 
later in this chapter. 

Selecting points according to color in legend 
All points in a color can be selected by clicking that color in the legend.  

 

Find 
With an active plot, list or spreadsheet, Find enables finding items meeting selected 
criteria. 

The Find dialog is opened by clicking Find in the Highlight group on the Tools tab, 
by pressing CTRL+F or from the Quick Access Toolbar. 
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In the table, the available items in the Find in, Find what, and Logical Expression 
boxes are listed. 

Find in Searches in Logical expressions 

Identifiers  The text or values of the selected 
identifier, primary or secondary, or all 
identifiers. 

For batches the secondary identifiers 
include the batch level IDs Phase, 
Maturity, Source, and Number, and 
the batch project IDs $BatchID and 
$PhaseID when available. 

For numerical identifiers:  

>, >=, <, <=, between, =, 
not equal. 

For text identifiers: 

begins with, ends with, 
contains, =, not equal. 

All Data  The vectors displayed on all axes. For 
the default score scatter plot, the 
search is done on both t1 and t2. 

>, >=, <, <=, between, =, 
not equal.  

Series 
Data  

The vectors that are selected as 
series. For 2D scatter, line, and 
column plots that means that the 
search is limited to the y-axis vectors 
while for the 3D scatter plot the search 
is limited to the z-axis vectors. For 
example, for the default score scatter 
plot, the search is limited to searching 
in the vector t2 found on the y-axis. 
For lists, this option is the same as All 
Data. 

>, >=, <, <=, between, =, 
not equal.  

X Axis  The vector displayed on the x-axis. 
Available for plots only. 

>, >=, <, <=, between, =, 
not equal.  

Vectors The selected vector in Find what. 

When selecting Vectors in Find in: 

 The Find what box contains all 
vectors available for the type of 
vector displayed in the active 
plot or list, e.g. if the plot 
displays t1 vs. t2, the available 
vectors are all vectors of data 
type Variables and Scores. 

 The Vector Details section 
becomes available enabling 
selection of model. 

>, >=, <, <=, between, =, 
not equal.  
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Find in Searches in Logical expressions 

Text  The list as if all entries where text and 
marks the matching cells. Available for 
lists and spreadsheets only. 

begins with, ends with, 
contains, =, not equal. 

Note: To search in a variable, in the Find in box select Vectors and in the 
Find what box select XVar. Then in the X Terms box in the Vector details 
section, select the desired variable. 

Highlight Series 
With highlight Series clicked, hovering over one series in the legend grays all series 
but the hovered one. 

 

Sorting ascending or descending 
All lists, the dataset spreadsheets, and column plots can be sorted ascending or 
descending. 

 

Sorting lists 
Sorting of the dataset spreadsheet is available both as sorting the presentation and as 
sorting the dataset. Sorting is only available when one variable is marked. 

To sort: 

1. Mark the variable to sort by. 

2. On the Tools tab click Sort | Sort ascending or Sort descending. 

3. When sorting a dataset, in the Sort Dataset dialog that opens select: 

a. Sort the list to sort only the presentation of the data in this 
spreadsheet. This sorting will not delete the models, only sort the 
list. When creating a new workset, the original order of the 
observations will be used. 

b. Sort the dataset to sort the dataset the models are built from. With 
this option all models will be deleted. When creating a new 
workset, the new sorted order of the observations will be used. 

Note: Read-only datasets cannot be sorted. 
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Sorting column plot by value or ID 
All column plots, including contributions, can be sorted by strings in the primary or 
secondary ID and/or by values. This allows displaying variables grouped as desired. 
The various groups will have different colors. 

To sort a column plot: 

 On the Tools tab, in the Highlight group, click Sort. 

 Alternatively, right-click the column plot and then click Sort Ascending or 
Sort Descending. 

To sort a column plot by ID 

1. On the Tools tab, in the Highlight group, click Sort | Advanced sorting.  

2. Select how to sort the data in the Sort Items dialog and then click OK. 

 
The Sort Items dialog is described in the table below. 

Option Description Default 

Sort by ID Select the Sort by ID check box to sort 
the column plot by the selected ID. 

After selecting the Sort 
by ID check box, the 
primary ID is the default. 

Start To sort by a part of the ID, enter the 
start character position in the Start 
field. 

'1' which means that the 
starting point is the first 
character. 

Length To sort by a part of the ID, enter the 
number of characters to use in the 
Length field. 

By default the entire ID 
is used in the sorting, 
that is Length is 
<empty>. 

Color by 
identifiers 

Select the Color by identifiers check 
box to color the columns according the 
identifier selected to sort by. 

Not selected. 

Sort by Selecting the Sort by check box and in 
the Sort by box select value or 
absolute value to sort the column plot 
accordingly. Selecting to sort by 
absolute value results in sorting 
according to size of the column, 
independent of whether it is positive or 
negative. 

After selecting the Sort 
by check box, value is 
by default selected. 
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Option Description Default 

In series When selecting the Sort by check box, 
the sorting has to be done using one of 
the series in the plot.  When available 
you can select another series if 
desired. 

After selecting the Sort 
by check box, the first 
series is by default 
selected. 

Zooming in 
To zoom in a plot, click the Zoom tool in the Zoom group. By default Zoom In is 
selected. 

 
Use the Zoom menu to select the type of zoom from the drop down menu: 

 Zoom In: Magnifies a rectangular region 

 Zoom X: Expands the x direction 

 Zoom Y: Expands the y direction 

 Zoom subplot: Magnifies a subplot in a multi-plot display.  

Then mark the desired region, or subplot, of the plot to zoom. 

Note: With any zooming type selected, double-clicking a subplot 
automatically zooms the subplot. 

Zooming in a scatter 3D plot is described in the Zooming in 3D scatter plot 
subsection in the Score Scatter 3D Plot section in the Home chapter. 

Zooming out 
Click Zoom Out to revert zoom to original scale in the steps taken when zooming. 

Zoom Out is available for all lists and spreadsheets from the shortcut menu.  

Layout tab 
The Layout contextual tab holds features pertaining to how the plot is displayed. 

 
The Templates group holds the features concerning the formatting in the plot. 
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The Show group controls which texts outside the plot are that are displayed, plus the 
Regression Line (for 1D and 2D plots) and the Resolve Coefficients for hierarchical 
top model coefficient plots. 

Format Plot to the right on the tab opens the Format Plot dialog.   

Templates group 
The Templates group holds features pertaining to the formatting of plots. This tab is 
available when the active window is a plot. 

The following features are available:  

 Load described in Switching plot formatting templates subsection. 

 Save as and Save as Default described in Saving Format Plot template 
subsection. 

 Open templates folder - opens the folder holding the templates when 
clicked. 

 Restore Default described in Restoring to default plot 
formatting subsection. 

The Format Plot is positioned to the far right on this tab, but is described in the 
Format Plot section later in this section. 

 

Switching plot formatting templates 
After having added customized plot formatting templates, these templates can be 
selected by clicking the Load button. 

After loading a new template, that template is applied to all open and future plots.  

The template Default (optimized for speed) should be used when your project has so 
much data that the plotting becomes slow. In this template the most CPU consuming 
features have been turned off.   

 

Saving Format Plot template 
After customizing the plots using Format Plot you can save the settings of some 
attributes, such as fonts, gridlines, symbol type etc, to a template. 

To save a template, with the plot open, click Save as Default or Save as and specify a 
name. 
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Note: Only the formatting available in the current plot is saved to the 
customized plot formatting configuration. All other formatting will remain 
default. This means that formatting of headers, footers etc. apply to all plot 
types (e.g. scatter, column, line) while default line color, default symbol shape 
are plot specific and need to be specified with that plot type open. 

Restoring to default plot formatting 
To restore to the Umetrics default plot formatting template, click Restore Default. 

Clicking Restore restores the Default plot formatting to the Umetrics default plot 
formatting and switches to it. 

Format Plot 
The most common attributes of the plot axes, plot area and of the header and footer can 
be customized directly in the plot using the mini-toolbar, or by opening the Format 
Plot dialog.  

The mini-toolbar is displayed after clicking an item (header, footer, legend, symbol, 
column etc.) and moving the cursor northeast.  

To open the Format Plot dialog use one of the following methods: 

 On the Layout tab, click Format Plot (button to the far right). 

 Double-click the plot area, header or footer, or axes in the plot. 

 Right-click the plot and then click Format Plot. 

Axis 

The properties under the Axis node apply to the selected axis: Axis X, Axis Y, Axis 
Y2 (second Y-axis) etc. 
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In the Format Plot dialog, Axis node, click: 

 The respective axis to customize the scaling of the selected axis, annotation 
rotation etc. 

 Axis General to access the following pages: 

1. Axis General to customize color, width and other properties of all 
axes.  

2. Tick Marks to select how to display major and minor tick marks.  

3. Axis Font to customize the font of the axis annotation.  

4. Title Font to customize the font of all axis titles. 

Changing the scale, tick mark label and the axis properties 

Use the General page of the Format Axes dialog to change the scale, tick mark label 
and axis properties of the currently marked axis. 

 

Individual axes 

The content for the individual axes is described in the table below: 

Field/button 
name 

Displays Result after entering a new 
value and clicking Apply 

Axis 

Show axis Default selected. If cleared, that axis is not displayed. 

Minimum Start point for the 
selected axis when 
the values are 
displayed in regular 
order.  For time-
variables the page is 
adjusted, see the 
Time axis topic. 

The new start point is used for the 
selected axis. 
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Field/button 
name 

Displays Result after entering a new 
value and clicking Apply 

Maximum End point for the 
selected axis when 
the values are 
displayed in regular 
order. 

The new end point is used for the 
selected axis. 

Auto adjust 
scales for 
suitable limits 
and step size 

Default selected. If cleared, enables the Step size 
field. 

Step size Default disabled. The entered value defines the major 
tick mark spacing for the selected 
axis.  

Reverse axis Default cleared. If selected, the scale is displayed 
with the highest number to the left 
and the lowest to the right. 

Annotation 

Rotation Default No Rotation. Selecting 90 degrees displays the 
annotation turned 90 degrees. 

Title 

Show title Default selected. If cleared, the axis title is not 
displayed. 

Title The vector name. The new title. Title changes cannot 
be saved. 

Note that the distance between the tick marks is constant. 

 
When you have more than one series in a plot, you can select to display more than one 
y-axis. For more, see the Multiple Y axes subsection later in this chapter. 
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Time axis  

The content for the Axis X and Axis X Title pages for a time variable is described in 
the table below: 

Field/button 
name 

Displays Result after entering a new 
value and clicking Apply 

Show axis Default selected. If cleared, that axis is not displayed. 

Minimum Start point in time 
units. Change by 
typing in the field. 

The new start point is used for the 
selected axis. 

Maximum End point in time 
units. Change by 
typing in the field. 

The new end point is used for the 
selected axis. 

Auto adjust 
scales for 
suitable limits 
and step size 

Default selected. If cleared, enables the Step size 
field. 

Step size Default disabled. The entered value defines the major 
tick mark spacing  for the selected 
axis. 

unit The unit of the step 
size. 

Switching between units updates the 
step size automatically. 

Axis X Title tab 

Rotation under 
Annotation 

Default No Rotation. Selecting 90 degrees displays the 
annotation turned 90 degrees. 

Show title 
under Title 

Default selected. If cleared, the axis title is not 
displayed. 

Title The vector name. The new title. Title changes cannot 
be saved. 

Note that the distance between the tick marks is constant. 
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Axis General  

In Axis General the following features are available and are applied for all axes: 

 Axis Color and Width. 

 Autoscale - when selected it autoscales all axis. Clearing it makes the current 
ranges of the axes stick even if the vector displayed is switched. 

 Show arrows - when selected the arrows are displayed at the end of the axes. 

 Arrow Color - Automatic here means the same as the axis color. 

 Annotation Color and Distance from axis.  

 Axis title Color. 

 

Tick Marks  

Use the Tick Marks page to specify how the tick marks should be oriented and how 
long they should be. 

Under Major tick marks and Minor tick marks the same boxes are available:  

 Tick mark type - where None is no tick mark, Outside is to have the tick 
mark outside the axis, Inside is to have the tick mark inside the axis and 
Cross is to have the tick mark on both sides of the axis. 

 Tick mark size is the length of the tick mark. 
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Font 

Use the respective font pages, to select the Font, Font style, Size, and Effects for the 
annotation, title, etc. 

 
  

Section Description 

Font Displays the currently selected font. Click another font to switch. 

Font 
style 

Displays the current font style. Select to display the text Regular 
(default), Bold, Italic, or Bold Italic. 

Size Displays the current size. Select another size as desired. 

Preview 
Displays a preview of the expected text according to the selections 
above. 

Anti 
aliased, 
Filled 
check 
boxes 

Allows selecting to display the text Anti aliased and/or Filled or 
neither. 
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Customizing the gridlines 

Use the Gridlines page to customize the gridlines and grid stripes. The gridlines are 
placed on the major tick marks. Grid stripes are the areas between the gridlines, where 
every second such area can be colored. 

Note: Gridlines and grid stripes can be specified individually for Vertical and 
Horizontal. Specification using the node applies to both. 

The following is available: 

Option/Box/Field Description 

No gridlines No gridlines are displayed when No gridlines is 
selected. 

Gridline When selecting Gridline you can select to display the 
lines Solid, Long Dash, Dotted, or Dashdot.  

Gridline Color The color of the grid, by default gray. 

Width The width of the gridlines. 

No grid stripes No grid stripes are displayed when No grid stripes is 
selected. 

Grid stripe Solid fill When selecting Solid fill the grid stripes are displayed in 
the selected color.  

Grid stripe Color Displays the current color and allows selecting a new 
color. 

Grid stripe Gradient 
fill 

When selecting Gradient fill you can select to display 
the stripes Horizontal, Vertical, Forward Diagonal, 
Backward Diagonal, Radial, Horizontal Bar, Vertical Bar. 

Grid stripe Color 2 Displays the current color and allows selecting a new 
second color for Gradient fill. 
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Background  

The Background node controls the attributes of the background displayed in the plot. 

Note: The background fill and border can be specified individually for the 
Window Area and Plot Area. Specification using the node applies to both. 

The table describes the available options: 

Option/Box/Field Description 

Fill 

No fill No background is displayed when No fill is selected. 

Sold fill When selecting Solid fill the background is displayed in 
the selected color.  

Gradient Fill When selecting Gradient fill you can select to display the 
background Horizontal, Vertical, Forward Diagonal, 
Backward Diagonal, Radial, Horizontal Bar, Vertical Bar.  

Color Displays the current color and allows selecting a new color 
for the background. 

Color 2 Displays the current color and allows selecting a new 
second color for Gradient fill.  

Border 

No border No border around the background area is displayed when 
No border is selected. 

Solid line When selecting Solid fill, the background is displayed in 
the selected color.  

Color Displays the current color and allows selecting a new color 
for the border. 

Width The width of the border. 
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Titles in Format Plot 

Use the Format Plot dialog to customize the items available in the Titles node. When 
customizing, the changes apply to the selected item, 
Header/Footer/Timestamp/Subheader. 

Note: Changing color, font and size of the 
Header/Footer/Timestamp/Subheader can be done directly in the plot by 
clicking and using the mini-toolbar. 

   
On the Titles page: 

 Select to hide or show by selecting or clearing the Is Visible check box. 

 Select where to display the title in the Anchor box, when applicable. 

 Customize the text displayed by changing or typing in the field. 

 Align the text right, center, or right by clicking the appropriate alignment 
button. 

 Customize the color of the text in the Text color box. 

 Customize the background color by clicking the Background color box. 

 Select to display a border by selecting the Is visible check box in the Border 
section. With it selected you can customize Color, Margin (to the text) and 
Width of the border.  

On the Font page you can select the Font, Font style, Size, and Effects. See also the 
Font subsection earlier in this chapter. 

Legend 

The Legend page controls the attributes of the legend, such as placement, color, and 
border. 
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The table describes the available options: 

Option/Box/Field Description 

Placement section 

Show legend The legend is displayed when the Show legend check 
box is selected. 

Position By default the legend is positioned Top right. To change 
from the default, click one of the available placement 
options. 

Orientation The orientation is by default Vertical. Horizontal is the 
other option. 

Text alignment Alignment of the text in the legend is by default Left. 
Right and Center are the other options. 

Color section 

Text color By default the text is black. 

To customize text color of the legend, click the Text 
color box. 

Background color The default background color is white. 

To select another color, click the Background color 
box. 

Border section 

Is visible By default the border is not displayed. To display the 
border around the legend, select the Is visible check 
box. 

Color To customize the border color of the legend, click the 
Color box in the Border section. 

Margin To specify the margin to the text, change the value in the 
Margin field. 

Width To increase or decrease the width, enter a new number 
in the Width field. 
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Limits and Regions 

There are a number of limits available in plots in SIMCA, for instance the ellipse in the 
score scatter plot, the DCrit limit in the DModX plot etc. Additionally there are 
regions, such as the background of phases in batch control charts and models in 
hierarchical top model coefficient and contribution plots that are colored to 
differentiate between models.  

The attributes of the limits and regions can be modified individually for each limit and 
region type under the Limits and Regions node in the Format Plot dialog, in the 
respective Region Style pages. The Region Style page is described in this section. 

For multi plots, Control Charts and Wavelet Structure, the limit pages are 
positioned last in the Format Plot dialog under Plot 1, Plot 2, Plot 3, etc. 

For batch control charts, the limit pages are positioned under Styles.   

Customizing Limits and Regions 

The selected limit or region can be customized in the Region Style page.  

Feature Description 

Line  

Style Select between No line, Solid, Long Dash, Dotted, Dash Dot. 

Width Increase or decrease as desired. 

Color Displays the current color and allows selecting a new color. 

Fill 

Type Select to fill the area Over or Under the limit, or select No fill. 

Style 
Select the fill to be Solid or Gradient. Selecting Solid enables the Color 
1 box and selecting Gradient enables the Gradient, Color 1 and Color 
2 boxes. 

Gradient 
When selecting Gradient you can select to display the fill Horizontal, 
Vertical, Forward Diagonal, Backward Diagonal, Radial, Horizontal Bar, 
Vertical Bar. 

Color 1 Displays the current color and allows selecting a new color.  

Color 2 
Displays the current color and allows selecting a new color. Available 
when the Style is Gradient. 

Font tab - see the Font topic. 

Label Style - see the Labels topic. 
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To not display the limit, see the Limits subsection previously in this chapter in the 
Tools section. 

Label Style  

The Labels pages control the attributes of the displayed plot marks. Color, alignment, 
font and rotation apply to all labels in a given series. 

The tabs available in the Labels node, Label Style, Font and General, are described 
in the table. 

Option/Box/Field Description 

Label section in Label Styles 

Position The default position of the label in reference to the point is 
Right. To position the label in another direction, click the 
Position box and make a new selection. 

Offset The offset defines the distance between the label and what 
it labels in the direction of the selected Position. 

To increase or decrease the distance between the label 
and item, enter a new value in the Offset field. 

Rotation The default rotation of the labels is 0. To rotate the label, 
enter a new value in the Rotation field. Note that this field 
is unavailable when Avoid overlapping labels has been 
selected in the General tab. 

Color section in Label Styles 

Text color Displays the current color of the text in the label and allows 
selecting a new color. Automatic displays the text in the 
same color as the symbol fill 

Background color The background color of the label is default transparent. To 
select a color, click the Color box and make the selection. 

Border section in Label Styles 

Is visible By default, no border for the label is displayed. To display a 
border around the label select the Is visible check box. 
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Option/Box/Field Description 

Color Displays the current color of the border and allows 
selecting a new color. 

Margin The margin between the text and the border can be 
customized in the Margin field. 

Width To increase or decrease the width, enter a new number in 
the Width field. 

Draw connection 
line 

Draw connection line is by default cleared. Selecting it 
will display a thin line between the label and its point. 

Font tab - see the Font topic. 

General tab 

Avoid overlapping 
labels 

With Avoid overlapping labels selected, point labels will 
try not to overlap each other. A high specified limit in the 
Limit field in combination with many labels can be quite 
time consuming.  

 

Error Bars 

The Error Bars page controls the attributes of the error bars displayed in the score, 
loading, coefficient, VIP, and Y PS column plots. 

The settings available are: 

 Is visible - hides the error bars when cleared. 

 Color of the error bars - by default black. To display the error bars in any 
other color, click the Color box. 

 Line width of the vertical and horizontal lines. To display wider error bars, 
enter a new number in the field. 

 Error bar width is how wide the horizontal line is compared to the column. 
By default 60%. 
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Styles 

In the Styles node the attributes of the series, Category Coloring and for BCC 
plots also limits can be customized.  

   
The available pages in the Styles node, different depending on which plot is open, are: 

 Marking Style 

 Category coloring 

 Symbol Style 

 Line Style 

 Column Style 

 Fill Style - See Region Style Fill section. 

 Options 

 Y-Axis 

 Font 
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Marking style  

In the Marking Style page you can change the marking colors by marking and 
selecting a new color in the color box to the right. 

 

Category coloring  

Category coloring is available after coloring and the Use different symbols on 
category colored values check box in the Options page is not selected.  

In this page, the colors can be changed as desired.  
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Symbol Style 

The Symbol Style page controls the attributes of the symbols displayed in the plot. 

The table describes the available options: 

Option/Box/Field Description 

Shape The shapes of the series can be changed by: 

1. Marking a series. 

2. Selecting a new shape in the Shape box. 

With None selected, no symbols are displayed. 

Size To increase or decrease the size, enter a new number in 
the Size field.  

After using the Size by feature, changing the value in Size 
affects the points proportionally. 

Fill 

No fill Results in symbols transparent inside the outline. 

Solid fill Displays the color selected in Color.  

Gradient fill Allows you to select to display the symbol with a gradient 
fill of type Horizontal, Vertical, Forward Diagonal, 
Backward Diagonal, Radial, Horizontal Bar, Vertical Bar.  

Color Displays the current color. To display another color, click 
the Color box, and then select a new color. 

Color 2 Displays the current second color for Gradient fill and 
allows selecting a color.  

Outline 

No outline No outlining contour of the symbols. 

Solid line The outline of the symbol is displayed. 

Color Color of the outline. Automatic results in an outline in the 
same color as the symbol but in a darker shade. 

Width Width of the outline. 

Glow 

Use glow When selected an area outside the outline is colored for a 
glowing effect.  

Color Color of the glow. 

Width Width of the glow. 
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Line Style 

The Line Style page controls the attributes of the lines displayed in the plot. 

The table describes the available options: 

Option/Box/Field Description 

Pattern Change the pattern of the line by clicking the Pattern 
box and selecting another pattern. 

The available types are: Solid, Long Dash, Dotted, and 
Dash Dot. 

Width To increase or decrease the width, enter a new number 
in the Width field.  

Color To display another color, click the Color box, and then 
select a new color. 

Smoothed line 
(Bezier) 

Select Smoothed line (Bezier) to smooth out the edges 
of the line.  

Note: Filling is available in the Fill Style tab. See the Customizing limits 
subsection for details. 
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Column and Column Style  

The Column and Column Style pages control the attributes of the columns displayed 
in the plot. 

The Column page, found above the Styles node, displays the current Column width 
and allows adjusting it. 

The Fill and Border options are described in the Symbol Style subsection; Border is 
there named Outline 

 
Options page in Format Plot 

Selecting the Use different symbols on category colored values check box will 
display different symbols for the different colors when coloring a plot.  

This also has the effect that each color becomes a series in the Format Plot dialog and 
thus enables the Symbol Style features. 

Note: Symbols for continuous coloring are not affected by this option. 
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Multiple Y axes  

When you have more than one series in a plot, you can select to display more than one 
y-axis and linking it to one of the series. 

To display multiple y-axes: 

1. Click the Styles node and click the series you want on the second y-axis. 

2. Click the Y Axis tab. 

3. In the Attach to Y Axis box, select Axis Y2. 

Steps 1 - 3 can be repeated for more series.  

 

Contour Levels 

For the Response Contour and Response Surface plots the Contour Levels page is 
available in Format Plot. 

In the Contour Levels page you can: 

 Change the number of Contour levels. 

 Increase/decrease the range by changing the Min and Max values. 

 Change the coloring scheme in the Begin and End Color boxes. 

 Change the colors of individual levels by clicking a level and selecting a new 
color in the color box to the right of the Individual level color section. 

 Remove a level by marking it and clicking the Remove button. 

 Add a specific level by typing a value in the field under the Add-button and 
then clicking Add. 

In the Contour Level Line Style page you can: 

 Select to not display the contour lines by clearing the Show lines check box. 

 Change the Pattern, Width and Color of the contour lines by introducing 
changes in the respective boxes. 
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See also the Response Contour plot options subsection in the Plot/List chapter. 

Multi plots  

In SIMCA there are two multi plots: Control Charts and Wavelet Structure. 

For these two plots there are Plot nodes beneath the Styles node, named Plot 1, Plot 2, 
etc. 

In these plot specific nodes the Sub Title and Plot area of the individual plots can be 
customized as described in Titles and Background respectively. 

Show group 
The Show group contains a number of features that can be turned on and off for the 
active plot. 

 Maximize Plot Area - see the Maximizing the plot area later in this 
section. 

 The Header, Footer, Legend, Axis Titles, Axes, and Timestamps check 
boxes which are displayed if selected and hidden when cleared.  

 Regression Line - see the Regression line subsection later in this section.  

 Resolve Coefficients - see the Coefficient Plot for hierarchical top level 
models subsection in Diagnostics & Interpretation section in the Home 
chapter. 

 

Maximizing the plot area 
Each plot displays a plot area and also a header and a footer. 

To view only the plot area and not the header and footer, on the Layout tab, click 
Maximize Plot Area. 
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To again view header and footer, click Maximize Plot Area again. 

 

Regression line 
The regression line and equation can be displayed for any 2D scatter or line plot in 
SIMCA. 

Open a plot, for instance the Observed vs. predicted plot, and select the Regression 
Line check box.  

The attributes of the line and equation can be changed in Format Plot, in the pages 
Region Style, Font, and Label Style. 

 

Marked Items tab 
The Marked Items tab is automatically activated when marking in a plot. The groups 
available on the Marked Items tab are:  

 Create from Marked Items 

 Drill Down 

 Modify Model 

 Layout 

 

Create from Marked Items group 
Display the selected items in another plot type or a list by clicking the desired plot/list 
icon in the Create from Selection group. The plots and list available here can also be 
created by clicking the Create command on the shortcut menu.  

Create from Selection group 

 Scatter - Creates a scatter plot of the currently selected items. 

 Line - Creates a line plot of the currently selected items. 

 Column - Creates a column plot of the currently selected items. 
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 List - described in the Creating lists subsection in this section. 

Creating plot from selection 
To generate a new plot from marked points in the open plot, list, or spreadsheet: 

1. Mark 

 the points in a plot or 

 rows or columns in a list or spreadsheet. 

2. On the Marked Items tab, click the desired plot type (Scatter, Line, 
Column) in the Create from Marked Items group. 

Creating special plots from selection 
Extended functionality of the Create from Marked Items group is available from the 
shortcut menu and described here. 

To generate a new plot from the open plot, list, or spreadsheet: 

1. Mark 

 the points in a plot or 

 cells, rows, or columns in a list or spreadsheet. 

 nothing which is the same as marking all. 

2. Right-click the plot, list, or selection and then click Create | Plot. 

3. In the Create Plot dialog, click the desired plot type. The plot types 
available are: Scatter Plot, Line Plot, Column Plot, Scatter 3D Plot, 
Normal Probability Plot, Histogram Plot, Control Chart, Wavelet 
Structure, Wavelet Power Spectrum, and Dendrogram. 

4. To use the window of the current plot for the new plot, select the Reuse plot 
window check box. 

5. Click OK to create the plot. 

 

Creating list from selection 
To generate a new list from marked points in the open plot, list, or spreadsheet: 

1. Mark 

 the points in a plot or 

 rows or columns in a list or spreadsheet. 
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2. On the Marked Items tab, in the Create from Marked Items group, click 
List. 

Creating list extended 
Extended functionality of the List feature is available from the shortcut menu and 
described here. 

To create a list from the open plot, list, or spreadsheet: 

1. Mark 

a. the points in a plot or 

b. cells, rows, or columns in a list or spreadsheet or 

c. nothing which is the same as marking all. 

2. Right-click the plot, list, or selection and then click Create | List. 
When only a cell is marked in a spreadsheet, the following message is 
displayed. Select the vectors to be displayed in the list by clicking Variable 
or Observation. 

   
When selecting Create List with a dendrogram plot active, a special list is created. For 
more, see the Create List for the dendrogram subsection in the Tools tab section 
previously in this chapter. 

Drill Down group 
Create comparison (contribution) plots and observations/variable line plots using the 
selected items by clicking a button in the Drill down group. The plots can also be 
created by clicking the Create command on the shortcut menu.  

The possible plots are: 

 Plot XObs and Plot YObs - described in the XObs and YObs line plots 
subsection in this section. 

 Variable Trend Plot - available when a variable is marked in a plot or list, 
for instance in the Loading Column Plot. For BEM this plot is the Variable 
BCC for the selected variable. 

 Contribution Plot - available after marking an observation. For more see the 
Creating plots from plots section in the Plot and list contextual tabs 
chapter. 

 Combined Contribution - available after marking more than one column in 
a batch level contribution plot. For more see the Combined Contribution 
plot in batch level models subsection in the Contribution plots section in 
the Analyze chapter. 
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Creating XObs and YObs line plots from selection 
Plot XObs and Plot YObs are available from the Marked Items tab.  

To create XObs for the entire spectra, click Spectra on the Data tab.  

To create a line plot of all or a selection of the observations: 

1. Mark the observations.  

2. Click Plot XObs or Plot YObs on the Marked Items tab. Plot YObs is only 
available when there are y-variables defined in the dataset spreadsheet. 
Define y-variables either at import or by clicking the Save As Default 
Workset button in the Workset dialog, tab Variables, after specifying the y-
variables. 

Note: The first secondary variable ID is by default displayed on the x-axis 
when it is numerical. 

 

Note: With spectral data, it is particularly useful to display the XObs plot of 
all observations. 

See also the Color subsection in the Tools chapter for details about coloring the line 
plot. 

Drill down contribution plots  
When a time point or batch point deviates from the expected, a contribution plot 
displays which variables that have contributed to the deviation. 

In the table, find a description on how to create the different types of contribution plots 
using the buttons on the Marked Items tab.  

The marking is done using Free Mark when not stated otherwise. Table 1 is valid for 
regular projects, batch level models, and for batch evolution models when Batch 
Marking Mode is NOT selected. Table 2 is valid when using Batch Marking Mode 
(only available for batch evolution models). 
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Table 1. Contribution plots for all types of projects when Batch Marking Mode is not 
the selected tool. 

  Plot type Action 

1 One point 
compared to 
the average. 

Mark a point and click Point to Average Comparison. 

2 One point 
compared with 
another point. 

Click one time point and then on the other. Click Point 
to Point Comparison. 

3 A group of 
points 
compared to 
the average. 

Mark all points in the group by circling them or by 
holding down the CTRL key and clicking the points. 
Then click Group to Average Comparison. 

4 One point 
compared to a 
group of points. 

Mark all points in the group by circling them and then 
click the single time point (without holding down the 
CTRL key). Click Group to Point Comparison. 

5 A group of 
points 
compared to 
another group 
of points. 

Mark all time points in the first group by circling them or 
by holding down the CTRL key and clicking the time 
points. Release the CTRL key before starting to mark 
the next group. 

Then mark all time points in the second group by circling 
them or by holding down the CTRL key and clicking the 
points. Click Group to Group Comparison. 

Table 2. Contribution plots for batch evolution models when comparing entire batches 
(Batch Marking Mode the selected tool). 

  Plot type Action 

1 One batch in a 
BEM compared to 
the group 
average. 

1. Select Batch Marking Mode by clicking the 
Select marking tool. 

2. Mark a point in the batch and note that all points 
of that batch are marked 

3. Click Group to Average Comparison. 

2 One batch 
compared with 
another batch. 

1. Select Batch Marking Mode. 

2. Mark a batch, and then mark another batch. 

3. Click Group to Group Comparison. 

3 A group of 
batches 
compared to the 
average. 

1. Select Batch Marking Mode. 

2. Mark at least one point in each batch by circling 
them or by holding down the CTRL key and 
clicking the points. 

3. Click Group to Group Comparison. 
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  Plot type Action 

4 One batch 
compared to a 
group of batches. 

1. Select Batch Marking Mode. 

2. Mark at least one point in each batch by circling 
them or by holding down the CTRL key and 
clicking the points. 

3. Mark the single batch (without holding down the 
CTRL key). 

4. Click Group to Group Comparison. 

5 A group of 
batches 
compared to 
another group of 
batches. 

1. Select Batch Marking Mode. 

2. Mark at least one point in each batch by circling 
them or by holding down the CTRL key and 
clicking the points. 

3. Release the CTRL key before starting to mark 
the next group. 

4. Mark at least one point in each batch by circling 
them or by holding down the CTRL key and 
clicking the points 

5. Click Group to Group Comparison. 

For more about contribution plots, see the Analyze and Predict chapters. 

Drill down plots possible 
The Drill down group becomes available after marking one or more points. 

The table lists the different buttons possible in the Drill down group, for regular and 
BLM. For BLM the group can be a batch or a group of batches.  

  Marked points in 
regular projects 

Buttons available after marking 

1 One or more observations 
in for instance a score plot. 

1. One observation 
marked. 

1. Point to Average Comparison - when 
clicked it displays the observation vs. 
average contribution plot, where the 
average is over all observations in the 
workset. 

2. A group of 
observations marked. 

2. Group to Average Comparison - when 
clicked it displays the group vs. average 
contribution plot. 

3. One observation first 
marked and then a 
group. 

3. Point to Group Comparison - when 
clicked it displays the observation vs. 
group contribution plot. 

4. A group first marked 
and then another 
group. 

4. Group to Group Comparison - when 
clicked it displays the group vs. group 
contribution plot. 

2 The above but for 
predicted observations 
(using the predictionset). 

The above but for the predictionset. 
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  Marked points in 
regular projects 

Buttons available after marking 

3 One or more variables in 
any plot, for instance in a 
loading or a contribution 
plot. 

Variable Trend Plot - when clicked displays a 
variable plot with one or more series. 

4 One or more observations 
in any plot. 

Plot XObs - when clicked displays a plot with 
one or more observation series. 

Additionally, there is a number of drill down plots possible for batch evolution models 
after marking. These are listed in the table below. This table also lists a couple of 
special drill down plots created from BLM. 

Marked points in 
BEM/BLM 

Buttons available after marking 

1 BEM. With the Batch Marking 
Mode selected, one or more 
batches in for instance a score 
BCC. 

1. One batch marked. 

1. Point to Average Comparison - 
when clicked it displays the 
observation vs. average contribution 
plot, where the average is the 
average batch. 

2. A group of batches 
marked. 

2. Group to Average Comparison - 
when clicked it displays the group vs. 
average contribution plot. 

3. One batch first marked 
and then a group. 

3. Point to Group Comparison - when 
clicked it displays the observation vs. 
group contribution plot. 

4. A group of batches first 
marked and then another 
group. 

4. Group to Group Comparison - 
when clicked it displays the group vs. 
group contribution plot. 

2 Time points in BEM (marked 
with the Marked Batch Mode 
unselected). 

1. One observation marked. 

1. Point to Average Comparison 

2. A group of observations 
marked. 

2. Group to Average Comparison 

3. An observation first 
marked and then a 
group. 

3. Point to Group Comparison 

4. A group first marked and 
then another group. 

4. Group to Group Comparison 

3 A variable in a plot from a 
BEM. 

Variable Trend Plot - displays a variable 
plot with control limits. This plot cannot 
display more than one variable at a time. 

4 A point in a BLM score plot for 
a model built on score or raw 
variables. 

A Sources of Variation, SoV, contribution 
plot. 
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Marked points in 
BEM/BLM 

Buttons available after marking 

5 A score (t) contribution column 
in a BLM. 

A BEM contribution plot. 

6 More than one score (t) 
contribution column in a BLM. 

Combined Contribution - displays a 
combined contribution plot. 

Modify model 
In the Modify Model group, features that modify the unfitted model, or create a new 
unfitted modified model, are available. 

The available features are described in this section and are listed here: 

 Exclude - Excluding marked items 

 Include - Including marked items 

 Class - Assigning observations to classes 

 Class | PLS-DA Model/OPLS-DA Model - described in the Creating a 
PLS-DA or OPLS-DA model from plot marking subsection in this 
chapter. 

 Class | Class Models - described in the Creating class models from plot 
marking subsection in this chapter. 

 

Excluding marked items 
Exclude observations, variables, expanded terms, lags, and batches, using the Exclude 
tool. 

 

Excluding observations or variables 

To exclude observations, variables, expanded terms, or lags: 

1. Open a plot, scores, loadings, VIP, etc. 

2. Mark the items to exclude. 

3. Click Exclude. 

4. SIMCA builds a new workset, with the selected items excluded. The new 
unfitted model becomes the active model. 

5. Repeat this operation as many times as needed; all exclusions are done in the 
unfitted model. 
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Note: The variables or observations are removed only from the new workset 
and not from any of the plots. 

For how to exclude items using the Variable, Observation, or Marked Items 
dockable windows, see the Show/Hide section in the View chapter. 

Excluding batches in the batch evolution model 

To exclude batches in a BEM: 

1. Open a plot displaying the batch. 

2. On the Tools tab, in the Highlight group, click Select | Batch Marking 
Mode. 

3. Click a point in the batch and note that all points in that batch are marked. 

4. Click Exclude. 

Excluding batches in batch level model creating new batch 
evolution and batch level model 

When marking batches in the BLM, clicking the arrow under the Exclude tool displays 
the options: 

1. Exclude (default) and 

2. Create new BEM and BLM without marked batches. 

Selecting the second choice leads to the following: 

1. SIMCA creates and fits a new BEM after excluding the marked batches. 

2. SIMCA creates a new batch level dataset and a new BLM with the same 
settings as before. 

This is very useful when outliers are found in the batch level model, and one needs to 
rebuild the BEM and BLM without the outlying batches. 

Excluding in predictionsets 

When the displayed observations are those of a predictionset, marking and excluding 
them excludes the observations from the predictionset. 

Including marked items 
The Include button creates a new model including only the marked items when there is 
no unfitted model. When there is an unfitted model, Include adds items to the unfitted 
model. 
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Creating class or DA-model from selection 
Create Class Models, Create OPLS-DA and Create PLS-DA are available when two 
(or more groups) are marked in any plot displaying observations. If only one class is 
marked, Class is available. 

  

To assign observations to classes: 

1. Mark the observations in a plot or list. 

2. Click Class, either the button or the arrow, and select the class name or 
number if listed, or click Class and enter a new class name or number in the 
dialog. 

3. Repeat this operation until you have selected all the observations you want in 
classes. 

4. When you are done editing the active model, verify the model type, mark the 
CM and click Autofit. 

To create class or DA-models: 

1. Mark two groups of observations in a plot. 

2. Click the Class arrow, and click Create Class Models, Create OPLS-DA or 
Create PLS-DA. 

3. Click Autofit to fit the model. 

Note: All unassigned observations are excluded. 

To create class models or a DA-model from a dendrogram plot: 

1. Mark in the dendrogram plot so that the desired groups are displayed in 
different colors. 

2. On the Marked Items tab, click Class | Create Class Models or Create 
OPLS-DA or Create PLS-DA. 
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Layout group 
The presentation of marked items in a plot can be manipulated by changing the label 
type, change the formatting, etc. available from the Layout group on the Marked 
Items tab. 

 

 

Changing/adding labels 
With a large numbers of variables or observations in a plot it is useful to be able to 
have labels on selected items. 

1. Mark interesting points in the plot. 

2. Click the Labels arrow on the Marked Items tab and select the desired label 
type. All available labels are listed. 

Note: If you want only labels on some items and there are labels on all in the 
plot, remove them by clicking Labels | No labels on the Tools tab first and 
then use step 1 and 2. 

 

Hiding marked/unmarked items 
To hide the marked items, without removing them from the model, click Hide.  

To hide the unmarked, without removing them from the model, click Hide | Hide 
unmarked items.  

To show hidden items, click the Show All button. 

The above can also be done from the Properties dialog in the Item Selection tab 
where hidden items can be selected to be displayed again. 

Locking rows or columns 
Locking rows and columns is available for all lists and spreadsheets when an entire 
row or column is marked in the spreadsheet. When locking rows or columns those 
rows or columns are always displayed when scrolling the list. 
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To lock rows or columns: 

1. Mark the columns or rows to lock in the list or spreadsheet by clicking the 
column or row number. 

2. On the Marked Items tab click Lock Columns or Lock Rows. 

The locked rows or columns are displayed when scrolling to the right or down, see the 
example here. 

 

 

Marked Values - changing attributes of selected items in a 
plot 
To change the fonts, symbols, size, etc., of only the marked points in a plot, click 
Format Symbol and Format Label respectively in the Layout group on the Marked 
Items tab. The Format Plot dialog is automatically opened with Custom under Styles 
or Custom Label under Labels default selected.  

Changing the properties of the custom series will only apply to the marked items. See 
also the Mini-toolbar - format plot section earlier in this chapter. 
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SIMCA-P+ 12 features - where 
to find them 

Introduction 
With the rearrangement of SIMCA into ribbons, features were moved, some renamed, 
others found obsolete. In this chapter the features of SIMCA-P+ 12 are listed with their 
position and name in SIMCA 13.  

The changes in terminology, listed in the table, were introduced. The list is in 
alphabetical order of the SIMCA-P+ 12 terminology. 

SIMCA-P+ 12 SIMCA 13 

Autocolor Autoformat 

Batch level Batch level, BL 

Batch level project (model) Batch level model, BLM 

BM BEM. BM includes BEM and optionally BLM. 

Contour Plot Response Contour 

Default plot action 
Buttons in the Drill down group on the Marked 
Items tab. 

Dendrogram HCA 

Distance to Model DModX, DModX PS 

Filter Summary Dataset Summary 

Hotelling’s T2Range Hotelling’s T2 

Import wizard SIMCA import 

Loadings Bi plot Biplot 

Model Overview Plot, List Summary of Fit, Summary of Fit List 

Next component Add 

Observation level Batch evolution, BE 

Observation level project 
(model) 

Batch evolution model, BEM 

Primary dataset Dataset 
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SIMCA-P+ 12 SIMCA 13 

Remove Component Remove 

Residuals Normal Probability 
Plot 

Residuals N-Plot 

Secondary dataset Dataset 

SIMCA-P+ SIMCA 

T Predicted Score PS 

Validate Permutations 

Variable Importance VIP 

Y Predicted Y PS 

SIMCA-P+ 12 File menu 
The items on the File menu in SIMCA-P+ 12 are arranged according to the table below 
in SIMCA 13. 

Feature in SIMCA-P+ 12 SIMCA 13 

File | New, first page of wizard 
allows selecting project type 
and turn on/off the audit trail. 

File | New Regular Project, File | New Batch 
Project. 

CTRL+N creates regular, CTRL+SHIFT+N 
creates batch. 

 
The type of project is specified when creating the 
project. The next time you create a project the 
project type used last time is default. Use the 
submenu to change project type, i.e. File | New 
Regular Project | New Batch Project. 

The Audit Trail is turned on in File | Options in 
SIMCA import.  

Open File | Open 

Close File | Close 

Close All Projects Obsolete. 

Each instance of SIMCA can only have one open 
project. SIMCA can be opened many times 
simultaneously. 
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Feature in SIMCA-P+ 12 SIMCA 13 

Delete | Project File | Manage | Delete Project 

 

Delete | Dataset On the Data tab, in the Modify Dataset 
group, Delete Dataset 

 

Delete | Model On the Home tab, in the Workset group, Delete. 

 

Save Project File | Save 

Save Project As File | Save As | Save Project As 

Save Plot/List As File | Save As | Save Plot/List As 

Import | Secondary Dataset File | Import Dataset. 

Datasets are equal in this version. This means 
that any dataset can be used to build a model 
whether it was imported first or last. 

Import | Import and Merge By 
Observation ID 

File | Import Dataset. 

In the Workset dialog, Select Data page, several 
datasets can be selected. Merge is done 
internally for the calculations. 

Generate HTML Report File | Generate Report 

The placeholder group Dataset was removed. 
The Model group items include all selected 
datasets.  

Create Batch Level Project On the Batch tab, in the Dataset group, Create 
Batch Level. 

The batch level datasets, BL DS, are created and 
the workset dialog automatically opened. For 
more, see the Create BLM subsection. 

Create Batch Level 
Secondary Datasets 

Obsolete. 

Specifying the predictionset for the BLM is done 
using the BE DS. The BE DS is rearranged to fit 
the BLM. 
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Feature in SIMCA-P+ 12 SIMCA 13 

Switch Batch Level Obsolete. BEM (observation level) and BLM 
(batch level) reside in the same project. 

Configure Batch Project for 
On-Line 

Obsolete. Handled by the on-line software. 

Print Setup File | Print | Print Setup 

Print Preview File | Print | Print Preview 

Print File | Print | Print 

Encrypt File | Manage | Encrypt 

Compact Project File File | Manage | Compact Project File 

Recent file list Recent files when clicking File.  

The most recently opened projects are listed and 
can be pinned.  

Exit File tab, button below Recent files, named Exit 
SIMCA. 
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Import wizard 
When importing a new dataset, the SIMCA-P+ 12 import wizard buttons and 
commands are available in the SIMCA import in SIMCA 13 according to the tables in 
the subsections that follow. 
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SIMCA-P+ 12 Import wizard spreadsheet - identifiers and 
variable roles 
In the import wizard spreadsheet of SIMCA-P+ 12 identifiers and variable roles were 
specified. These buttons/shortcut menu commands/arrow menu 
commands/Commands button commands were arranged according to the table below, 
in the SIMCA import in SIMCA 13. 

Feature in SIMCA-P+ 12 SIMCA 13 

Identifier specification available 
from buttons, column/row arrow 
menus and from Commands | 
Column/Row Formatting 

Specification of identifiers is done in the 
Identifiers group on the Home tab. 

 

 

Variable role specification 
available from the button in the 
Data section, from the column 
arrow menu and from 
Commands | Column 
Formatting 

 

Variable role specification is done on the Home 
tab, in the Variable Types group. 

 
To specify a quantitative x-variable, mark the 
variable and click Quantitative and X Variables. 

To specify a quantitative y-variable, mark the 
variable and click Quantitative and Y Variables. 

To specify a qualitative x-variable, mark the 
variable and click Qualitative and X Variables. 

To specify a qualitative y-variable, mark the 
variable and click Qualitative and Y Variables. 

To specify a variable as x and Date/Time, mark 
the variable and click Date/Time and X 
Variables. 

To specify a variable as y and Date/Time, mark 
the variable and click Date/Time and Y 
Variables. 
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Feature in SIMCA-P+ 12 SIMCA 13 

Specifying batch conditions, 
available from the button in the 
Data section, from the column 
arrow menu and from 
Commands | Column 
Formatting. 

 
To specify a quantitative x-variable, mark the 
variable and click Quantitative, Batch 
Conditions, and X Variables. 

To specify a quantitative y-variable, mark the 
variable and click Quantitative, Batch 
Conditions, and Y Variables. 

To specify a qualitative x-variable, mark the 
variable and click Qualitative, Batch Conditions, 
and X Variables. 

To specify a qualitative y-variable, mark the 
variable and click Qualitative, Batch Conditions, 
and Y Variables 

 

SIMCA-P+ 12 Import wizard spreadsheet additional features 
For identifiers and variable roles, see SIMCA-P+ 12 Import wizard spreadsheet - 
identifiers and variable roles. 

Other features available from buttons, arrow menus and Commands were arranged 
according to the table below, in the SIMCA import of SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Enable Audit trail for the import in 
the project type page. 

  

 

Specify to Log events to the Audit trail as 
Yes or No in Options on the File tab. 

  

 

Data with a row marked. 

 

Include | Include Row in the Exclude group 
on the Home tab. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Exclude - button 

 

Exclude in the Exclude group, on the Home 
tab. 

 

Missing Value field 

 

Missing Value field in Options on the File 
tab. 

Auto-Color Dataset On the Edit tab, in the Formatting group, 
Apply Formatting | Autoformat. 

 

Auto-Format Column Widths General auto formatting as in MS Excel was 
implemented. Double-click when the cursor 
shows auto formatting symbol. 

Import Another File File | New Spreadsheet. 

 
You can import arbitrarily many files to the 
SIMCA import. These can be imported in 
separate datasets or merged if desired. 

Save As File | Save As | Save Spreadsheet As 

If you want to save all spreadsheets and 
continue working in the SIMCA import later, 
see the Workspace subsection in the 
SIMCA import chapter. 

Column Formatting | Exclude 
Column 

Exclude | Exclude Column in the Exclude 
group on the Home tab. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Row Formatting | Data Include | Include Row in the Exclude group 
on the Home tab. 

 

Row Formatting | Exclude Row Exclude | Exclude Row in the Exclude 
group on the Home tab. 

 

Undo, Cut, Copy, Paste, Find On the Home tab, in the Clipboard and 
Editing groups. 

 
Some are also available in the Quick 
Access Toolbar. 

 

Insert | Rows 

Insert | Columns 

Delete 

Shift 

Clear Contents 

On the Edit tab, in the Rows & Columns 
group. 

 
Clear Contents is available by clicking 
Delete | Clear. 

Create Index On the Edit tab, in the Indexes group. The 
first button creates an index column, the 
second an index row. 

 

Merge Columns Merge Columns in the Merge group on the 
Edit tab. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Zoom out Missing Value Map available on the View 
tab. 

 
Zoom out was discontinued but feature 
available as Missing Value Map. 

Transpose Transpose in the Rows & Columns group 
on the Edit tab. 

Downsize Downsize in the Rows & Columns group 
on the Edit tab. 

 

Exclude Phases In the Batch & Phase pane, mark what to 
exclude and click the Exclude button in the 
toolbar in the pane. 

See the Batch & Phase pane batch part 
topic in the SIMCA import chapter. 

Search and Exclude Find/Replace in the Editing group, on the 
Home tab. CTRL+F. For more, see the Find 
subsection in the SIMCA import chapter. 

 

Hide Formatting Buttons Minimize the Ribbon on the Quick Access 
Toolbar arrow menu. 

 

SIMCA-P+ 12 Import wizard class page 
After specifying Class ID clicking Next in SIMCA-P+ 12 opened the class page. The 
features of this page are available in the Class pane of the SIMCA import in SIMCA 
13.  

Feature in SIMCA-P+ 12 
Position in SIMCA 13 Class 
pane 

Rename 

Merge 

Rename 
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Feature in SIMCA-P+ 12 
Position in SIMCA 13 Class 
pane 

Reset 

Delete 

Undo Delete 

Move using arrows 

Collapse and expand nodes 

Merge 

 

Undo on the Quick Access Toolbar or 
CTRL+Z. 

 

Exclude  

 

Include  

 

Arrows  

 

Collapse and expand nodes. 

 

For more see the Class pane subsection in the SIMCA import chapter. 

SIMCA-P+ 12 Import wizard phase and batch page 
After specifying Batch ID and Phase ID clicking Next in SIMCA-P+ 12 opened the 
Phase page, Next again opened the Batch page. The features of these pages are 
available in the Batch & Phase pane in the SIMCA import of SIMCA 13.  

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Phase page 

Time/Maturity variable for the selected 
phase  

Rename 

Merge 

Reset 

Delete 

Move using arrows 

Collapse and expand nodes 

With more than one y-variable defined, 
specify time/maturity variable for the 
selected phase by clicking Configure. 

Also rename a phase by clicking 
Configure.  

 

Merge  
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

 

Undo on the Quick Access Toolbar or 
CTRL+Z. 

 

Exclude 

 

Arrows  

 

Collapse and expand nodes 

 

Batch page 

Conditional Delete 

Delete 

Undo Delete 

 

Conditional Exclude 

 

Exclude 

 

Include  

 

For more, see the Batch & Phase pane batch part and Batch & Phase pane phase 
part subsections in the SIMCA import chapter. 
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SIMCA-P+ 12 Import wizard last page 
The last page of the import wizard contained the features listed in the table.  

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Project name field. 

 

File name field in Save As dialog that 
opens when clicking Finish in the 
Import group on the Home tab. 

 

Destination folder 
Available in the Save As dialog opened 
when clicking Finish. 

Variable ID Names 

Secondary variable ID names can be 
changed in the spreadsheet. The 
primary variable ID name cannot be 
changed; it is always Primary ID. 

Observation ID Names 

Secondary observation ID names can 
be changed in the spreadsheet. The 
primary observation ID name cannot be 
changed; it is always Primary ID. 

Missing Value Map 

Missing Value Map in the Missing 
Values group on the View tab. 

 

Import Local Centering 

View Local Centering 

  

Local Centering | Import/View in the 
Modify Dataset group on the Data tab 
in SIMCA after completed import. 

 
See the Importing local centering and 
the View imported local centering 
topics in the Data chapter.  
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

View Batch Conditions 

Batch conditions, when imported with 
the batch evolution dataset 
(observation level) are rearranged and 
positioned in a separate dataset named 
'BC - dataset'. 

On the Home tab in SIMCA after 
completed import, click the Dataset 
arrow. 

View Import Log 

Summary pane  

 
Display by selecting it on the View tab. 

Use simple mode workset dialog 

Toggle on and off by clicking Use 
Simple Mode/Use Advanced Mode 
button available bottom right in the 
Workset dialog. 

SIMCA-P+ 12 Edit menu 
The items on the Edit menu (Undo, Cut, Copy, Paste, Select All, and Find) in 
SIMCA-P+ 12 are found on the Quick Access Toolbar in SIMCA 13. Delete is 
unavailable; use the DELETE key on your keyboard. 

SIMCA-P+ 12 View menu 
The items on the View menu in SIMCA-P+ 12 were arranged according to the table 
below in SIMCA 13.  

SIMCA-P+ 12 Position in SIMCA 13 

Toolbars See the SIMCA-P+ 12 View menu - Toolbars subsection. 

Dockable 
windows 

On the View tab, in the Show/Hide group. 

 

Dockable 
windows | 
Favorites, Add 
Command to 
Favorites feature 

Discontinued 
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SIMCA-P+ 12 Position in SIMCA 13 

Dockable 
windows | What 
If 

Discontinued 

Project Window  

In the Show/Hide group on the View tab, see above. 

The Project Window is by default docked and default 
displayed below the ribbon but can be dragged to different 
positions. 

To have the project window as a regular window, clear the 
Enable docking for the project window check box in 
Customize dialog available on the shortcut menu of the 
Project Window. 

Model Window  In the Show/Hide group on the View tab, see above. 

Add to Favorites 

Add to Report 

In the Add group on the View tab. 

 

Interface Mode 
Discontinued. Each instance of SIMCA can only have one open 
project. SIMCA can be opened many times simultaneously. 

Set Active 
Project 

Discontinued. Each instance of SIMCA can only have one open 
project. SIMCA can be opened many times simultaneously. 

Full Screen  

In the Show/Hide group on the View tab, see the top of the 
table.  

Project Options  

On the File tab, button below Recent files. 

The Interface page was removed. Workset mode can be 
changed by clicking Use Simple Mode/Use Advanced Mode 
in the Workset dialog. The positioning of tabs feature was 
discontinued.  

 

General Options 
Renamed SIMCA Options. On the File tab, button below 
Recent files, see above.  
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SIMCA-P+ 12 Position in SIMCA 13 

Save As Global 
Options 

Project Options, General tab. Click Save as General. 

 

SIMCA-P+ 12 View menu - Toolbars 
The buttons available from toolbars in SIMCA-P+ 12 are available according to the 
table below in SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Customize toolbar Discontinued. There are no toolbars in SIMCA 13. 

Standard toolbar 

 

New, Open, Save  

On the File tab, click New Regular Project or 
New Regular Project | New Batch Project. 

On the File tab, click Open. 

On the File tab, click Save. 

Cut, Copy, Paste 

Quick Access Toolbar. 

 

Print  On the File tab, click Print. 

New workset  
On the Home tab, in the Workset group, click 
New. 

Fit buttons, for ex. Autofit, 
Calculate the two first 
components, Calculate next 
component etc. 

On the Home tab, in the Fit model group. 

The Zero component model command was 
discontinued. Click Add and then Remove for a 
zero component model. 

Shortcut Bar 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Active Model 

Displayed in the caption of the Project Window. 
Switching active model is done by marking a new 
model in the Project Window. 

The Automatic change of active model can be 
turned off by selecting No in Automatically 
change active model in the SIMCA Options 
dialog, More Options tab. 

Validate  
On the Analyze tab, in the Validate group, click 
Permutations. 

Create four overview plots 
On the Home tab, in the Diagnostics & 
Interpretation group, click Overview. 

Plot R2 and Q2 
On the Home tab, in the Diagnostics & 
Interpretation group, click Summary | X/Y 
Overview. 

Score Scatter Plot 
On the Home tab, in the Diagnostics & 
Interpretation group, click Scores. 

Loading Scatter Plot 
On the Home tab, in the Diagnostics & 
Interpretation group, click Loadings.  

DModX Plot 
On the Home tab, in the Diagnostics & 
Interpretation group, click DModX. 

Visualization Plots 
Discontinued. Add the 4 plots: score scatter plot 
and the XVar line plot of the first 3 variables to a 
group in Favorites and open together. 

Quick Info 
On the View tab, in the Show/Hide group, select 
the Quick Info check box. 

Plot  
The contextual tabs Tools and Layout are opened when a plot is opened and Marked 
Items when marking. These contextual tabs are grouped in the Plot umbrella. With a 
list active, the List umbrella holds Tools and after marking Marked Items. 

 

Select plot items 
On the Tools tab, in the Highlight group, click 
Select. 

The No Mark tool is no longer available.  

Insert text Discontinued. 

Zoom plot On the Tools tab, in the Zoom group, click Zoom. 

Zoom out 
On the Tools tab, in the Zoom group, click Zoom 
out.  

Read coordinate values 
Discontinued. The Status Bar displays the plot 
coordinates. 

Show/Hide Regression line 
On the Layout tab, in the Show group, select the 
Regression Line check box. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Rotate plot 
See the Rotating 3D scatter plot subsection in 
the Diagnostics & Interpretation section in the 
Home chapter.  

Add alarm zone Discontinued. 

Plot default action 
Drill Down group buttons on the Marked Items 
tab.  

Exclude 
On the Marked Items tab, in the Modify Model 
group, click Exclude. 

Exclude | Create New 
Observation Level Model and 
Batch Level Project without 
Marked Batches. 

On the Marked Items tab, in the Modify Model 
group, click Exclude | Create new BEM and 
BLM without marked batches. 

Include 

On the Marked Items tab, in the Modify Model 
group, click Include. 

Note that Include does not work as in the 
previous version. See the Including marked 
items subsection. 

Set Class 

On the Marked Items tab, in the Modify Model 
group, click Set Class. 

For more see the Creating class or DA-model 
from selection subsection in the Plot and list 
contextual tabs chapter. 

Selected item manipulations | 
Label Type 

To add or change labels for all points in the plot, 
click Labels in the Properties group on the Tools 
tab.   

To add or change labels for marked points, click 
Labels in the Layout group on the Marked Items 
tab.  

Selected item manipulations | 
Format Marked Items 

On the Marked Items tab, in the Layout group, 
click Format Symbol or Format Label 
depending on what to format. 

Selected item manipulations | 
Create List 

To create a list of for all points in the plot, click 
List in the Change Type group on the Tools tab. 
  

To create a list of only the marked points, click 
List in the Create from Marked Items group on 
the Marked Items tab.  

Selected item manipulations | 
Hide Marked Items 

On the Marked Items tab, in the Layout group, 
click Hide. 

Selected item manipulations | 
Hide Unmarked Items 

On the Marked Items tab, in the Layout group, 
click Hide | Hide unmarked items. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Property Bar 

 

 

Model Type, Comp, R2X, R2Y, 
Q2.   

The data available in the Property bar when a 
model window was active in SIMCA-P+ 12 is 
available in the Model Window and Project 
Window. 

Model, Comp, X-Axis, Y-Axis, 
Z-Axis, Batch, Observations, 
Variables, Y-Variable 

On the Tools tab, in the Data group. 

Available for plots and lists displaying results from 
one model. 

Color by 
On the Tools tab, in the Properties group, Color 
by. 

Properties 
On the Tools tab, the dialog box launcher in the 
Properties group. 

Adaptive Predictions Discontinued. 

SIMCA-P+ 12 Dataset menu 
The items on the Dataset menu in SIMCA-P+ 12 were arranged according to the table 
below in SIMCA 13.  

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Open On the Home tab, click Dataset. 

Quick Info | Variables, 
Observations 

On the View tab, in the Show/Hide group, select 
the Quick Info check box. 

Trimming Overview 
On the Data tab, in the Summary group, click 
Trimming Overview. 

Generate Variables 
On the Data tab, in the Modify Dataset group, 
click Generate Variables. 

Merge 
On the Data tab, in the Modify Dataset group, 
click Merge. 

Transpose Dataset 
On the Data tab, in the Modify Dataset tab, click 
Transpose. 

Spectral Filters 

On the Data tab, in the Filters tab, click Spectral 
Filters. 

The individual filters Derivatives, MSC, and SNV 
are available from the menu. 

Time Series Filters 
On the Data tab, in the Filters group, click Time 
Series Filters. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Export Dataset Discontinued. Use File | Save As | Save List As. 

Filter Summary 
On the Data tab, in the Summary group, click 
Dataset Summary. In the dialog click the Filter 
tab. 

Dataset Properties 
On the Data tab, in the Summary group, click 
Dataset Summary. 

SIMCA-P+ 12 Workset menu 
The items on the Workset menu in SIMCA-P+ 12 were arranged according to the 
table below in SIMCA 13.  

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Statistics 
On the Home tab, in the Workset group, click 
Statistics. 

New 
On the Home tab, in the Workset group, click 
New. 

New as Model 
On the Home tab, in the Workset group, click 
New As. 

Edit 
On the Home tab, in the Workset group, click 
Edit. 

Delete 
On the Home tab, in the Workset group, 
click Delete. 

Create Hierarchical Batch 
Models 

On the Batch tab, in the Dataset group, click 
Create Hierarchical Batch Models. 

Spreadsheet 
Discontinued as separate spreadsheet. 
Accessible through the Workset dialog, 
Spreadsheet tab.  

Model Options 
On the Home tab, click the Model Options dialog 
box launcher in the Workset group. 

SIMCA-P+ 12 Analysis menu 
The items on the Analysis menu in SIMCA-P+ 12 were arranged according to the table 
below in SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Change Model Type 
On the Home tab, in the Workset group, click 
Change Model Type. 

Change Model Type | 
Hierarchical Base Model, Non 
Hierarchical Base Model 

On the Data tab, in the Base Model group, click 
Hierarchical, Non Hierarchical. 



SIMCA-P+ 12 features - where to find them 

505 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Autofit 
On the Home tab, in the Fit Model group, click 
Autofit. 

Next component 
On the Home tab, in the Fit Model group, click 
Add. 

Two First Components 
On the Home tab, in the Fit Model group, click 
Two First. 

Zero Components 
Discontinued. Fit model and Remove 
components until zero. 

Remove Component 
On the Home tab, in the Fit Model group, click 
Remove. 

Autofit Class Models 
On the Home tab, in the Fit Model group, click 
Autofit with the BEM/CM marked in the Project 
Window. 

Summary 
On the Home tab, in the Diagnostics & 
Interpretation group, click Summary of Fit. 

Summary | Model Overview 
Plot 

On the Home tab, in the Diagnostics & 
Interpretation group, click Summary of Fit | 
Summary of Fit. 

The Model Overview Plot and List were 
renamed Summary of Fit. 

Scores 
On the Home tab, in the Diagnostics & 
Interpretation group, click Scores. 

Loadings 
On the Home tab, in the Diagnostics & 
Interpretation group, click Loadings. 

Loadings Bi plot 
On the Analyze tab, in the Analysis group, click 
Biplot. 

Hotelling's T2Range 
On the Home tab, in the Diagnostics & 
Interpretation group, click Hotelling's T2. 

Coefficients 
On the Home tab, in the Diagnostics & 
Interpretation group, click Coefficients. 

Coefficients | Y Related 
Profiles 

On the Analyze tab, in the Analysis group, click 
Y Related Profiles. Y Related Profiles 
Overview was discontinued. 

Variable Importance | Plot 
On the Home tab, in the Diagnostics & 
Interpretation group, click VIP. 

Variable Importance | List 
Discontinued. To create the list, open the plot and 
on the Tools tab, in the Change Type group, 
click List. 

Residuals | Normal 
Probability Plot 

On the Analyze tab, in the Analysis group, click 
Residuals N-Plot. 
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Residuals | List 

Not available from button in ribbon. On the 
Plot/List tab, in the Standard Plots group, click 
List, select YVarRes, YVar, YPred, SerrL,and 
SerrU.  

Distance to Model 
On the Home tab, in the Diagnostics & 
Interpretation group, click DModX. 

Observed vs. Predicted 
On the Home tab, in the Diagnostics & 
Interpretation group, click Observed vs. 
Predicted. 

Contribution 
On the Analyze tab, in the Analysis group, click 
Contribution. 

Observation Risk 
Not available from button in ribbon. On the 
Plot/List tab, in the Standard Plots group, click 
Column and select to plot ORisk.  

Batch Control Charts | 
Scores Plot  

On the Batch tab, in the Analysis Control 
Charts, click Scores BCC. 

Batch Control Charts | 
Distance to Model X Plot  

On the Batch tab, in the Analysis Control 
Charts, click DModX BCC. 

Batch Control Charts | 
Variable Plot  

On the Batch tab, in the Analysis Control 
Charts, click Variable BCC. 

Batch Control Charts | 
Hotelling's T2Range Plot  

On the Batch tab, in the Analysis Control 
Charts, click Hotelling's T2 BCC. 

Batch Control Charts | 
Observed vs. Time/Maturity 
Plot  

On the Batch tab, in the Analysis Control 
Charts, click Obs vs. Time/Maturity BCC. 

Batch Control Charts List  
On the Batch tab, in the Analysis Control 
Charts, click List BCC. 

Validate 
On the Analyze tab, in the Validate group, click 
Permutations. 

Batch Variable Importance 
On the Batch tab, in the Variable Summary 
group, click Variable Importance Plot. 

Available when a BLM is the active model. 

CV-ANOVA 
On the Analyze tab, in the Validate group, click 
CV-ANOVA. 

SIMCA-P+ 12 Predictions menu 
The items on the Predictions menu in SIMCA-P+ 12 were arranged according to the 
table below in SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Specify Predictionset | 
Specify 

On the Predict tab, in the Specify Predictionset 
group, click Specify. 
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Specify Predictionset | 
Specify, Import section. 

On the Data tab, in the Modify Dataset group, 
click Local Centering. 

Local centering does not discriminate 
predictionsets.  

Specify Predictionset | 
Specify, Spreadsheet 

Discontinued. Add new observations in a dataset 
and select the new observations as predictionset. 

Specify Predictionset | 
Dataset 

On the Predict tab, in the Specify Predictionset 
group, click As Dataset. 

Specify Predictionset | 
Complement 
WS/Complement WS Batches 

On the Predict tab, in the Specify Predictionset 
group, click Complement WS/Complement WS 
Batches. 

Specify Predictionset | As 
Workset 

On the Predict tab, in the Specify Predictionset 
group, click As Workset. 

Specify Predictionset | Class 
On the Predict tab, in the Specify Predictionset 
group, click Class. 

Adaptive Predictions Discontinued. 

Save as Secondary Dataset 
Discontinued. Predictionsets can be saved under 
a specified name without saving a dataset. See 
the Specify subsection in the Predict chapter. 

Y Predicted 
On the Predict tab, in the Plots group, click Y 
PS. 

T Predicted 
On the Predict tab, in the Plots group, click 
Score PS. 

Hotelling's T2Range 
On the Predict tab, in the Plots group, click 
Hotelling's T2PS. 

Distance to Model 
On the Predict tab, in the Plots group, click 
DModX PS. 

Time Series 
On the Predict tab, in the Plots group, click Time 
Series PS. 

Contribution 
On the Predict tab, in the Plots group, click 
Contribution PS. 

Coomans' Plot 
On the Predict tab, in the Classification group, 
click Coomans' plot. 

Classification List 
On the Predict tab, in the Classification group, 
click Classification List. 

Misclassification Table 
On the Predict tab, in the Classification group, 
click Misclassification Table. 

Prediction List 
On the Predict tab, in the List group, click 
Prediction List. 

Control Charts 
On the Predict tab, in the Plots group, click 
Control Charts PS. 
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Batch Control Charts | 
Scores Plot  

On the Batch tab, in the Prediction Control 
Charts, click Scores PS BCC. 

Batch Control Charts | 
Distance to Model X Plot  

On the Batch tab, in the Prediction Control 
Charts, click DModX PS BCC. 

Batch Control Charts | 
Variable Plot  

On the Batch tab, in the Prediction Control 
Charts, click Variable PS  BCC. 

Batch Control Charts | 
Hotelling's T2Range Plot  

On the Batch tab, in the Prediction Control 
Charts, click Hotelling's T2 PS BCC. 

Batch Control Charts | 
Observed vs. Time/Maturity 
Plot  

On the Batch tab, in the Prediction Control 
Charts, click Obs vs. Time/Maturity PS BCC. 

Batch Control Charts List  
On the Batch tab, in the Prediction Control 
Charts, click List PS BCC. 

SIMCA-P+ 12 Plot/List menu 
The items on the Plot/List menu in SIMCA-P+ 12 were arranged according to the 
table below in SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Scatter Plots 
On the Plot/List tab, in the Standard Plots 
group, click Scatter. 

Scatter 3D Plot 
On the Plot/List tab, in the Standard Plots 
group, click Scatter 3D. 

Line Plots 
On the Plot/List tab, in the Standard Plots 
group, click Line.  

Time Series Plots 
On the Plot/List tab, in the Control Charts 
group, click Time Series. 

Column Plots 
On the Plot/List tab, in the Standard Plots 
group, click, Column.  

Histogram Plots 
On the Plot/List tab, in the Custom Plots group, 
click Histogram.  

Contour Plots 
On the Plot/List tab, in the Custom Plots group, 
click Response Contour. 

Response Surface Plots 
On the Plot/List tab, in the Custom Plots group, 
click Response Surface. 

Normal Probability Plots 
On the Plot/List tab, in the Custom Plots group, 
click Normal Probability. 

Dendrogram  
On the Analyze tab, in the Clustering group, 
click HCA.  

Batch Plots | Observed vs. 
Smoothed Y Plot 

On the Batch tab, in the Time/Maturity group, 
click Observed vs. Smoothed Y. 
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Batch Plots | Unaligned vs. 
Aligned Plot. 

On the Batch tab, in the Time/Maturity group, 
click Unaligned vs. Aligned Plot. 

Control Charts 
On the Plot/List tab, in the Control Charts 
group, click Control Charts. 

Wavelet Structure 
On the Plot/List tab, in the Custom Plots group, 
click Wavelet Structure. 

Wavelet Power Spectrum 
On the Plot/List tab, in the Custom Plots group, 
click Wavelet Power Spectrum. 

Lists 
On the Plot/List tab, in the Standard Plots 
group, click List. 

Export to Spotfire Discontinued. 

Step Response Plot 
On the Plot/List tab, in the Custom Plots group, 
click Step Response Plot. 

Filter Summary 
On the Data tab, in the Summary group, click 
Dataset Summary. The Filter tab is available 
after filtering the dataset. 

Visualization plots 
Discontinued. Add the 4 plots: score scatter plot 
and the XVar line plot of the first 3 variables to a 
group in Favorites and open together.  

 

SIMCA-P+ 12 Window menu 
The items on the Window menu in SIMCA-P+ 12 were positioned in the Window 
group on the View tab in SIMCA 13, according to the table below. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Close Click the cross in the caption of the window. 

Close All 
On the View tab, in the Window group, click 
Close | Close All. 

Cascade 
On the View tab, in the Window group, click 
Cascade. 

Tile Horizontally 
On the View tab, in the Window group, click Tile 
Horizontally. 

Tile Vertically 
On the View tab, in the Window group, click Tile 
Vertically. 

Open items list Discontinued. 

Windows 
On the View tab, in the Window group, click the 
Window Options dialog box launcher. 
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SIMCA-P+ 12 Help menu 
The commands on the Help menu in SIMCA-P+ 12 are found on the ?-mark menu in 
SIMCA 13. 

 

SIMCA-P+ 12 shortcut menu 
The commands on the context sensitive shortcut menu for plots and lists in SIMCA-P+ 
12 were arranged according to the table below in SIMCA 13. The items are generally 
also still available from the shortcut menu but that is only mentioned in this table when 
it is the only place the item is available from. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

Add Observations, Add 
Variables 

Same. 

Show as Histogram 
The quick shortcut was discontinued. Create | 
Plot, Histogram on the shortcut menu or view the 
histogram in the Quick Info. 

Create 

On the Tools tab, in the Change Type group. 

With marking, on the Marked Items tab, in the 
Create from Marked Items and the Drill Down 
groups.  

For more, the SIMCA-P+ 12 shortcut menu - 
Create subsection. 

Add to Favorites 
On the View tab, in the Add group, click Add to 
Favorites. 

  

Add to Report 
On the View tab, in the Add group, click Add to 
Favorites. 

Format Date/Time Same. 

Lock the First xx Rows and 
Lock the First xx Columns. 

On the Marked Items tab, in the Layout group, 
click Lock... 

Sort Ascending and Sort 
Descending 

On the Tools tab, in the Highlight group, click 
Sort | Sort Ascending or Sort Descending. 

Maximize Plot Area 
On the Layout tab, in the Show group, click 
Maximize Plot Area. 

Plot Settings  
Renamed Format Plot and is available on the 
Layout tab, to the far right. 

Properties  
Same with some exceptions. See the SIMCA-P+ 
12 Properties dialog subsection. 

Quick Info 
On the View tab, in the Show/Hide group, select 
the Quick Info check box. 

Reset rotation Same. 
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Feature in SIMCA-P+ 12 Position in SIMCA 13 

Save Plot or List As On the File tab, Save As. 

Save Plot Settings | Default 

On the Layout tab, in the Templates group, click 
Save as default. 

On the shortcut menu, renamed Plot Templates | 
Save as default. 

Save Plot Settings | saved 
plot settings 

On the Layout tab, in the Templates group, click 
Save as.  

On the shortcut menu, renamed Plot Templates | 
Save as and select the old plot formatting file in 
the dialog. 

Save Plot Settings | 
Configurations which allows 
saving to new name and to 
delete custom configurations. 

To save to a new template: On the Layout tab, in 
the Templates group, click Save as. On the 
shortcut menu, renamed Plot Templates | Save 
as and select the old plot formatting file in the 
dialog. 

To delete a template: On the Layout tab, in the 
Templates group, click Open templates folder 
and delete the unwanted file.  

On the shortcut menu, (renamed) Plot Templates 
| Save as/Open templates folder. 

Switch Plot Settings | Default 

On the Layout tab, in the Templates group, click 
Load. 

On the shortcut menu, renamed Plot Templates | 
Save as default. 

Switch Plot Settings | saved 
plot settings 

On the Layout tab, in the Templates group, click 
Load | saved template.  

On the shortcut menu, renamed Plot Templates | 
Load | saved template and select the plot 
formatting file in the dialog. 

Switch Plot Settings | 
Configurations 

On the Layout tab, in the Templates group, click 
Load/Save as/Open templates folder depending 
on desired action.  

On the shortcut menu renamed Plot Templates | 
Load/Save as/Open templates folder. 

Zoom Out On the Tools tab, in the Zoom group. 
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SIMCA-P+ 12 shortcut menu - Create 
The shortcut menu item Create commands SIMCA-P+ 12 were arranged according to 
the table below in SIMCA 13. 

Feature in SIMCA-P+ 12 Position in SIMCA 13 

List 

On the Tools tab, in the Change Type group, 
click List. 

With marking: On the Marked Items tab, in the 
Create from Marked Items, click List. 

Plot  

On the Tools tab, in the Change Type group, 
click the desired plot type or click the dialog box 
launcher. 

With marking: On the Marked Items tab, in the 
Create from Marked Items, click the desired 
plot type or click the dialog box launcher. 

Specifically for the Sources of Variation plot, 
click Column to display batch conditions too.  

Plot XObs, Plot YObs  
On the Marked Items tab, in the Drill Down 
group, click Plot XObs, Plot YObs. 

Variable Line Plot 

VarDS Line Plot 
On the Marked Items tab, in the Drill Down 
group, click Variable Trend Plot. 

Contribution Plot  
On the Marked Items tab, in the Drill Down 
group, click the comparison plots. 

Combined Contribution 
On the Marked Items tab, in the Drill Down 
group, click Combined Contribution. 

Merge List for HCA 
dendrogram. 

On the Tools tab, in the Change Type group, 
click Merge List. 

Variable Batch Control Chart 
after marking a variable in a 
BEM variable plot. 

On the Marked Items tab, in the Create from 
Marked Items group, click Variable Trend Plot. 

PLS-DA Model after marking 
two or more observation 
groups. 

On the Marked Items tab, in the Modify Model 
group, click Class | Create PLS-DA Model. 

Class Models after marking in 
an observation plot. 

On the Marked Items tab, in the Modify Model 
group, click Class | Class... 

Sources of Variation plot for a 
Loading or Contribution plot 
from a model built from raw or 
score variables. 

On the Tools tab, in the Change Type group, 
click Sources of Variation.  

Toggle between the Sources of Variation plot 
and the Column plot by clicking the respective 
button in the Change Type group.   

Out of Control Summary Plot 
(OOC) for BCC plots. 

On the Tools tab, in the Change Type group, 
click Out of Control Summary. 

Batch Control Chart when the 
Out of Control Summary plot 
is the active plot. 

On the Tools tab, in the Change Type group, 
click Batch Control Chart. 
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SIMCA-P+ 12 Color in Properties dialog 
This table describes the coloring types in the Color page that work differently in 
SIMCA 13. 

A general change is that the colors of the categories and continuous cannot be changed 
in the Properties dialog in SIMCA 13. Colors can instead be changed and saved in 
Format Plot. 

Color by SIMCA-P+ 12 SIMCA 13 

Batch 
Conditions 

Color by Batch 
Conditions available 
after importing batch 
conditions with the 
observation level dataset. 

Color by batch conditions is 
available as color by Categories or 
Continuous after selecting a batch 
condition dataset. 

Hierarchical 
Variables 

For hierarchical top 
models the variables can 
be colored according to 
base model by selecting 
by Hierarchical 
Variables. 

Coloring by hierarchical variables is 
done by selecting the hierarchical 
dataset in the Data box and then 
selecting the variable. Alternatively 
by selecting the model in the Data 
box, XVar in the Item box and the 
hierarchical variable in the X 
Variables box. 

Score 
Categories 

Available for any plot 
displaying observations. 

Color by Score Categories is a 
subset of coloring by Vector 
(categories). 

What If Colors the predictionset 
observations originating 
from the What If in a 
different color from the 
original predictions. 

The What If was discontinued and 
consequently this coloring type. 
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SIMCA-P+ 12 Properties dialog 
The following property pages are no longer available in the Dataset Properties dialog: 

 Batch Conditions are found as batch level datasets, prefixed BC when 
automatically created at the import of the batch evolution (observation level) 
dataset.  

 Local centering is found by clicking Local centering | View in the Modify 
Dataset group on the Data tab. 

 Default centering - Default centering used for predictionsets was 
discontinued. Predictionsets use local centering if available. How local 
centering is done when unavailable for the predictionset is described in the 
Local centering missing subsection.   

The Properties dialog for the Response Contour and Response Surface plots no 
longer include the following features:  

 Use color for the Response Contour plot. To display the plot without 
colors, change the Begin and End colors to white in the Contour Levels 
page in the Format Plot dialog.   

 Rotation of axis labels, previously available in the Labels page, is now 
available in the Format Plot dialog, in the Axis node.  

 Save as Default Options, previously available in the Labels page, is now 
available in the Project Options dialog, Plot Labels page only. 

 

SIMCA-P+ 12 Plot Settings 
The 2D plot library was rewritten resulting in many changes in the plot settings pages. 
The three pages Axis, Header and Footer, and Plot Area are combined in the new 
Format Plot dialog where the: 

 Axis features are found in the Axis node. 

 Header and Footer features are found in the Titles node. 

 Plot Area features are found in the other nodes where Background, Legend 
and Limits mainly contain the same features. 
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This section describes where to find old functionality. See the Format Plot section to 
read about all features in the Format Plot dialog. 

Features with the same name positioned in the same place are not listed here. 

In SIMCA-P+ 12 Point of the feature 
Placement in 
SIMCA 13 

Axis 

Increment by (major 
ticks) 

To define spacing 
between major tick 
marks. 

Step size in the 
individual axis pages. 

Minor tick spacing 
To define spacing 
between minor tick 
marks. 

Discontinued. 

Decimal places 
To define how many 
decimals to display in the 
axis annotation. 

Discontinued. 

Recalculate Scale 
Resets minimum and 
maximum to default. 

Renamed Always 
recalculate scales. 

Tick Mark Label - 
Scientific, Time 

To display the scale in the 
specified unit. 

Renamed Annotation 
and discontinued except 
for Rotation. 

Rotation 
Rotating the tick mark 
label/annotation. 

In the Annotation 
section in the respective 
Axis pages. 

Logarithmic scale 
To display the axis in 
logarithmic scale. 

Discontinued. 

Values in reverse order 

To display the axis with 
the highest number to the 
left and lowest to the 
right. 

Reverse axis in the 
respective Axis pages. 

Always recalculate 
scales 

When cleared the plot 
was not updated with a 
new value range. 

Clearing the Autoscale 
check box in the Axis 
General page results in 
that the plot is not 
updated with new values 
when switching vectors 
one the axes. An 
exception is when the 
range of the new vector is 
larger; in that case the 
scale is updated to show 
all values.  

Aspect ratio available 
when clicking Aspect 
ratio under Axes. 

To define the ratio 
between the x and y-axis. 

Discontinued. 

Font Effects Strikeout 
and Underline 

To display the annotation 
or axis title underlined or 
with a line through the 
text. 

Discontinued. 
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In SIMCA-P+ 12 Point of the feature 
Placement in 
SIMCA 13 

Header and Footer 

Border style 
To customize the line 
style of the border around 
the header or footer. 

Discontinued. 

Font Effects Strikeout 
and Underline 

To display the header or 
footer underlined or with a 
line through the text. 

Discontinued. 

Plot Area where Series was renamed Styles 

Show symbols 
To show/hide symbols in 
scatter and line plots. 

In line plots, select a 
symbol type in the Styles 
node, Symbol Style 
page, Shape box (default 
None for line plots). In 
scatter plots you can 
select another shape but 
not None.  

Show line 
To show the line between 
points in a scatter plot. 

For scatter plots there is 
no Line Style page which 
means that this feature 
was discontinued. 
However, if you create 
the line plot, you can 
select to display symbols 
by selecting a Shape in 
the Symbol Style page 
in the Styles node. 

Show data labels To hide the data labels. 
Handled by the 
Properties dialog. 

Anchor and Alignment 
of Data Labels  

To align the plot label. 

In the Label Style page 
in the Labels node, 
Position specifies where 
to put the label with 
respect to the point. 

Offset of data labels 
To specify how far from 
its item the label should 
be placed.  

Labels Style page in the 
Labels node. 

Use the symbol color 
To display the label in the 
same color as the point. 

The labels are by default 
displayed in the same 
color as the outline of the 
symbols. By default the 
outline of the symbols is 
dark gray. To display the 
labels in the same color 
as the interior of the 
symbol, in the Symbol 
Style page, change the 
Outline color to 
Automatic. 
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In SIMCA-P+ 12 Point of the feature 
Placement in 
SIMCA 13 

Font Effects Strikeout 
and Underline 

To display the legend or 
plot labels underlined or 
with a line through the 
text. 

Discontinued. 

Background 
To customize the 
background of the plot. 

The functionality has 
been changed for this 
version allowing gradient 
fill but discontinuing 
border styles. 

Is boxed was 
discontinued. 

Ellipse 

Ellipse page Set the 
ellipse coordinates: To 
distort the ellipse. 

The Line Style features 
for the ellipse are found in 
the Limits and 
Regions node. 

Discontinued to avoid 
distortion of the ellipse. 

Alarm Zones 
To mark an area of 
interest. 

Discontinued. 

Location 
To change the positioning 
of the plot area in the plot 
window. 

Discontinued. 

Plot Area Margins 

To change the margins 
around the plot area in 
reference to the plot 
window. 

Discontinued. 

Rotation of data labels 
To specify the direction of 
the data label. 

Labels Style page in the 
Labels node. 

Alignment of data 
labels 

To align somehow. Only 
when the label is 
displayed on more than 
one line. 

Discontinued. 

Text color 
To color all labels in one 
specific color. 

In the Labels node, 
Labels Style page, 
Label section, select the 
desired color in the Color 
box. 

Anchor 
To specify where to 
display the item. 

Position in the Label 
Style page in the Labels 
node. 

Column Style Pattern 
To display a pattern on 
the columns. 

Gradient Fill, in Column 
Style in the Styles node, 
replaces this feature. 

Overlap 
Enabling overlapping of 
columns 

Discontinued. 
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In SIMCA-P+ 12 Point of the feature 
Placement in 
SIMCA 13 

Tick Marks in 3D scatter 
plots 

Customizing how the ticks 
are displayed. 

Click Axis General and 
Tick Marks. 

Marked values  
To change symbol style, 
symbol color, label color, 
or font, marking style. 

The Custom style is 
created after marking and 
clicking Format Symbol 
or Format Label. The 
marked item formatting 
can be changed here. 

Bubble-page available 
after sizing score vectors. 

Specifying the size of the 
bubbles in Min and Max 
fields. 

Styles node, Symbol 
Style, vector series, Size 
field. Here you cannot 
specify minimum and 
maximums, just enlarge 
or shrink all symbols 
proportionally. 

Limit Zero in Control 
Charts 

To customize the zero-
line. 

Discontinued. 

Display the Surface 
Mesh in Contour Levels 

To display the Contour 
Plot as a surface plot. 

Discontinued. Create the 
surface plot by clicking 
the Response Surface 
button. 

Display the Contour 
Level lines in Contour 
Levels 

To display/hide the 
contour lines. 

Select/clear the Show 
lines check box in the 
Contour Level Line 
Style page in the 
Contour node. 

3D Label - Contour Plot 
To customize the label 
size, font etc. 

See the Labels 
subsection in the Layout 
tab section in the Plot 
and list contextual tabs 
chapter.  

View 3D To customize the rotation. 

Turn the plot as desired 
by holding down the 
mouse-button and 
moving the mouse. 

Managing plot settings 

Delete plot settings 
Being able to delete 
unwanted plot settings 
configurations. 

Plot Settings is now 
called Format Plot. 
Different configurations 
can be saved to file. 
These files are handled 
as any other files.  

On the Layout tab, in the 
Templates group, 
clicking Open templates 
folder enables deleting 
unwanted templates. 
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In SIMCA-P+ 12 Point of the feature 
Placement in 
SIMCA 13 

Managing plot settings 
Saving/replacing/restoring 
plot settings. 

The managing of plot 
formatting is done in the 
Templates group on the 
Layout tab. 
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Help 

Introduction 
This chapter describes all commands on the Help menu. 

Use the Help menu to: access the help, register your product, access the Umetrics web 
site, or view version details. 

The SIMCA help is based on the user guide. The user guide documents are transferred 
to a compiled HTML file. To read the Help file, Internet Explorer version 6.0 or higher 
must be installed but does not need to be the default browser. 

HTML help 
The HTML help file is installed to include interactive and stand alone help. 

Open the help by: 

 Clicking Contents/Search/Index from the help menu . 

 Clicking the Help-button  in one of the dialogs or wizards. 

 Clicking SIMCA Help from the Program menu.  

Use the Contents, Index, or Search tabs to find what you are looking for. 

Note: Using citation marks <"> allows searching of phrases.  

Additionally, the Analysis Advisor is available to guide you through the analysis. 
Open it by selecting the Analysis Advisor check box in the Show/Hide group on the 
View tab. For more, see the Analysis Advisor subsection in the View chapter. 

Register 
After installing SIMCA, if your license needs an activation key, SIMCA will issue a 
message requesting you to contact Umetrics to register. 

If you choose to register later, from the Help menu, click Register and follow the 
directions. 

Umetrics on the Web 
If you have an Internet connection, you can visit the web page of Umetrics 
(www.umetrics.com) to get the latest news and other information by clicking 
Umetrics on the Web on the Help menu. 
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About SIMCA 
To find the version number of SIMCA, click About SIMCA on the Help menu. 
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Appendix A: Statistics 

Introduction 
This chapter contains brief background information and formulas for SIMCA. For 
more extensive reading, use the reference material. 

The topics covered are: 

 PCA - Principal Components modeling 

 PLS - Partial Least Squares Projection to Latent Structures modeling 

 OPLS/O2PLS - Orthogonal PLS modeling 

 Cluster Analysis (CA), dendrograms, Hierarchical CA (HCA), PLS 
including Hierarchical Cluster Analysis - HCA and PLS-Trees 

 Vectors available in SIMCA 

 Formulas and descriptions 

 Transform page criteria 

 Scaling 

 Cross validation 

 PLS Time Series Analysis 

 CV-ANOVA 

 Fisher's Exact test 

 Control Chart statistics 

 S-plot 

Fit methods background 
A dataset is composed of N rows and K columns. The N rows are here called 
observations and the K columns are called variables. 

Geometrically we can represent the observations as points in a multidimensional space 
where the variables define the axes. The lengths of the axes are determined by the 
scaling of the variables. 
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To calculate a model that approximates the dataset the following fit methods are 
available in SIMCA: 

 Principal Components modeling - PC modeling. 

 Partial Least Squares Projection to Latent Structures modeling - PLS 
modeling. 

 Orthogonal PLS - OPLS and O2PLS modeling. 

All other fit methods, available by clicking Change Model Type use one of the fit 
methods above, see the Model types available subsection in the Home chapter. 

PCA - Principal Components modeling 
Principal Component Analysis is the technique for finding a transformation that 
transforms an original set of correlated variables to a new set of uncorrelated variables, 
called principal components. The components are obtained in order of decreasing 
importance, the aim being to reduce the dimensionally of the data. 

The analysis can also be seen as an attempt to uncover approximate linear 
dependencies among variables. 

PC modeling shows the correlation structure of your data matrix X, approximating it 
by a matrix product of lower dimension (TP'), called the principal components plus a 
matrix of residuals (E). 

X = Xbar + TP’ + E 

where 

Xbar contains X average. 

T is a matrix of scores that summarizes the X-variables. 

P is a matrix of loadings showing the influence of the variables. 

E is a matrix of residuals; the deviations between the original values and the 
projections. 

This geometrically corresponds to fitting a line, plane or hyper plane to the data in the 
multidimensional space with the variables as axes. The scaling of the variables 
specifies the length of the axes of this space. For more about scaling see the Scaling 
section later in this chapter. 

SIMCA iteratively computes one principal component at a time, comprising a score 
vector ta and a loading vector pa. 

Number of model dimensions (A) 
To get an overview of the dataset, a few (2 or 3) principal components are often 
sufficient. 

However, if the PC model is used for modeling or for other predictions (e.g. principal 
properties), cross validation (CV) should be used for testing the significance of the 
principal components. In this way, the “significant” number of PC components, A, is 
obtained, which is essential in modeling. 

It is also possible to use the eigenvalue limit (EV) for testing component significance 
by clearing the Use cross validation when fitting check box in Model Options, tab 
Model. 

Eigenvalue Limit (EV): A component is considered significant if its normalized 
eigenvalue is larger than 2. 
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Cross validation (CV) is described in the Cross validation section later in this 
chapter. 

Reference PCA 
1. Jackson, J.E. (1991), A User’s Guide to Principal Components, John Wiley, 

New York. ISBN 0-471-62267-2. 

PLS - Partial Least Squares Projection to Latent 
Structures modeling 
When fitting a Partial Least Squares Projection to Latent Structures model, PLS finds 
the linear (or polynomial) relationship between a matrix Y (dependent variables) 
and a matrix X (predictor variables) expressed as: 

Y = f(X) + E 

The matrix X refers to the predictor variables and their squared and/or cross terms if 
these have been added. Active X variables or expansions participating in the model are 
sometimes referred to as terms. The function f(X) is usually a polynomial, possibly in 
the transformed variables. 

Note: Cross terms should be added to the linear terms in X only when the 
data supports such terms, for instance after using a design to generate X. 

PLS is most easily understood geometrically, where we see the matrices X and Y as N 
points in two spaces, the X-space with K axes, and the Y-space with M axes, K and M 
being the number of columns in X and Y. 

PLS modeling consists of simultaneous projections of both the X and Y spaces on low 
dimensional hyper planes. The coordinates of the points on these hyper planes 
constitute the elements of the matrices T and U. The analysis has the following 
objectives: 

 To well approximate the X and Y spaces 

 To maximize the correlation between X and Y 

The PLS model accomplishing these objectives can be expressed as: 

X = Xbar + TP’ + E 

Y = Ybar + UP’ + F 

U = T + H  (the inner relation) 

where 

Xbar contains X average. 

Ybar contains Y average. 

Note that the coefficients of the inner relation are 1. 

In the PLS algorithm there are additional loadings, W, called weights. These express 
the correlation between U and X and are used to calculate T. 

This modeling geometrically corresponds to fitting a line, plane or hyper plane to both 
the X and Y data represented as points in a multidimensional space, with the objective 
of well approximating the original data tables X and Y, and maximizing the 
covariance between the observation positions on the hyper planes. 
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SIMCA will iteratively compute one PLS component at a time, that is: one vector each 
of X-scores t, Y-scores u, weights w and c, and loadings p. 

The PLS components are calculated in descending order of importance. 

Vector Description 

T Matrix of scores that summarizes the X variables. 

W Matrix of weights expressing the correlation between X and U (Y). 

U Matrix of scores that summarizes the Y variables. 

C Matrix of weights expressing the correlation between Y and T (X). 

E, F, H Matrices of residuals. 

Number of model dimensions (A) 
The criterion used to determine the model dimensionality, (number of significant PLS 
components), is cross validation (CV). With CV, observations are kept out of the 
model development, then the response values (Y) for the kept out observations are 
predicted by the model, and compared with the actual values. 

This procedure is repeated several times until every observation has been kept out once 
and only once. 

Reference PLS 
Wold, S., Sjöström, M., and Eriksson, L., (2001b), PLS-Regression: A Basic Tool of 
Chemometrics, Journal of Chemometrics, 58, 109-130. 

OPLS/O2PLS - Orthogonal PLS modeling 

OPLS - Orthogonal PLS modeling 
A simple way to understand OPLS is to consider how PLS and OPLS differ in their 
handling of the variance of the X-matrix. PLS divides the variability in X in two parts 
(figure below), i.e., the systematic and residual parts. The systematic part is the sum of 
the variability in X that is correlated (predictive) to Y and the variability in X that is 
uncorrelated (orthogonal) to Y. Thus, whereas PLS divides the sum of squares of X in 
two parts, OPLS divides it in three parts. This yields good predictions and improved 
interpretability.  

It should be noted that in the single-Y case, by theory, the OPLS model can only have 
one predictive component [Trygg and Wold, 2002]. Should a single-Y OPLS model 
comprise more than one component, all components beyond the first one reflect 
orthogonal variation. However, with multiple Y-variables there can be more than one 
predictive OPLS component. 

For the single-y case only OPLS is available in SIMCA. The results from 
OPLS/O2PLS in SIMCA-P+ 12 are identical to the results using OPLS in SIMCA 13. 
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Figure: PLS (left) divides the variability in the X-matrix in two parts, the systematic 
variability and the residual variability. OPLS (right) further splits the systematic 
variability, R2X, in two parts, the part that is correlated (predictive) to Y and the part 
that is uncorrelated (orthogonal) to Y. 

In the case of a single response variable, we can write the X-part of the OPLS model as 

X = 1x' + tp' + ToPo' + E  

and the OPLS model prediction of y as 

y = y'  + tq' + f  

The multi-Y OPLS model can be expressed as follows: 

X = 1x' + TP' + ToPo'+ E 

and the OPLS model prediction of Y as 

Y = 1y'  + TQ' + F  

Where the matrix products TP' and TQ' hold the joint X/Y information overlap. The 
number of score vectors (in T and U) and loading vectors (in P' and Q') is determined 
using cross-validation. 

Thus, in comparison with the single-y OPLS model, the main difference lies in the fact 
that there can be more than one predictive component in the multi-y OPLS model. The 
number of predictive components is regulated by the number of latent variables in the 
information overlap between X and Y, which in turn often is linked to the rank of Y. 

O2PLS - Orthogonal PLS modeling 
The O2PLS model can be written as follows: 

X = 1x' + TP' + ToPo' + E  

Y = 1y'  + UQ' + UoQo' + F  

Where the matrix products TP' and UQ' hold the joint X/Y information overlap. The 
number of score vectors (in T and U) and loading vectors (in P' and Q') is determined 
using cross-validation. In the example in the Model Window for OPLS and O2PLS 
models subsection in the View chapter, there are seven components of this type 
(predictive components).  

The number of components in the respective set of components is determined using 
cross validation. 

For any part of the OPLS/O2PLS model, the percentages explained and predicted 
variances can be obtained from plots and lists in the software. 

For more about the differences between OPLS/O2PLS and PLS, see the Conventional 
PLS compared with OPLS and O2PLS subsection. 



User Guide to SIMCA 

528 

Conventional PLS compared with OPLS and O2PLS 

PLS 

Conventional PLS applies to the two-block (X/Y) regression problem. It uses X to 
construct a model of Y, where the objective is to predict the latter from the former for 
new samples in the predictionset. In that sense, PLS is unidirectional, i.e., X  Y, but 
not vice versa. 

When X is composed of e.g. spectroscopic data, process readings or measurements 
from bio-analytical platforms, there is a risk that systematic variation may reside in X 
which is not linearly correlated with Y. Such variability in X is usually called 
Orthogonal in X [1]. Although the Orthogonal in X variation can be handled by a PLS 
model, it often makes model interpretation more difficult [2].  

OPLS 

The OPLS method is a recent modification of the PLS method [1-3], which is designed 
to handle variation in X that is orthogonal to Y. OPLS separates the systematic 
variation in X into two parts, one that is linearly related (and therefore predictive) to Y 
and one that is orthogonal to Y. The predictive variation of Y in X is modeled by the 
predictive components. The variation in X which is orthogonal to Y is modeled by the 
orthogonal components. This partitioning of the X-data provides improved model 
transparency and interpretability, and gives very similar predictive power. For OPLS 
with one Y the predictive model with the same number of components is identical to 
the same PLS model. Similarly to PLS, OPLS is a unidirectional method, where the 
scope is the relation X  Y. 

O2PLS 

O2PLS is a generalization of OPLS [4,5]. In contrast to PLS and OPLS, O2PLS is 
bidirectional, i.e. X  Y. Additionally, with O2PLS it is possible to partition the 
systematic variability in X and Y into three parts, (i) the X/Y joint predictive variation, 
(ii) the variation in X orthogonal to Y (X-unique Variation), and (iii) the X-unrelated 
variation in Y (Y-unique Variation). The variation in X orthogonal to Y can be further 
divided into two parts; one part which is equivalent to the component in OPLS 
(Orthogonal in X (OPLS)) is a matrix effect that needs to be modeled to achieve the 
best possible prediction and interpretation. The second part (Orthogonal in X (PCA)) 
consists of structured variation that does not affect the prediction but can be interesting 
to study to further improve the interpretation of complex multivariate data. The X-
unrelated variation in Y may be modeled in a similar way. 

  

Figure 1. Overview of the O2PLS model relating two data tables to each other. Unique 
variation in X also named variation in X orthogonal to Y in the left-hand side of the 
Figure. The X/Y joint predictive variation (middle part of the Figure) describes the 
predictive variation between X and Y, the information overlap. The Unique variation in 
Y also named variation Orthogonal in Y in the right-hand side of the figure. 
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The ability to interpret the X/Y joint predictive variation separated from the non-
correlated variation implies that the model interpretation is refined and simplified. 
Furthermore, it should be noted that for the single-y case the OPLS and O2PLS 
methods are identical. For such a model there can only be one predictive component 
expressing the joint X/Y predictive variation [4,5]. 

Combination with the hierarchical approach 
Because of its ability to divide the information in X and Y into different parts, the 
O2PLS model is ideally suited for combining with the hierarchical modeling approach. 
This is of interest when working with multi-block process data and spectroscopic data 
[6,7]. The flexible structure of the O2PLS method also allows setting it up as a filter 
for peeling off any undesired systematic variability in your data. 

Y-Related Profiles 
The Y-Related Profiles are coefficients rotated displaying the pure profiles of the 
underlying constituents in X using the assumption of additive Y-variables. 

The estimation includes a linear transformation of the coefficient matrix, Bp(BpTBp)-1, 
using only the predictive components to compute the coefficients (i.e., the components 
orthogonal to Y are not included in the computation of the Y related profile). 

References OPLS and O2PLS 
1. Trygg, J., and Wold, S., (2002), Orthogonal Projections to Latent Structures 

(OPLS), Journal of Chemometrics, 16, 119-128. 

2. Trygg, J., (2004), Prediction and Spectral Profile Estimation in Multivariate 
Calibration, Journal of Chemometrics, 18, 166-172. 

3. Eriksson, L., Johansson, E., Kettaneh-Wold, N., Trygg, J., Wikström, M., 
and Wold, S., Multi- and Megavariate Data Analysis, Part II, Method 
Extensions and Advanced Applications, Chapter 23, Umetrics Academy, 
2005. 

4. Trygg, J., (2002), O2-PLS for Qualitative and Quantitative Analysis in 
Multivariate Calibration, Journal of Chemometrics, 16, 283-293. 

5. Trygg, J., and Wold, S., (2003), O2-PLS, a Two-Block (X-Y) Latent Variable 
Regression (LVR) Method With an Integral OSC Filter, Journal of 
Chemometrics, 17, 53-64. 

6. Gabrielsson, J., Jonsson, H., Airiau, C., Schmidt, B., Escott, R., and Trygg, 
J., (2006), The OPLS methodology for analysis of multi-block batch process 
data, Journal of Chemometrics, 20, 362-369. 

7. Eriksson, L., Dyrby, M., Trygg, J., and Wold, S., (2006), Separating Y-
predictive and Y-orthogonal variation in multi-block spectral data, Journal 
of Chemometrics, 20, 352-361. 
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Cluster Analysis (CA), dendrograms, Hierarchical CA 
(HCA), PLS-Tree 

Large datasets are often clustered, grouped, and relationships between variables are 
often different in different groups (clusters). Cluster analysis tries to find a natural 
grouping (clustering) of a data set so that there is less variation (greater similarity) 
within the clusters, and more variation (less similarity) between the clusters. The 
difference between on the one hand CA, and on the other hand classification and 
discriminant analysis (CDA) is that in the latter the classes are pre-defined by the user, 
and each observation in the workset belongs to one of these classes. CA has no 
predefined classes, but after the analysis a set of clusters has been “found”, and each 
observation belongs to one of these. In HCA and PT the “fineness” of the solution, i.e., 
number of clusters and the observation assignment, can be modified by moving the 
cursor up and down in the dendrogram (tree diagram). 

CA is particularly useful in the analysis of large data sets, often called “Data Mining”. 
The resulting groups, clusters, can lead to the generation of new ideas – exploratory 
data analysis – and often better models for parts of the data. 

SIMCA has two approaches of hierarchical clustering. 

1. HCA = hierarchical clustering, available on the Analyze tab, in the 
Clustering group, by clicking HCA, and 

2. PT = PLS-Trees which is a new PLS-based clustering method developed by 
Umetrics (PLS-TREE™), available on the Analyze tab, in the Clustering 
group, by clicking PLS-Tree. 

Note that much of what is described regarding dendrograms and coloring applies both 
to HCA and PLS-Trees. Hence, the reader is recommended to also read the following 
topics and sections: 

 Hierarchical Cluster Analysis - HCA later in this section. 

 HCA in the Analyze chapter. 

 PLS-Trees later in this section. 

 PLS-Tree in the Analyze chapter. 

Hierarchical Cluster Analysis - HCA 
In Hierarchical Clustering Analysis (HCA) a similarity or distance criterion is first 
specified by the user (default = “Ward”, other option: Single Linkage). Then HCA 
basically starts with as many clusters as there are observations (N). The two closest 
clusters or observation points are merged, thereafter the two closest clusters or points 
are again merged, etc., until only one cluster remains. The result is shown by means of 
a dendrogram. Open plots, e.g., score plots, are colored according to the clusters 
marked in the dendrogram. For more, see the HCA section in the Analyze chapter. 

Ward clustering 
In Ward clustering the distance measure is a function that measures the error increase 
of the model when a pair of clusters are merged into one new cluster. The error 
function used in SIMCA is the classical error function which calculates the difference 
in the sum of sum of squares around the mean of each cluster before and after merging 
two clusters. 

This type of clustering works well when the clusters are spherical. 
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Single linkage 
In single linkage clustering, the distance between a pair of clusters is the Euclidean 
distance between the two observations (one in each cluster) closest to each other. This 
type of clustering works well when the clusters are warped filaments. 

PLS-Trees 
PLS-Trees is an approach similar to regression and classification trees [3], but using 
the first score vectors of PLS and PLS-DA instead of the original X-variables for 
splitting clusters into two. 

Thus, the basic idea of a PLS-Tree is to start with a PLS model of the whole data set 
(the user must before specify what is X and Y, scaling, etc.), and then split the data 
along the sorted 1st score (t) of the PLS model. This split is made to optimize a 
criterion with three parts: 

a. improving the variance of the score (t) so that when combined, the variance 
in the resulting two sub-groups is as small as possible, and 

b. analogously for the variance of Y, and 

c. do this so that the sizes of the two sub-groups are as equal as possible. Each 
of these three criteria is in advance given a relative weight by the user, and 
the criterion to be optimized is the combination of the three parts weighted 
by the user supplied weights. The user also specifies a minimal size of a 
cluster beyond which it cannot be further split. 

The weight allows the user to focus on the clustering in the X-space, or in the Y-space, 
or in both, and to more or less focus on splitting into groups of approximately the same 
size. 

Once the split is made and the criterion indicates an improvement, the split goes on 
with the two sub-groups, and thereafter with the resulting sub-groups of these, until all 
“branches” have been terminated due to either lack of improvement by further 
splitting, or that the clusters are reaching the minimal size. 

The result is a hierarchical set of PLS models in a tree structure. Each model is an 
ordinary PLS model which can be further modified, investigated, displayed, and 
interpreted. 

See also the PLS-Tree and HCA - Dendrogram sections in the Analyze chapter for 
details about coloring etc. 
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Figure 1. A typical PLS-Tree. Each branch of the tree corresponds to a PLS model 
fitted to a sub-set of observations. 

Calculation of PLS-Trees 
Cross validation is used to terminate the branches of the tree, and to determine the 
number of components of each cluster PLS model. 

To accomplish a PLS-Tree the data matrices, X and Y, are first centered and scaled, as 
usual. A PLS analysis is made of X and Y. Thereafter, the first X-score, t1, is used as 
the dividing coordinate together with the Y-data (X and Y are sorted along t1). The 
point on t1 is searched that divides X and Y in two parts, 1 and 2, such that the 
following expression is minimized:   

β * (N1- N2)
2/(N1+ N2)

2 + (1 - β) * [α * (( VY1 + VY2)/ VY) + (1 - α) * + ((Vt1 + 
Vt2)/Vt)] 

In the expression above, V denotes variance, 

α and β, A and B in SIMCA, are two adjustable parameters. 

The parameters A and B both run between 0 and 1. They regulate how the PLS models 
are split (i.e., how the observations from one upper level PLS model are distributed 
among two lower level models) according to the score t1, the Y-variable(s) or the 
group size. The first parameter, A, sets the balance between the score t1 and the Y; the 
closer to zero the more weight is attributed to the score t1. The second parameter, B, 
takes into account the group size of the resulting clusters; the closer to zero the less 
important it becomes to have equal group sizes in the dendrogram. In summary, this 
means that a division along t1 is sought that minimizes the within groups variation and 
hence maximizes the between group differences in t1 and Y. 

The approach results in the row-wise splitting of data into a tree structure 
(dendrogram) of PLS models, one split for each cluster (node in the dendrogram). The 
dendrogram with the associated PLS models is called a PLS-Tree. When Y comprises 
a discrete matrix with 1/0 columns corresponding to a number of predefined classes, 
the result is a PLS classification tree. 
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References cluster analysis 
1. Kriegl, J.M., Eriksson, L., Arnhold, T., Beck, B., Johansson, E., and Fox, T., 

(2005), Multivariate Modeling of Cytochrome P450 3A4 Inhibition, 
European Journal of Pharmaceutical Sciences, 24, 451-463. 

2. Eriksson, L., Johansson, E., Müller, M., and Wold, S., (2000c), On the 
Selection of Training Set in Environmental QSAR When Compounds are 
Clustered, Journal of Chemometrics, 14, 599-616. 

3. Breiman, L., Friedman, J.H., Olshen, R.A., and Stone, C.J., (1984) 
Classification and Regression Trees, Wadsworth & Brooks / Cole Advanced 
Books & Software, Monterey, CA. 

4. Everitt, B.S., Landau, S., Leese, M., (2001), Cluster Analysis, Fourth Edition 
Arnold Publishers, London. 

5. Ward, J.H., (1963), Hierarchical grouping to optimize an objective function. 
J. Am. Stat. Assoc., 58, 236-244. 

Vectors available in SIMCA 
Modeling using PCA, PLS, OPLS, and O2PLS results in a number of vectors 
describing the model and its properties, and the residuals. 

In the subsections that follow all vectors available in SIMCA are described. The 
vectors are divided in groups according to their data type in the Plot/List dialogs. 

 For vectors such as variables, scores, and distance to model, see the 
Variables and Scores vectors subsection. 

 For vectors such as observations, loadings, and Q2VX, see the Observations 
and Loadings vectors subsection. 

 For vectors pertaining to a component such as Q2, R2X, or SDt see the 
Function of component vectors subsection. 

 For lag vectors for models with lags defined in the workset, see the Function 
of lags vectors subsection. 

 For aligned vectors for batch evolution models, see the Aligned Vectors 
subsection. 

 For Out Of Control vectors for models in batch evolution models, see the 
Batch Vectors - Out Of Control Summary subsection. 

Some of the vectors are described with formulas in the Formulas and descriptions 
section later in this chapter. 

Note: All vectors available for PLS are also available (with the same 
description) for OPLS and O2PLS unless otherwise stated. For OPLS and 
O2PLS these common vectors generally refer to the predictive side. 

OPLS and O2PLS specific vectors are described in the Orthogonal PLS modeling 
subsection earlier in this chapter. 
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Variables and Scores vectors 
In the Plot/List tab dialogs, the vectors found in the Items box with data type 
Variables and Scores are column vectors with the same shape as variables and scores, 
i.e., with one element per observation. 

See the table for the vectors available and their description in alphabetical order. The 
rightmost column displays the plot/list/spreadsheet where the vector is available, when 
applicable, in bold text if the vector is displayed by default. 

Vector Description Displayed 

CVgroups The cross-validation group that each 
observation is assigned to. 

  

Date/Time Variable in the dataset specified as 
Date/Time Variable in the SIMCA import. 
For more see the Formatting variable as 
Date/Time subsection in the SIMCA 
import chapter. 

All line plots 
displaying 
observations, 
for instance: 

Home | 
Scores | Line 

Date/Time-PS Predictionset variable specified as 
Date/Time Variable in the SIMCA import. 
For more see the Formatting variable as 
Date/Time subsection in the SIMCA 
import chapter. 

All line plots 
displaying 
observations, 
for instance: 

Predict | 
Score PS| 
Line 

DModX 

  

Distance to the model in X space (row 
residual SD), after A components (the 
selected model dimension), for the 
observations used to fit the model. If you 
select component 0, it is the standard 
deviation of the observations with scaling 
and centering as specified in the workset, 
i.e., it is the distance to the origin of the 
scaled coordinate system. 

(A)  = Absolute distance. 

(N) = Normalized distance. 

(M) = Mpow weighted residuals. 

Home | 
DModX 

DModXPS Distance to the model in the X space (row 
residual SD), after A components (the 
selected dimension), for new observations 
in the predictionset. Displaying component 
0, it is the standard deviation of the 
observations with scaling as specified in 
the workset times v (correction factor for 
workset observations, see the Absolute 
distance to the model of an observation 
in the workset  subsection in Appendix 
A: Statistics), i.e., it is the distance to the 
origin of the scaled coordinate system. 

Predict | 
DModX PS 

DModXPS+ 

  

Combination of DModXPS and tPS, when 
the latter is declared different from the 
workset observations. 

Predict | 
DModX PS 
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Vector Description Displayed 

DModY Distance to the model in the Y space (row 
residual SD) after A components (the 
selected model dimension) for the 
observations used to fit the model. If you 
select component 0, it is the standard 
deviation of the observations with scaling 
and centering as specified in the workset.  

Line or Column 
under the 
DModY header 
in Home | 
DModX 

DModYPS Distance to the model in the Y space (row 
residual SD) after A components (the 
selected model dimension) for 
observations in the predictionset. If you 
select component 0, it is the standard 
deviation of the observations with scaling 
and centering as specified in the workset.  

Line or Column 
under the 
DModY header 
in  Predict | 
DModXPS 

Num Index number: 1, 2, 3 etc. All lists 
displaying 
observations, 
for instance 
Predict | Y PS 
| List 

ObsID Numerical observation identifiers, primary, 
secondary, batch, or phase. 

  

OLevX The leverage is a measure of the influence 
of a point (observation) on the PC model 
or the PLS model in the X space. 

The observations leverages are computed 
as the diagonal elements of the matrix H0 
after A dimensions. 

H0 = T[T'T]-1T'. 

  

OLevY The leverage is a measure of the influence 
of a point (observation) on the PLS model 
in the Y space. 

The observations leverages are computed 
as the diagonal elements of the matrix Hy 
after A dimensions. 

Hy = U[U'U]-1U'. 

  

ORisk The observation risk is a sensitivity 
measure and indicates the "risk" (the 
influence) of including an observation in 
the workset. ORisk is based on the Y 
residual (in a PLS/OPLS/O2PLS model) 
for a selected observation. It is computed 
from the difference between the residual 
standard deviation of the selected Y, when 
the observation is and is not in the model.  
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Vector Description Displayed 

ORisk(pooled) The pooled ORisk is analogous to ORisk 
but is valid across all Y variables in a 
PLS/OPLS/O2PLS model rather than an 
individual Y variable. It is computed from 
the difference between the pooled residual 
standard deviation of the Y variables, 
when the observation is and is not in the 
model.  

  

PModX Probability of belonging to the model in the 
X space, for observations used to fit the 
model. Component 0 corresponds to a 
point model, i.e., the center of the 
coordinate system. 

Observations with probability of belonging 
of less than 5% are considered to be non-
members, i.e., they are different from the 
normal observations used to build the 
model. 

  

PModY Probability of belonging to the model in the 
Y space, for observations used to fit the 
model. Component 0 corresponds to a 
point model, i.e., the center of the 
coordinate system. 

Observations with probability of belonging 
of less than 5% are considered to be non-
members, i.e., they are different from the 
normal observations used to build the 
model. 

  

PModXPS Probability of belonging to the model in the 
X space, for new observations in the 
predictionset. Component 0 corresponds 
to a point model, i.e., the center of the 
coordinate system. 

Observations with probability of belonging 
of less than 5% are considered to be non-
members, i.e., they are different from the 
normal observations used to build the 
model. 

Predict | 
Prediction 
List 

PModXPS+ The same as PModXPS but based on 
DModXPS+ instead of DModXPS.  

Predict | 
Prediction 
List 

Predict | 
Classification 
List 
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Vector Description Displayed 

PModYPS Probability of belonging to the model in the 
Y space, for new observations in the 
predictionset. Component 0 corresponds 
to a point model, i.e., the center of the 
coordinate system. 

Observations with probability of belonging 
of less than 5% are considered to be non-
members, i.e., they are different from the 
normal observations used to build the 
model. 

  

SerrL Lower limit of the standard error of the 
predicted response Y for an observation in 
the workset.  

  

SerrLPS Lower limit of the standard error of the 
predicted response Y for a new 
observation in the predictionset. 

SerrLPS is always in original units, i.e., 
back transformed when Y was 
transformed, when displayed in the 
Prediction List. 

Predict | 
Prediction 
List 

SerrU Upper limit of the standard error of the 
predicted response Y for an observation in 
the workset. 

  

SerrUPS Upper limit of the standard error of the 
predicted response Y for a new 
observation in the predictionset. 

SerrUPS is always in original units, i.e., 
back transformed when Y was 
transformed, when displayed in the 
Prediction List. 

Predict | 
Prediction 
List 

t 

  

Scores t, one vector for each model 
dimension, are new variables computed as 
linear combinations of X. They provide a 
summary of X that best approximates the 
variation of X only (PC model), and both 
approximate X and predict Y 
(PLS/OPLS/O2PLS model). 

Home | 
Scores 

  

T2Range Hotelling's T2 for the selected range of 
components. It is a distance measure of 
how far away an observation is from the 
center of a model hyperplane. 

For OPLS/O2PLS the range is locked to 
using first predictive to last Orthogonal in 
X. 

Home | 
Hotelling's T2 

T2RangePS Predicted Hotelling's T2 for the selected 
range of components. 

For OPLS/O2PLS the range is locked to 
using first predictive to last Orthogonal in 
X. 

Predict | 
Hotelling's 
T2PS 
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Vector Description Displayed 

tcv X score t for the selected model 
dimension, computed from the selected 
cross validation round. 

For PLS/OPLS/O2PLS tcv contains one 
value per observation and for PCA one 
value per observation and cross validation 
round. 

Analyze | CV 
Scores 

tcvSE Jack-knife standard error of the X score t 
computed from all rounds of cross 
validation. 

  

to Orthogonal X score to of the X-part of the 
OPLS/O2PLS model, for the selected 
component. It summarizes the unique X 
variation, i.e., the X variation orthogonal to 
Y. 

Home | 
Scores 

Home | 
Scores | Orth 
X 

tocv Orthogonal X score to from the X-part of 
the OPLS/O2PLS model, for a selected 
model dimension, computed from the 
selected cross validation round. 

toPS Predicted orthogonal X score to of the X-
part of the OPLS/O2PLS model, for the 
observations in the predictionset 

Predict | 
Scores PS 

toPScv Matrix of cross validated predicted scores 
ToPS for the predictionset. Available for 
OPLS and O2PLS models. 

tPS Predicted X score t, for the selected model 
dimension, for the observations in the 
predictionset.  

Predict | 
Score PS 

tPScv Predicted X score t, for the selected model 
dimension, computed from the selected 
cross validation round. 

  

tPScvSE Jack-knife standard error of the X score t, 
for the observations in the predictionset, 
computed from all rounds of cross 
validation. 

  

u 

  

Scores u, one vector for each model 
dimension, are new variables summarizing 
Y so as to maximize the correlation with 
the X scores t.  

Analyze | 
Inner Relation 

ucv Y score u for the selected model 
dimension, computed from the selected 
cross validation round. 

  

uo Orthogonal Y score uo of the Y-part of the 
OPLS/O2PLS model, for the selected 
component. It summarizes the unique Y 
variation, i.e., the Y variation orthogonal to 
X. 

Home | 
Scores | Orth 
Y 
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Vector Description Displayed 

uocv Orthogonal Y score uo of the Y-part of the 
OPLS/O2PLS model, computed from the 
selected cross validation round. 

  

VarDS Variable from the selected dataset, in 
original units. Available after selecting a 
DS in the Data box. 

  

VarID Variable Identifier.   

VarPS 

  

X variable from the predictionset. Can be 
displayed in transformed or scaled units. 

  

XVar X variable from the workset. Can be 
displayed in transformed or scaled units. 

  

XVarPred A reconstructed variable from the workset. 
For PLS and PCA models, an X variable 
from the workset is reconstructed as 
X=TP'. For OPLS models XVarPred 
represents the X-values predicted from the 
given Y-values. 

  

XVarPredPS A reconstructed variable from the 
predictionset. For PLS and PCA models, 
an X variable from the predictionset is 
reconstructed as X=TPS * P'. For OPLS 
models XVarPredPS represents the X-
values predicted from the given Y-values. 

  

XVarPS X variable from the predictionset. Can be 
displayed in transformed or scaled units. 

Predict | 
Prediction 
List 

XVarRes X variable residuals for observations in the 
workset, in original units. Can be displayed 
in transformed or scaled units. 

  

XVarResPS X variable residuals for observations in the 
predictionset, in original units. Can be 
displayed in transformed or scaled units. 

  

XVarResPSSt X variable residuals for observations in the 
predictionset, in standardized units 
(divided by the residual standard 
deviation). Can be displayed in 
transformed or scaled units. 

  

XVarResSt X variable residuals for observations in the 
workset, in standardized units (divided by 
the residual standard deviation). Can be 
displayed in transformed or scaled units. 

  

XVarResYRelated X variable residuals where the systematic 
variation orthogonal to Y has been 
removed. Available for OPLS and O2PLS. 
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Vector Description Displayed 

YPred Predicted values of Y variables for 
observations in the workset, in original 
units, i.e., back-transformed when 
transformations are present. Can be 
displayed in transformed or scaled units. 

Home | 
Observed vs. 
Predicted 

YPredcv Predicted values of the fitted Ys for 
observations in the workset, computed 
from the cross validation procedure.  

  

YPredPS Predicted values for Y variables for 
observations in the predictionset, in 
original units, i.e. back transformed when 
transformations are present. Can be 
displayed in transformed or scaled units. 

Predict | Y PS 

Predict | 
Prediction 
List 

YPredErrcv Prediction error of the fitted Ys for 
observations in the workset, computed 
from the cross validation procedure.  

  

YPredPSConfInt- 

YPredPSConfInt+ 

Lower/upper limit for the confidence 
interval of predicted Ys from the 
predictionset. The limit is calculated from 
the cross validation and the confidence 
level specified in model options. 

  

YPredPScv Predicted values of the modeled Ys for 
observations in the predictionset, 
computed from the cross validation 
procedure.  

  

YPredPScvSE Jack-knife standard error of the prediction 
of Y for observations in the predictionset, 
computed from all rounds of cross 
validation. 

  

YVar Y variable from the workset. Can be 
displayed in transformed or scaled units. 

Home | 
Observed vs. 
Predicted 

YVarPS Y variable from the predictionset. Can be 
displayed in transformed or scaled units.  

Predict | Y PS 

YVarRes Y variable residuals for observations in the 
workset, in original units. Can be displayed 
in transformed or scaled units.  

  

YVarResSt 

  

Y variable residuals for observations in the 
workset, in standardized units (divided by 
the residual standard deviation). Can be 
displayed in transformed or scaled units. 

  

YVarResPS Y variable residuals for observations in the 
predictionset, in original units. Can be 
displayed in transformed or scaled units. 
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Vector Description Displayed 

YVarResPSSt Y variable residuals for observations in the 
predictionset, in standardized units 
(divided by the residual standard 
deviation). Can be displayed in 
transformed or scaled units. 

  

Observations and Loadings vectors 
In the Plot/List tab dialogs the vectors found in the Items box with data type 
Observations and Loadings are row vectors with the same “shape” as an observation, 
i.e., with one row per variable. 

See the table for the vectors available and their description in alphabetical order. The 
rightmost column displays the plot/list/spreadsheet where the vector is available, when 
applicable, in bold text if the vector is displayed by default. 

Vector Description Displayed 

Batch VIP 

  

The Batch Variable Importance plot (Batch 
VIP) is available for batch level models and 
displays the overall importance of the variable 
on the final quality of the batch. With phases, 
the plot displays the importance of a variable 
by phase. With a PLS model, the Batch VIP 
displays the plot for one y-variable at a time, 
with a column per variable and per selected 
phase. 

Note: The Batch VIP is only available for 
scores batch level datasets. 

Batch | 
Variable 
Importance 

c For every dimension in the PLS model there is 
a c vector. It contains the Y loading weights 
used to linearly combine the Y's to form the Y 
score vector u. This means the c vector 
actually expresses the correlation between the 
Y's and the X score vector t. 

Home | 
Loadings 

c(corr) Y loading weight c scaled as a correlation 
coefficient between Y and u. 

Home | 
Loadings 

Analyze | 
Biplot 

ccv Y loading weight c for a selected model 
dimension, computed from the selected cross 
validation round. 

  

ccvSE Jack-knife standard error of the Y loading 
weight c computed from the rounds of cross 
validation. 
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Vector Description Displayed 

co Orthogonal Y loading weights co combine the 
Y variables (first dimension) or the Y residuals 
(subsequent dimensions) to form the scores 
Uo. 

These orthogonal Y loading weights are 
selected so as to minimize the correlation 
between Uo and T, thereby indirectly between 
Uo and X. Available for OPLS and O2PLS 
models. 

  

cocv Orthogonal Y loading weights co from the Y-
part of the model, for a selected model 
dimension, computed from the selected cross 
validation round. Available for OPLS and 
O2PLS models. 

  

Coeff PLS/OPLS/O2PLS regression coefficients 
corresponding to the unscaled and uncentered 
X and Y. This vector is cumulative over all 
components up to the selected one. 

Home | 
Coefficients 

  

CoeffC PLS/OPLS/O2PLS regression coefficients 
corresponding to the unscaled but centered X 
and unscaled Y. This vector is cumulative over 
all components up to the selected one. 

Home | 
Coefficients 

CoeffCS 

  

PLS/OPLS/O2PLS regression coefficients 
corresponding to centered and scaled X, and 
scaled (but uncentered) Y. This vector is 
cumulative over all components up to the 
selected one. 

Home | 
Coefficients 

CoeffCScv PLS/OPLS/O2PLS regression coefficients 
corresponding to the centered and scaled X 
and the scaled (but uncentered) Y computed 
from selected the cross validation round. 

  

CoeffCScvSE Jack-knife standard error of the coefficients 
CoeffCS computed from all rounds of cross 
validation. 

  

CoeffMLR PLS/OPLS/O2PLS regression coefficients 
corresponding to the scaled and centered X 
but unscaled and uncentered Y. This vector is 
cumulative over all components up to the 
selected one. 

Home | 
Coefficients 

CoeffRot Rotated PLS/OPLS/O2PLS regression 
coefficients corresponding to the unscaled and 
uncentered X and Y. This vector is cumulative 
over all components up to the selected one. 

Home | 
Coefficients 

MPowX The modeling power of variable X is the 
fraction of its standard deviation explained by 
the model after the specified component. 

  

Num Index number: 1, 2, 3 etc.   
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Vector Description Displayed 

ObsDS Observation in the dataset, selected in the 
Data box, in original units. 

  

ObsPS Observation in the current predictionset, in 
original units. There is only one current 
predictionset at a time although many can be 
specified. 

  

p Loadings of the X-part of the model. 

With a PCA model, the loadings are the 
coefficients with which the X variables are 
combined to form the X scores, t. 

The loading, p, for a selected PCA dimension, 
represent the importance of the X variables in 
that dimension. 

With a PLS model, p expresses the importance 
of the variables in approximating X in the 
selected component. 

Home | 
Loadings 

p(corr) 

  

X loading p scaled as a correlation coefficient 
between X and t. 

Home | 
Loadings 

Analyze | 
Biplot 

pc X loading p and Y loading weight c combined 
to one vector. 

Home | 
Loadings 

pc(corr) X loading p and Y loading weight c scaled as 
correlation coefficients between X and t (p) and 
Y and u (c), and combined to one vector. 

Home | 
Loadings 

Analyze | 
Biplot 

pccvSE  Jack-knife standard error of the combined X 
loading p and Y loading weight c computed 
from all rounds of cross validation. 

  

pcv X loading p for a selected model dimension, 
computed from the selected cross validation 
round. 

  

pcvSE Jack-knife standard error of the X loading p 
computed from all rounds of cross validation. 

  

po Orthogonal loading po of the X-part of the 
OPLS/O2PLS model. po expresses the unique 
variability in X not found in Y, i.e, X variation 
orthogonal to Y, in the selected component. 

Home | 
Loadings 

Home | 
Loadings | 
Orth X 

po(corr) Orthogonal loading po of the X-part of the 
OPLS/O2PLS model, scaled as the correlation 
coefficient between X and to, in the selected 
component. 



User Guide to SIMCA 

544 

Vector Description Displayed 

pocv Orthogonal loading po of the X-part of the 
OPLS/O2PLS model, for a selected model 
dimension, computed from the selected cross 
validation round. 

poso Orthogonal loading po of the X-part and the 
projection of to onto Y, so, combined to one 
vector. Available for OPLS and O2PLS. 

Home | 
Loadings 

Home | 
Loadings | 
Orth X 

pq X loading weight p and Y loading weight q 
combined to one vector. Available for OPLS 
and O2PLS. 

Home | 
Loadings 

Home | 
Loadings | 
Pred X-Y 

q Loadings of the Y-part of the OPLS/O2PLS 
model. 

q expresses the importance of the variables in 
approximating Y variation correlated to X, in 
the selected component. Y variables with large 
q (positive or negative) are highly correlated 
with t (and X). 

Home | 
Loadings 

Home | 
Loadings | 
Pred X-Y 

qcv Y loading q for a selected model dimension, 
computed from the selected cross validation 
round. Available for OPLS and O2PLS models. 

Q2VX, Q2VY 

  

Predicted fraction, according to cross 
validation, of the variation of the X (PCA) and Y 
variables (PLS/OPLS/O2PLS), for the selected 
component.  

Home | 
Component 
Contribution 

Q2VXcum, 
Q2VYcum 

Cumulative predicted fraction, according to 
cross validation, of the variation of the X 
variables (PCA model) or the Y variables 
(PLS/OPLS/O2PLS model). 

Home | 
Summary of 
Fit 

qo Orthogonal loading qo of the Y-part of the 
OPLS/O2PLS model. 

qo expresses the unique variability in Y not 
found in X, i.e, Y variation orthogonal to X, in 
the selected component. 

Home | 
Loadings | 
Orth Y 

qocv Orthogonal loading qo of the Y-part of the 
OPLS/O2PLS model, for a selected model 
dimension, computed from the selected cross 
validation round. 

qor qo and r combined to one vector. Available for 
OPLS and O2PLS.  

Home | 
Loadings | 
Orth Y 
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Vector Description Displayed 

r R is the projection of uo onto X.  

R contains non-zero entries when the score 
matrix Uo is not completely orthogonal to X. 
The norm of this matrix is usually very small 
but is used to enhance the predictions of X. 
Available for OPLS and O2PLS.  

Home | 
Loadings | 
Orth Y 

R2VX Explained fraction of the variation of the X 
variables, for the selected component. 

Home | 
Component 
Contribution 

R2VXAdj Explained fraction of the variation of the X 
variables, adjusted for degrees of freedom, for 
the selected component.  

Home | 
Component 
Contribution 

R2VXAdjcum Cumulative explained fraction of the variation 
of the X variables, adjusted for degrees of 
freedom. 

Home | X/Y 
Overview 

R2VXcum Cumulative explained fraction of the variation 
of the X variables. 

Home | X/Y 
Overview 

R2VY Explained fraction of the variation of the Y 
variables, for the selected component.  

Home | 
Component 
Contribution 

R2VYAdj 

  

Explained fraction of the variation of the Y 
variables, adjusted for degrees of freedom, for 
the selected component.  

Home | 
Component 
Contribution 

R2VYAdjcum 

  

Cumulative explained fraction of the variation 
of the Y variables, adjusted for degrees of 
freedom. 

Home | X/Y 
Overview 

R2VYcum Cumulative explained fraction of the variation 
of the Y variables. 

Home | X/Y 
Overview 

RMSEcv Root Mean Square Error, computed from the 
selected cross validation round. 

Analyze | 
RMSECV 

RMSEE Root Mean Square Error of the Estimation (the 
fit) for observations in the workset. 

  

RMSEP Root Mean Square Error of the Prediction for 
observations in the predictionset. 

Predict | Y PS 
| Scatter 

Predict | Y PS 
| Line 

S2VX Residual variance of the X variables, after the 
selected component, scaled as specified in the 
workset. 

  

S2VY Residual variance of the Y variables, after the 
selected component, scaled as specified in the 
workset.  
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so So is the projection of to onto Y.  

So contains non-zero entries when the score 
matrix To is not completely orthogonal to Y. 
The norm of this matrix is usually very small 
but is used to enhance the predictions of Y. 
Available for OPLS and O2PLS models. 

Home | 
Loadings | 
Orth X 

VarID Numerical variable identifiers, primary or 
secondary. 

All lists 
displaying 
variables, for 
instance Home 
| Coefficients | 
List 

VIP Variable Influence on the Projection. It provides 
the influence of every term in the matrix X on 
all the Y's. Terms with VIP>1 have an above 
average influence on Y. This vector is 
cumulative over all components up to the 
selected one.  

Home | VIP 

VIPcv VIP computed from the selected cross 
validation round. 

  

VIPcvSE Jack-knife standard error of the VIP computed 
from all rounds of cross validation. 

  

w 

  

X loading weight that combine the X variables 
(first dimension) or the X residuals (subsequent 
dimensions) to form the scores t. This loading 
weight is selected so as to maximize the 
correlation between t and u, thereby indirectly 
between t and Y. 

X variables with large w's (positive or negative) 
are highly correlated with u (and Y). 

Home | 
Loadings 

w* 

  

X loading weight that combines the original X 
variables (not their residuals in contrast to w) to 
form the scores t. 

In the first dimension w* is equal to w. 

w* is related to the correlation between the X 
variables and the Y scores u. 

W* = W(P'W)-1 
X variables with large w* (positive or negative) 
are highly correlated with u (and Y). 

Home | 
Loadings 

w*c X loading weight w* and Y loading weight c 
combined to one vector. 

Home | 
Loadings 

w*ccvSE 

  

Jack-knife standard error of the combined X 
loading weight w* and Y loading weight c 
computed from all rounds of cross validation. 

  

w*cv X loading weight w*, for a selected model 
dimension, computed from the selected cross 
validation round. 
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Vector Description Displayed 

w*cvSE Jack-knife standard error of the X loading 
weight w* computed from all rounds of cross 
validation. 

  

wcv X loading weight w, for a selected model 
dimension, computed from the selected cross 
validation round. 

  

wcvSE Jack-knife standard error of the X loading 
weight w computed from all rounds of cross 
validation. 

  

wo Orthogonal loading weight wo of the X-part of 
the OPLS/O2PLS model. It combines the X 
residuals to form the orthogonal X score to. 
This loading weight is selected so as to 
minimize the correlation between to and u, 
thereby indirectly between to and Y.  

  

wocv Orthogonal loading weight wo of the X-part of 
the OPLS/O2PLS model, for a selected model 
dimension, computed from the selected cross 
validation round. 

  

Xavg Averages of X variables, in original units. If the 
variable is transformed, the average is in the 
transformed metric. 

  

XObs X variables for the selected observation in the 
workset in original units. Can be displayed in 
transformed or scaled units. 

  

XObsPred Reconstructed observations as X=TP’ from the 
workset. Can be displayed in transformed or 
scaled units. 

  

XObsPredPS Reconstructed observations as X=TP’ from the 
predictionset. Can be displayed in transformed 
or scaled units. 

  

XObsRes Residuals of observations (X space) in the 
workset, in original units. Can be displayed in 
transformed or scaled units. 

  

XObsResPS Residuals of observations (X space) in the 
predictionset, in original units. Can be 
displayed in transformed or scaled units. 

  

Xws Scaling weights of the X variables.   
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Vector Description Displayed 

Y-Related 
Profiles 

Displays the estimated pure profiles of the 
underlying constituents in X under the 
assumption of additive Y-variables. 

Estimation includes a linear transformation of 
the Coefficient matrix, Bp(BpTBp)-1, where Bp 
is the Coefficient matrix using only the 
predictive components to compute the 
Coefficient matrix (i.e., the components 
orthogonal to Y are not included in the 
computation of Bp). Available for OPLS and 
O2PLS models. 

Analyze | Y-
Related 
Profiles 

Yavg Averages of Y variables, in original units. If the 
variable is transformed, the average is in the 
transformed metric. 

  

YObs Y variables for the selected observation in the 
workset in original units. Can be displayed in 
transformed or scaled units. 

  

YObsRes Residuals of observations (Y space) in the 
workset, in original units. Can be displayed in 
transformed or scaled units. 

  

YObsResPS Residuals of observations (Y space) in the 
predictionset, in original units. Can be 
displayed in transformed or scaled units. 

  

Yws Scaling weights of the Y variables.   

Function of component vectors 
For the Plot/List tab dialogs the vectors found in the Items box with data type 
F(Component) are available per component. Some statistics apply to the whole 
matrix; others are for selected variable, for each component. 

See the table for the vectors available and their description in alphabetical order. The 
rightmost column displays the plot/list/spreadsheet where the vector is available, when 
applicable, in bold text if the vector is displayed by default. 

Vector  Description Displayed 

Eig Eigenvalues of the X matrix. View | Model 
Window 

Iter Number of iterations of the 
algorithm till convergence. 

View | Model 
Window 

Num Index number: 1, 2, 3 etc.   

Q2 Fraction of the total variation of 
the X block (PCA) or the Y block 
(PLS) that can be predicted by 
each component. 

View | Model 
Window 
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Vector  Description Displayed 

Q2(cum)progression Cumulative Q2 for the extracted 
components, showing the 
progression of cumulative values 
for each added orthogonal 
component in the OPLS/O2PLS 
model, e.g. 1+0, 1+1, 1+2. 
Available for OPLS/O2PLS 
models with 1+x+0 components. 

Home | Summary of 
Fit 

Q2cum Cumulative Q2 for the extracted 
components. 

View | Model 
Window 

Home | Summary of 
Fit 

Q2VX, Q2VY Predicted fraction, according to 
cross validation, of the variation 
of the X (PCA) and Y variables 
(PLS/OPLS/O2PLS), for the 
selected component.  

Home | Summary of 
Fit | Component 
Contribution 

Q2VXcum, 
Q2VYcum 

Cumulative predicted fraction, 
according to cross validation, of 
the variation of the X variables 
(PCA model) or the Y variables 
(PLS/OPLS/O2PLS model). 

Home | Summary of 
Fit | X/Y Overview 

R2(cum)progression Cumulative fraction of Y 
variation, showing the 
progression of cumulative values 
for each added orthogonal 
component in the OPLS/O2PLS 
model, e.g. 1+0, 1+1, 1+2. 
Available for OPLS/O2PLS 
models with 1+x+0 components. 

Home | Summary of 
Fit 

R2VX Explained fraction of the variation 
of the X variables, for the 
selected component. 

Home | Summary of 
Fit | Component 
Contribution 

R2VXAdjcum Cumulative explained fraction of 
the variation of the X variables, 
adjusted for degrees of freedom. 

Home | Summary of 
Fit | X/Y Overview 

R2VXcum Cumulative explained fraction of 
the variation of the X variables. 

Home | Summary of 
Fit | X/Y Overview 

R2VY Explained fraction of the variation 
of the Y variables, for the 
selected component.  

Home | Summary of 
Fit | Component 
Contribution 

R2VYAdjcum Cumulative explained fraction of 
the variation of the Y variables, 
adjusted for degrees of freedom. 

Home | Summary of 
Fit | X/Y Overview 

R2VYcum Cumulative explained fraction of 
the variation of the Y variables. 

Home | Summary of 
Fit | X/Y Overview 
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Vector  Description Displayed 

R2X Fraction of the total variation of 
the X block that can be explained 
by each component. 

View | Model 
Window. 

Home | Summary of 
Fit 

R2XAdj Explained fraction of the variation 
of the X block, adjusted for 
degrees of freedom, for the 
selected component. 

Home | Summary of 
Fit 

R2XAdjcum Cumulative explained fraction of 
the variation of the X block, 
adjusted for degrees of freedom. 

  

R2Xcum Cumulative explained fraction of 
the variation of the X block. 

View | Model 
Window. 

Home | Summary of 
Fit 

R2Y Fraction of the total variation of 
the Y block that can be explained 
by each component. 

View | Model 
Window. 

Home | Summary of 
Fit 

R2YAdj Explained fraction of the variation 
of the Y block, adjusted for 
degrees of freedom, for the 
selected component. 

Home | Summary of 
Fit 

R2YAdjcum Cumulative explained fraction of 
the variation of the Y block, 
adjusted for degrees of freedom. 

  

R2Ycum Cumulative explained fraction of 
the variation of the Y block. 

View | Model 
Window. 

Home | Summary of 
Fit 

RMSEcv Root Mean Square Error, 
computed from the selected 
cross validation round. 

Analyze | RMSECV 

RMSEcv-
progression 

Root Mean Square Error showing 
the progression of RMSEcv 
values for each added orthogonal 
component in the OPLS/O2PLS 
model, e.g. 1+0, 1+1, 1+2. 
Available for OPLS/O2PLS 
models with 1+x+0 components. 

Analyze | RMSECV 

S2X Variance of the X block. For 
component number A, it is the 
residual variance of X after 
component A. 
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Vector  Description Displayed 

S2Y Variance of the Y block. For 
component number A, it is the 
residual variance of Y after 
component A. 

  

SDt Standard deviation of the X 
scores, T. 

  

SDu Standard deviation of the Y 
scores, U. 

  

SSX Sum of squares of the X block. 
For component number A, it is 
the X residual Sum of Squares 
after component A. 

  

SSY Sum of squares of the Y block. 
For component number A, it is 
the Y residual Sum of Squares 
after component A. 

  

YPredErrcvSE Jack-knife standard error of the 
prediction error of the fitted Ys for 
observations in the workset, 
computed from the cross 
validation rounds. 

  

Function of lags vectors 
For the Plot/List tab dialogs vectors found in the Items box with data type F(Lags) are 
available as functions of lags. 

See the table for the vectors available and their description in alphabetical order. 

Vector Description 

CoeffCScvSELag Jack-knife standard error on the coefficients as a function of 
lag, computed from all cross validation rounds. 

CoeffCSLag Coefficients (for scaled and centered data) of a lagged variable 
x, for a selected Y as a function of lags. 

Num Index number: 1, 2, 3 etc. 

pLag X loading p of a lagged variable X, as a function of lags. 

wLag X loading weight w of a lagged variable as a function of lags 

w*Lag X loading weight w* of a lagged variable as a function of lags 

VIPLag VIP of a lagged variable X as a function of lags. 

Aligned Vectors 
In the Plot/List tab dialogs the vectors found in the Items box with data type Aligned 
Vectors are available for vectors aligned to median length. The average or standard 
deviation of the vector can be displayed, and selected batches. 
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Aligned vectors are available for batch evolution models. 

Note: All aligned vectors are named '(Aligned)' in addition to the vector 
name. 

See the table for the vectors available and their description in alphabetical order. The 
rightmost column displays the plot/list/spreadsheet where the vector is available. 

Vector Description Displayed 

DModX DModX vector aligned to median 
length. See DModX description 
previously. 

Batch | DModX BCC. 

DModXPS DModXPS vector aligned to median 
length. See DModXPS description 
previously. 

Batch | DModX PS 
BCC. 

Num Index vector: 1, 2, 3 etc.   

t t vector aligned to median length. See t 
description previously. 

Batch | Scores BCC. 

T2Range T2Range vector aligned to median 
length. See T2Range description 
previously. 

Batch | Hotelling's T2 
BCC. 

T2RangePS T2RangePS vector aligned to median 
length. See T2RangePS description 
previously. 

Batch | Hotelling's 
T2PS BCC. 

Time/Maturity Time or Maturity variable determining 
the end point of a Batch/Phase and 
used as Y in the observation level 
models. This variable is used to align 
Batch/Phase to the median length.  

All aligned batch 
control charts. 

tPS tPS vector aligned to median length. 
See tPS description previously. 

Batch | Scores PS 
BCC. 

XVar XVar vector aligned to median length. 
See XVar description previously. 

Batch | Variable BCC. 

XVarPS XVarPS vector aligned to median 
length. See XVarPS description 
previously. 

Batch | Variable PS 
BCC. 

YPred YPred vector aligned to median length. 
See YPred description previously. 

Batch | Observed vs. 
Time/Maturity BCC. 

YPredPS YPredPS vector aligned to median 
length. See YPredPS description 
previously. 

Batch | Observed vs. 
Time/Maturity PS 
BCC. 

YVar YVar vector aligned to median length. 
See YVar description previously. 

Batch | Observed vs. 
Time/Maturity BCC. 

YVarPS YVarPS vector aligned to median 
length. See YVarPS description 
previously. 

Batch | Observed vs. 
Time/Maturity PS 
BCC. 
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Batch Vectors 
In the Plot/List tab dialogs the vectors found in the Items box with data type Batch 
Vectors are the Out of Control Summary vectors, OOCSum, for all vectors displayed 
in the batch control charts. That is: DModX, DModXPS, T2Range, T2RangePS, t, tPS, 
XVar, XVarPS, YPred, and YPredPS. The OOCSum vectors are all named as the 
mother vector with the suffix AlignedOOCSum. 

The OOCSum for a given vector is the ratio of the area of the vector outside the 
control limits to the total area inside the limits, for each batch. The OOCSum is then 
expressed as a percent of the area inside the limits. With no part of the batch outside 
the limits, OOCSum=0. 

OOCSum is always computed on aligned vectors, both for workset and predictionset 
vectors. 

The OOCSum vector is default displayed using the default limits. 

Change the limits as desired under High limit and Low limit after adding the series. 

   
 

Vector  Description 

DModXAlignedOOCSum For a plot of DModX vs. Maturity for a batch in the 
workset the out of control (OOC) sum is the area 
outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to a DModX vector aligned to 
median length.  

DModXPSAlignedOOCSum For a plot of DModX vs. Maturity for a batch in the 
predictionset the out of control (OOC) 

sum is the area outside the control limits 
expressed as a percentage of the total area. 

T2RangeAlignedOOCSum For a plot of T2Range vs. Maturity for a batch in 
the workset the out of control (OOC) sum is the 
area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to a T2Range vector aligned to 
median length.  
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Vector  Description 

T2RangePSAlignedOOCSum For a plot of T2Range vs. Maturity for a batch in 
the predictionset the out of control (OOC) sum is 
the area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to a T2RangePS vector aligned to 
median length.  

TAlignedOOCSum For a plot of scores (t) vs. Maturity for a batch in 
the workset the out of control (OOC) sum is the 
area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to a t vector aligned to median 
length.  

TPSAlignedOOCSum For a plot of scores (t) vs. Maturity for a batch in 
the predictionset the out of control (OOC) sum is 
the area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to a tPS vector aligned to median 
length.  

XVarAlignedOOCSum For a plot of an X-variable vs. Maturity for a batch 
in the workset the out of control (OOC) sum is the 
area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to an XVar vector aligned to median 
length.  

XVarPSAlignedOOCSum For a plot of an X-variable vs. Maturity for a batch 
in the predictionset the out of control (OOC) sum is 
the area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to an XVarPS vector aligned to 
median length.  

YPredAlignedOOCSum For a plot of YPred vs. Maturity for a batch in the 
workset the out of control (OOC) sum is the area 
outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to an YPred vector aligned to 
median length.  

YPredPSAlignedOOCSum For a plot of YPred vs. Maturity for a batch in the 
predictionset the out of control (OOC) sum is the 
area outside the control limits expressed as a 
percentage of the total area. The summation is 
made relative to an YPredPS vector aligned to 
median length.  

  



Appendix A: Statistics 

555 

Formulas and descriptions 
Fitting a PCA, PLS, OPLS, or an O2PLS model generates all the vectors listed in the 
Vectors available in SIMCA section earlier in this chapter. This section describes and 
provides formulas for a selection of those vectors. The descriptions for PLS vectors are 
also true for the vectors created when fitting OPLS/O2PLS models unless otherwise 
stated. When fitting with OPLS/O2PLS a few additional vectors are calculated and 
these are listed in the same tables.  

All vectors that have a 'Y' in the name refer to PLS/OPLS/O2PLS models. 

SIMCA will iteratively compute one component at a time, that is: one vector each of 
X-scores t, Y-scores u (for PLS/OPLS/O2PLS), weights w and c (for 
PLS/OPLS/O2PLS), and loadings p. 

The components are calculated in descending order of importance. 

Prediction vectors 
After fitting a model, this model can be used for predictive purposes for a given set of 
observations. 

The following vectors are described in this section: 

 R2Y, R2X, R2Yadj, R2Xadj 

 R2V and R2Vadj 

 Q2 and Q2V 

 Q2(cum) and Q2V(cum) 

 Leverages 

 RSD of observations and variables 

 Modeling power - MPowX 

 Hotelling's T2 

 Missing values correction factor 

 Score and loading vectors 

 Distance to the model 

 Variable importance, VIP 

 Standard Error on the predicted values 

 Coefficients 

R2Y, R2X, R2Yadj, R2Xadj 
R2Y and R2X display the fraction of the sum of squares for the selected component, SS 
explained. 

R2Yadj, R2Xadj display the variance explained in the model, that is, SS explained 
corrected for degrees of freedom 
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R2V and R2Vadj 
For every variable in the model, the fraction of SS (R2V) or variance (R2Vadj) 
explained can be displayed. This is computed for both the current component and 
accumulated over all PC or PLS components. For response variables Y, this 
corresponds to R2 (the multiple correlation coefficient), the goodness of fit. 

Q2 and Q2V 
Q2: The fraction of the total variation of X or Y that can be predicted by a component, 
as estimated by cross-validation. 

Q2 is computed as: 

Q2 = (1.0 - PRESS/SS) 

Q2V: The fraction of the variation of a variable, e.g. xk or ym, that can be predicted by 
a component, as estimated by cross-validation. 

Q2V is computed as: 

Q2VX = (1.0 - PRESS/SS) k 

Q2VY = (1.0 - PRESS/SS) m   

where Q2VX is available for both PCA and PLS, but Q2VY only for PLS. 

When using SIMCA with cross validation, Q2 and the limit are displayed in the model 
window and the significance column informs if the component is significant or not and 
according to which rule. 

For details about the cross validation rules, see the Cross validation section later in 
this chapter. 

Q2(cum) and Q2V(cum) 
The cumulative Q2 for the extracted components is computed as: 

Q2(cum) = (1.0 - Π(PRESS/SS)a) 

where 

[a = 1, ...A] 

Π(PRESS/SS)a = the product of PRESS/SS for each individual component a. 

When a component is insignificant the value PRESS/SS is truncated for that component 
to –0.1, when that value is smaller than –0.1. 

The cumulative Q2V of a variable is similarly computed as: 

Q2V(cum) = (1.0 - Π(PRESS/SS)ka) 

where 

[a = 1, ...A] 

When responses have large values of Q2V(cum) accumulated over all dimensions, the 
model for this variable is good. An accumulated value larger than about 0.5 can be 
considered large. 
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Leverages 
The leverage is a measure of the influence of a point (observation) on the PC or PLS 
model. Leverage (OLev) is proportional to Hotelling's T2.  Observations with high 
leverages can exert a large influence on the model. A high leverage observation falling 
near a component axis reinforces the model. A high leverage observation lying far 
away from a component line causes a rotation of the model. 

SIMCA computes the observations leverages in the X and Y spaces as the diagonal 
elements of the matrices H0 and Hy, respectively: 

H0 = T(T'T)-1T' 

HY = U(U'U)-1U' 

RSD of observations and variables 
The residual standard deviation (RSD) can be computed for observations and variables. 
The RSD of an observation in the X or Y space (rows in E and F) is proportional to the 
observation distance to the hyper plane of the PLS model in the corresponding space 
(DModX and DModY). 

The RSD of an X variable (columns in E) relates to its relevance in the PC or PLS 
model. The RSD of a Y variable (columns in F) is a measure of how well this response 
is explained by the PLS model. 

Relevance of variables 
The importance of a variable in a PC model is indicated by the size of its explained 
Sum of Squares (R2X) or variance (R2Xadj). 

A variable is relevant if its modeling power = 1.0. Variables with low modeling power, 
i.e., around (A/K) are of little relevance (A = number of model dimensions, K= number 
of variables). 

Modeling power - MPowX 
The modeling power of a variable is defined as its explained standard deviation: 

Mpowk = 1.0 - SVk/SV0k 

where 

SVk = residual standard deviation (RSD) of variable xk. 

SV0k= initial standard deviation of variable k. SV0k= 1.0 if the variable has been 
autoscaled. 

Hotelling's T2 
T2Range is basically calculated as the sum over the selected range of components of 
the scores in square divided by their standard deviations in square, provided the 
variables were centered. Hence, T2Range is the distance in the model plane (score 
space) from the origin, in the specified range of components. This means that the same 
component is selected as 'From' and 'To' components, the plot displays the Hotelling's 
T2 for that component. 

For OPLS and O2PLS the range is locked to 'From' the first predictive 'To' the last 
orthogonal in x. 
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The Hotelling's T2 for observation i, based on A components is: 

Ti 
2= Σ ((tia - tavg)

2 / sta
2)   

where 

the summation is done over the range of the selected components, 

s2
ta = Variance of ta according to the class model. 

Ti
2 * (N - A) / A(N - 1) 

is F distributed with A and N-A degrees of freedom. 

N = Number of observations in the workset. 

A = Number of components in the model or the selected number of components. 

Hence if 

Ti
2 > A(N - 1) / (N - A) * Fcritical (p=0.05) 

then observation i is outside the 95% confidence region of the model. 

Ellipse in score plot 
The confidence region for a two dimensional score plot of dimension a and b is an 
ellipse with axis: 

(s2
ta or b *F(2,N-2, * 2 * ((N -1)/(N-2))) 

The significance level is by default 0.05. On the File tab, click Project Options and in 
the Fit tab change the default level if desired. 

To not display the ellipse, see the Limits and Regions and Limits subsections in the 
Plot and list contextual tabs chapter. 

Missing values correction factor 
The NIPALS algorithm has been modified for data containing missing values. A limit 
has been introduced on the correction factor used with missing values. This stabilizes 
both the algorithm and the solution. A value of 3.0 for the limit on the correction factor 
for both the scores and the loadings has generally been found to be appropriate. 

Missing values and PCA 
A very important problem in industrial applications of PCA, such as multivariate 
statistical process control applications, is the estimation of scores when the observation 
vector has missing data. SIMCAs approach to score calculations for such incomplete 
observations are based on methods described in Nelson, P.R.C., Taylor, P.A., 
MacGregor, J.F., Missing Data Methods in PCA and PLS: Score Calculations with 
Incomplete Observation, Chemometrics and Intelligent Laboratry Systems, 35, 45-65, 
1996. 

SIMCA uses different approaches to compute t and tPS for incomplete observations 
and if the proportion of missing data is large there can be numerical differences 
between t and tPS. 
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Score and loading vectors 
The score and loading plots available for plotting are described below. 

Note that the score and loading plots complement each other. The position of an 
observation in a given direction in a score plot is influenced by variables lying in the 
same direction in the loading plot. 

All of these score plots described here will reveal: 

 Groups 

 Trends 

 Outliers 

 Similarity 

T scores (X): t1 vs. t2, ... 
T score plots are windows in the X space displaying the observations as situated on the 
projection plane or hyper plane. 

With a 2-dimensonal score plot SIMCA draws the elliptical confidence interval based 
on Hotelling's T2. 

U scores (Y): u1 vs. u2, ... 
U score plots are windows in the Y space, displaying the observations as situated on 
the projection plane or hyper plane. 

T vs. U scores (X&Y): t1 vs. u1, ... 
T vs U score plots display the observations in the projected X(T) and Y(U) space, and 
show how well the Y space correlates to the X space. 

P loadings (X): p1 vs. p2,... 
P loading plots show the importance of the X variables in the approximation of the X 
matrix. 

W loadings (X): w1 vs. w2, ... 
W loading plots display the correlation between the X variables, in the first dimension, 
or the residuals of the X variables in subsequent dimensions, and the Y or Y residuals 
scores U(Y). 

The w's are the weights that combine the X variables (first dimension) or the residuals 
of the X variables (subsequent dimensions) to form the scores t. These weights are 
selected so as to maximize the covariance between T and U, thereby indirectly T and 
Y. 

X variables with large w's (positive or negative) are highly correlated with U(Y). 

Variables with large w's are situated far away from the origin (on the positive or 
negative side) on the plot. 
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W* loadings (X): w*1 vs. w*2, ... 
For every PLS dimension the W*'s are the weights that combine the original X 
variables (not their residuals as with w) to form the scores t. 

W* is computed as follows: 

W* = W(P'W)-1 

From this formula we can see that w* is equal to w in the first dimension. 

Also, when P is equal to W (for all dimensions), W* is equal to W because W'W (and 
P’W) is equal to 1. 

Relation of W* to the PLS regression coefficients 
For a given response Y, the PLS regression coefficients are (for the model Y = XB): 

B = W(P'W)-1C' 

or 

B = W*C' and Y = XW*C' 

Hence, W* is directly related to the PLS regression coefficients. 

C loadings (Y): c1 vs. c2, ... 
C loading plots display the correlation between the Y variables and T(X). The c's are 
the weights that combine the Y variables with the scores u, so as to maximize their 
correlation with X. Y variables with large c's are highly correlated with T(X). 

WC or W*C loadings (X&Y): wc1 vs. wc2, ... 
WC or W*C loading plots show both the X-weights (w or w*) and Y-weights (c), and 
thereby the correlation structure between X and Y. One sees how the X and Y 
variables combine in the projections, and how the X variables relate to Y. 

TPS scores (X): tPS1 vs. tPS2, ... 
The plots On the Predict tab classify (new) observations in the predictionset with 
respect to a PC or PLS model and predicts responses (values of Y variables) for (new) 
observations (PLS). 

For a given set of observations, SIMCA computes the predicted scores: tPS. With 
missing data in the new observation (denoted by z below), these scores are calculated 
by means of PLS and the model below, according to Nelson, Taylor, and MacGregor 
(see reference list). 

z = P*tPS + e 

Distance to the model 
This section describes the different distances to the model available in SIMCA for 
observations in the workset or in the predictionset. 

 Absolute distance to the model of an observation in the workset 

 Normalized Distance to the model of an observation in the workset 

 Distance to the model of new observations in the predictionset 

 MPow weighted distance to the model 
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 Critical distance to the model 

 Membership significance level 

Absolute distance to the model of an observation in the 
workset - DModX, DModY(Absolute) 
For observations in the workset, SIMCA computes the observation distance to the 
model in the X space, DModX, and in the Y space, DModY (for PLS models). These 
distances are equivalent to X and Y residual standard deviations, respectively. 

DModX absolute 

DModX of an observation in the workset (i.e., that was part of the model) is computed 
as: 

si= sqrt(Σeik
2 / (K-A))* v 

The summation is made over the X variables (k) and eik are the X-residuals of 
observation i. 

v is a correction factor (function of the number of observations and the number of 
components) and is slightly larger than one. 

This correction factor takes into account the fact that the distance to the model 
(DModX) is expected to be slightly smaller for an observation that is part of the 
workset since it has influenced the model. 

DModY absolute 

DModY of an observation in the workset (i.e., that was part of the model) is computed 
as: 

si= sqrt(Σfim
2/ M)  

The summation is made over the Y variables (m) and fim are the Y residuals of 
observation i. 

DModY absolute for OPLS/O2PLS 

DModY of an observation in the workset, when the fit method is OPLS/O2PLS is 
computed as: 

si= sqrt(Σfim
2/ M) * v  

The summation is made over the Y variables (m) and fim are the Y residuals of 
observation i. 

Normalized distance to the model of an observation in the 
workset - DModX, DModY (Normalized) 
The normalized distance to the model is the observation absolute DModX or DModY 
divided by the pooled RSD of the model, s0, in the X space and in the Y space. 

The pooled RSD for the X space is calculated as: 

s0= (ΣΣeik
2/ ((N-A-A0)*(K-A))) 

A0 = 1 if model is centered, 0 otherwise. 

DModX normalized 

DModX normalized = si/s0 

where 

si is the absolute DModX. 
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s0 is the pooled RSD for the X space. 

The pooled RSD for the Y space is calculated as: 

s0= (ΣΣfim
2/ ((N-A-A0)*M))  

DModY normalized  

DModY normalized = si/s0       

where  

si is the absolute DModY.  

s0 is the pooled RSD for the Y space.  

Absolute distance to the model of new observations in the 
predictionset - DModXPS, DModYPS (Absolute) 
The absolute distance to the model DModXPS of a new observation is computed as the 
observation RSD: 

si= sqrt(Σeik
2 / (K-A))  

The difference in the formula in comparison with the calculation of DModX is that the 
correction factor in not present. 

The distance to the model in the Y space, DModYPS, of a new observation (i.e., that 
was not part of the model) is computed in the same way as DModY, that is, for an 
observation that was part of the model: 

si= (Σfim
2/ M)  

Normalized distance of a new observation to the model - 
DModXPS, DModYPS (Normalized) 
The normalized distance to the model is the observation absolute DModXPS or 
DModYPS divided by the pooled RSD of the model (not the predictionset) s0: 

Normalized DModXPS = si/s0 

where 

s0= (ΣΣeik
2/ ((N-A-A0)*(K-A))  

Normalized DModYPS = si/s0 

where 

s0= (ΣΣfim
2/ ((N-A-A0)*M)  

A0 = 1 if model is centered, 0 otherwise. 

Distance to the model augmented - DModXPS+ (Absolute) 
or (Normalized) 
With predictions, the distance to the model can be augmented with a term measuring 
how far outside (d) the acceptable model domain the projection of the observation 
falls. The result is called DModXPS+. Hence, for an observation in the predictionset 
(hence the “PS” label), this is: 

DModXPS+ = [DModXPS2 + d2]1/2 
Where 

d = ∑d0i
2*S2Xi/(SDt(i))2 for components i = 1 to A. 
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d0 is the distance between the score value t and the score limit for component 
i for an observation in the predictionset. If t is within the limits, d0 is zero. 
The score limits are: 

Upper limit: Max(t) + SDt/2 

Lower Limit: Min(t) - SDt/2 

S2Xi is the residual variance.  

Here the distance from the projected point of the observation to the model domain is 
re-expressed in the same units as the residuals by multiplication by the RSD of the 
workset (s0) and division by the pooled standard deviation of the score vectors in 
which the projected point is outside the acceptable interval. 

The DModXPS+ can be expressed in absolute or normalized, and weighted by the 
modeling power, just like DModXPS. 

MPow weighted distance to the model - DModX, DModXPS, 
DModXPS+ (Abs/Norm and weighted) 
With MPow weighted DModX/DModXPS/DModXPS+, that is, distance to the model 
for the X-block weighted by the modeling power, the observation RSD is computed 
with weighted residuals, where the weights are the modeling powers of the variables. 

Critical distance to the model 
The critical limit for the distance to model measure (DCrit) is calculated by an inverse 
cumulative F-distribution function. The three input parameters for this function are the 
significance level and the degrees of freedom of the numerator and the denominator of 
the F-distribution. In this case, the numerator is the degrees of freedom of the 
observations in the training set (DF_obs) and the denominator is the degrees of 
freedom of the model (DF_mod). DCrit is equal to the value F* in the figure below 
where the blue area is the probability p that an observation will be outside the DCrit 
limit. For example, if the significance level is set to 0.95, typically 95% of the 
observations would have a DModX value below DCrit. The exact shape and scale of 
the curve is determined by the degrees of freedom. The F* value can be extracted from 
statistical tables of the F-distribution. 

 
In SIMCA, the value of the degrees of freedom for the model is calculated as: 

DF_mod = ((N-C-A)*(K-A))   

where 

N = number of observations 
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C = 1 if all X variables are centered, else 0 

A = number of components 

K = number of X variables 

(DF_mod cannot be smaller than 1) 

The value of the degrees of freedom for the observations is calculated as: 

If K > DF_mod 

DF_obs = (M + Q – A) / CORR 

else 

DF_obs = (M – A) / CORR 

where 

M = the smallest value of [K, 100, DF_mod] 

Q = square root of (K-DF_mod) 

CORR =  N / (N-C-A)   

(N-C-A and DF_obs cannot be smaller than 1). 

The expressions above result in a normalized DCrit value. If the critical limit is to be 
presented in absolute values, DCrit is multiplied by the residual variance in X. 

Membership significance level 
As default, observations with a probability of class membership less than 5% are 
considered non-members. 

Variable importance, VIP 
SIMCA computes the influence on Y of every term (xk) in the model, called VIP 
(variable importance in the projection). VIP is the sum over all model dimensions of 
the contributions VIN (variable influence). For a given PLS 

dimension, a, (VIN)ak
2 is equal to the squared PLS weight (wak)

2 of that term, 
multiplied by the explained SS of that PLS dimension. 

The accumulated (over all PLS dimensions) value, 

VIPak
2 = Σ(VIN)k

2 

where the summation is made over a = 1 to A. 

This value is then divided by the total explained SS by the PLS model and multiplied 
by the number of terms in the model. 

The final VIP is the square root of that number. 

The formula can also be expressed as: 

VIPAk= (Σ(wak
2 * (SSYa-1 -   SSYk))* (K/( SSYa -   SSYA))) 

The Sum of squares of all VIP's is equal to the number of terms in the model hence the 
average VIP is equal to 1. 

One can compare the VIP of one term to the others. Terms with large VIP, larger than 
1, are the most relevant for explaining Y. 
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Standard Error and Jack-knifing uncertainties 
SIMCA computes standard errors on the predicted Y values in two different ways: 

 According to Höskuldsson resulting in the Serr vectors. 

 From Jack-knifing resulting in error bars in plots. 

Standard error according to Höskuldsson - Serr 
The variance of the prediction (Yhat) for a given response y at a point X0 according to 
Höskuldsson, is computed as: 

V(Yhat) = (1/N + t0 (T'T)-1 t0' )σ
2 

where 

t0 are the scores t of observation X0 

σ2 is the y error variance estimated from the Sum of Squares of the residuals of y 
divided by the degrees of freedom for PLS, i.e. (N-A-A0). 

A = number of PLS components and A0 is 1 or 0, depending on whether y is centered 
or not. 

Confidence intervals can be computed from the standard error by multiplying by a t 
(distribution) value with the appropriate degrees of freedom. 

Jack-knifing (JK) uncertainties 
Jack-knifing is a method for finding the precision of an estimate, by iteratively keeping 
out parts of the underlying data, making estimates from the subsets and comparing 
these estimates. 

In both PCA and PLS, the set of multiple models resulting from the cross-validation is 
used to calculate jack-knifing uncertainty measures (standard errors and confidence 
intervals) of scores, loadings, PLS-regression coefficients, predicted Y-values, and 
VIP. These are displayed by default in column plots, and can also be listed by right-
clicking the plot and clicking Create List. 

Right-clicking a column plot and clicking Properties, clicking the Limits tab, and then 
selecting None as confidence limit provides the means to remove the confidence 
intervals if desired. 

The standard formula of JK is used (see e.g., B. Efron and G. Gong). 

Reference Jack-knifing 

1. Efron, B., and Gong, G., (1983), A Leisurely Look at the Bootstrap, the Jack-
knife, and Cross-validation, American Statistician, 37, 36-48. 

Coefficients 
The PLS model parameters are used to re-express the Y variables as multiple 
regression models of the X variables: 

Y = XB 

where 

X refers to the X matrix, including squared and/or cross terms if those were added 

Y is the matrix of responses. 

The values of the regression coefficients depend on the scaling of X and Y. 
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Note: These coefficients are usually not independent unless X has been 
generated by a statistical design. 

The types of coefficients available are described in the subsections that follow. 

For the OPLS/O2PLS specific Y Related Profiles, see the Y-Related Profiles 
subsection earlier in this chapter. 

Scaled and centered coefficients - CoeffCS 
CoeffCS are the coefficients when X is scaled and centered and Y is scaled. These 
coefficients are used for interpreting the influence of the variables X on Y. 

The scaling weights are those selected in the workset, usually to give the X and Y 
variables unit variance (autoscaling). 

The centered and scaled coefficients are expressed according to the following formula: 

y * wsm = ybar * wsm + bk(xk - xbark ) * wsk + ...   

... + bkk(zk
2 *  wsk

2 - mkk) * vk + ...   

... + bjk(zj *  zk * wsj * wsk - mjk) + vjk + ...   

where 

zk = ( xk - xbark ) 

wsm = Scaling weights of response ym 

wsk = Scaling weights of variable xk 

mkk = Average of zk
2 

mjk= Average of zj * zk   

vk = Scaling weight of zk
2 

vij= Scaling weight of zi * zj 

Coefficients MLR - CoeffMLR 
CoeffMLR are the coefficients when Y is unscaled and uncentered and X is scaled and 
centered and the second centering and scaling of the squared and cross terms has been 
removed. 

y = b0 + bk(xk - xbark) * wsk + ...   

... + bkk(zk
2 * wsk

2) + ...   

... + bik(zi *  zk * wsi * wsk) + ...   

where 

zk = ( xk - xbark )  

wsk = Scaling weights of variable xk 

These coefficients correspond to the multiple regression coefficients. 

Coefficients unscaled - Coeff 
The coefficients when X and Y are unscaled and uncentered are expressed as follows: 

ym = b0 + b1x1 + …+ bkxk + b11x1
2 + b12x1x2 +… 

The unscaled coefficients should be used only for computations, for example contour 
plots, but are difficult to interpret because of the differences in units between the raw 
variables. 
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Note: When x was transformed in the model it also needs to be transformed 
when used in the equation. 

Rotated coefficients 
When working with spectral data, it is often desirable to estimate the pure spectral 
profile as they relate to Y. 

The PLS coefficients as relating to centered and scaled data are expressed as 

B = W(P'W)-1C' 

The rotated coefficients are obtained by the transformation of the B matrix into the 
pure constituent profile estimates, KPLS. 

KPLS = B(BTB)-1 

This corresponds to a projection of the X space into the B space, in order to estimate 
the pure constituents profile from Y, in other word a direct calibration. 

Rotating the coefficients is warranted not only with spectral data, but in any situation, 
similar to indirect calibration, where Y is assumed to contribute additively to the 
variation in X. 

Reference rotated coefficients 

1.  Trygg, J., (2004), Prediction and Spectral Profile Estimation in Multivariate 
Calibration, Journal of Chemometrics, 18, 166-172. 

Coefficients with Y unscaled uncentered, X unscaled 
centered - CoeffC 
The coefficients when Y is unscaled and uncentered, and X is unscaled but centered, 
are computed as follow: 

y = ybar + bk(xk - xbark ) + ...    

... + bkk(zk
2 - mkk) + ...   

... + bjk(zj *   zk - mjk) + ...   

where the terms are defined as for the other coefficients. 

Note: CoeffC cannot be selected in the Properties dialog of the Coefficient 
Plot only in the Plot/List tab dialogs. 

RMSEE, RMSEP and RMSECV 
A popular plot to interpret the performance of a regression model is the scatter plot 
showing the relationship between the observed Y and the predicted Y. Such a plot can 
be constructed both for the workset observations and the predictionset observations, 
provided that the observed Y is known for the latter group.  

By using the regression line tool in SIMCA, the resulting R2 of the regression line can 
be used to quantify the strength of the association between the observed Y and the 
predicted Y for the workset observations. The closer to unity the stronger the 
association. The drawback of the obtained association measure, however, is that 
neither it (R2) nor its residual correspondence (1-R2) relate to the measurement unit of 
the observed Y.  
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It is possible to obtain a performance measure that relates to the unit of the observed Y, 
which is denoted Root Mean Square Error of Estimation (RMSEE). RMSEE is 
computed as ((Yobs-Ypred)2/(N-1-A)), where Yobs-Ypred refers to the fitted 
residuals for the observations in the workset. RMSEE measures the fit of the model. 
An analogous parameter for the predictionset is denoted Root Mean Square Error of 
Prediction (RMSEP). RMSEP is computed as ((Yobs-Ypred)2/N), where Yobs-
Ypred refers to the predicted residuals for the observations in the predictionset. 
RMSEP measures the predictive power of the model.  

An alternative predictivity measure for the model is available through summarizing the 
cross-validation residuals of the observations in the workset. The predictivity measure 
obtained is called Root Mean Square Error from cross-validation (RMSECV). 
RMSECV can be regarded as an intermediary to RMSEE and RMSEP, as it applies to 
the workset (as does RMSEE) but indicates predictive power (as does RMSEP). The 
RMSEE, RMSEP and RMSECV values are listed at the bottom of plots wherever these 
parameters are applicable.  

RMSECV is available through a separate plot in the Analysis group on the Analyze 
tab, allowing the evolution of RMSECV across the model components to be displayed. 

For OPLS and O2PLS models with 1+x+0 components, the RMSEcv plot is displayed 
showing the progression. For more see the RMSEcv plot subsection in the Analyze 
chapter. 

Transform page criteria 
In the Transform page in the Workset dialog the Min/Max and Skewness values are 
colored red when a transformation is recommended. 

The criteria for the coloring are: 

 Min/Max is colored red when 0<=Min/Max<0.1. 

 Skewness is colored red when sTest < -2 or 2 < sTest 

where 

sTest = Skewness/((6.0*dN*(dN-1.0)/((dN-2.0)*(dN+1.0)*(dN+3.0))))) 

Skewness is the skewness value listed in the variable list. 

dN = number of non missing values in the variable and has to be equal to or larger than 
3. 

Automatic transformation criteria 
When using the Transform button to automatically log transform when appropriate, 
the criteria used to decide if a log transform is needed is the same criteria as used for 
coloring Skewness and Min/Max red, with the following additions: 

 When calculating Min/Max the Min value used is the smallest not counting 
0. 

 The number of non-missing values has to be larger than 4 and larger than 
0.1*number of rows in the dataset. 

A small constant is added to the values when needed for the transformation. 
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Scaling 
The results of both PC and PLS modeling are scale dependent. Selecting the scaling of 
the variables is therefore an important step in fitting projection models such as PC or 
PLS. 

The SIMCA default for all selected variables is a unit variance base weight and a block 
scaling factor of 1 (no block scaling). For more, see the Scaling variables section in 
the Home chapter. 

This section describes the computation of autoscaling, block scaling, the scaling 
weight, the scaling of expanded terms, transformed variables, lagged variables, 
variables in classes, scaling after reselecting observations, and calculation of the 
scaling weight. 

Autoscaling 
If one has no prior information about the importance of the variables, autoscaling all 
variables to unit variance (UV) is recommended. This is equivalent to making all of the 
variable axes have the same length, which is, giving all of the variables equal 
importance. 

If one has prior information about the importance of the variables, it may be desirable 
to scale some variables up or down, by modifying their unit variance weights. 

Block scaling 
Block-wise scaling is warranted when a data table contains several types (blocks) of 
variables, with a highly different number of variables in each block. Block-wise 
scaling allows each block to be thought of as a unit and to be given the appropriate 
variance which is smaller than if each variable was autoscaled to unit variance. 

In such cases you can select to scale a block, i.e., a number of variables of the same 
type, such that the whole block has 

(Kblock) 

or 

((Kblock)) 

variance, where Kblock is the number of variables in the block. 

Scaling weight calculation 
The final scaling weight (Xws or Yws) is the product of: 

 Base weight, usually Unit Variance. 

 Block scaling weight. 

 Modifier (default = 1; used to scale variables up or down relative to the base 
scaling weight). 

When the variable is not blocked (block scaling weight = 1) and when the modifier is 
equal to 1, the scaling weight is equal to the base weight. 
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Scaling of expanded terms 
Expanded variables, i.e. squares, cross or cubic terms are displayed in the Scale page. 
You can block scale expanded terms and/or change their modifier, but you cannot 
change the base type as it is inherited from the mother variable. 

Note: Whenever you change the base type of the mother variables, the scaling 
of both lagged variables and expanded terms is re-computed accordingly. 

Computation 
To compute expanded variables, all mother variables are first always centered (even if 
mother variables in themselves are uncentered) and then scaled as specified by the base 
type of the mother variables. 

Scaling and centering of the expanded term after 
computation 
Expanded variable are scaled using the scaling base type of the mother variables. 

For cross terms, if mother variables have different scaling types, the expanded term 
inherits the scaling type of the majority, or for 2 factor interactions the highest ranking 
scaling type. 

The hierarchy of scaling types is as follow: 

 Centered and then Noncentered. 

 UV, Pareto, and then None. 

Scaling weights for transformed variables 
When variables are transformed, the scaling weights are those of the transformed 
variables. 

If you later further transform a variable, the scaling weight is re-computed according to 
the base type. 

If you transform a variable after selecting base type Freeze, the scaling weight is not 
recomputed. It is frozen with the status of the variable and the current selection of 
observations at the time you selected Freeze as base type. 

Scaling of variables with classes 
When you have grouped observations in classes, and fitted a PC or PLS class model, 
the scaling weights of the variables are computed using the observations in the class. If 
a variable has zero variance within the class observations, this variable is not excluded 
but is given a scaling weight based on the observations of the whole workset. 

Scaling of lagged variables 
The lagged variables, by default, inherit the scaling weight (and transformation) of the 
mother variables. It is strongly recommended not to change the scaling weight of 
lagged variables. 

Scaling after changing the observation selection 
The scaling weights of all variables, except those with base type Frozen, are 
recomputed when you change the selection of observation. 
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The scaling weights of variables with a frozen base type are not computed when the 
selection of observations is changed after Freeze was selected as base type. 

Cross validation 

Cross validation for PCA 
The cross validation works as follows: 

1. Parts of the X data are kept out of model development. 
SIMCA uses the approach of Krzanowski [1] where in two sub rounds, data 
are first kept out observation-wise (row-wise) to get a set of loading vectors, 
and second data are kept out variable-wise (column-wise) to get a set of 
score vectors. 

2. The kept out parts are then predicted by the model. 

3. The predictions of the kept out parts are compared with the actual values. 

4. 1-3 is repeated until all parts have been kept out once and only once. 

PRediction Error Sum of Squares - PRESS 

The prediction error sum of squares (PRESS) is the squared differences between 
observed and predicted values for the data kept out of the model fitting. The prediction 
of the (i, k) element in scaled and centered form is the ith score value multiplied by the 
kth loading value, where both have been estimated in a CV round when this element 
was kept out. 

This procedure is repeated several times until every data element has been kept out 
once and only once. The final PRESS then has contributions from all data. 

For each component consecutively, SIMCA computes the overall PRESS/SS, where 
SS is the residual sum of squares of the previous component. SIMCA also computes 
(PRESS/SS)k for each X variable (xk). 

Data kept out observation and variable wise 

A special (proprietary) PC estimation is used in the CV rounds to minimize the 
tendency for the present component to partly rotate into later components. 

Cross validation for PLS, OPLS and O2PLS 
The cross validation works as follows: 

1. Rows of the X/Y-data are kept out of model development 

2. The kept out parts are then predicted by the model. 

3. The predictions of the kept out parts are compared with the actual values. 

4. 1-3 is repeated until all parts have been kept out once and only once. 

PRediction Error Sum of Squares - PRESS 

The prediction error sum of squares (PRESS) is the squared differences between 
observed and predicted values for the Y-data kept out of the model fitting. The 
prediction of the (i, m) element in scaled and centered form is the ith score value 
multiplied by the mth loading value, where both have been estimated in a CV round 
when this element was kept out. 

This procedure is repeated several times until every data element has been kept out 
once and only once. The final PRESS then has contribution from all data. 
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PLS Specific 
For each component consecutively, SIMCA computes the overall PRESS/SS, where 
SS is the residual sum of squares of the previous component. This type of cross 
validation is usually named partial cross validation. SIMCA also computes 
(PRESS/SS)m for each Y variable (xm).  

OPLS and O2PLS Specific 
The OPLS and O2PLS cross-validation is performed as follows: 

1.  The number of predictive or joint X/Y components is estimated; this number 
may be adjusted using rule R2 after calculating all predictive and orthogonal 
components.  

2.  The number of orthogonal components in X and Y are decided.  

For these steps, rule R1 is used to determine the significance of the components.  

For all included components, SIMCA computes the overall Q2=1-PRESS/SS, where 
SS is the sum of squares of Y. This type of cross validation is called full cross 
validation. SIMCA also computes (Q2)m for each Y variable.  

The cross validation for the Orthogonal in X(PCA) and the Orthogonal in Y(PCA) is 
performed as for the regular PCA above. 

Reference cross validation 
1. Eastment, H. and Krzanowski, W., Crossvalidatory choice of the number of 

components from a principal component analysis, Technometrics 24 (1982) 
73-77. 

2. Martens, H and Naes, T., Multivariate Calibration, 1989. 

Cross validation rules - Significant component 
When calculating the PCA orthogonal components of O2PLS, the cross validation 
rules for PCA apply. 

Rule 1: R1 
A component is significant according to Rule 1 when 

Q2 > Limit 

where 

Limit = 0 for PLS models with more than 100 observations. 

Limit = 0.05 for PLS models with 100 observations or less. 

Limit = 0.01 for OPLS and O2PLS. 

Limit depends on the number of components for PCA. The limit increases with 
subsequent components to account for the loss in degrees of freedom. 

The significance limit for each component is displayed in the Model Window. 

Rule 2: R2 for PCA 
A component is significant according to Rule 2 when  

Q2V> Limit for at least 

 20% of the x-variables when K > 25. 
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 sqrt(K)*log10(max(10, K-20)) when K < 25. 

K = number of x-variables. 

Q2V is Q2 for individual variables. 

Provided the eigenvalue > 1.5 or K < 30. 

Rule 2: R2 for PLS, OPLS and O2PLS 
A component is significant according to Rule 2 when  

Q2V> Limit for at least 

 20% of the y-variables when M > 25. 

 sqrt(M) when M < 25. 

M = number of y-variables. 

Q2V is Q2 for individual variables. 

Rule 3: U and R5 
With PCA when a component is insignificant it is first labeled U (Undecided). If the 
next component is significant and has a similar eigenvalues (tolerance of 5%) as the 
previous one, then both component together are considered significant. The U of the 
undecided component is changed to R5. 

Cross validation rules - Non Significant component 
The significance column of the model summary for a “non significant” component is 
marked NS, N3, or N4. When calculating the PCA orthogonal components of O2PLS, 
the cross validation rules for PCA apply. 

N3 
The component is not significant when the remaining data for that component have 
insufficient degrees of freedom. For PCA, SIMCA stops when the number of extracted 
components is larger than N/2 or K/2 whichever is smaller. 

N4 
The component is not significant according to rule 4 when the explained variance for X 
(PC) / Y (PLS) is less than 1% and no variable has more than 2% (PC) / 3% (PLS) 
explained variance. 

NS 
The component is not significant according to rule 1 or rule 2 and N3 and N4 do not 
apply. 

NS is only displayed when the component is computed with cross validation. 

Note: N3 and N4 are always displayed when applicable, irrespective of 
whether cross validation was used or not. 

Cross validation rules for batches 
The cross validation rules for batch evolution models are different from other types of 
models since the objective here is to extract as much of X as possible. 
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The cross validation rules are: 

 Minimum of 3 components, if R2X = 85 % continue if next component R2X 
 > 7% and then next component if R2X > 5%. 

 As many as needed to reach R2X of 85% not exceeding N/2. 

 K/2 or 15 comp (K=Number of variables) whichever smaller and stop when 
R2X of a component is less than 3%. 

Rule 1: RB1 
As long as 85% has NOT been reached and a component explains more than 5% of 
R2X, it is considered significant and labeled RB1. 

Rule 2: RB2 
If a component explains between 3% and 5% of R2X, it is considered significant and 
labeled RB2. 

NB1 - stopping rule 
NB1, stopping rule, is the label when the number of component exceeds one of the 
following: 

 N/2 

 K/2 

 15 

NS - Not Significant 
The component explains less than 3% of R2X and is considered not significant. The 
label is NS. 

PLS time series analysis 
Processes often have a “memory”, i.e., the state of the process at time t is influenced 
by the state at earlier times, i.e., t-1, t-2, t-3, ..., etc. To model such processes with 
“memory”, Box-Jenkins time series models, ARMA, and ARIMA models 
(autoregressive / integrated / moving average), have been widely used in process 
modeling and control. A time series model is basically formulated as an ordinary 
regression model, but including also lagged variables, possibly in both X and Y: 

Yt, m = b0mXt + b1mXt-1 + b2mXt-2 +…+c1mYt-1+c2mYt-2 +…+et 

The main problem with this model formulation has been that the predictor variables 
(Xt, Xt-1, etc.) usually are very collinear and also noisy. Multiple regression with its 
assumptions of independence and preciseness of the predictors is therefore difficult to 
use for the model estimation. 

With PLS, however, collinear and noisy predictor variables do not cause any particular 
problems, so the model can be directly estimated on the form above. Technically, this 
is done in SIMCA by creating an expanded predictor matrix, X*, that contains the 
appropriate selection of the original variables, plus lagged variables, i.e., time shifted 
one, two, or any selected time units. 
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The PLS analysis of the relationship between X* and the pertinent Y is straightforward, 
and will give the ordinary PLS parameters, X and Y-scores t and u, weights w and c, 
and regression coefficients, b. These can be plotted and interpreted in the same way as 
with ordinary PLS models. Additionally, plots of weights (w) and coefficients (b) for 
the different lags of a single variable are of interest for the identification of the most 
important lag. 

In this way time series analysis is incorporated in the same framework of modeling as 
ordinary data analysis of “non-dynamic” data, reducing the complexity and difficulties 
involved. 

References PLS time series 
1. Efron, B., and Gong, G., (1983), A Leisurely Look at the Bootstrap, the Jack-

knife, and Cross-validation, American Statistician, 37, 36-48. 

2. Eastment, H. and Krzanowski, W., (1982), Crossvalidatory choice of the 
number of components from a principal component analysis, Technometrics 
24  73-77. 

3. Höskuldsson, A., PLS regression methods. J. Chemometrics, 2, (1988) 211-
228. 

4. Nelson, P.R.C., Taylor, P.A., MacGregor, J.F., Missing Data Methods in 
PCA and PLS: Score Calculations with Incomplete Observation, 
Chemometrics and Intelligent Laboratry Systems, 35, 45-65, 1996. 

CV-ANOVA 
CV-ANOVA, ANalysis Of VAriance testing of Cross-Validated predictive residuals, is 
a diagnostic tool for assessing the reliability of PLS, OPLS and O2PLS models. It is 
implemented for single-Y and multiple-Y models for the relation X  Y. The 
diagnostic is based on an ANOVA assessment of the cross-validatory (CV) predictive 
residuals of a PLS, OPLS or O2PLS model. The advantages of using the CV-residuals 
are that no extra calculations are needed and that this procedure secures reasonably 
independent data and variance estimates. 

Formally, ANOVA is a method to compare two models by the size of their residuals 
when fitted to the same data [1, 2, 3, 4]. In the regression context, the two models 
compared are: 

yi = constant + di  (1) 

yi = constant + bxi + ei  (2) 

The ANOVA is then made on the size of the sum of squares, SS(d) and SS(e), noting 
that they are not independent since the data underlying them (y) are the same. In the 
current context, this means that we test whether the (PLS/OPLS/O2PLS) model has 
significantly smaller cross validated predictive residuals than just the variation around 
the global average. In summary, the CV-ANOVA provides a significance test 
(hypothesis test) of the null hypothesis of equal residuals of the two compared models. 
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The ANOVA table 
The output of the CV-ANOVA is given in a tabulated format using the conventional 
ANOVA lay-out (see illustration below). 

 
In the ANOVA table, the following numbers are displayed: 

Vector Type Description 

SS Total corr 
(Total 
corrected) 

SS of the Y of the workset corrected for the mean. 

Regression Fraction of Total Corrected SS accounted for by the 
model, estimated via the cross validation principle. 

Residual Difference between Total Corrected and Regression 
SS, i.e., the fraction of Total Corrected unaccounted 
for by the model. 

DF Total corr, 
Regression, 
residual 

The number of degrees of freedom (DF). This is an 
approximate number based on the experience that 
PLS needs half the components to reach the same 
explanation of Y as principal components regression. 

MS Total corr, 
Regression, 
residual 

By dividing each SS by the respective DF, the 
corresponding mean squares (MS), or variances, are 
obtained. 

F   The F-test, based on the ratio MS Regression/MS 
Residual, formally assesses the significance of the 
model. 

p   The p-value indicates the probability level where a 
model with this F-value may be the result of just 
chance. The common practise is to interpret a p-value 
lower than 0.05 as pointing to a significant model. 

SD Standard 
deviation 

Square root of MS. 
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The great benefit of CV-ANOVA is its user-friendliness. It brings the results of cross-
validation to a familiar standard ANOVA format. Thus, CV-ANOVA can be seen as a 
formal test of the significance of the Q2YCV using the F-distribution. CV-ANOVA is 
fast and has a minimal additional computation time beyond the one of the standard 
cross validation. This is in contrast to response permutation testing which is time 
consuming with large data sets and many components. 

References CV-ANOVA 
1. Box, G.E.P., Hunter, W.G., and Hunter, J.S. (1978). Statistics for 

experimenters. Wiley, New York. 2.nd Edition, Wiley 2006. 

2. Ståhle, L., and Wold, S., (1989), Analysis of variance (ANOVA), 
Chemometrics and Intelligent Laboratory Systems, 6, 259-272. 

3. Ståhle, L., and Wold, S., (1990), Multivariate analysis of variance 
(MANOVA), Chemometrics and Intelligent Laboratory Systems, 9, 127-141. 

4. Eriksson, L., Trygg, J., and Wold, S., CV-ANOVA for significance testing of 
PLS and OPLS models, submitted for publication 2008. 

Fisher's Exact test 
The Fisher Exact test is derived from the probability of the particular classification 
result and all outcomes more extreme than the one observed. For a 2x2 contingency 
table the probability of a particular outcome is given by the formula below. 

p = ((a + b)!(c + d)!(a + c)!(b + d)!)/(a! + b! + c! + d! + n!) 

Where ! means factorial (the product of all numbers down to 1). 

All probabilities more extreme than the observed pattern are computed and summed to 
give the probability of the table occurring by chance. 

References Fisher's Exact test 
1. Fisher, R.A., (1922), On the interpretation of χ2 from contingency tables, 

and the calculation of P. Journal of the Royal Statistical Society 85(1):87-94. 

2. Fisher, R.A., (1954), Statistical Methods for research workers, Oliver and 
Boyd. 

3. Fisher, R.A., and MacKenzie, W., (1923), Studies in Crop Variation. II. The 
manurial response of different potato varieties, Journal of Agricultural 
Science, 13, 311-320. 
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Control Chart statistics 
This section describes the statistics described in the footers of the plots in the 
subsections: 

 Nomenclature and notation 

 Target and Standard deviation 

Nomenclature and notation in Control Charts 
In the control charts there are a number of statistics displayed in the footer of the plot. 
This subsection describes the statistics, the data source for the statistics, the standard 
deviation types calculated, and the model specific statistics. 

See the table for the description of the statistics. 

Statistic Description 

UCL Upper Control Limit 

LCL Lower Control Limit 

S process standard deviation 

Target aim of the process 

SAvg average of standard deviation of subgroup 

RAvg average range of subgroup 

In the table the available data sources used to estimate S or Target are listed: 

There are a number of methods for estimating the standard deviation leading to 
different types of standard deviations. The different standard deviations are described 
in the table. 

Method Description 

SAvg (within) subgroup standard deviation estimated as the average 
standard deviation of the subgroups 

SAvg (between) between group standard deviation estimated as the MSSD 

S ordinary standard deviation when the sample size is 1 

S(Target) standard deviation estimated around the user entered target. 

The model specific statistics available are described in the table. Model specific here 
means that they are calculated using the multivariate model. 

Vector Description 

R2X[1] Fraction of sum of squares for the first 
component. 

Mxx-D-Crit[last component] critical distance in the DModX plot. 

1 – R2X(cum)[last component] 1 – cumulative fraction of sum of squares up to 
the last component. 
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Target and Standard deviation 
With all control charts, the Target and Standard Dev (standard deviation) can be 
Estimated from the workset or User Entered. 

In the plots the following standard deviations and targets are displayed: 

 S(Mxx) = process standard deviation over all observations in the model. 

 SAvg(within) and SAvg(between) see the Control limits… sections in the 
sections for the respective plots. Displayed for >1 subgroups. 

 S(UE) = user entered standard deviation. Displayed after selecting User 
Entered in the Standard Dev box. 

 Target(Mxx) = overall average when there are no subgroups. With 
subgroups, the average of the averages of the subgroups. 

 Target(UE) = user entered target. Displayed instead of Target(Mxx) after 
selecting User Entered in the Target box. 

Note: When displaying plots with items from the predictionset, the estimated 
target and standard deviation values are computed from the workset of the 
selected model. 

 

S-plot 
The S-plot is an easy way to visualize an OPLS discriminant analysis model of two 
classes. It has mainly been used to filter out putative biomarkers from “omics” data e.g. 
NMR, GC/MS and LC/MS metabolomics data. 

In the S-plot both magnitude (intensity) and reliability is visualized. In spectroscopic 
data the peak magnitude is important as peaks with low magnitude are close to the 
noise level and thus have a higher risk for spurious correlation. The meaning of high 
reliability means high effect and lower uncertainty for putative biomarker. 

The axes that are plotted in the S-plot from the predictive component are p1 vs 
p(corr)1, representing the magnitude (modeled covariation) and reliability (modeled 
correlation) respectively. 

Reference S-plot 
Wiklund, S., Johansson, E., Sjöström, L., Mellerowicz, E.J., Edlund, U., Shockcor, 
J.P., Gottfries, J., Moritz, T., and Trygg, J., (2008), Visualization of GC/TOF-MS-
Based Metabolomics Data for Identification of Biochemically Interesting Compounds 
Using OPLS Class Models, Anal. Chem. 80, 115-122. 

Note: The vector 'Cov(tp,X)' is named p[1] and the vector 'Corr(tp,X) is 
named p(corr)[1] in SIMCA. 
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Observation Risk 
For PLS models, the Observation Risk plot is a measure of the sensitivity of the results 
of a workset observation in the Y space measured as a change in the Y residuals when 
the observation is in the workset or not. 

Observation Risk is computed for each individual y-variable and for all y-variables 
together. The column plot displays the observation risk for each y-variable and for the 
pooled y-variables, as different series. 

ORisk = 1 is displayed as a reference line. When ORisk for an observation equals 1, 
this means that the predicted result for the observation is the same whether the 
observation is included in the model or not. 

ORisk(pooled), the rightmost columns, can be larger than or smaller than the ORisk of 
individual y-variables. This is due to a correction factor added to prevent DModY, 
when the observation is in the model, from becoming too small. 

A plot displaying observation risk can be created by selecting the vector ORisk or 
ORisk(pooled) in one of the standard plots on the Plot/List tab.  
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Appendix B: Preprocessing 

Preprocessing available in SIMCA 
There are a number of transformations, or filters, available in SIMCA. 

Transformations 

In the Plot/List tab dialogs, clicking the Transformation tab offers: Auto 
Correlation, Cross Correlation, Power Spectrum, Wavelet Coefficients, EWMA, 
Histogram, Normalize, and R2X. 

Time Series Filters 

The following time series filters are available on the Data tab, Filters group, Time 
Series Filters: Wavelet Compress Time Series (WCTS) and Wavelet 
Denoising/Decimation (WDTS). 

Spectral Filters 

The following spectral filters, applied observation wise, are available on the Data tab, 
Filters group, Spectral Filters: 

Filter name in dialog Full name 

Derivative 1st , 2nd & 3rd Derivative 

MSC  Multiplicative Signal Correction 

SNV  Standard Normal Variate 

Row Center Row Center 

Savitzki-Golay Savitzki-Golay 

EWMA Exponentially Weighted Moving Average 

Wavelet Compression Wavelet Compression Spectral (WCS) 

Wavelet Denoising Wavelet Denoise Spectral (WDS) 

OSC Orthogonal Signal Correction 

This chapter describes the following: 

 Auto and cross correlation of variables or observations 

 Power Spectrum Density 

 Wavelet transformations 

 Filtering and calibration 
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 Derivatives 

 Multiplicative Signal Correction (MSC) 

 Standard Normal Variate (SNV) 

 Wavelet compression or de-noising of signals 

 Orthogonal Signal Correction (OSC) 

Auto and cross correlation of variables or 
observations 

The auto correlation of a vector x is a measure of the dependence between adjacent 
observations. 

In the time domain, for time series, the properties of ARMA processes are 
characterized by their auto correlation functions. 

The auto covariance of a vector x is defined as the Auto-Covariance of lag L of the 
vector y: 

cyy(L) = 1/N((yt - yavg)(yt +L - yavg)) 

where : t=1 to N-L, for L = 0, 1, 2, etc. 

The auto correlation of a vector x is defined as the Auto-correlation of lag L of the 
vector y: 

rL = cyy(L) / cyy(0), cyy(0) = 1/N( (yt - yavg)
2) variance of yt 

Note that rL = r-L 

Similarly the cross covariance of two vectors x and y are defined as the cross 
covariance of lag L between x and y: 

c_xy(L) = 1/N (x_t - x_avg)(y_t+L - y_avg);       t = 1,2,..,N-L, L = 0,1,2,... 

For negative L this is: 

c_xy(L)  = 1/N (y_t - y_avg)(x_t-L - x_avg);       t = 1,2,..,N+L, L = 0,-1,-2,... 

Similarly the cross correlation of two vectors x and y are defined as the cross 
correlation of lag L between x and y: 

r_xy(L) = c_xy(L)/(s_x s_y),             

where s_x and s_y are the standard deviations of x and y. 

SIMCA-P+ estimates the auto/cross correlation using the FFT (Fast Fourier 
Transform). 

Centering and detrending are optional in SIMCA. 

Note: When excluding observations in time series data, the auto and cross 
correlation transformations are approximate as the excluded observations are 
not replaced by missing values. 

Reconstruction of wavelet compressed data 
With a dataset that has been wavelet transformed and compressed variable wise using 
Data | Spectral Filters, the time series plot and the auto correlation observation wise 
refer to the reconstructed observations. 
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To display the auto correlation in the wavelet domain: 

1. Click File | Project Options | Fit and clear the Reconstruct wavelet check 
box. 

2. Use the Plot/List tab to recreate the plot. 

In Quick info, observations in the wavelet domain are always reconstructed. 

References auto and cross correlation 
1. Box, G.E.P., Jenkins, G.M., and Reinsel, G.C., (1994), Time Series Analysis 

- Forecasting and Control, 3rd edition, Prentice-Hall, Inc., Englewood 
Cliffs, NJ. Pages 29-33, Page 411-415. 

2. Press, W., Flannery, B., Teukolsky, S., and Vetterling, W., Numerical 
Recipes in C, Cambridge University Press. 

Power Spectrum Density 
The Power spectrum density (PSD) is the representation of the sequence x (t) in the 
frequency domain. The power spectrum is the square of the amplitude of the Fourier 
component at each frequency. 

The frequency domain representation is particularly helpful to detect irregular cycles 
and pseudo periodic behavior, i.e. tendency towards cyclic movements centered on a 
particular frequency. 

SIMCA uses the Welsch’s non-parametric method to estimate the PSD. 

Note: With a dataset that has been wavelet transformed and compressed 
variables wise, (using Data | Spectral Filters), the PSD observation wise 
refers to the reconstructed observations, when the reconstruct option is on. 

Reference power spectrum 
1. Belsley, D., Kuh, E,. and Welsch, R., (1980), Identifying Influential Data 

and Sources of Collinearity, John Wiley, New York. 

Wavelet transformations 

Introduction 
Wavelet transformation is a linear transformation, similar to the Fourier transform and 
its trademarks are good compression and de-noising of complicated signals. Wavelets 
look like small oscillating waves, and they have the ability to analyze a signal 
according to scale, i.e. inverse frequency. The size of the analyzing window in wavelet 
transform varies with different scales, and it is this small but still very important 
property, along with the fact that wavelet functions are local in both time and 
frequency, that makes the wavelet transform so useful. 
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Overview of the wavelet transform 
The wavelet transform analyzes signals locally without prejudice to scale. This is 
possible because a basis function is employed, called the ‘mother’ wavelet, with a 
certain scale, i.e. window width. The mother wavelet is then stretched or compressed to 
create other scales, changing the width of the window, as can be seen in figure 1. Using 
a narrow wavelet for detecting the sharp features, and a broader wavelet for detecting 
the more general features, means that you see both the forest and the trees. The mother 
wavelet is local in time* and frequency, making wavelets useful not only for 
compression but also for removing noise and for feature extraction. 

*(time, wavelength, wave number, etc.) 

Scale 

Translation 
 

Figure 1. Changing the width of the wavelet function makes it possible to analyze 
different scales. 

Wavelet theory 
A very brief introduction will be given, for a more complete theory description, the 
interested reader is referred to [12,13]. Wavelets belong to the absolutely 
squared integrable function space L2. The wavelet transform is simply the dot product 

between the signal )()( 2  Ltf and the wavelet functions  )(, tnm . 

Discrete Wavelet transform: 






 dtttfttf nmnm )()()(),( ,,  

Mother wavelet: 
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)2(2)( 2/
, ntt mm
nm   

 
where 

m = Scale (Dilation), n = Translation in time. 

One of the mathematical restrictions that apply to the wavelet is the admissibility 
condition: 





dC 









2
)(ˆ

<  

for finite energy 

00)(ˆ   for  

where ω= Frequency )(ˆ  = FT on wavelet function. 

Multiresolution analysis, MRA 
In 1986, a fast wavelet transformation technique called multiresolution analysis was 
presented by Mallat [14]. The signal needs to be of length 2n, where n is an integer. 
This poses no problems, because the signal can be padded to the nearest 2n. In 
multiresolution analysis, another function called the scaling function is introduced, 
which acts as a starting point in the analysis and makes it possible to compute wavelet 
coefficients fast. From the wavelet and scaling function respectively, filter coefficients 
are derived and used in the transformation, and are implemented as finite impulse 
response (FIR) filters. These filter coefficients are put in a filter coefficient matrix of 
size k*k, where k is the length of the signal to be analyzed, and a pyramid algorithm is 
used. The filter coefficients are normalized to make sure that the energy on each scale 
is the same, and the normalizing constant is 1/ (2). Energy is defined as the squared 
sum of all the coefficients. The scaling filter S is located on the first k/2 rows, and the 
wavelet filter D is located on the last k/2 rows. The filter matrix is constructed by 
moving the filter coefficients two steps to the right when moving from row to row, 
requiring k/2 rows to cover the signal. The number of filter coefficients depends on 
what wavelet function is being used. The wavelet filter coefficients can be derived 
from the scaling filter coefficients. 

Wavelet coefficient (c-i+1) = (-1)i Scaling coefficient (i), i=1,2,...,c where c is the 
number of filter coefficients. The Daubechies-4 wavelet function has the following 
four scaling filter coefficients: 

[(1 + (3))/4, (3 + (3))/4, (3 - (3))/4, (1 - (3))/4] 

and wavelet filter coefficients: 

[(1 - (3))/4, (3 - (3))/4, (3 + (3))/4, (1 + (3))/4]  

Reconstruction of the original signal from the wavelet coefficients is straightforward, 
because the normalized orthogonal wavelet filters are used, WTW=I where W is the 
normalized filter coefficient matrix and I is the identity matrix. Simply transpose the 
filter matrix and reverse the procedure. 
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For a signal of length 2n the filtering procedure is performed n times, creating n levels 
of different scales, separated with a factor two. The wavelet filter produces the detailed 
part, and those are the wavelet coefficients. The scaling filter creates an approximate 
description of the signal, and those coefficients are used for representing the signal at 
the next scale, see figure 2. When reaching the highest scale, only one scaling 
coefficient is produced, and it is related to the average value of the original signal. It is 
now possible to reconstruct the original signal using the average value and the wavelet 
coefficients. The size of the transformed signal is the same as the original signal, if the 
average value is taken into account. This method is fast, approximately 2*c*k 
calculations are necessary for a complete transformation [11], where c is the number of 
filter coefficients and k is the original length of the signal. 

Original signal

Approximation Detail

Approximation Detail

Appr. Detail

Scale 1

Scale 2

Scale 3

Multiresolution analysis

Wavelet coefficients

The signal is at each scale
filtered into a course and a
detailed part

 
Figure 2. The fast multiresolution analysis results in a coefficient vector of the same 
size as the analyzed signal. 

Example of MRA using the orthogonal Haar wavelet 
Let us show an example how multiresolution analysis works by using the simplest 
orthogonal wavelet, the Haar wavelet. The filter coefficients for the scaling function is 
1,1, and for the wavelet function 1,-1. 

We start off with the original signal of length 23= 8, see figure 3. The normalized filter 
coefficient matrix is of size 8*8. The scaling filter coefficients are placed on the first 
half of the matrix, and the wavelet filter coefficients are placed on the second half of 
the rows, as described earlier. 

1. Filtering the original signal with the filter matrix produces a signal of the 
same length as the filtered signal, where the coefficients on the right half 
represent the details in the signal at the given scale. 

2. These coefficients are the wavelet coefficients, and they are removed and 
saved. 

3. The remaining coefficients represent an approximate description of the 
original signal and are used to represent the original signal at the next scale. 
With the signal being half the length of the original signal, the filters are 
automatically up-scaled by a factor two, i.e. changing the width of the filter. 
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4. The coarse signal is then filtered with a reduced filter matrix. The procedure 
from the last scale is repeated, removing the right half of the coefficients as 
wavelet coefficients and using the other half to represent the signal at the 
next scale. 

5. With an even more reduced filter matrix, the filtered output signal of length 
two consists of one wavelet coefficient and also the normalized average 
value of the original signal. 

6. Both of these are put in the wavelet coefficient vector. Now, the fast wavelet 
transformation is done, and the wavelet coefficient vector can be used for a 
complete reconstruction of the original signal, by transposing the normalized 
filter coefficient matrix and reversing the filtering operations previously 
done. It is important to realize that the sum of the coarse and the detailed 
signal at a certain scale matches the signal on the scale below, if this is not 
the case we would not be able to recover the original signal. 

Wavelet transformation
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Figure 3. Describes the technique that MRA uses for retrieving the wavelet 
coefficients, and how reconstruction of the original signal is performed. 
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We have seen how MRA works on a signal, so let us try to understand how to interpret 
the different wavelet coefficients. In the Haar example we had a signal with length 23 = 
8. As was shown in figure 5, the first scale in MRA gave 23-1 = 4 wavelet coefficients. 
These coefficients contain the highest frequency details of the original signal, usually 
represented by white noise, and reside in the right half of figure 4. The second scale 
produce 23-2 = 2 coefficients and those coefficients represent lower frequency details 
than scale 1, and are placed next to the coefficients from scale 1. 

scale 1scale 2

Original signal with 8 variables = 23

23 - 1 = 4 coeff.23 - 2 = 2 coeff.

Average value
of signal
(normalized)

scale 3

23 - 3 = 1 coeff.

1 3 3 5 5 3 2 2

8.48 0 -2    2 -1.41    -1.41   1.41  0.00

Wavelet transformation on signal

 
Figure 4. Description of the wavelet coefficient vector. 

Now it is easy to understand that as we move further to the left, information about 
lower and lower frequencies in the original signal is detected. For example when 
compressing NIR-spectra, since they are usually smooth, most of the wavelet 
coefficients in the upper scales will be large, whereas all wavelet coefficients in the 
lower scales representing higher frequencies will be close to zero. 

Best Basis 
The MRA assumes that lower frequencies contain more important information than 
higher frequencies. With MRA only the low pass filter is iterated, creating a 
logarithmic tree. For many signals, in particular time series data, this is not always a 
good assumption. Hence, for compression of non-smooth signals, one uses the best 
basis decomposition. A selected signal (the average spectra, or a representative 
response Y) is decomposed using the wavelet packet. This means that at every node, 
the signal is sent to the low pass-high pass filter bank. This creates a 2-D matrix 
(n*(j+1)), where each column represents a new scale (j). The first column is the 
original signal (average spectra, or Y). This matrix is called a packet table and 
represents the complete dyadic tree structure. 

 



Appendix B: Preprocessing 

589 

An additive measure of information, called entropy by Coifman and Wickerhauser, is 
calculated for each block (node) in the packet table. Entropy is calculated as 

!Sum(p. * (logp)) 

where p are the normalized coefficients (divided by the norm of the original signal), 
squared, in the block (node). Hence, the entropy is related to the sum of squares. 

The best-basis algorithm is used to pick out the “best” basis from the entire possible 
basis in the packet table. Here “best” means the one that minimizes the entropy of the 
signal. 

SIMCA uses this best basis, determined on the target signal, to calculate the wavelet 
transform (coefficients) of the X matrix, for spectra and the X and Y block for time 
series. 

The compression is performed by extracting only a selected number of significant 
coefficients. 

Wavelet families 
The wavelet families available in SIMCA are the orthogonal and the biorthogonal 
wavelet families. 

Orthogonal wavelet families 
The orthogonal wavelet families are: 

 The Beylkin wavelet places roots for the frequency response function close 
to the Nyquist frequency on the real axis. The length of the associated FIR 
filter is equal to 18. This wavelet gives good frequency localization. but 
causes dephasing. 

 The Coiflet wavelets of order 2N are designed to give the wavelet function 
2N odd vanishing moments and the scaling function (2N –1) odd vanishing 
moments. These wavelets have good compression properties. 

 The Daubechies wavelets maximize the smoothness of the "scaling 
function" by maximizing the rate of decay of its Fourier transform. The order 
of the wavelets is 2N. They have N odd vanishing moments and their support 
is of length 2N-1. These wavelets have good overall properties. 

 The Symmlets are the "least asymmetric" compactly supported wavelets 
with maximum number of vanishing moments. Other properties are similar 
to the Daubechies wavelets. 

Note: All orthogonal wavelets are asymmetrical and hence their associated 
filters are not linear phase. 

Biorthogonal wavelet families 
With Biorthogonal wavelets one uses two sets of wavelets and scaling functions, one 
set for the decomposition and the other set for the reconstruction. 

In SIMCA the Biorthogonal wavelets are referred to as ”biorNr” and of order ”Nd”. 
Nr is the reconstruction order and Nd is the decomposition order 

The reconstruction wavelets have a support width of (2Nr +1) and the decomposition 
wavelets have a support width of (2Nd +1). 
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Note: Biorthogonal wavelets are symmetrical and their associated filters are 
linear phase. 

Criteria in selecting a wavelet 
The support (width) of the wavelet function determines the speed of convergence to 0 
when the time or the frequency goes to infinity. 

The support quantifies both the time and frequency localization. You want short 
support for better time localization and long support for better frequency localization. 

The symmetry of the wavelet function is needed to avoid dephasing in image and 
sound analysis. Only the biorthogonal wavelets are symmetrical. 

The number of odd vanishing moments of the wavelet function determines how well 
the wavelet compresses a signal. 

The regularity of the wavelet function is useful to achieve smoothness of the 
reconstructed signal. 

Wavelet compression or de-noising of signals 
SIMCA uses, as default, the Discrete Wavelet transform (DWT) and the MRA 
algorithm. We have found that for NIR spectra, which are usually smooth signal, the 
Daubechies–4 works very well for both compression and reconstruction. You can 
select to use the “Best Basis” decomposition instead of DWT (for signals with high 
frequency content) and select other orthogonal or biorthogonal wavelet. With Best 
Basis we recommend that you use a wavelet with short support as the objective is to 
achieve good time localization. Select a biorthogonal wavelet if having no dephasing is 
important. 

Wavelet denoising vs. compression 
The objective with denoising is to remove noise. The objective with compression is to 
compress the dataset removing some frequencies. These objectives are very similar and 
the results are in most cases very similar. 

The steps performed when wavelet compressing a dataset, are described in the 
subsections that follow in this section. The steps performed in Wavelet denoising are 
very similar to compression in all steps performed, with the exception that after 
compressing the spectra with denoising, the wavelet compressed X matrix is 
transformed back to the original domain before creating the new project. This means 
that with denoising no reconstruction is available, nor necessary, since the denoised 
dataset is in the original domain. 

Steps in wavelet compression of spectra using Variance 
In SIMCA the raw spectra (observations) are padded to the nearest length 2n, n = 
integer. 

Each spectrum, in the dataset, is transformed, with the selected wavelet using DWT or 
Best Basis as computed on the target signal (average spectra). 
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Wavelet compressing the signal using Variance 

The wavelet compression of the signal using Variance is done as follows: 

1. With DWT: 

a. The variance spectrum of the coefficient matrix (training set) in the 
wavelet domain is calculated. 

b. The positions of a selected number of the largest variance 
coefficients are located, and those columns are extracted from the 
wavelet coefficient matrix into a compressed data matrix. 

2. With Best Basis: 

a. The Sum of Squares of the selected signal (the average spectra) in 
the wavelet domain is calculated. 

b. The positions of a selected number of the largest Sum of Squares 
coefficients are located, and those columns are extracted from the 
wavelet coefficient matrix. 

3. The original positions of the extracted coefficients are saved. These are used 
both in future compression of spectra, and in the reconstruction of 
loadings, or scores etc. 

4. A new project is created with the compressed dataset. 

Reconstructing the wavelet signal using Variance 

Reconstruction to the original loadings, coefficients, etc, is done as follows: 

1. The coefficients are placed in their original position in the wavelet vector, 
and all other positions are filled with zeros. 

2. The inverse wavelet transformation is performed. 

The following picture illustrates the steps in the data compression of spectra when 
DWT is used. 
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Figure 5. Overview of the different steps taken in the data compression and regression analysis. 
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Steps in wavelet compression of spectra using the Detail 
levels 
In SIMCA the raw spectra (observations) are padded to the nearest length 2n, n = 
integer. 

Each spectrum, in the dataset, is transformed, with the selected wavelet using DWT. 

Wavelet compressing the signal using Detail levels 

With DWT, the percentage of Sum of Squares of the coefficient matrix in the wavelet 
domain, for each detail level (scale), is calculated. The lowest level (scale) contains the 
highest frequencies. 

In the Wavelet Compression wizard in SIMCA, select the details to include and a new 
project is created with the compressed dataset consisting of the wavelet coefficients 
from the selected detail levels. For more about the actual steps in SIMCA, see the 
Wavelet Compression Spectral – WCS section in the Data chapter. 

This compression method is recommended for smooth signals, when most of the high 
frequencies are noise. 

Reconstructing the wavelet signal using Detail levels 

When reconstructing to the original loading, coefficients, etc., the inverse wavelet 
transform with the coefficients of the details removed (set to 0), is performed. 

PLS wavelet compression of time series 
The objective with time series is to compress the X and Y blocks column wise, 
reducing the number of observations, while keeping the relationship between the Y and 
X blocks. The model in the compressed form should be as predictive as the model in 
the original data. The wavelet transform of time series focuses on one response, Y, 
with the objective to achieve a parsimonious representation of this signal, while 
keeping all of the information related to the relationship between X and Y. With 
several y-variables, one should first do a PCA selecting only a group of positively 
correlated y-variables to be compressed together. One y-variable is selected as the most 
representative, and becomes the target signal. 

Steps in wavelet compression of time series using Sum of 
Squares 

The raw data (X and Y variables), are padded to the nearest length 2n, n = integer, and 
mean centered. 

Each variable, in the dataset, is transformed, using DWT or the Best Basis, as 
computed on the target signal Y. 

Wavelet compressing the time series signal using Sum of Squares 

The wavelet compression of the time series signal, using Sum of Squares, is done as 
follows: 

1. With Best Basis and DWT, the Sum of Squares of the selected signal Y, is 
calculated in the wavelet domain. 

2. The positions of a selected number of the largest Sum of Squares coefficients 
are located, and those columns extracted from the wavelet coefficient matrix 
X and Y. 

3. The original positions of the extracted coefficients are saved and used in 
future compression of time series. 
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4. A new project is created with the compressed dataset. 

In summary, each series (the selected X and Y) are wavelet transformed, and the 
coefficients are kept which preserves the specified “focus variable” y. The same 
coefficients are kept for all variables (all X and Y). 

No reconstruction of loading, coefficients etc. is necessary, in the compressed project, 
due to the fact that the relationship between variables has not been altered. 

Steps in wavelet compression of time series using Detail levels 

The raw data (X and Y variables), are padded to the nearest length 2n, n = integer, and 
mean centered. 

Each variable, in the dataset, is transformed, using DWT. 

Wavelet compressing the time series signal using Detail levels 

The wavelet compression of the time series signal, using Detail levels, is done as 
follows: 

1. With DWT, the percentage of the Sum of Squares, of the selected signal Y, 
for each detail level (scale) is calculated. The lowest level (scale) contains 
the highest frequencies. 

2. Select the detail levels to include and a new project is created with the 
compressed dataset (X and Y) containing only the coefficients from the 
selected detail levels. 

No reconstruction of loadings, coefficients etc. is necessary, in the compressed project, 
due to the fact that the relationship between variables has not been altered. 

This compression method is recommended for smooth Y signals, when most of the 
high frequencies are noise. 

Note: Use detail level selection to perform “Multiscale” analysis of time 
series. 

References for wavelets 
1. Mittermayr, C.R., Nikolov, S.G., Hutter, H., and Grasserbauer, M , (1996), 

Wavelet denoising of Gaussian peaks: a comparative study, Chemometrics 
Intell. Lab. Syst., 34, 187-202. 

2. Barclay, V.J., Bonner, R.F., and Hamilton, I.P.,  (1997), Application of 
Wavelet Transforms to Experimental Spectra: Smoothing, Denoising, and 
Data Set Compression, Anal.Chem., 69, 78-90. 

3. Alsberg, B.K., Woodward, A.M., and Kell, D.B.,  (1997), An Introduction to 
Wavelet Transforms for Chemometricians: A Time-Frequency Approach, 
Chemometrics Intell. Lab. Syst., 37, 215-239.  

4. Walczak, B. and Massart, D.L., (1997), Noise Suppression and Signal 
Compression using the Wavelet Packet Transform, Chemometrics Intell. 
Lab. Syst., 36, 81-94. 

5. Bos, M. and Vrielink, J.A.M.,  (1994), The wavelet transform for pre-
processing IR spectra in the identification of mono- and di-substituted 
benzenes, Chemometrics Intell. Lab. Syst., 23, 115-122. 

6. Walczak, B., Bogaert, B., and Massart, D.L., (1996), Application of Wavelet 
Packet Transform in Pattern Recognition of Near-IR Data, Anal. Chem., 68, 
1742-1747. 
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7. Hubbard, B.B., (1995), The world according to wavelets, A K Peters, 
Wellesley, MA. 

8. Daubechies, (1992), Ten Lectures on wavelets, SIAM, Philadelphia, PA. 

9. Kaiser, G., (1994), A Friendly Guide to Wavelets, Birkhäuser, Boston, MA. 

10. Mallat, S.G., (1989), A Theory for Multiresolution Signal Decomposition: 
The Wavelet Representation, IEEE Transactions on Pattern Analysis and 
Machine Intelligence, v.11 n.7, p.674-693, July 1989. 

11. Trygg, J., and Wold, S., (1998), PLS Regression on Wavelet Compressed 
NIR Spectra, Chemometrics and Intelligent Laboratory Systems, 42, 209-
220.  

12. Wickerhauser, M.V., (1994), Adapted Wavelet Analysis from Theory to 
Software, AK Peters. 

13. Bakshi, B.R ,(1998), Multiscale PCA with Application to Multivariate 
Statistical Process Monitoring, AIChe Journal, 44,7,1596-1610.  

Filtering and calibration 
Base line correction, signal correction, and the like are special cases of filtering, where 
a signal (e.g., a NIR spectrum) is made to look "better" by passing it through a "filter" 
= mathematical function. 

In calibration, one can quantitatively specify at least one objective with filtering, 
namely that the filtering should NOT remove information about Y from the spectra. 
Here Y is what we calibrate against, e.g., concentrations. 

One can often formulate the filtering as a projection (PCA or PLS-like). The X block is 
the (N x K) matrix of unfiltered, uncorrected, set of digitized spectra, while E is the (N 
x K) matrix of "filtered" spectra, T a (N x A) matrix of scores, and P' a (K x A) matrix 
of "filters", loadings. N and K are the numbers of samples and variables of the 
"training set" (calibration set). 

X = TP' + E 

If T can be made orthogonal against Y, we are not removing information from X that 
is linearly related to Y. With this simple insight, we can now develop filters, base-line 
corrections, signal corrections, etc., with this orthogonal constraint. 

Derivatives 
A rapid and often utilized method for reducing scatter effects for continuous spectra 
consists of using derivatives [Naes, et al., 2002]. The first derivative spectrum is the 
slope at each point of the original spectrum. It peaks where the original spectrum has 
maximum slope and it crosses zero where the original has peaks. The second derivative 
spectrum is a measure of the curvature at each point in the original spectrum. Usually, 
this derivative spectrum is more similar to the original spectrum and has peaks 
approximately as the original spectrum, albeit with an inverse configuration [Naes, et 
al., 2002]. The effect of the first derivative is usually to remove an additive baseline 
(“offset”), whereas the effect of the second derivative also involves removal of a linear 
baseline. 
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The third derivative spectrum is a measure of the “wigglyness” of the original 
spectrum. Alternatively, the third derivative spectrum can be understood as the slope at 
each point in the second derivative spectrum, much in the same way as the second 
derivative spectrum indicates the slope at each point of the first derivative spectrum, 
and the latter the slope at each point of the original spectrum. 

A problem with the above approach is that differencing may reduce the signal and 
increase the noise, thus producing very noisy derivative spectra. Realizing this risk 
Savitzky and Golay (SG) proposed an improvement based on a smoothing approach 
[Savitzky and Golay, 1964]. SG-derivatives are based on fitting a low degree 
polynomial function (usually of quadratic or cubic degree) piece-wise to the data, 
followed by calculating the first derivative and second derivative from the resulting 
polynomial at points of interest. SIMCA supports the SG-derivative option. 

References for derivatives 

1. Naes, T., Isaksson, T., Fearn, T., and Davies, T., (2002), A User-friendly 
Guide to Multivariate Calibration and Classification, NIR Publications, 
Chichester, UK. ISBN: 0-95286662-5. 

2. Savitzky, A., and Golay, M.J.E., (1964), Smoothing and Differentiation by 
Simplified Least Squares Procedures, Analytical Chemistry, 36, 1627-1632. 

Multiplicative Signal Correction (MSC) 
The empirical fact that the regression of spectral values (of related samples), against 
the mean spectral values is approximately linear, is the primary motivation for the 
MSC correction. 

The MSC correction is defined as follows: 

Each observation (spectra) xi, is “normalized” by regressing it against the average 
spectrum (mk =  xik/n). 

xik = ai + bi mk + eik 

This gives the MSC corrected spectra: 

xik, corrected = (xik  ai )/bi 

References for MSC 
1. Martens, H. and Naes, T., Multivariate Calibration. Wiley, N.Y., 1989. 

2. Geladi, P., MacDougall, D., and Martens, H., (1985), Linearization and 
Scatter-correction for Near-infrared Reflectance Spectra of Meat, Applied 
Spectroscopy, 3, 491-500. 

Standard Normal Variate (SNV) 
The standard normal variate transformation of Barnes et al is defined by: 

xik = [( xik - xi ) / ((xik -xi )
2)] * (K-1) 

where k = (1,.....K) gives the wavelength and i = the sample index xi = ixi/K 
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Reference for SNV 
1. Barnes, R.J., Dhanoa, M.S., and Lister, S.J., (1989), Standard Normal 

Variate Transformation and De-trending of Near-Infrared Diffuse 
Reflectance Spectra, Applied Spectroscopy, 43, 772-777. 

Orthogonal Signal Correction (OSC) 
OSC is a PLS-related solution, which removes only so much of X as is unrelated 
(orthogonal) to Y. 

The OSC algorithm performs the following steps: 

Step Description Formula 

1. Specifies a starting "loading" or "correction" vector, 
p' 
In the first dimension this can be a row of 1's 
(corresponding to additive correction), or the 
loading of the first principal component of X 
(uncentered), or, 
in the second dimension, p' can be the average 
spectrum (multiplicative signal correction), or the 
second principal components loading etc. 

  

2 Calculates a "score vector", t, in the ordinary 
"NIPALS" way. 

t = Xp/p'p 

3 Orthogonalizes t to Y. tnew = 
(1 - Y(Y'Y)-1Y’)t 

4 Calculates a weight vector, w, that makes Xw = 
tnew. This is done by a PLS estimation giving a 
generalized inverse = (X'X)- 

w = (X'X)-tnew 

5 Computes a new loading vector. p' = 
tnew'X/(tnew'tnew) 

6 Subtracts the "correction" from X, to give the 
"filtered" X. One can then, optionally, continue with 
the next "component", then another one, etc., until 
satisfaction. Usually two components should 
suffice, but with non-linear corrections three are 
sometimes warranted. 

Xnew = 
X - tnew p' 
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This approach is based on the fact that as long as the steps of the PLS NIPALS 
iterative algorithm are retained, the weight vector w can be modified in any way to 
encompass constraints, smoothness, or, as here, the objective that t = Xw is orthogonal 
to Y. This was shown by Höskuldsson (1988). 

 
Umetrics recommends using OPLS/O2PLS instead of OSC as the OSC filter is prone 
to overfit and may give results that are too optimistic. The OPLS/O2PLS approach 
provides more realistic results and separates orthogonal variation from predictive 
variation in a single model. 

Reference for OSC 
1. Wold, S., Antti, H., Lindgren, F., and Öhman, J., (1998a), Orthogonal Signal 

Correction of Near-Infrared Spectra, Chemometrics and Intelligent 
Laboratory Systems, 44, 175-185. 





 

599 

References 

This section holds references for multivariate data analysis. The appendices sections 
list numbered section specific references. These references are available in the 
References for multivariate analysis reference list too. 

References for multivariate analysis 
Albano, C., Dunn, III, W.J., Edlund, U., Johansson, E., Nordén, B., Sjöström, M., and 
Wold, S., (1978), Four Levels of Pattern Recognition, Analytica Chimica Acta, 103, 
429-443. 

Alsberg, B.K., Woodward, A.M, and Kell, D.B., (1997),  An Introduction to Wavelet 
Transforms for Chemometricians: A Time-Frequency Approach, Chemometrics and 
Intelligent Laboratory Systems, 37, 215-239. 

Andersson, G., Kaufmann, P., and Renberg, L, (1996), Non-Linear Modelling with a 
Coupled Neural Network – PLS Regression System, Journal of Chemometrics, 10, 605-
614. 

Andersson, P., Haglund, P., Tysklind, M., (1997a), The Internal Barriers of Rotation 
for the 209 Polychlorinated Biphenyls, Environmental Science and Pollution Research, 
4, 75-81. 

Andersson, P., Haglund, P., and Tysklind, M., (1997b), Ultraviolet Absorption Spectra 
of all 209 Polychlorinated Biphenyls Evaluated by Principal Component 
Analysis, Fresenius Journal of Analytical Chemistry, 357, 1088-1092. 

Andersson, G., (1998), Novel Nonlinear Multivariate Calibration Methods, Ph.D. 
Thesis, The Royal Institute of Technology, Stockholm, Sweden. 

Andersson, P.M., Sjöström, M., and Lundstedt, T., (1998), Preprocessing Peptide 
Sequences for Multivariate Sequence-Property Analysis, 42, 41-50. 

Andersson, P.M., Sjöström, M., Wold, S., and Lundstedt, T., (2001), Strategies for 
Subset Selection of Parts of an In-house Chemical Library, Journal of Chemometrics, 
15, 353-369. 

Andersson, P.M., and Lundstedt, T., (2002), Hierarchical Experimental Design 
Exemplified by QSAR Evaluation of a Chemical Library Directed Towards the 
Melanocortin 4 Receptor, Journal of Chemometrics, 16, 490-496. 

Andersson, M., Svensson, O., Folestad, S., Josefson, M., and Wahlund, K.G., (2005), 
NIR Spectroscopy on Moving Solids Using a Scanning Grating Spectrometer – Impact 
on Multivariate Process Analysis, Chemometrics and Intelligent Laboratory Systems, 
75, 1-11. 

Andre, M., (2003), Multivariate Analysis and Classification of the Chemical Quality of 
7-aminocephalosporanic-acid Using Near-infrared Reflectance Spectroscopy, 
Analytical Chemistry, 75, 3128-3135. 



User Guide to SIMCA 

600 

Anonymous, SIMCA-P manual, Umetrics AB. 

Antti, H., Bollard, M.E., Ebbels, T., Keun, H., Lindon, J.C., Nicholson, J.K, and 
Holmes, E., (2002), Batch Statistical Processing of 1H-NMR-derived Urinary Spectral 
Data, Journal of Chemometrics, 16, 461-468. 

Antti, H., Ebbels, T.M.D., Keun. H.C., Bollard, M.A., Beckonert, O., Lindon, J.C., 
Nicholson, J.K., and Holmes, E., (2004), Statistical Experimental Design and Partial 
Least Squares Regression Analysis of Biofluid Metabonomic NMR and Clinical 
Chemistry Data for Screening of Adverse Drug Effects, Chemometrics and Intelligent 
Laboratory Systems, 73, 139-149. 

Atif, U., Earll, M., Eriksson, L., Johansson, E., Lord, P., and Margrett, S., (2002), 
Analysis of Gene Expression Datasets Using Partial Least Squares Discriminant 
Analysis and Principal Component Analysis. In: Martyn Ford, David Livingstone, John 
Dearden and Han Van de Waterbeemd (Eds.), Euro QSAR 2002 Designing Drugs and 
Crop Protectants: processes, problems and solutions. Blackwell Publishing, ISBN 1-
4051-2561-0, pp 369-373. 

Austel, V., (1995), Experimental Design, In: Mannhold, R., Krogsgaard-Larsen, P., 
and Timmerman, H., (Eds.), Methods and Principles in Medicinal Chemistry, Vol 2, 
VCH, Weinheim, Germany, pp. 49-62. 

Bakshi, B.R., (1999), Multiscale Analysis and Modelling Using Wavelets, Journal of 
Chemometrics, 13, 415-434. 

Barclay, V.J., Bonner, R.F., and Hamilton, I.P., (1997), Application of Wavelet 
Transforms to Experimental Spectra: Smoothing, Denoising, and Data Set 
Compression, Anal.Chem., 69, 78-90. 

Barnes, R.J., Dhanoa, M.S., and Lister, S.J., (1989), Standard Normal Variate 
Transformation and De-trending of Near-Infrared Diffuse Reflectance Spectra, 
Applied Spectroscopy, 43, 772-777. 

Baroni, M., Clementi, S., Cruciani, G., Kettaneh-Wold, S., and Wold, S., (1993a), D-
Optimal Designs in QSAR, Quantitative Structure-Activity Relationships, 12, 225-231. 

Baroni, M., Constatino, G., Cruciani, G., Riganelli, D., Valigi, R., and Clementi, S., 
(1993b), Generating Optimal PLS Estimations (GOLPE): An Advanced Chemometric 
Tool for Handling 3D-QSAR Problems, Quantitative Structure-Activity Relationships, 
12, 9-20. 

Barnett, V., and Lewis, T., (1994), Outliers in Statistical Data, John Wiley & Sons, 
Chichester, England. 

Belsley, D., Kuh, E,. and Welsch, R., (1980), Identifying Influential Data and Sources 
of Collinearity, John Wiley, New York. 

Berglund, A., and Wold, S., (1997a), INLR, Implicit Non-Linear Latent Variable 
Regression, Journal of Chemometrics, 11, 141-156. 

Berglund, A., DeRosa, M.C., and Wold, S., (1997b), Alignment of Flexible Molecules 
at Their Receptor Site Using 3D Descriptors and Hi-PCA, Journal of Computer-Aided 
Molecular Design, 11, 601-612. 

Berglund, A., and Wold, S., (1999), A Serial Extension of Multi Block PLS, Journal of 
Chemometrics, 13, 461-471. 

Berglund, A., Kettaneh, N., Uppgård, L.L., Wold, S., Bandwell, N., and Cameron, 
D.R., (2001), The GIFI Approach to Non-Linear PLS Modelling, Journal of 
Chemometrics, 15, 321-336. 



References 

601 

Berntsson, O., Danielsson, L.G., Johansson, M.O., and Folestad, S., (2000), 
Quantitative Determination of Content in Binary Powder Mixtures Using Diffuse 
Reflectance Near Infrared Spectrometry and Multivariate Analysis, Analytica Chimica 
Acta, 419, 45-54. 

Berntsson, O., (2001), Characterization and Application of Near Infrared 
Spectroscopy for Quantitative Process Analysis of Powder Mixtures, PhD Thesis, 
KTH, Stockholm, Sweden, ISBN 91-7283-074-3. 

Bharati, M.H., Liu, J.J., and MacGregor, J.F., (2004), Image Texture Analysis: 
Methods and Comparisons, Chemometrics and Intelligent Laboratory Systems, 72, 57-
71. 

Blanco, M., Coello, J., Iturriaga, H., Maspoch, S., and Pagès, J., (2000), NIR 
Calibration in Non-linear Systems: Different PLS Approaches and Artificial Neural 
Networks, Chemometrics and Intelligent Laboratory Systems, 50, 75-82. 

Blum, D.J.W., and Speece, R.E., (1990), Determining Chemical Toxicity to Aquatic 
Species, Environmental Science and Technology, 24, 284-293. 

Bos, M. and Vrielink, J.A.M., (1994), The wavelet transform for pre-processing IR 
spectra in the identification of mono- and di-substituted benzenes, Chemometrics 
Intell. Lab. Syst., 23, 115-122. 

Box, G.E.P., Hunter, W.G., and Hunter, J.S., (1978), Statistics for Experimenters, John 
Wiley & Sons, Inc., New York. 

Box, G.E.P., Jenkins, G.M., and Reinsel, G.C., (1994), Time Series Analysis - 
Forecasting and Control, 3rd edition, Prentice-Hall, Inc., Englewood Cliffs, NJ. 

Breiman, L., Friedman, J.H., Olshen, R.A., and Stone, C.J., (1984) Classification and 
Regression Trees, Wadsworth & Brooks / Cole Advanced Books & Software, 
Monterey, CA. 

Bro, R., (1996), Håndbog i Multivariabel Kalibrering, KVL, Copenhagen, Denmark. 

Bro, R., (1999), Exploratory Study of Sugar Production Using Fluorescence 
Spectroscopy and Multi-way analysis, Chemometrics and Intelligent Laboratory 
System, 46, 133-147. 

Burnham, A.J., Viveros, R., and MacGregor, J.F., (1996), Frameworks for Latent 
Variable Multivariate Regression, Journal of Chemometrics, 10, 31-45. 

Burnham, A.J., MacGregor, J.F, and Viveros, R., (1999), A Statistical Framework for 
Multivariate Latent Variable Regression Methods Based on Maximum Likelihood, 
Journal of Chemometrics, 13, 49-65. 

Burnham, A.J., MacGregor, J., and Viveros, R., (2001), Interpretation of Regression 
Coefficients Under a Latent Variable Regression Model, Journal of Chemometrics, 15, 
265-284. 

Buydens, L.M.C., Reijmers, T.H., Beckers, M.L.M., and Wehrens, R., (1999), 
Molecular Data Mining: a Challenge for Chemometrics, Chemometrics and Intelligent 
Laboratory Systems, 49, 121-133. 

Börås, L., Sjöström, J., and Gatenholm, P., (1997), Characterization of Surfaces of 
CMTP Fibers Using Inverse Gas Chromatography Combined with Multivariate Data 
Analysis, Nordic Pulp & Paper Research Journal, 12, 220-224. 

Carlson, R., Lundstedt, T., and Albano, C., (1985), Screening of Suitable Solvents in 
Organic Synthesis. Strategies for Solvent Selection, Acta Chemica Scandinavica, B39, 
79-91. 



User Guide to SIMCA 

602 

Carlson, R., (2004), Designs For Explorative Experiments in Organic Synthetic 
Chemistry, Chemometrics and Intelligent Laboratory Systems, 73, 151-166. 

Carlson, R., and Carlson, J.E., (2005), Design and Optimization in Organic Synthesis – 
Second Revised and Enlarged Edition, Data Handling in Science and Technology, 
Elsevier, ISBN: 0-444-51527-5. 

Cho, R.J., Campbell, M.J., Winzeler, E.A., Steinmetz, L., Conway, A., Wodicka, L., 
Wolfsberg, T.G., Gabrielian, A.E., Landsman, D., Lockhart, D.J., and Davis R.W., 
(1998), A Genome-wide Transcriptional Analysis of the Mitotic Cell Cycle, Molecular 
Cell, 2, 65-73. 

Cocchi, M., and Johansson, E., (1993), Amino Acids Characterization by GRID and 
Multivariate Data Analysis, Quantitative Structure-Activity Relationships, 12, 1-8. 

Connor, K., Safe, S., Jefcoate, C.R., and Larsen, M., (1995), Structure-Dependent 
Induction of CYP2B by Polychlorinated Biphenyl Congeners in Female Sprague-
Dawley Rats, Biochemical Pharmacology, 50, 1913-1917. 

Coomans, D., Broeckaert, I., Derde, M.P., Tassin, A., Massart, D.L., and Wold, S., 
(1984), Use of a Microcomputer for the Definition of Multivariate Confidence Regions 
in Medical Diagnosis Based on Clinical Laboratory Profiles, Computational 
Biomedical Research, 17, 1-14. 

Cronin, M.T.D, and Schultz, T.W., (2003), Pitfalls in QSAR, Journal of Molecular 
Structure (Theochem), 622, 39-51. 

Cramer, R.D., Pattersson, D.E., and Bunce, J.D., (1988), Comparative Molecular Field 
Analysis (CoMFA). I. Effects of Shape on Binding of Steroids to Carried Proteins, 
Journal of American Chemical Society, 110, 5959. 

Cruciani, G., Baroni, M., Carosati, E., Clementi, M., Valigi, R., and Clementi, S., 
(2004), Peptide Studies by Means of Principal Properties of Amino Acids Derived from 
MIF Descriptors, Journal of Chemometrics, 18, 146-155. 

Dahl, K.S., Piovoso, M.J., and Kosanovich, K.A., (1999), Translating Third-order 
Data Analysis Methods to Chemical Batch Processes, Chemometrics and Intelligent 
Laboratory Systems, 46, 161-180. 

Daubechies, (1992), Ten Lectures on wavelets, SIAM, Philadelphia, PA. 

Davis, O.L., and Goldsmith, P.L., (1986), Statistical Methods in Research and 
Production, Longman, New York. 

Dayal, B., MacGregor, J.F., Taylor, P.A., Kildaw, R., and Marcikic, S., (1994), 
Application of Feedforward Neural Networks and Partial Least Squares Regression 
for Modelling Kappa Number in a Continuous Kamyr Digester, Pulp and Paper 
Canada, 95, 26-32. 

DeAguiar, P.F., Bourguignon, B., Khots, M.S., Massart, D.L., and Phan-Than-Luu, R., 
(1995), D-Optimal Designs, Chemometrics and Intelligent Laboratory Systems, 30, 
199-210. 

Dearden, J., (1985), Partitioning and Lipophilicity in Quantitative Structure-Activity 
Relationships, Environmental Health Perspectives, 61, 203-228. 

De Jong, S., (1993), PLS Fits Closer Than PCR, Journal of Chemometrics, 7, 551-557. 

De Jong, S., Wise, B.M., and Ricker, N.L., (2001), Canonical Partial Least Squares 
and Continuum Power Regression, Journal of Chemometrics, 15, 85-100. 



References 

603 

Deneer, J.W., Sinninge, T.L., Seinen, W., and Hermens, J.L.M., (1987), Quantitative 
Structure-Activity Relationships for the Toxicity and Bioconcentration Factor of 
Nitrobenzene Derivatives Towards the Guppy (Poecilia reticulata), Aquatic 
Toxicology, 10, 115-129. 

Deneer, J.W., van Leeuwen, C.J., Seinen, W., Maas-Diepeveen, J.L., and Hermens, 
J.L.M., (1989), QSAR Study of the Toxicity of Nitrobenzene Derivatives Towards 
Daphnia Magna, Chlorella Pyrenoidosa and Photobacterium Phosphoreum, Aquatic 
Toxicology, 15, 83-98. 

Denham, M.C., (1997), Prediction Intervals in Partial Least Squares, Journal of 
Chemometrics, 11, 39-52. 

Dhanoa, M.S., Lister, S.J., Sanderson, R., and Barnes, R.J., (1994), The Link Between 
Multiplicative Scatter Correction (MSC) and Standard Normal Variate (SNV) 
Transformation of NIR Spectra, Journal of Near Infrared Spectroscopy, 2, 43-47. 

Drewry, D.H., and Young, S.S., (1999), Approaches to the Design of Combinatorial 
Libraries, Chemometrics and Intelligent Laboratory Systems, 48, 1-20. 

Duarte, I., Barros, A., Belton, P.S., Righelato, R., Spraul, M., Humper, E., and Gil, 
A.M., (2002), High-resolution Nuclear Magnetic Resonance Spectroscopy and 
Multivariate Analysis for the Characterization of Beer, Journal of Agricultural and 
Food Chemistry, 50, 2475-2481. 

Dunn, III, W.J., (1989), Quantitative Structure-Activity Relationships (QSAR), 
Chemometrics and Intelligent Laboratory Systems, 6, 181-190. 

Dyrby, M., Petersen, R.V., Larsen, J., Rudolf, B., Nørgaard, L., Engelsen, S.B., (2004), 
Towards On-line Monitoring of the Composition of Commercial Carrageenan 
Powders, Carbohydrate Polymers, 57, 337-348. 

Efron, B., and Gong, G., (1983), A Leisurely Look at the Bootstrap, the Jack-knife, and 
Cross-validation, American Statistician, 37, 36-48. 

Elg-Kristoffersson, K., Sjöström, M., Edlund, U., Lindgren, Å., and Dolk, M., (2002) 
Reactivity of Dissolving Pulp: Characterisation Using Chemical Properties, NMR 
Spectroscopy and Multivariate Data Analysis, Cellulose, 9, 159-170. 

Ergon, R., (1998), Dynamic System Multivariate Calibration by System Identification 
Methods, Modelling Identification and Control, 19, 77-97. 

Eriksson, L., Dyrby, M., Trygg, J., and Wold, S., (2006), Separating Y-predictive and 
Y-orthogonal variation in multi-block spectral data, Journal of Chemometrics, 20, 352-
361. 

Eriksson, L., Jonsson, J., Sjöström, M., Wikström, C., and Wold, S., (1988), 
Multivariate Derivation of Descriptive Scales for Monosaccharides, Acta Chemica 
Scandinavica, 42, 504-514. 

Eriksson, L., Jonsson, J., Hellberg, S., Lindgren, F., Sjöström, M., Wold, S., 
Sandström, B., and Svensson, I., (1991), A Strategy for Ranking Environmentally 
Occurring Chemicals. Part V: The Development of two Genotoxicity QSARs for 
Halogenated Aliphatics. Environmental Toxicology and Chemistry, 10, 585-596. 

Eriksson, L., Sandström, B.E., Tysklind, M., and Wold, S., (1993), Modelling the 
Cytotoxicity of Halogenated Aliphatic Hydrocarbons. Quantitative Structure-Activity 
Relationships for the IC50 to Human HeLa Cells, Quantitative Structure-Activity 
Relationships, 12, 124-131. 



User Guide to SIMCA 

604 

Eriksson, L., and Hermens, J.L.M., (1995a), A Multivariate Approach to Quantitative 
Structure-Activity and Structure-Property Relationships, In: The Handbook of 
Environmental Chemistry, (Ed.) J. Einax, Vol2H, Chemometrics in Environmental 
Chemistry, Springer Verlag, Berlin. 

Eriksson, L., Hermens, J.L.M., Johansson, E., Verhaar, H.J.M. and Wold, S., (1995b), 
Multivariate Analysis of Aquatic Toxicity Data with PLS, Aquatic Sciences, 57, 217-
241. 

Eriksson, L., and Johansson, E., (1996), Multivariate Design and Modelling in QSAR, 
Chemometrics and Intelligent Laboratory Systems, 34, 1-19. 

Eriksson, L., Johansson, E., Müller, M., and Wold, S., (1997), Cluster-based Design in 
Environmental QSAR, Quantitative Structure-Activity Relationships, 16, 383-390. 

Eriksson, L., Johansson, E., Tysklind, M., and Wold, S., (1998), Pre-processing of 
QSAR Data by Means of Orthogonal Signal Correction, The QSAR and Modelling 
Society, Newsletter 1998, www/pharma-ethz.ch./qsar. 

Eriksson, L., Andersson, P., Johansson, E., Tysklind, M., Sandberg, M., and Wold, S., 
(1999a), The Constrained Principal Property Space in QSAR – Directional and Non-
Directional Modelling Approaches, Proceedings 12th European Symposium on QSAR, 
August 1998, Copenhagen, Denmark. 

Eriksson, L., Johansson, E., Kettaneh-Wold, N., Wikström, C., and Wold, S., (1999b), 
Design of Experiments – Principles and Applications, Umetrics AB. 

Eriksson, L., Trygg, J., Johansson, E., Bro, R., and Wold, S., (2000a), Orthogonal 
Signal Correction, Wavelet Analysis, and Multivariate Calibration of Complicated 
Process Fluorescence Data, Analytica Chimica Acta, 420, 181-195. 

Eriksson, L., Johansson, E., Lindgren, F., and Wold, S., (2000b), GIFI-PLS: Modeling 
of Non-Linearities and Discontinuities in QSAR, Quantitative Structure-Activity 
Relationships, 19, 345-355. 

Eriksson, L., Johansson, E., Müller, M., and Wold, S., (2000c), On the Selection of 
Training Set in Environmental QSAR When Compounds are Clustered, Journal of 
Chemometrics, 14, 599-616. 

Eriksson, L., Hagberg, P., Johansson, E., Rännar, S., Whelehan, O., Åström, A., and 
Lindgren, T., (2001), Multivariate Process Monitoring of a Newsprint Mill. 
Application to Modelling and Predicting COD Load Resulting from Deinking of 
Recycled Paper, Journal of Chemometrics, 15, 337-352. 

Eriksson, L., Johansson, E., Lindgren, F., Sjöström, M., and Wold, S., (2002), 
Megavariate Analysis of Hierarchical QSAR Data, Journal of Computer-Aided 
Molecular Design, 16, 711-726. 

Eriksson, L., Jaworska, J., Worth, A.P., Cronin, M.T.D., McDowell, R.M., and 
Gramatica, P., (2003), Methods for Reliability and Uncertainty Assessment and for 
Applicability Evaluations of Classification- and Regression-based QSAR, 
Environmental Health Perspectives, 11, 1361-1375. 

Eriksson, L., Arnhold, T., Beck, B., Fox, T., Johansson, E., and Kriegl, J.M., (2004a), 
Onion Design and its Application to a Pharmaceutical QSAR Problem, Journal of 
Chemometrics, 18, 188-202. 

Eriksson, L., Antti, H., Gottfries, J., Holmes, E., Johansson, E., Lindgren, F., Long, I., 
Lundstedt, T., Trygg, J., and Wold, S., (2004b), Using Chemometrics for Navigating in 
the Large Data Sets of Genomics, Proteomics and Metabonomics, Analytical and 
Bioanalytical Chemistry, 380, 419-429. 



References 

605 

Eriksson, L., Antti, H., Holmes, E., and Johansson, E., (2005), in: Robertson, D. (Ed.), 
Modern Safety Assessment Methods of Compounds and Biomarkers: Metabonomics 
and Evaluation, Chapter 8: Multi- and Megavariate Data Analysis: Finding and Using 
Regularities in Metabonomics Data, Marcel Dekker/CRC Press, ISBN: 0-8247-2665-0. 

Eriksson, L., Damborsky, J., Earll, M., Johansson, E., Trygg, J., and Wold, S., (2004c), 
Three-block Bi-focal PLS (3BIF-PLS) and its application in QSAR, SAR and QSAR in 
Environmental Research, 5/6, 481-499. 

Eriksson, L., Gottfries, J., Johansson, E., and Wold, S., (2004d), Time-resolved QSAR: 
an Approach to PLS Modelling of Three-way Biological Data, Chemometrics and 
Intelligent Laboratory Systems, 73, 73-84. 

Eriksson, L., Johansson, E., Kettaneh-Wold, N., Trygg, J., Wikström, M., and Wold, 
S., Multi- and Megavariate Data Analysis, Part II, Method Extensions and Advanced 
Applications, Chapter 23, Umetrics Academy, 2005. 

Eriksson, L., Wold, S., and Trygg, J., (2006), Multivariate Analysis of Congruent 
Images (MACI), Chemometrics and Intelligent Laboratory Systems, In press. 

Eriksson, L., Trygg, J., and Wold, S., CV-ANOVA for significance testing of PLS and 
OPLS models, submitted for publication 2008. 

Esbensen, K., and Geladi, P., (1989), Strategy of Multivariate Image Analysis (MIA), 
Chemometrics and Intelligent Laboratory Systems, 7, 67-86. 

Espina, J.R., Shockcor, J.P., Herron, W.J., Car, B.D., Contel, N.R., Ciaccio, P.J., 
Lindon, J.C., Holmes, E., and Nicholson, J.K., (2001), Detection of In-vivo Biomarkers 
of Phospholipidosis Using NMR-based Metabonomic Approaches, Magnetic 
Resonance in Chemistry, 39, 559–565. 

Eastment, H. and Krzanowski, W., (1982), Crossvalidatory choice of the number of 
components from a principal component analysis, Technometrics 24 73-77. 

Etemad, K., and Chellappa, R., (2004), Discriminant Analysis for Recognition of 
Human Face Images, Journal of Optical Society of America, 14, 1724-1733. 

Everitt, B.S., Landau, S., Leese, M., (2001), Cluster Analysis, Fourth Edition Arnold 
Publishers, London. 

Fisher, R.A., (1922), On the interpretation of χ2 from contingency tables, and the 
calculation of P. Journal of the Royal Statistical Society 85(1):87-94. 

Fisher, R.A., and MacKenzie, W., (1923), Studies in Crop Variation. II. The manurial 
response of different potato varieties, Journal of Agricultural Science, 13, 311-320. 

Fisher, R.A., (1936), The use of Multiple Measurements in Taxonomic Problems, Ann. 
Eugenics, 7, 179-188. 

Fisher, R.A., (1954), Statistical Methods for research workers, Oliver and 
Boyd. 

Flåten, G.R., and Walmsley, A.D., (2004), A Design of Experiment Approach 
Incorporating Layered Designs for Choosing the Right Calibration Model, 
Chemometrics and Intelligent Laboratory Systems, 73, 55-66. 

Frank, I.E., and Friedman, J.H., (1993), A Statistical View of Some Chemometrics 
Regression Tools, Technometrics, 35, 109-135. 

Frank, I., (1995), Modern Nonlinear Regression Methods, Chemometrics and 
Intelligent Laboratory Systems, 27, 1-19. 

Gabrielsson, J., Lindberg, N.O., and Lundstedt, T., (2002), Multivariate Methods in 
Pharmaceutical Applications, Journal of Chemometrics, 16, 141-160. 



User Guide to SIMCA 

606 

Gabrielsson, J., Jonsson, H., Airiau, C., Schmidt, B., Escott, R., and Trygg, J., (2006), 
The OPLS methodology for analysis of multi-block batch process data, Journal of 
Chemometrics, 20, 362-369. 

Gallagher, N.B., Shaver, J.M., Martin, E.B., Morris, J., Wise, B.M., Windig, W., 
(2004), Curve Resolution for Multivariate Images with Applications to TOF-SIMS and 
Raman, Chemometrics and Intelligent Laboratory Systems, 73, 105-117. 

Gallop, M.A., Barrett, R.W., Dower, W.J., Fodor, S.P.A., and Gordon, E.M., (1994), 
Applications of Combinatorial Technologies to Drug Discovery. 1. Background and 
Peptide Combinatorial Libraries, Journal of Medicinal Chemistry, 37, 1233-1251. 

Gauchi, J.P., and Chagnon, P., (2001), Comparison of Selection Methods of 
Explanatory Variables in PLS Regression with Application to Manufacturing Process 
Data, Chemometrics and Intelligent Laboratory Systems, 58, 171-193. 

Geladi, P., MacDougall, D., and Martens, H., (1985), Linearization and Scatter-
correction for Near-infrared Reflectance Spectra of Meat, Applied Spectroscopy, 3, 
491-500. 

Geladi, P., Isaksson, H., Lindqvist, L., Wold, S., and Esbensen, K., (1989), Principal 
Component Analysis of Multivariate Images, Chemometrics and Intelligent Laboratory 
Systems, 5, 209-220. 

Geladi, P., (1992), Some Special Topics in Multivariate Image Analysis, Chemometrics 
and Intelligent Laboratory Systems, 14, 375-390. 

Gillet, V.J., (2002), Reactant- and Product-based Approaches to the Design of 
Combinatorial Libraries, Journal of Computer-Aided Molecular Design, 16, 371-380. 

Giraud, E., Luttmann, C., Lavelle, F., Riou, J.F., Mailliet, P., and Laoui, A., (2000), 
Multivariate Data Analysis using D-optimal Designs, Partial Least Squares, and 
Response Surface Modelling, A Directional Approach for the Analysis of 
Farnesyltransferase Inhibitors, Journal of Medicinal Chemistry, 43, 1807-1816. 

Goodford, P., (1996), Multivariate Characterization of Molecules for QSAR Analysis, 
Journal of Chemometrics, 10, 107-117. 

Gordon, E.M., Barret, R.W., Dower, W.J., Fodor, S.P.A., and Gallop, M.A., (1994), 
Applications of Combinatorial Technologies to Drug Discovery. 2. Combinatorial 
Organic Synthesis, Library Screening Strategies, and Future Directions, Journal of 
Medicinal Chemistry, 37, 1385-1401. 

Gottfries, J., Blennow, K., Wallin, A., and Gottfries, C.G., (1995), Diagnosis of 
Dementias Using Partial Least Squares Discriminant Analysis, Dementia, 6, 83-88. 

Gottfries, J., Depui, H., Fransson, H., Jongeneelen, M., Josefsson, M., Langkilde, 
F.W., and Witte, D.T., (1996), Vibrational Spectrometry for the Assessment of Active 
Substance in Metoprolol Tablets: A Comparison Between Transmission and Diffuse 
Reflectance Near-Infrared Spectrometry, Journal of Pharmaceutical and Biomedical 
Analysis, 14, 1495-1503. 

Gottfries, J., Sjögren, M., Holmberg, B., Rosengren, L., Davidsson, P., and Blennow, 
K., (2004), Proteomics for Drug Target Discovery, Chemometrics and Intelligent 
Laboratory Systems, 73, 47-53. 

Grainger, D.J., (2003), Megavariate Statistics Meets High Data-density Analytical 
Methods: The Future of Medical Diagnostics, IRTL Reviews 1, 1-6. 

Granberg, R., (1998), Solubility and Crystal Growth of Paracetamol in Various 
Solvents, Ph.D. Thesis, Royal Institute of Technology, Stockholm, Sweden. 



References 

607 

Gunnarsson, I., Andersson, P., Wikberg, J., and Lundstedt, T., (2003), Multivariate 
Analysis of G Protein-coupled Receptors, Journal of Chemometrics, 17, 82-92. 

Gustafsson, A., (1993), QFD and Conjoint Analysis – The Key to Customer Oriented 
Products, Ph.D. Thesis, Linköping University, Linköping, Sweden. 

Hammett, L.P., (1970), Physical Organic Chemistry, 2nd edn., McGraw-Hill, New 
York. 

Hand, D.J., (1998), Data Mining: Statistics and More?, American Statistician, 52, 112-
188. 

Hansch, C., and Leo, A.J., (1970), Substituent Constants for Correlation Analysis in 
Chemistry and Biology, Wiley, New York. 

Hartnett, M.K., Lightbody, G., and Irwin, G.W., (1999), Identification of State Models 
Using Principal Components Analysis, Chemometrics and Intelligent Laboratory 
Systems, 46, 181-196. 

Hellberg, S., (1986), A Multivariate Approach to QSAR, Ph.D. Thesis, Umeå 
University, Umeå, Sweden. 

Hellberg, S., Sjöström, M., and Wold, S., (1986), The Prediction of Bradykinin 
Potentiating Potency of Pentapeptides. An Example of a Peptide Quantitative 
Structure-Activity Relationship, Acta Chemica Scandinavica, B40, 135-140. 

Hellberg, S., Eriksson, L., Jonsson, J., Lindgren, F., Sjöström, M., Skagerberg, B., 
Wold, S., and Andrews, P., (1991), Minimum Analogue Peptide Sets (MAPS) for 
Quantitative Structure-Activity Relationships, International Journal of Peptide and 
Protein Research, 37, 414-424. 

Hermens, J.L.M., (1989), Quantitative Structure-Activity Relationships of 
Environmental Pollutants. In: Hutzinger, O., (Ed.), Handbook of Environmental 
Chemistry, Vol 2E, Reactions and Processes. Springer-Verlag, Berlin, 1989, pp. 111-
162. 

Hubbard, B.B., (1995), The world according to wavelets, A K Peters, Wellesley, MA. 

Hunter, J.S., (1986), The Exponentially Weighted Moving Average, Journal of Quality 
Technology, 18, 203-210. 

Höskuldsson, A., PLS regression methods. J. Chemometrics, 2, (1988) 211-228. 

Höskuldsson, A., (1996), Prediction Methods in Science and Technology, Thor 
Publishing, Copenhagen, Denmark. 

Höskuldsson, A., (1998), The Heisenberg Modelling Procedure and Application to 
Nonlinear Modelling, Chemometrics and Intelligent Laboratory Systems, 44, 15-30. 

Höskuldsson, A., (2001), Causal and Path Modelling, Chemometrics and Intelligent 
Laboratory Systems, 58, 287-311. 

Indahl, U.G., and Naes, T., (1998), Evaluation of Alternative Spectral Feature 
Extraction Methods of Textural Images for Multivariate Modeling, Journal of 
Chemometrics, 12, 261-278. 

Jackson, J.E. (1991), A User’s Guide to Principal Components, John Wiley, New 
York. 
ISBN 0-471-62267-2. 

Janné, K., Pettersen, J., Lindberg, N.O., and Lundstedt, T., (2001), Hierarchical 
Principal Component Analysis (PCA) and Projection to Latent Structure Technique 
(PLS) on Spectroscopic Data as a Data Pretreatment for Calibration, Journal of 
Chemometrics, 15, 203-213. 



User Guide to SIMCA 

608 

Jellum, E., Björnsson, I., Nesbakken, R., Johansson, E., and Wold, S., (1981), 
Classification of Human Cancer Cells by means of Capillary Gas Chromatography 
and Pattern Recognition Analysis, Journal of Chromatography, 217, 231-237. 

Johansson, D, and Lindgren, P., (2002), Analysis of Microarray Data Using a 
Multivariate Approach, Masters Thesis in Bioinformatics, Umeå University, Umeå, 
Sweden. 

Johansson, D., Lindgren, P., and Berglund, A., (2003), A Multivariate Approach 
Applied to Microarray Data for Identification of Genes with Cell Cycle-Coupled 
Transcription, Bioinformatics, 19, 467-473. 

Jonsson, J., Eriksson, L., Hellberg, S., Sjöström, M., and Wold, S., (1989a), 
Multivariate Parametrization of 55 Coded and Non-Coded Amino Acids, Quantitative 
Structure-Activity Relationships, 8, 204-209. 

Jonsson, J., Eriksson, L., Hellberg, S., Sjöström, M., and Wold, S., (1989b), A 
Multivariate Approach to Saccharide Quantitative Structure-Activity Relationships 
Exemplified by Two Series of 9-Hydroxyellipticine Glycosides, Acta Chemica 
Scandinavica, 43, 286-289. 

Jonsson, J., Eriksson, L., Hellberg, S., Lindgren, F., Sjöström, M., and Wold, S., 
(1991), A Multivariate Representation and Analysis of DNA Sequence Data, Acta 
Chemica Scandinavica, 45, 186-192. 

Jonsson, J., (1992), Quantitative Sequence-Activity Modelling (QSAM), Ph. D. Thesis, 
Umeå University, Umeå, Sweden. 

Jonsson, J., Norberg, T., Carlsson, L., Gustafsson, C., and Wold, S., (1993), 
Quantitative Sequence-Activity Models (QSAM) – Tools for Sequence Design, Nucleic 
Acids Research, 21, 733-739. 

Jonsson, P., Sjöström, M., Wallbäcks, L., and Antti, H., Strategies for Implementation 
and Validation of On-line Models for Multivariate Monitoring and Control of Wood 
Chips Properties, Journal of Chemometrics, 18, 203-207. 

Kaiser, G., (1994), A Friendly Guide to Wavelets, Birkhäuser, Boston, MA. 

Kassidas, A., MacGregor, J.F., and Taylor, P.A., (1998), Synchronization of Batch 
Trajectories Using Dynamic Time Warping, AlChE Journal, 44, 864-875. 

Kettaneh-Wold, N., MacGregor, J.F., Dayal, B., and Wold, S., (1994), Multivariate 
Design of Process Experiments (M-DOPE), Chemometrics and Intelligent Laboratory 
Systems, 23, 39-50. 

Kettaneh, N., Berglund, S., and Wold, S., (2005), PCA and PLS with Very Large Data 
Sets, Computational Statistics & Data Analysis, 48, 69-85. 

Kim, K.H., (1993), Non-linear Dependence in Comparative Molecular Field Analysis, 
Journal of Computer-Aided Molecular Design, 7, 71-82. 

Kimura, T., Miyashita, Y., Funatsu, K., and Sasaki, S., (1996), Quantitative Structure-
Activity Relationships of the Synthetic Substrates for Elastase Enzyme Using Nonlinear 
Partial Least Squares Regression, Journal of Chemical Information and Computer 
Science, 36,185-189. 

Kjaer Pedersen, D., Martens, H., Pram Nielsen, J., Engelsen, S.B., (2002), Near-
infrared Absorption and Scattering Separated by Extended Inverted Signal Correction 
(EISC): Analysis of Near-infrared Transmittance Spectra of Single Wheat Seeds, 
Applied Spectroscopy, 56, 1206-1214. 

Kourti, T., (2002), Process Analysis and Abnormal Situation Detection: From Theory 
to Practice, IEEE Control Systems Magazine, October 2002, 10-25. 



References 

609 

Kourti, T., (2003), Multivariate Dynamic Data Modeling for Analysis and Statistical 
Process Control of Batch Processes, Start-ups and Grade Transitions, Journal of 
Chemometrics, 17, 93-109. 

Kriegl, J.M., Eriksson, L., Arnhold, T., Beck, B., Johansson, E., and Fox, T., (2005), 
Multivariate Modeling of Cytochrome P450 3A4 Inhibition, European Journal of 
Pharmaceutical Sciences, 24, 451-463. 

Kristal, B.S., (2002), Practical Considerations and Approaches for Entry-level 
Megavariate Analysis. 
http://mickey.utmem.edu/papers/bioinformatics_02/pdfs/Kristal.pdf. 

Kubinyi, H., (1990), Quantitative Structure-Activity Relationships and Molecular 
Modelling in Cancer Research, Journal Cancer Research & Clinical Oncology, 116, 
529-537, 1990. 

Könemann, H., (1981), Quantitative Structure-Activity Relationships in Fish Studies. 
Part 1: Relationship for 50 Industrial Pollutants, Toxicology, 19, 209-221. 

Larsson, U., Carlson, R., and Leroy. J., (1993), Synthesis of Amino Acids with Modified 
Principal Properties. 1. Amino Acids with Fluorinated Side Chains, Acta Chemica 
Scandinavica, 47, 380-390. 

Leardi, R., (2001), Genetic Algorithms in Chemistry and Chemometrics: A Review, 
Journal of Chemometrics, 15, 559-569. 

Lewi, P.J., (1995), Spectral Mapping of Drug-Test Specificities, In: H. van de 
Waterbeemd (Ed.), Chemometric Methods in Molecular Design, VCH, Weinheim. 

Lied, T.T., Geladi, P., and Esbensen, K.H., (2000), Multivariate Image Regression 
(MIR): Implementation of Image PLSR – First Forays, Journal of Chemometrics, 14, 
585-598. 

Lindberg, N.O., and Gabrielsson, J., (2004), Use of Software to Facilitate 
Pharmaceutical Formulation – Experiences from a Tablet Formulation, Journal of 
Chemometrics, 18, 133-138. 

Linderholm, J., and Lundberg, E., (1994), Chemical Characterization of Various 
Archaeological Soil Samples using Main and Trace Elements Determined by 
Inductively Coupled Plasma Atomic Emission Spectrometry, Journal of Archaeological 
Science, 21, 303-314. 

Lindgren, F., and Geladi, P., (1992), Multivariate Spectrometric Image Analysis – An 
Illustrative Study with two Constructed Examples of Metal Ions in Solution, 
Chemometrics and Intelligent Laboratory System, 14, 397-412. 

Lindgren, Å., Sjöström, M., and Wold, S., (1996), Quantitative Structure-Effect 
Relationships for Some Technical Nonionic Surfactants, JAOCS, 7, 863-875. 

Lindgren, Å., (2000), Use of Multivariate Methods and DOE to Improve Industrial-
Scale Production Quality of a Cellulose Derivative. Journal of Chemometrics, 14, 657-
665. 

Linusson, A., Gottfries, J., Lindgren, F., and Wold, S., (2000), Statistical Molecular 
Design of Building Blocks for Combinatorial Chemistry, Journal of Medicinal 
Chemistry, 43, 1320-1328. 

Linusson, A., (2000), Efficient Library Selection in Combinatorial Chemistry, Ph.D. 
Thesis, Umeå University, Umeå, Sweden. 



User Guide to SIMCA 

610 

Linusson, A., Gottfries, J., Olsson, T., Örnskov, E., Folestad, S., Nordén, B., and 
Wold, S., (2001), Statistical Molecular Design, Parallel Synthesis, and Biological 
Evaluation of a Library of Thrombin Inhibitors, Journal of Medicinal Chemistry, 44, 
3424-3439. 

Lockhart, D.J., and Winzeler, E.A., (2000), Genomics, Gene Expression and DNA 
Arrays, Nature, 405, 827-836. 

Long, I., Andersson, P., Siefert, E., and Lundstedt, T., (2004), Multivariate Analysis of 
Five GPCR Receptor Classes, Chemometrics and Intelligent Laboratory Systems, 73, 
95-104. 

Louwerse, D.J., Tates, A.A., Smilde, A.K., Koot, G.L.M., and Berndt, H., (1999), PLS 
Discriminant Analysis with Contribution Plots to Determine Differences Between 
Parallel Batch Reactors in the Process Industry, Chemometrics and Intelligent 
Laboratory Systems, 46, 197-206. 

Lowe, G., (1995), Combinatorial Chemistry, Chemical Society Reviews, 24, 309-317. 

Lundstedt, T., (1991), A QSAR Strategy for Screening of Drugs and Predicting Their 
Clinical Activity, Drug News & Perspectives, 4, 468-475. 

Lundstedt, T., Carlson, R., and Shabana, R., (1987), Optimum Conditions, for the 
Willgerodt-Kindler Reaction. 3. Amine Variation, Acta Chemica Scandinavica, B41, 
157-163. 

Lundstedt, T., Clementi, S., Cruciani, G., Pastor, M., Kettaneh, N., Andersson, P.M., 
Linusson, A., Sjöström, M., Wold, S., and Nordén. B., (1997), Intelligent 
Combinatorial Libraries, In: H. van de Waterbeemd, B. Testa and G. Folkers, eds., 
Computer-Assisted Lead Finding and Optimization, Current Tools for Medicinal 
Chemistry, Wiley-VCH, Weinheim. 

MacFie, H., Moore, P.B., and Wakeling, I., (1999), Changes in the Sensory Properties 
and Consumer Preferences for Dessert Apples, Apples and Pears Research Council, 
UK. 

MacGregor, J.F., and Nomikos, P., (1992), Monitoring Batch Processes, Proceedings 
NATO Advanced Study Institute for Batch Processing Systems Eng., May 29 – June 7, 
1992, Antalya, Turkey. 

MacGregor, J.F., and Kourti, T., (1995), Statistical Process Control of Multivariate 
Processes, Control Eng. Practice, 3, 403-414. 

MacGregor, J.F., (1996), Using On-Line Process Data to Improve Quality, ASQC 
Statistics Division Newsletter, 16, 6-13. 

Maitra, R., (2001), Clustering Massive Data Sets with Applications in Software Metrics 
and Tomography, Technometrics, 43, 336-346. 

Mallat, S.G., (1989), A Theory for Multiresolution Signal Decomposition: The Wavelet 
Representation, IEEE Transactions on Pattern Analysis and Machine Intelligence, v.11 
n.7, p.674-693, July 1989. 

Mallat, S.G., (1998), A Wavelet Tour of Signal Processing, Academic Press. 

Martens, H., and Naes, T., (1989), Multivariate Calibration, John Wiley, New York. 

Martens, H., and Martens, M., (2000), Modified Jack-Knife Estimation of Parameter 
Uncertainty in Bilinear Modeling (PLSR), Food Quality and Preference, 11, 5-16. 

Martens, H., Pram Nielsen, J., and Engelsen, S.B., (2003), Light Scattering and Light 
Absorbance Separated by Extended Multiplicative Signal Correction. Application to 
Near-Infrared Transmission Analysis of Powder Mixtures, Analytical Chemistry, 75, 
394-404. 



References 

611 

Martin, E.J., Blaney, J.M., Siani, M.A., Spellmeyer, D.C., Wong, A.K., and Moos, 
W.H., (1995), Measuring Diversity: Experimental Design of Combinatorial Libraries 
for Drug Discovery, Journal of Medicinal Chemistry, 38, 1431-1436. 

Marvanova, S., Nagata, Y., Wimmerova, M., Sykorova, J., Hynkova, K., and 
Damborsky, J., (2001), Biochemical Characterization of Broad-specificity Enzymes 
Using Multivariate Experimental Design and a Colorimetric Microplate Assay: 
Characterization of the Haloalkane Dehalogenase Mutants, Journal of Microbiological 
Methods, 44, 149-157. 

Massart, B., (1997), Environmental Monitoring and Forecasting by Means of 
Multivariate Methods, Ph.D. Thesis, University of Bergen, Bergen, Norway. 

Massart, D.L., Vandeginste, B.G.M., Deming, S.N., Michotte, Y., and Kaufman, L., 
(1988), Chemometrics: A Textbook, Elsevier. 

Massart, D.L., Vandeginste, B.G.M., Buydens, L.M.C., De Jong, S., Lewi, P.J., and 
Smeyers-Verbeke, J., (1998), Handbook of Chemometrics and Qualimetrics, Elsevier. 

McCloskey, J.T., Newman, M.C., and Clark, S.B., (1996), Predicting the Relative 
Toxicity of Metal Ions Using Ion Characteristics: Microtox Bioluminescence Assay, 
Environmental Toxicology and Chemistry, 15, 1730-1737. 

McEwan, J.A., Earthy, P.J., and Ducher, C., (1998), Preference Mapping – A Review, 
Review No. 6, Campden & Chorleywood Food Research Association, Gloucestershire, 
UK. 

McEwan, J.A., and Ducher, C., (1998), Preference Mapping – Case Studies, Review 
No. 7, Campden & Chorleywood Food Research Association, Gloucestershire, UK. 

McNeese, W.H., Klein, R.A., (1991) Statistical methods for the process industries, 
Quality and Reliability/28. 

Michailidis, G., and de Leeuw, J., (1998), The GIFI System of Descriptive Multivariate 
Analysis, Statistical Science, 13, 307-336. 

Mittermayr, C.R., Nikolov, S.G., Hutter, H., and Grasserbauer, M., (1996), 
Wavelet denoising of Gaussian peaks: a comparative study, Chemometrics Intell. Lab. 
Syst., 34, 187-202. 

Moberg, L., Karlberg, B., Blomqvist, S., and Larsson, U., (2000), Comparison 
Between a New Application of Multivariate Regression and Current Spectroscopy 
Methods for the Determination of Chlorophylls and Their Corresponding 
Pheopigments, Analytica Chimica Acta, 411, 137-143. 

Moberg, L., and Karlberg, B., (2001), Validation of a Multivariate Calibration Method 
for the Determination of Chlorophyll a, b, and c and Their Corresponding 
Pheopigments, Analytica Chimica Acta, 450, 143-153. 

Mullet, G.M., (1976), Why Regression Coefficients have the Wrong Sign, Journal of 
Quality Technology, 8, 121-126. 

Munck, L., Nörgaard, L., Engelsen, S.B., Bro, R., and Andersen, C., (1998), 
Chemometrics in Food Science – A Demonstration of the Feasibility of a Highly 
Exploratory, Inductive Evaluation Strategy of Fundamental Scientific Significance, 
Chemometrics and Intelligent Laboratory, 44, 31-60. 

Musumarra, G., Barresi, V., Condorelli, D.F., Fortuna, C.G., and Scirè, S., (2004) 
Potentialities of Multivariate Approaches in Genome-based Cancer Research: 
Identification of Candidate Genes for New Diagnostics by PLS Discriminant Analysis, 
Journal of Chemometrics, 18, 125-132. 



User Guide to SIMCA 

612 

Naes, T., and Indahl, U., (1998), A Unified Description of Classical Classification 
Methods for Multicollinear Data, Journal of Chemometrics, 12, 205-220. 

Naes, T., and Mevik, B.H., (1999), The Flexibility of Fuzzy Clustering Illustrated by 
Examples, Journal of Chemometrics, 13, 435-444. 

Naes, T., Isaksson, T., Fearn, T., and Davies, T., (2002), A User-friendly Guide to 
Multivariate Calibration and Classification, NIR Publications, Chichester, UK. ISBN: 
0-95286662-5. 

Nelson, P.R.C., Taylor, P.A., MacGregor, J.F., Missing Data Methods in PCA and 
PLS: Score Calculations with Incomplete Observation, Chemometrics and Intelligent 
Laboratry Systems, 35, 45-65, 1996. 

Nicholson, J.K., Lindon, J.C., Holmes, E., (1999), Metabonomics: Understanding the 
Metabolic Responses of Living Systems to Pathophysiological Stimuli via Multivariate 
Statistical Analysis of Biological NMR Spectroscopic Data, Xenobiotica, 29, 1181-
1189. 

Nicholson, J.K, Connelly, J., Lindon, J.C., and Holmes, E., (2002), Metabonomics: a 
Platform for Studying Drug Toxicity and Gene Function, Nature Reviews, 1, 153-162. 

Nijhuis, A., de Jong, S., and Vandeginste, B.G.M., (1997), Multivariate Statistical 
Process Control in Chromatography, Chemometrics and Intelligent Laboratory 
Systems, 38, 51-62. 

Nilsson, D., (2005), Prediction of Wood Species and Pulp Brightness from Roundwood 
Measurements, PhD Thesis, Umeå University, Umeå, Sweden. 

Nomikos, P., and MacGregor, J.F., (1995a), Multivariate SPC Charts for Monitoring 
Batch Processes, Technometrics, 37, 41-59. 

Nomikos, P., and MacGregor, J.F., (1995b), Multiway Partial Least Squares in 
Monitoring of Batch Processes, Chemometrics and Intelligent Laboratory System, 30, 
97-108. 

Nomizu, M., Iwaki, T., Yamashita, T., Inagaki, Y., Asano, K., Akamatsu, M., and 
Fujita, T., (1993), Quantitative Structure-Activity Relationship (QSAR) Study of 
Elastase Substrates and Inhibitors, International Journal of Peptide and Protein 
Research, 42, 216-226. 

Nordahl, Å., and Carlson, R., (1993), Exploring Organic Synthetic Procedures, Topics 
in Current Chemistry, 166, 1-64. 

Norinder, U., (1996), Single and Domain Mode Variable Selection in 3D QSAR 
Applications, Journal of Chemometrics, 10, 95-105. 

Norinder, U., Sjöberg, P., and Österberg, T., (1998), Theoretical Calculation and 
Prediction of Brain-Blood Partitioning or Organic Solutes using Molsurf 
Parametrization and PLS Statistics, Journal of Pharmaceutical Sciences, 87, 952-959. 

Norinder, U., (2003), Support Vector Machine Models in Drug Design: Applications to 
Drug Transport Processes and QSAR Using Simplex Optimisations and Variable 
Selection, Neurocomputing, 55, 337-346. 

Nouwen, J., Lindgren, F., Hansen, B., Karcher, W., Verhaar, H.J.M., and Hermens, 
J.L.M., (1997), Classification of Environmentally Occurring Chemicals Using 
Structural Fragments and PLS Discriminant Analysis, Environmental Science and 
Technology, 31, 2313-2318. 

Nyström, Å., Andersson, P.M., and Lundstedt, T., (2000), Multivariate Data Analysis 
of Topographically Modified a-Melanotropin Analogues Using Auto- and Cross-Auto 
Covariances, Quantitative Structure-Activity Relationships, 19, 264-269. 



References 

613 

Olsson, I.M., Gottfries, J., and Wold, S., (2004a), D-optimal Onion Design in 
Statistical Molecular Design, Chemometrics and Intelligent Laboratory Systems, 73, 
37-46. 

Olsson, I.M., Gottfries, J, and Wold, S., (2004b), Controlling Coverage of D-optimal 
Onion Designs and Selections, Journal of Chemometrics, 18, 548-557. 

Oprea, T.I., (2000), Property Distribution of Drug-Related Chemical Data-Bases, 
Journal of Computer-Aided Molecular Design, 14, 251-264. 

Oprea, T.I., and Gottfries, J., (2001), Chemography: The Art of Navigating in 
Chemical Space, Journal of Combinatorial Chemistry, 3, 157-166. 

Phatak, A., and DeJong, S., (1997), The Geometry of PLS, Journal of Chemometrics, 
11, 311-338. 

Press, W., Flannery, B., Teukolsky, S., and Vetterling, W., Numerical Recipes in C, 
Cambridge University Press. 

Qin, S.J., and McAvoy, T.J., (1992), Non-Linear PLS Modelling Using Neural 
Networks, Computation and Chemical Engineering, 16, 379-391. 

Ramos, E.U., Vaes, W.H.J., Verhaar, H.J.M., and Hermens, J.L.M., (1997), Polar 
Narcosis: Designing a Suitable Training Set for QSAR Studies, Environmental Science 
& Pollution Research, 4, 83-90. 

Rius, A., Ruisanchez, I., Callao, M.P., Rius, F.X., (1998), Reliability of Analytical 
Systems: Use of Control Charts, Time Series Models and Recurrent Neural Networks, 
Chemometrics and Intelligent Laboratory Systems, 40, 1-18. 

Rännar, S., MacGregor, J.F., and Wold, S., (1998), Adaptive Batch Monitoring Using 
Hierarchical PCA, Chemometrics and Intelligent Laboratory Systems, 41, 73-81. 

Sandberg, M., Sjöström, M., and Jonsson, J., (1996), A Multivariate 
Characterization of tRNA Nucleosides, Journal of Chemometrics, 10, 493-508. 

Sandberg, M., Eriksson, L., Jonsson, J., Sjöström, M., and Wold, S., (1998), New 
Chemical Dimensions Relevant for the Design of Biologically Active Peptides. A 
Multivariate Characterization of 87 Amino Acids, Journal of Medicinal Chemistry, 41, 
2481-2491. 

Savitzky, A., and Golay, M.J.E., (1964), Smoothing and Differentiation by Simplified 
Least Squares Procedures, Analytical Chemistry, 36, 1627-1632. 

Schaper, K.J., (1991), QSAR Analysis of Chiral Drugs Including Stereoisomer 
Combinations, In: Silipo, C., and Vittoria, A, (Eds.), QSAR: Rational Approaches to 
the Design of Bioactive Compounds, Elsevier Science Publishers, Amsterdam, 1991, 
pp. 25-32. 

Schüürmann, G., Rayasamuda, K., and Kristen, U., (1996), Structure-Activity 
Relationships for Chloro- and Nitrophenol Toxicity in the Pollen Tube Growth Test, 
Environmental Toxicology and Chemistry, 15, 1702-1708. 

Sekulic, S., Seasholtz, M.B., Wang, Z., Kowalski, B., Lee, S.E., and Holt, B.R, (1993), 
Non-linear Multivariate Calibration Methods in Analytical Chemistry, Analytical 
Chemistry, 65, 835-845. 

Seydel, J.K., Wiese, M., Cordes, H.P., Chi, H.L., Schaper, K.-J., Coats, E.A., Kunz, B., 
Engel, J., Kutscher, B., and Emig, H., (1991), QSAR and Modelling of Enzyme 
Inhibitors, Anticonvulsants and Amphiphilic Drugs Interacting with Membranes, In:, 
Silipo, C., and Vittoria, A, (Eds.), QSAR: Rational Approaches to the Design of 
Bioactive Compounds, Elsevier Science Publishers, Amsterdam, 1991, pp. 367-376. 



User Guide to SIMCA 

614 

Shao, J., (1993), Linear Model Selection by Cross-Validation, Journal of the American 
Statistical Association, 88, 486-494. 

Shewhart, W., (1931), Economic Control of Quality of Manufactured Product, Van 
Nostrand, Princeton, N.J. 

Singhal, A., and Seborg, D.E., (2002), Pattern Matching in Historical Batch Data 
Using PCA, IEEE Control Systems Magazine, October 2002, 53-63. 

Sjöblom, J., Svensson, O., Josefson, M., Kullberg, H., and Wold, S., (1998), An 
Evaluation of Orthogonal Signal Correction Applied to Calibration Transfer of Near 
Infrared Spectra, Chemometrics and Intelligent Laboratory Systems, 44, 229-244. 

Sjöström, M., Wold, S., Lindberg, W., Persson, J.-Å., and Martens, H., (1983), A 
Multivariate Calibration Problem in Analytical Chemistry Solved by Partial Least-
Squares Models in Latent Variables, Analytica Chimica Acta, 150, 61-70. 

Sjöström, M., Wold, S., and Söderström, B., (1986), PLS Discriminant Plots, 
Proceedings of PARC in Practice, Amsterdam, June 19-21, 1985. Elsevier Science 
Publishers B.V., North-Holland. 

Sjöström, M., Eriksson, L., Hellberg, S., Jonsson, J., Skagerberg, B., and Wold, S., 
(1989), Peptide QSARs: PLS Modelling and Design in Principal Properties. In: J.L. 
Fauchère (ed.): QSAR - Quantitative Structure-Activity Relationships in Drug Design. 
Proc. 7th European Symposium on QSAR, Sept. 1988, Interlaken, Switzerland. Alan 
R. Liss, Inc., New York, pp. 131-134. 

Sjöström, M., Rännar, S., and Rilfors, L., (1995), Polypetide Sequence Property 
Relationships in Escherichica Coli Based on Auto Cross Covariances, Chemometrics 
and Intelligent Laboratory Systems, 29, 295-305. 

Sjöström, M., Lindgren, Å., and Uppgård, L.L., (1997), Joint Multivariate Quantitative 
Structure-Property and Structure-Activity Relationships for a Series of Technical 
Nonionic Surfactants, In: F. Chen & G. Schüürmann (eds.), Quantitative Structure-
Activity Relationships in Environmental Sciences – VII. Proceedings of the 7th 
International Workshop on QSAR in Environmental Sciences, June 24-28, 1996, 
Elsinore, Denmark. SETAC Press, Pensacola, Florida, 1997, pp. 435-449. 

Skagerberg, B., Sjöström, M., and Wold, S., (1987), Multivariate Characterization of 
Amino Acids by Reversed Phase High Pressure Liquid Chromatography, Quantitative 
Structure-Activity Relationships, 6, 158-164. 

Skagerberg, B., Bonelli, D., Clementi, S., Cruciani, G., and Ebert, C., (1989), Principal 
Properties for Aromatic Substituents. A Multivariate Approach for Design in QSAR, 
Quantitative Structure-Activity Relationships, 8, 32-38. 

Skoglund, A., Brundin, A., and Mandenius C.F., (2004), Monitoring a Paperboard 
Machine Using Multivariate Statistical Process Control, Chemometrics and Intelligent 
Laboratory Systems, 73, 3-6. 

  

Spellman, P.T., Sherlock, G., Zhang, M.Q., Iyer, V.R., Anders, K., Eisen, M.B., 
Brown, P.O., Botstein, D., and Futcher, B., (1998), Comprehensive Identification of 
Cell Cycle-Regulated Genes of the Yeast Saccharomyces Cerevisiae by Microarray 
Hybridization, Molecular Biology of the Cell, 9, 3273-3297. 

Stefanov, Z.I., and Hoo, K.A., (2003), Hierarchical Multivariate Analysis of Cockle 
Phenomena, Journal of Chemometrics, 17, 550-568. 

Stork, C.L., and Kowalski, B.R., (1999), Distinguishing Between Process Upsets and 
Sensor Malfunctions Using Sensor Redundancy, Chemometrics and Intelligent 
Laboratory Systems, 46, 117-131. 



References 

615 

Strouf, O., (1986), Chemical Pattern Recognition, John Wiley, New York. 

Ståhle, L., and Wold, S., (1987), Partial Least Squares Analysis with Cross-Validation 
for the Two-Class Problem: A Monte Carlo Study, Journal of Chemometrics, 1, 185-
196. 

Ståhle, L., and Wold, S., (1989), Analysis of variance (ANOVA), Chemometrics and 
Intelligent Laboratory Systems, 6, , 259-272. 

Ståhle, L., and Wold, S., (1990), Multivariate analysis of variance (MANOVA), 
Chemometrics and Intelligent Laboratory Systems, 9, 127-141. 

Svensson, O., Josefsson, M., and Langkilde, F.W., (1997), Classification of Chemically 
Modified Celluloses Using a Near-Infrared Spectrometer and Soft Independent 
Modelling of Class Analogy, Applied Spectroscopy, 51, 1826-1835. 

Svensson, O., Josefsson, M., and Langkilde, F.W., (1999), Reaction Monitoring Using 
Raman Spectroscopy and Chemometrics, Chemometrics and Intelligent Laboratory 
Systems, 49, 49-66. 

Svensson, O., Kourti, T., and MacGregor, J.F., (2002), An Investigation of Orthogonal 
Signal Correction Algorithms and their Characteristics, Journal of Chemometrics, 16, 
176-188. 

Taft, R.W., (1956), In: Newman, M.S., (ed.), Steric Effects in Organic Chemistry, 
Wiley, New York. 

Tano, K., (1996), Multivariate Modelling and Monitoring of Mineral Processes using 
Partial Least Squares Regression, Licentiate Thesis, Luleå University of Technology, 
Sweden. 

Tano, K., (2005), Continuous Monitoring of Mineral Processes with Special Focus on 
Tumbling Mills, PhD Thesis, Luleå University of Technology, Sweden. 

Teague, S.J., Davis, A.M., Leeson, P.D., and Oprea, T., (1999), The Design of Leadlike 
Combinatorial Libraries, Angewandte Chemie International Edition, 38, 3743-3748. 

Tenenhaus, M., Esposito Vinzi, V., Chatelin, Y.M., and Lauro, C., (2005), PLS Path 
Modelling, Computational Statistics & Data Analysis, 48, 159-205. 

Teppola, P., Mujunen, S.P., Minkkinen, P., Puijola, T., and Pursiheimo, P., (1998), 
Principal Component Analysis, Contribution Plots and Feature Weights of Sequential 
Process Data from a Paper Machine’s Wet End, Chemometrics and Intelligent 
Laboratory Systems, 44, 307-317. 

Teppola, P., and Minkkinen, P., (2000), Wavelet-PLS Regression Models for Both 
Exploratory Data Analysis and Process Monitoring, Journal of Chemometrics, 14, 
383-400. 

Teppola, P., and Minkkinen, P., (2001), Wavelets for Scrutinizing Multivariate 
Exploratory Models Through Multiresolution Analysis, Journal of Chemometrics, 15, 
1-18. 

Tompson, C.J.S., (1990), The Lure and Romance of Alchemy - a History of the Secret 
Link Between Magic and Science, Bell Publishing Company, New York. 

Topliss, J.G., and Edwards, R.P., (1979), Chance Factors in Studies of Quantitative 
Structure-Activity Relationships, Journal of Medicinal Chemistry, 22, 1238-1244. 

Trygg, J., and Wold, S., (1998), PLS Regression on Wavelet Compressed NIR Spectra, 
Chemometrics and Intelligent Laboratory Systems, 42, 209-220. 

Trygg, J., Kettaneh-Wold, N., and Wallbäcks, L., (2001), 2-D Wavelet Analysis and 
Compression of On-line Industrial Process Data, Journal of Chemometrics, 15, 299-
319. 



User Guide to SIMCA 

616 

Trygg, J., and Wold, S., (2002), Orthogonal Projections to Latent Structures (OPLS), 
Journal of Chemometrics, 16, 119-128. 

Trygg, J., (2002), O2-PLS for Qualitative and Quantitative Analysis in Multivariate 
Calibration, Journal of Chemometrics, 16, 283-293. 

Trygg, J., and Wold, S., (2003), O2-PLS, a Two-Block (X-Y) Latent Variable 
Regression (LVR) Method With an Integral OSC Filter, Journal of Chemometrics, 17, 
53-64. 

Trygg, J., (2004), Prediction and Spectral Profile Estimation in Multivariate 
Calibration, Journal of Chemometrics, 18, 166-172. 

Tysklind, M., Andersson, P., Haglund, P., van Bavel, B., and Rappe, C., (1995), 
Selection of Polychlorinated Biphenyls for use in Quantitative Structure-Activity 
Modelling, SAR and QSAR in Environmental Research, 4, 11-19. 

Undey, C., and Cinar, A., (2002), Statistical Monitoring of Multistage, Multiphase 
Batch Processes, IEEE Control Systems Magazine, October 2002, 40-52. 

Uppgård, L., Sjöström, M., and Wold, S., (2000). Multivariate Quantitative Structure-
Activity Relationships for the Aquatic Toxicity of Alkyl Polyglucosides, Tenside 
Surfactants Detergents, 37, 131-138. 

Walczak, B., Bogaert, B., and Massart, D.L., (1996), Application of Wavelet Packet 
Transform in Pattern Recognition of Near-IR Data, Anal. Chem., 68, 1742-1747. 

Walczak, B. and Massart, D.L., (1997), Noise Suppression and Signal Compression 
using the Wavelet Packet Transform, Chemometrics Intell. Lab. Syst., 36, 81-94. 

Van der Voet, H., (1994), Comparing the Predictive Accuracy of Models Using a 
Simple Randomization Test, Chemometrics and Intelligent Laboratory Systems, 25, 
313-323. 

Van de Waterbeemd, H., (1995), Chemometric Methods in Molecular Design, In: 
Mannhold, R., Krogsgaard-Larsen, P., and Timmerman, H., (Eds.), Methods and 
Principles in Medicinal Chemistry, Vol 2, VCH, Weinheim, Germany. 

Van Espen, P., Janssens, G., Vanhoolst, W., and Geladi, P., (1992), Imaging and 
Image Processing in Analytical Chemistry, Analusis, 20, 81-90. 

Verron, T., Sabatier, R., and Joffre, R., (2004), Some Theoretical Properties of the 
OPLS Method, Journal of Chemometrics, 18, 62-68. 

Wakeling, I.N., Morris, J.J., (1993), A Test of Significance for Partial Least Squares 
Regression, Journal of Chemometrics, 7, 291-304. 

Ward, J. H. Hierarchical grouping to optimize an objective function, J. Am. Stat. 
Assoc. 1963, 58, 236-244. 

Westerhuis, J., Kourti, T., and MacGregor, J.F., (1998), Analysis of Multiblock and 
Hierarchical PCA and PLS Models, Journal of Chemometrics, 12, 301-321. 

Westerhuis, J.A., de Jong, S., and Smilde, A.K., (2001), Direct Orthogonal Signal 
Correction, Chemometrics and Intelligent Laboratory Systems, 56, 13-25. 

Whelehan, O.P.W., Eriksson, L., Earll, M.E., Johansson, E., and Dyrby, M., (2005), 
Detection of Ovarian Cancer using Chemometric Analysis of Proteomic Profiles, In 
manuscript. 

Wickerhauser, M.V., (1994), Adapted Wavelet Analysis from Theory to Software, AK 
Peters. 



References 

617 

Wiklund, S., Johansson, E., Sjöström, L., Mellerowicz, E.J., Edlund, U., Shockcor, 
J.P., Gottfries, J., Moritz, T., and Trygg, J., (2008), Visualization of GC/TOF-MS-
Based Metabolomics Data for Identification of Biochemically Interesting Compounds 
Using OPLS Class Models, Anal. Chem. 80, 115-122. 

Wikström, C., Albano, C., Eriksson, L., Fridén, H., Johansson, E., Nordahl, Å., 
Rännar, S., Sandberg, M., Kettaneh-Wold, N., and Wold, S., (1998a), Multivariate 
Process and Quality Monitoring Applied to an Electrolysis Process – Part I. Process 
Supervision with Multivariate Control Charts, Chemometrics and Intelligent 
Laboratory Systems, 42, 221-231. 

Wikström, C., Albano, C., Eriksson, L., Fridén, H., Johansson, E., Nordahl, Å., 
Rännar, S., Sandberg, M., Kettaneh-Wold, N., and Wold, S., (1998b), Multivariate 
Process and Quality Monitoring Applied to an Electrolysis Process – Part II. 
Multivariate Time-series Analysis of Lagged Latent Variables, Chemometrics and 
Intelligent Laboratory Systems, 42, 233-240. 

Wikström, P.B., Andersson, A.C., Forsman, M., (1999), Biomonitoring Complex 
Microbial Communities Using Random Amplified Polymorphic DNA and PCA, FEMS 
– Microbiology, Ecology, 28, 131-139. 

Wikström, P.B., (2001), Biomonitoring of Complex Microbial Communities that 
Biodegrade Aromatics, Ph.D. Thesis, Umeå University, Umeå, Sweden. 

Wikström, M., and Sjöström, M., (2004), Identifying Cause of Quality Defect in 
Cheese Using Qualitative Variables in a Statistical Experimental Design, Journal of 
Chemometrics, 18, 139-145. 

Winiwarter, S., Bonham, N.M., Ax, F., Hallberg, A., Lennernäs, H., and Karlén, A., 
(1998), Correlation of Human Jejunal Permeability (in Vivo) of Drugs with 
Experimentally and Theoretically Derived Parameters – A Multivariate Data Analysis 
Approach, Journal of Medicinal Chemistry, 41, 4939-4949. 

Winiwarter, S., Ax, F., Lennernäs, H., Hallberg, A., Pettersson, Cu., and Karlén, A., 
(2003), Hydrogen Bonding Descriptors in the Prediction of Human In Vivo Intestinal 
Permeability, Journal of Molecular Graphics and Modelling, 21, 273-287. 

Wise, B.M., Gallagher, N.B, and Martin, E.B., (2001), Application of PARAFAC2 to 
Fault Detection and Diagnosis in Semiconductor Etch, Journal of Chemometrics, 15, 
285-298. 

Wold, S., (1978), Cross-Validatory Estimation of the Number of Components in Factor 
and Principal Components Models, Technometrics, 20, 397-405. 

Wold, H., (1982), Soft Modelling. The Basic Design and Some Extensions. In: 
Jöreskog, K.G., and Wold, H., (eds.), Systems Under Indirect Observation, Vol. I and 
II, North-Holland, Amsterdam, The Netherlands. 

Wold, S., and Dunn, III, W.J., (1983), Multivariate Quantitative Structure-Activity 
Relationships (QSAR): Conditions for their Applicability, Journal Chemical 
Information & Computer Science, 23, 6-13. 

Wold, S., Albano, C., Dunn, W.J., Edlund, U., Esbensen, K., Geladi, P., Hellberg, S., 
Johansson, E., Lindberg, W., and Sjöström, M., (1984), Multivariate Data Analysis in 
Chemistry, In: B.R. Kowalski (ed.) Chemometrics: Mathematics and Statistics in 
Chemistry, D. Reidel Publishing Company, Dordrecht, Holland. 

Wold, S., Geladi, P., Esbensen, K., and Öhman, J., (1987a), Multiway Principal 
Components and PLS-Analysis, Journal of Chemometrics, 1, 41-56. 



User Guide to SIMCA 

618 

Wold, S., Hellberg, S., Lundstedt, T., Sjöström, M. and Wold, H., (1987b), PLS 
Modeling with Latent Variables in Two or More Dimensions, Proceedings Frankfurt 
PLS-meeting, September, 1987. 

Wold, S., Carlson, R., and Skagerberg, B., (1989a), Statistical Optimization as a 
Means to Reduce Risks in Industrial Processes, The Environmental Professional, 11, 
127-131. 

Wold, S., Kettaneh-Wold, N., and Skagerberg, B. (1989b), Nonlinear PLS Modelling, 
Chemometrics and Intelligent Laboratory Systems, 7, 53-65. 

Wold, S., (1992), Non-linear Partial Least Squares Modelling. II. Spline Inner 
Relation, Chemometrics and Intelligent Laboratory Systems, 14, 71-84. 

Wold, S., Johansson, E., and Cocchi, M., (1993a), PLS, In: Kubinyi, H., (ed.), 3D-
QSAR in Drug Design, Theory, Methods, and Applications, ESCOM Science, Ledien, 
pp. 523-550. 

Wold, S., Jonsson, J., Sjöström, M., Sandberg, M., and Rännar, S., (1993b), DNA and 
Peptide Sequences and Chemical Processes Multivariately Modelled by Principal 
Components Analysis and Partial Least Squares Projections to Latent 
Structures, Analytica Chimica Acta, 277, 239-253. 

Wold, S., (1994), Exponentially Weighted Moving Principal Components Analysis and 
Projections to Latent Structures, Chemometrics and Intelligent Laboratory Systems, 
23, 149-161. 

Wold, S., Kettaneh, N., and Tjessem, K., (1996), Hierarchical Multiblock PLS and PC 
Models for Easier Model Interpretation and as an Alternative to Variable Selection, 
Journal of Chemometrics, 10, 463-482. 

Wold, S., Antti, H., Lindgren, F., and Öhman, J., (1998a), Orthogonal Signal 
Correction of Near-Infrared Spectra, Chemometrics and Intelligent Laboratory 
Systems, 44, 175-185. 

Wold, S., Kettaneh, N., Fridén, H., and Holmberg, A., (1998b), Modelling and 
Diagnostics of Batch Processes and Analogous Kinetic Experiments, Chemometrics 
and Intelligent Laboratory Systems, 44, 331-340. 

Wold, S., Sjöström, M., Eriksson, L., (1999), PLS in Chemistry, In: The Encyclopedia 
of Computational Chemistry, Schleyer, P. v. R.; Allinger, N. L.; Clark, T.; Gasteiger, 
J.; Kollman, P. A.; Schaefer III, H. F.; Schreiner, P. R., Eds., John Wiley & Sons, 
Chichester, 1999, pp 2006-2020. 

Wold, S. and Josefson, M., (2000), Multivariate Calibration of Analytical Data, in: 
Meyers, R., Encyclopedia of Analytical Chemistry, John Wiley & Sons, Ltd., pp 9710-
9736. 

Wold, S., Trygg, J., Berglund, A., and Antti, H., (2001a), Some Recent Developments 
in PLS Modeling, Chemometrics and Intelligent Laboratory Systems, 58, 131-150. 

Wold, S., Sjöström, M., and Eriksson, L., (2001b), PLS-Regression: A Basic Tool of 
Chemometrics, Journal of Chemometrics, 58, 109-130. 

Wold, S., Berglund, A., and Kettaneh, N., (2002), New and Old Trends in 
Chemometrics. How to Deal With the Increasing Data Volumes in RDP – With 
Examples From Pharmaceutical Research and Process Modelling, Journal of 
Chemometrics, 16, 377-386. 

Wold, S., Josefson, M., Gottfries, J., and Linusson, A., (2004), The Utility of 
Multivariate Design in PLS Modeling, Journal of Chemometrics, 18, 156-165. 



References 

619 

Wold, S., and Kettaneh, N., (2005), PLS and Data Mining, Computational Statistics, In 
press. 

Wormbs, G., Larsson, A., Alm, J., Tunklint-Aspelin, C., Strinning, O., Danielsson, E., 
and Larsson, H., (2004), The use of Design of Experiments and Sensory Analysis as 
Tools for the Evaluation of Production Methods for Milk, Chemometrics and 
Intelligent Laboratory Systems, 73, 67-71. 

Wu, J., Hammarström, L.G., Claesson, O., and Fängmark, I.E., (2003), Modeling the 
Influence of Physico-Chemical Properties of Volatile Organic Compounds on 
Activated Carbon Adsorption Capacity, Carbon, 41, 1309-1328. 

Zuegge, J., Fechner, U., Roche, O., Parrott, N.J., Engkvist, O., and Schneider, G., 
(2002), A Fast Virtual Screening Filter of Cytochrome P450 3A4 Inhibition Liability of 
Compound Libraries, QSAR, 21, 249-256, 2002. 

Öberg, T., (2003), Optimization of an Industrial Afterburner, Journal of 
Chemometrics, 17, 5-8. 

Österberg, T., and Norinder, U., (2000), Theoretical Calculation and Prediction of P-
Glycoprotein-Interacting Drugs Using Molsurf Parametrization and PLS Statistics, 
European Journal of Pharmaceutical Sciences,10, 295-303. 

  





 

621 

Glossary 

A 
AR model: Auto regressive model. 

ARL: Average Run Length. 

ARMA model: Auto Regressive Moving Average model. 

B 
Batch conditions: Batch conditions pertain to the whole batch and are therefore used in the 

batch level model. Also named Initial condition, Final condition. 

Batch process: A finite duration process. 

Best basis: Best basis is an option used in wavelet transformation for high frequency signals. 
See also DWT. 

Bilinear modeling: Matrices modeled as a product of two low rank matrices, e.g. X=T*P’. 

Block-wise variable scaling: Making the total variance equal for each block of similar 
variables in a dataset. 

C 
Calibration dataset: See: Reference dataset. 

Characteristic vector analysis: See: Principal component analysis. 

Class: A subset of similar observations from a dataset. 

Closed form: The calculation of a closed form can be completed without iterations. 

Cluster analysis: Techniques for dividing a set of observations into subgroups or clusters. 

Column space: Space spanned by the column vectors of a matrix. 

Contingency table: A table which contains counts or frequencies of different events. 

Contribution: A measure of the differences in variable values between two observations. 
The differences might optionally be weighted by model loadings or modeled variability. 
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Correspondence analysis: A special double scaled variant of PCA, suitable for some 
applications, e.g. analysis of contingency tables. 

Cross validation: Parameters are estimated on one part of a matrix and the goodness of the 
parameters tested in terms of its success in the prediction of another part of the matrix. 

CUSUM: CUmulative SUM. 

D 
Dataset: A dataset is the base of all multivariate data analysis, often also called a data matrix. 

It is made up of values of several different variables for a number of observations.The 
data are collected in a data matrix (data table) of N rows and K columns, often denoted 
X. The N rows in the table are termed observations. The K columns are termed variables. 

Dependent variables: Variables (often denoted y or Y) that are modeled as dependent on 
other variables.The later variables (often denoted x or X) are often in this context 
misleadingly called independent, rather than predictor variables. 

Discriminant analysis: A method for allocating observations to one class of a given set of 
classes by means of a decision rule based on a function of the data. The function is 
derived from data for a reference set of individuals where it is known which class each 
individual belongs to. 

DWT: Discrete wavelet transform option used in wavelet transformation when the signal is 
fairly smooth, that is, the information is mainly contained in the low frequencies. See 
also Best basis. 

E 
Eigenvalue: The length change when an eigenvector is projected onto itself. This is 

equivalent to the length of a principal diameter of the data. 

Eigenvector: Eigenvectors exists only for square matrices. An eigenvector to a square matrix 
has the property of being projected onto itself when projected by the matrix. The degree 
of elongation or diminution is expressed by the eigenvalue. 

Eigenvector analysis: See: Principal component analysis. 

Euclidean distance: Geometric distance in a Euclidean space (isomorphic with orthogonal 
basis vectors). 

EWMA model: Exponentially Weighted Moving Average model. 

Explanatory variables: Variables (x) used to 'explain' the variation in the dependent 
variables (y). Also often called predictor variables. 

F 
Factor: A term often used in experimental design. It signifies controlled and varied variable. 

See: Predictor. Also a term for one model dimension in factor and bilinear models. 



Glossary 

623 

Factor analysis: Has an aim similar to PCA, but assumes an underlying model with a 
specified number of factors which are linear combinations of the original variables. The 
analysis is more concerned with 'explaining' the covariance structure of the variables 
rather than with 'explaining' the variances. 

I 
Identifiers: Variable and observation identifiers are displayed in plots and lists. The Find 

function searches the identifiers in the Workset dialog. In the Observations page of the 
Workset dialog the identifiers can be used to set classes. 

Independent variable: Often misleading connotation. See: Predictor variable. 

Inner vector product: The product of two vectors that produces a scalar. 

J 
Jack-knifing: A method for finding the precision of an estimate, by iteratively keeping out 

parts of the underlying data, making estimates from the subsets and comparing these 
estimates. 

K 
K-space: A space, spanned by K orthogonal variable axes. See: Variable space. 

Karhunen-Loève transformation: See: Principal component analysis. 

L 
Least squares estimate: A method to estimate model parameters by minimizing the sum of 

squares of the differences between the actual response value and the value predicted by 
the model. (SASSTAT). 

Leverage: Observations in the periphery of a dataset might have great influence on the 
modeling of the dataset. That influence is termed leverage, based on the Archimedian 
idea that anything can be lifted out of balance if the lifter has a long enough lever. 

Loading vector: Direction coefficients of a PC or PLS component axis. 

M 
M-space: Measurement space, or: multivariate space. Synonym: K-space. See: K-space 

MA model: Moving Average model. 

Mahalanobis distance: In short: Eigenvalue-weighed distance. 

Matrix: A rectangular array of elements, with certain rules of computations. 
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Missing value: Element in a data matrix without a defined value. As a rule of thumb, each 
observation and variable should have more than five defined values per PC. Observations 
(or variables) with missing values that show up as outliers should be treated with 
suspicion. 

Model: 1) An approximation of reality. A good model preserves all properties of interest. 2) 
Hyperplane, with limited extension, that approximates the variable space spanned by a 
class of observations. 

MSPC: Multivariate Statistical Process Control - The use of multivariate methods to 
characterize the state of a process with respect to known states. The state is determined 
from model score plots and distance to model plots. See also: SPC. 

Multidimensional scaling: Roughly corresponding to a principal component analysis of a 
matrix of ‘distances’ between observations. 

Multiple linear regression: The linear regression of one variable, Y, in many Xs. See also: 
Regression. 

Multivariate analysis: A group of statistical methods, which are appropriate when 
measurements are made on several variables for each of a large number of individuals or 
observations. 

Multivariate data: Multivariate data consist of observations on several different variables for 
a number of individuals or observations. Indeed, the vast majority of data is multivariate, 
although introductory statistics courses naturally concentrate on the simpler problems 
raised by observations on a single variable. 

N 
NIPALS: Non-linear Iterative Partial Least Squares 

Non-linear: Two uses:1) Curved relationship between X and Y. 2) A model, which 
parameters cannot be estimated by a closed form. 

O 
Observation space: The space spanned by the observation vectors of a data matrix. Each 

variable vector is represented as a point in that space. See also: Row space. 

Ordinal data: A discrete variable is called ordinal if its possible data can be arranged in 
some numerical order. 

Ordinal number: Showing order or position in a series, e.g. first, second, third. 

Outer vector product: Product of two vectors that produces a matrix: M = t * p' where mij = 
ti * pj 

P 
Pareto's principle: 20% of the variables account for 80% of the effect. 
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Partial Least Squares: See: Projection to Latent Structures. 

PC: See: Principal component. 

PC modeling: See: Principal component modeling. 

PCA: See: Principal component analysis. 

PLS: Partial Least Squares Projection to Latent Structures. See: Projection to Latent 
Structures. 

Power method: An iterative projection method for finding eigenvectors. 

Predictionset: A dataset used together with an established model in order to obtain model 
predictions for each of the observations in the set. 

Predictor variable: See: Explanatory variables. 

Principal component: One model dimension of a PC model. Often also used as a term for 
the scores t. 

Principal component analysis: Principal Component Analysis is the technique for finding a 
transformation that transforms an original set of correlated variables to a new set of 
uncorrelated variables, called principal components. The components are obtained in 
order of decreasing importance, the aim being to reduce the dimensionally of the data. 
The analysis can also be seen as an attempt to uncover approximate linear dependencies 
among variables (SASSTAT). 

Principal component modeling: 1) The use of PCs to define a model. 2) The approximation 
of a matrix by a model, defined by averages and a relatively small number of outer vector 
products. The components can often be used in place of the original variables for 
plotting, regression, clustering and so on (SASSTAT). 

Principal coordinate analysis: The aim is an algebraic reconstruction of the positions of the 
observations assuming that the distances are approximately Euclidean. See also: 
Multidimensional scaling. 

Principal factor analysis: See: Principal component analysis. 

Projection: 1) The act of projecting. 2) Something that has been projected, i.e. the 'picture' of 
orthogonally projected points on a line, plane or hyperplane. 

Projection methods: A group of methods that can efficiently extract the information inherent 
in MVD. They give results that are easy to interpret because they can be presented as 
pictures. Such methods are efficient for pattern recognition, classification, and 
predictions. The most commonly used methods are PC and PLS modeling. 

Projection point: The point, along a line or in a plane or hyperplane (created by 
approximating data in k-space as a low dimensional hyperplane), which is closest to the 
original point. 

Projection to Latent Structures: A generalization of PCA where a projection model is 
developed predicting Y from X via scores of X. Can also be seen as a generalized 
multiple regression method that can cope with multiple collinear X and Y variables. 



User Guide to SIMCA 

626 

R 
Reference dataset: This term is used for datasets with known properties and origin, often 

used to define models. Synonyms: Calibration dataset, training dataset, workset. 

Regression: In mathematics Y is called a function of X, but in statistics the term regression 
of Y on X is generally used to describe the (sound, approximate) relationship. 

Regression analysis: The fitting of an equation to a set of values. The equation predicts a 
response variable from a function of regressor variables and parameters, adjusting the 
parameters such that a measure of fit is optimized. (SASSTAT) 

Regressor variable: See: dependent variable 

Residual: Left-over; un-modeled part. The mismatch between the observed and modeled 
values. 

Response variable: See: dependent variable 

Row space: The space spanned by the row vectors of a matrix. 

S 
Score: Distance from the origin, along a loading vector, to the projection point of an 

observation in K- or M-space. Or: the coordinates of a point when it is projected on a 
model hyperplane. 

Score vector: Observation coordinates along a PC or PLS component axis. Scores for all 
observations for one model dimension (component). 

Singular value decomposition: See: Principal component analysis 

SPC: Statistical Process Control - The behavior of a process is characterized using data when 
the process is operating well and is in a state of control. In the monitoring phase the new 
incoming, measured, data are used to detect whether the process is in control or not. See 
also: MSPC. 

Subspace methods: See: Projection methods. 

T 
Test dataset: A dataset with unknown properties, often subjected to projections to models. 

Training dataset: See: Reference dataset. 

V 
Variable space: The space spanned by the variable vectors of a data matrix. Each 

observation vector is represented as a point in that space. See also: K space, and M space. 

VSI: Variable Sampling Interval. 
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OSC ................................................ 255 
Partial models ................................. 135 
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